Jak naprawić błąd #ARG! błąd w funkcji Suma/suma

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

W tym temacie wymieniono najbardziej typowe przyczyny błędu #ARG! w przypadku funkcji SUMA.JEŻELI i SUMA.WARUNKÓW oraz sposoby ich usuwania.

Problem: formuła odwołuje się do komórek w zamkniętym skoroszycie

Funkcje Suma/suma, które odwołują się do komórki lub zakresu w zamkniętym skoroszycie, spowodują #VALUE! .

Uwaga: Jest to znany problem dotyczący kilku innych funkcji programu Excel, takich jak LICZ. Jeżeli, licz, licz. puste, w celu napisania kilku. Zobacz funkcje Suma, licz i LICZ. puste zwracają "#VALUE!" Błąd artykuł, aby uzyskać więcej informacji.

Rozwiązanie: Otwórz skoroszyt wskazany w formule i naciśnij klawisz F9, aby odświeżyć formułę.

Możesz również obejść ten problem, używając jednocześnie funkcji Suma i jeżeli w formule tablicowej. Zobacz funkcje Suma, licz i LICZ. puste zwracają #VALUE! błąd artykuł, aby uzyskać więcej informacji.

Problem: ciąg kryteriów ma więcej niż 255 znaków

Funkcje SUMA.JEŻELI/SUMA.WARUNKÓW zwracają niepoprawne wyniki w razie próbowania dopasowania ciągów mających więcej niż 255 znaków.

Rozwiązanie: Skróć ciąg, jeśli to możliwe. Jeśli nie można go skrócić, podziel tę wartość na wiele ciągów za pomocą funkcji ZŁĄCZ.TEKSTY lub operatora &. Na przykład:

=SUMA.JEŻELI(B2:B12;"długi ciąg"&"inny długi ciąg")

Problem: w funkcji SUMA.WARUNKÓW argument kryteria_zakres jest niezgodny z argumentem suma_zakres

Argumenty zakresu zawsze muszą być takie same w funkcji SUMA.WARUNKÓW. Oznacza to, że argumenty kryteria_zakres i suma_zakres powinny odwoływać się do takiej samej liczby wierszy i kolumn.

W poniższym przykładzie formuła powinna zwrócić sumę dziennej sprzedaży jabłek w Międzyzdrojach. Argument suma_zakres (C2: C10) nie odpowiada jednak tej samej liczbie wierszy i kolumn w criteria_range (A2: A12 _AMP_ B2: B12) . Użycie składni = suma (C2: C10;a2: A12; A14;B2: B12, B14) spowoduje #VALUE! .

Niepoprawna formuła to =SUMA.WARUNKÓW(C2:C10;A2:A12;A14;B2:B12;B14), w której zakres C2:C10 musi być zakresem C2:C12

Rozwiązanie: Postępując zgodnie z tym przykładem, zmień wartość argumentu suma_zakres na C2:C12 i ponownie sprawdź formułę.

Uwaga:  W funkcji SUMA.JEŻELI można używać zakresów o różnych rozmiarach.

Masz pytanie dotyczące konkretnej funkcji?

Zadaj pytanie na forum społeczności programu Excel

Pomoc w ulepszaniu programu Excel

Masz sugestie dotyczące możliwości ulepszenia następnej wersji programu Excel? Jeśli tak, zapoznaj się z tematami w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Naprawianie błędu #ARG! błąd

SUMA.JEŻELI

SUMA.WARUNKÓW

Zaawansowane klipy wideo funkcji jeżeli

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Wykrywanie błędów w formułach

Wszystkie funkcje programu Excel (alfabetycznie)

Wszystkie funkcje programu Excel (według kategorii)

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×