Instalowanie i wyświetlanie dodatków oraz zarządzanie nimi w programach pakietu Office

Uwaga:  Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Włączenie dodatku umożliwia uzupełnienie funkcjonalności programów pakietu Office o niestandardowe polecenia i nowe funkcje usprawniające pracę. W związku z tym, że dodatki mogą być używane przez hakerów do uszkodzenia komputera, można skorzystać z ustawień zabezpieczeń dodatków, aby zmienić ich działanie.

Uwaga: Te kroki dotyczą tylko aplikacje Microsoft Office w systemie Windows.

Kliknij poniższy nagłówek, aby uzyskać więcej informacji.

Jeśli wiadomo, że dodatek pochodzi z wiarygodnego źródła, można go włączyć, klikając pozycję Włącz zawartość na pasku komunikatów.

Pasek komunikatów z komunikatem Część zawartości aktywnej została wyłączona.

Aby wyłączyć lub usunąć dodatek, wykonaj następujące czynności:

  1. Kliknij pozycję Plik > Opcje >Dodatki.

  2. W dolnej części okna, tam, gdzie znajduje się napis Zarządzaj, kliknij przycisk Przejdź.

  3. W oknie dialogowym wybierz dodatki, które chcesz wyłączyć lub usunąć.

    Wyłączanie lub usuwanie niechcianych dodatków za pomocą okna dialogowego Zarządzanie dodatkami COM
  4. Aby wyłączyć dodatek, po prostu wyczyść pole wyboru przed jego nazwą. Aby odinstalować dodatek, zaznacz go i kliknij pozycję Usuń.

  5. Kliknij przycisk OK, aby zapisać zmiany i wrócić do dokumentu.

W Centrum zaufania można wyświetlać i zmieniać ustawienia dodatków (opisy tych ustawień znajdują się w następnej sekcji). Ustawienia zabezpieczeń dotyczące dodatków mogą być określone przez organizację, więc może się okazać, że niektórych opcji nie można zmienić.

  1. Kliknij pozycję Plik > Opcje.

  2. Kliknij pozycję Centrum zaufania > Ustawienia Centrum zaufania > Dodatki.

  3. Zaznacz odpowiednie pola lub anuluj ich zaznaczenie.

Obszar Dodatki w Centrum zaufania

  • Wymagaj podpisów zaufanego wydawcy w dodatkach aplikacji    Zaznaczenie tego pola powoduje, że Centrum zaufania będzie sprawdzać, czy podpis cyfrowy wydawcy używany przez dodatek jest zaufany. Jeśli podpis wydawcy nie jest zaufany, program pakietu Office nie załaduje dodatku i na pasku zaufania zostanie wyświetlone powiadomienie, że dodatek został wyłączony.

  • Wyłącz powiadomienia dla niepodpisanych dodatków (kod będzie wyłączony)    Po zaznaczeniu pola Wymagaj podpisów zaufanego wydawcy w dodatkach aplikacji ta opcja nie jest już wyszarzona. Dodatki podpisane przez zaufanego wydawcę są włączane, a dodatki niepodpisane są wyłączane.

  • Wyłącz wszystkie dodatki aplikacji (może spowodować ograniczenie funkcji)    To pole należy zaznaczyć, gdy żadne dodatki nie są zaufane. Wszystkie dodatki będą wyłączane bez powiadomienia, a pozostałe pola dotyczące dodatków będą wyszarzone.

Uwaga: To ustawienie jest stosowane po zakończeniu działania i ponownym uruchomieniu programu pakietu Office.

W przypadku używania dodatków konieczne może być zapoznanie się z dodatkowymi informacjami na temat podpisów cyfrowych i certyfikatów, które służą do uwierzytelniania dodatku, oraz zaufanych wydawców, czyli deweloperów, którzy często tworzą dodatki.

  1. Kliknij pozycję Plik > Opcje >Dodatki.

  2. Wyróżnij dowolny dodatek, aby wyświetlić jego nazwę, wydawcę, informacje o zgodności, lokalizację na komputerze i opis funkcji.

Przeglądanie obszaru Dodatki w Centrum zaufania

Uwaga: Jeśli dodatek został zablokowany przez funkcję Zapobieganie wykonywaniu danych (DEP, Data Execution Prevention), warto zapoznać się z informacjami na jej temat dostępnymi w temacie Dlaczego mój dodatek ulega awarii?

  • Aktywne dodatki aplikacji    Dodatki zarejestrowane i obecnie uruchomione w programie pakietu Office.

  • Nieaktywne dodatki aplikacji     Dodatki znajdujące się na komputerze, ale obecnie niezaładowane. Na przykład schematy XML są aktywne wtedy, gdy jest otwarty odwołujący się do nich dokument. Innym przykładem są dodatki COM: Jeśli dodatek COM jest wybrany, jest aktywny. Jeśli pole wyboru dodatku COM jest wyczyszczone, dodatek jest nieaktywny.

  • Dodatki związane z dokumentami    Pliki szablonów, do których odwołują się otwarte dokumenty.

  • Wyłączone dodatki aplikacji    Dodatki, które zostały wyłączone automatycznie, ponieważ powodowały awarie programów pakietu Office.

  • Dodatek    Tytuł dodatku.

  • Wydawca    Deweloper lub organizacja, która utworzyła dodatek.

  • Zgodność    W tym miejscu należy szukać informacji na temat wszelkich problemów ze zgodnością.

  • Lokalizacja     Ta ścieżka pliku określa lokalizację na komputerze, w której dodatek jest zainstalowany.

  • Opis Ten tekst stanowi objaśnienie działania dodatku.

Uwaga: W programie Microsoft Outlook Centrum zaufania zawiera jedną opcję dotyczącą dodatków: Zastosuj ustawienia bezpieczeństwa makr do zainstalowanych dodatków. W programie InfoPath nie ma żadnych ustawień zabezpieczeń związanych z dodatkami.

Poniższe instrukcje umożliwiają instalowanie dodatków i zarządzanie nimi.

  1. Kliknij pozycję Plik > Opcje >Dodatki.

  2. Wybierz typ dodatku.

  3. Kliknij pozycję Przejdź.

  4. Wybierz dodatki, które chcesz dodać, usunąć, załadować lub przekazać. Możesz także wyszukiwać dodatki do zainstalowania.

Jeśli nie chcesz kontynuować subskrypcji dodatku zakupionej za pośrednictwem Sklepu Office, możesz ją anulować.

  1. Otwórz aplikację pakietu Office i przejdź na kartę Wstawianie na Wstążce.

  2. W grupie Dodatki kliknij pozycję Moje dodatki.

    Na karcie Wstawianie na Wstążce znajduje się grupa Dodatki umożliwiające zarządzanie dodatkami programu Excel
  3. Wybierz polecenie Zarządzaj moimi dodatkami.

    W oknie dialogowym Dodatki pakietu Office znajduje się lista zainstalowanych dodatków. Kliknij polecenie Zarządzaj moimi dodatkami, aby nimi zarządzać.
  4. Kliknij aplikację, którą chcesz anulować, i w obszarze Akcja kliknij pozycję Zarządzaj subskrypcją.

  5. W sekcji Płatności i rozliczenia wybierz polecenie Anuluj subskrypcję.

  6. Kliknij przycisk OK, a następnie kliknij przycisk Kontynuuj.

Po zakończeniu tych czynności w polu komentarzy listy aplikacji powinien zostać wyświetlony komunikat z informacją „Anulowano subskrypcję aplikacji”.

Niektóre dodatki mogą być niezgodne z zasadami określonymi przez dział IT organizacji. Jeśli taka sytuacja dotyczy dodatków zainstalowanych ostatnio w programie pakietu Office, funkcja Zapobieganie wykonywaniu danych (DEP, Data Execution Prevention) wyłączy dodatek i program może ulec awarii.

Więcej informacji o funkcji Zapobieganie wykonywaniu danych

Zobacz też

Kliknij poniższy nagłówek, aby uzyskać więcej informacji.

Podczas instalacji pakietu Microsoft Office 2007 na komputerze są automatycznie instalowane i rejestrowane pewne dodatki.

Word, Excel, Access i PowerPoint

  1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , przycisk Opcje, a następnie kategorię Dodatki.

  2. Wyświetl dodatki i rozszerzenia aplikacji, które są podzielone na następujące kategorie:

    • Aktywne dodatki aplikacji    Rozszerzenia zarejestrowane i aktualnie uruchomione w programie pakietu Office.

    • Nieaktywne dodatki aplikacji    Rozszerzenia znajdujące się na komputerze, ale aktualnie niezaładowane. Na przykład akcje lub schematy XML są aktywne tylko wtedy, gdy otwarty jest dokument, który się do nich odwołuje. Innym przykładem są dodatki COM wymienione w oknie dialogowym Dodatki COM. Jeśli pole wyboru dodatku COM jest zaznaczone, dodatek jest aktywny. Jeśli pole wyboru dodatku COM jest wyczyszczone, dodatek jest nieaktywny. Informacje o otwieraniu okna dialogowego Dodatek COM znajdują się w następnej sekcji: Wyłączanie zainstalowanych dodatków i zarządzanie nimi.

    • Dodatki związane z dokumentami    Pliki szablonów, do których odwołują się aktualnie otwarte dokumenty.

    • Wyłączone dodatki aplikacji    Dodatki, które zostały wyłączone automatycznie, ponieważ powodowały awarie programów pakietu Office.

Outlook, InfoPath, Publisher i Visio

  1. W menu Narzędzia kliknij polecenie Centrum zaufania, a następnie polecenie Dodatki.

  2. Wyświetl dodatki i rozszerzenia aplikacji, które są podzielone na następujące kategorie:

    • Aktywne dodatki aplikacji    Rozszerzenia zarejestrowane i aktualnie uruchomione w programie pakietu Office.

    • Nieaktywne dodatki aplikacji    Rozszerzenia znajdujące się na komputerze, ale aktualnie niezaładowane. Na przykład akcje lub schematy XML są aktywne tylko wtedy, gdy otwarty jest dokument, który się do nich odwołuje. Innym przykładem są dodatki COM wymienione w oknie dialogowym Dodatki COM. Jeśli pole wyboru dodatku COM jest zaznaczone, dodatek jest aktywny. Jeśli pole wyboru dodatku COM jest wyczyszczone, dodatek jest nieaktywny. Informacje o otwieraniu okna dialogowego Dodatek COM znajdują się w następnej sekcji: Wyłączanie zainstalowanych dodatków i zarządzanie nimi.

    • Dodatki związane z dokumentami    Pliki szablonów, do których odwołują się aktualnie otwarte dokumenty.

    • Wyłączone dodatki aplikacji    Dodatki, które zostały wyłączone automatycznie, ponieważ powodowały awarie programów pakietu Office.

Zarządzanie dodatkami obejmuje ich włączanie lub wyłączanie, dodawanie lub usuwanie oraz oznaczanie jako aktywnych lub nieaktywnych.

Word, Excel, Access i PowerPoint

  1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , przycisk Opcje programu Word, a następnie kategorię Dodatki.

  2. W polu Dodatki odszukaj dodatek, który chcesz włączyć lub wyłączyć, i zapamiętaj typ dodatku podany w kolumnie Typ.

  3. Wybierz odpowiedni typ dodatku w polu Zarządzaj i kliknij przycisk Przejdź.

  4. Zaznacz lub wyczyść pole wyboru dodatku, który chcesz włączyć lub wyłączyć, a następnie kliknij przycisk OK.

Uwaga: Dodatki typu Inspektor dokumentów są włączane inną metodą. Te dodatki są automatycznie włączane podczas sprawdzania obecności ukrytych metadanych lub informacji osobistych w dokumentach. Aby przeprowadzić inspekcję dokumentu, kliknij przycisk pakietu Microsoft Office, pozycję Przygotuj, a następnie pozycję Przeprowadź inspekcję dokumentu.

Outlook, InfoPath, Publisher i Visio

  1. W menu Narzędzia kliknij polecenie Centrum zaufania, a następnie polecenie Dodatki.

  2. W polu Dodatki odszukaj dodatek, który chcesz włączyć lub wyłączyć, i zapamiętaj typ dodatku podany w kolumnie Typ.

  3. Wybierz odpowiedni typ dodatku w polu Zarządzaj i kliknij przycisk Przejdź.

  4. Zaznacz lub wyczyść pole wyboru dodatku, który chcesz włączyć lub wyłączyć, a następnie kliknij przycisk OK.

Dodatki i dokumenty mogą powodować dodawanie niestandardowych przycisków i kontrolek do Wstążki, która stanowi część elementu interfejs użytkownika Microsoft Office Fluent. Wszystkie niestandardowe kontrolki na Wstążce interfejsu Office Fluent mają specjalne etykietki ekranowe, na których zidentyfikowano pochodzenie tych kontrolek. W tym przykładzie kontrolka pochodzi z pliku RXDemo.xlsm i jest zidentyfikowany na etykietce ekranowej.

Obraz Wstążki

Dzięki temu zawsze znasz pochodzenie niestandardowych kontrolek i możesz usunąć lub aktualizować dokument, szablon globalny lub dodatek COM, który dodaje kontrolkę. W poprzedniej sekcji opisano, jak wyświetlać zainstalowane dodatki COM.

Domyślnie zainstalowane i zarejestrowane dodatki mogą być uruchamiane bez powiadomienia. Dodatki mogą być używane przez hakerów do szkodliwych działań (na przykład w celu rozpowszechniania wirusa), dlatego można zmienić to zachowanie, korzystając z ustawień zabezpieczeń dodatków. Aby uzyskać więcej informacji, zobacz sekcję Wyświetlanie lub zmienianie ustawień zabezpieczeń dodatków w dalszej części tego artykułu.

Jeśli użytkownik lub administrator ustawił wyższy poziom zabezpieczeń dla dodatków i Centrum zaufania wykryło potencjalnie niebezpieczny dodatek, który nie spełnia tych kryteriów, jest on domyślnie wyłączany i wyświetlany jest pasek komunikatów z powiadomieniem o potencjalnie niebezpiecznym dodatku lub rozszerzeniu aplikacji.

Pasek komunikatów

Kliknięcie przycisku Opcje na pasku komunikatów powoduje wyświetlenie okna dialogowego zabezpieczeń umożliwiającego włączenie dodatku. W następnej sekcji opisano sposób podejmowania bezpiecznej decyzji przed kliknięciem opcji.

Uwaga: W programach Microsoft Office Outlook 2007 i Microsoft Office Publisher 2007 alerty zabezpieczeń są wyświetlane w oknach dialogowych, a nie na pasku komunikatów. Domyślnie program Office Outlook 2007 umożliwia uruchomienie każdego zainstalowanego dodatku. Sposób zmieniania ustawienia domyślnego opisano w sekcji Wyświetlanie lub zmienianie ustawień zabezpieczeń dodatków w dalszej części tego artykułu.

Zmiana ustawienia zabezpieczeń dodatków jest stosowana tylko w programie, w którym została wprowadzona. W następujących programach pakietu Microsoft Office 2007 wykonaj poniższe czynności:

Word, Excel, Access i PowerPoint

  1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij przycisk Opcje.

  2. Kliknij pozycję Centrum zaufania, kliknij pozycję Ustawienia Centrum zaufania, a następnie kliknij pozycję Dodatki.

  3. Kliknij odpowiednie opcje. Te ustawienia nie są zaznaczone domyślnie, chyba że pracujesz w organizacji i administrator informatyczny zmienił wartości domyślne, korzystając z zasad administratora.

    • Wymagaj podpisów zaufanego wydawcy w dodatkach aplikacji Zaznaczenie tej opcji powoduje, że Centrum zaufania będzie sprawdzało podpis cyfrowy w pliku biblioteki dołączanej dynamicznie (dll) zawierającym dodatek. Jeśli wydawca nie jest zaufany, program pakietu Office nie załaduje dodatku i na pasku komunikatów zostanie wyświetlone powiadomienie o tym, że dodatek został wyłączony.

    • Wyłącz powiadomienia dla niepodpisanych dodatków (kod będzie wyłączony) To pole wyboru jest dostępne tylko wtedy, gdy zostanie zaznaczone pole wyboru Wymagaj podpisów zaufanego wydawcy w rozszerzeniach aplikacji. W pewnych sytuacjach plik biblioteki dołączanej dynamicznie (dll) zawierający dodatek może być niepodpisany. W takich przypadkach dodatki podpisane przez zaufanego wydawcę są włączane, a dodatki niepodpisane są wyłączane bez powiadomienia.

    • Wyłącz wszystkie dodatki aplikacji (może spowodować ograniczenie funkcji) To pole wyboru należy zaznaczyć, gdy żadne dodatki nie są zaufane. Wszystkie dodatki będą wyłączane bez powiadomienia, a pozostałe pola wyboru dotyczące dodatków będą niedostępne.

      Uwaga: To ustawienie jest stosowane dopiero po zakończeniu działania i ponownym uruchomieniu programu pakietu Office.

Outlook

Domyślnie program Outlook umożliwia uruchomienie każdego zainstalowanego dodatku. Można ograniczyć uruchamiane dodatki w programie Outlook do tylko tych, które są podpisane cyfrowo, przez zastosowanie ustawienia Wyświetl ostrzeżenia dla podpisanych makr; wszystkie niepodpisane makra są wyłączone dla dodatków, wykonując następujące czynności:

  1. W menu Narzędzia kliknij polecenie Centrum zaufania.

  2. W lewym okienku kliknij pozycję Bezpieczeństwo makr.

  3. Kliknij pozycję Wyświetl ostrzeżenia dla podpisanych makr; wszystkie niepodpisane makra są wyłączone.

  4. W lewym okienku kliknij pozycję Dodatki.

  5. Zaznacz pole wyboru Zastosuj ustawienia bezpieczeństwa makr do zainstalowanych dodatków.

InfoPath, Publisher i Visio

  1. W menu Narzędzia kliknij polecenie Centrum zaufania.

  2. Kliknij pozycję Dodatki.

  3. Kliknij odpowiednie opcje. Te ustawienia nie są zaznaczone domyślnie, chyba że pracujesz w organizacji i administrator informatyczny zmienił wartości domyślne, korzystając z zasad administratora.

    • Wymagaj podpisów zaufanego wydawcy w dodatkach aplikacji Zaznaczenie tej opcji powoduje, że Centrum zaufania będzie sprawdzało podpis cyfrowy w pliku biblioteki dołączanej dynamicznie (dll) zawierającym dodatek. Jeśli wydawca nie jest zaufany, program pakietu Office nie załaduje dodatku i na pasku komunikatów zostanie wyświetlone powiadomienie o tym, że dodatek został wyłączony.

    • Wyłącz powiadomienia dla niepodpisanych dodatków (kod będzie wyłączony) To pole wyboru jest dostępne tylko wtedy, gdy zostanie zaznaczone pole wyboru Wymagaj podpisów zaufanego wydawcy w rozszerzeniach aplikacji. W pewnych sytuacjach plik biblioteki dołączanej dynamicznie (dll) zawierający dodatek może być niepodpisany. W takich przypadkach dodatki podpisane przez zaufanego wydawcę są włączane, a dodatki niepodpisane są wyłączane bez powiadomienia.

    • Wyłącz wszystkie dodatki aplikacji (może spowodować ograniczenie funkcji) To pole wyboru należy zaznaczyć, gdy żadne dodatki nie są zaufane. Wszystkie dodatki będą wyłączane bez powiadomienia, a pozostałe pola wyboru dotyczące dodatków będą niedostępne.

      Uwaga: To ustawienie jest stosowane dopiero po zakończeniu działania i ponownym uruchomieniu programu pakietu Office.

Jeśli przy próbie wyłączenia dodatku zostanie wyświetlony komunikat „Nie można zmienić stanu połączenia dodatków Add-Ins pakietu Office zarejestrowanych w kluczu HKEY_LOCAL_MACHINE”, wykonaj następujące czynności:

  1. Zamknij program Outlook, jeśli jest otwarty.

  2. Sprawdź, czy nie jest uruchomiona usługa programu Outlook, wykonując następujące czynności:

    • Kliknij prawym przyciskiem myszy pusty obszar na pasku zadań, kliknij pozycję Menedżer zadań, a następnie pozycję Procesy.

    • Na liście procesów poszukaj pozycji Microsoft Outlook:

      • Jeśli na liście nie ma pozycji Outlook, przejdź do punktu 3.

      • Jeśli na liście znajduje się pozycja Outlook, kliknij ją, a następnie kliknij przycisk Zakończ proces.

  3. Kliknij prawym przyciskiem myszy pozycję Outlook w menu Start, a następnie kliknij polecenie Uruchom jako administrator.

  4. Wyłącz odpowiednie dodatki, wykonując czynności opisane w tym artykule we wcześniejszej sekcji Wyłączanie zainstalowanych dodatków i zarządzanie nimi.

  5. Zamknij program Outlook.

  6. Otwórz program Outlook normalnie, ale już nie w trybie administratora.

Gdy zostanie wyświetlone okno dialogowe zabezpieczeń, można włączyć dodatek tylko dla bieżącej sesji, klikając pozycję Włącz ten dodatek tylko dla tej sesji, lub pozostawić dodatek wyłączony. Włączaj dodatek tylko wtedy, gdy masz pewność, że pochodzi on z wiarygodnego źródła.

Okno dialogowe Opcje zabezpieczeń pakietu Microsoft Office

Można też wyraźnie wskazać zaufanego wydawcę, klikając pozycję Zawsze włączaj kod opublikowany przez tego wydawcę. Wykonanie tej operacji włącza dodatek i powoduje, że wszystkie programy od tego wydawcy są zawsze traktowane jako zaufane.

Po wyświetleniu w programie Office Outlook 2007 okna dialogowego zabezpieczeń można włączyć dodatek tylko dla bieżącej sesji, klikając pozycję Włącz dodatek aplikacji, lub pozostawić dodatek wyłączony. Włączaj dodatek tylko wtedy, gdy masz pewność, że pochodzi on z wiarygodnego źródła.

Powiadomienie dotyczące zabezpieczeń programu Microsoft Office Outlook

Można też wyraźnie wskazać zaufanego wydawcę, klikając pozycję Ufaj wszystkim dokumentom od tego wydawcy. Wykonanie tej operacji włącza dodatek i powoduje, że wszystkie programy od tego wydawcy są zawsze traktowane jako zaufane.

Aby uzyskać więcej informacji o zaufanych wydawcach, zobacz Dodawanie, usuwanie lub wyświetlanie zaufanego wydawcy.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×