INDEKS, funkcja

Funkcja INDEKS zwraca wartość lub odwołanie do wartości, która znajduje się w tabeli lub zakresie.

Docieranie do odbiorców za pomocą ogłoszeń

Funkcji INDEKS można używać na dwa sposoby:

  • Jeśli chcesz zwrócić wartość określonej komórki lub tablicy komórek, zobacz Forma tablicowa.

  • Jeśli chcesz zwrócić odwołanie do określonych komórek, zobacz Forma odwołaniowa.

Forma tablicowa

Opis

Zwraca wartość elementu w tabeli lub tablicy, wybranego przez indeksy numerów wiersza i kolumny.

Jeśli pierwszy argument funkcji INDEKS jest stałą tablicową, należy używać formy tablicowej.

Składnia

INDEKS(tablica;nr_wiersza;[nr_kolumny])

W formie tablicowej funkcji indeks występują następujące argumenty:

  • tablica    Argument wymagany. Zakres komórek lub stała tablicowa.

    • Jeśli tablica zawiera tylko jedno wiersza lub kolumnę, odpowiednie row_num lub column_num argument jest opcjonalny.

    • Jeśli tablica zawiera więcej niż jeden wiersz i więcej niż jednej kolumny, a używana jest tylko row_num lub column_num, funkcja indeks zwraca tablicę z całego wiersza lub kolumny w tablicy.

  • nr_wiersza    Wymagane, chyba że column_num jest obecny. Wskazuje wiersz tablicy, z którego zostanie zwrócona wartość. Jeśli row_num zostanie pominięty, wymagana jest column_num.

  • column_num    Argument opcjonalny. Wskazuje kolumnę tablicy, z której zostanie zwrócona wartość. Jeśli column_num zostanie pominięty, wymagana jest row_num.

Spostrzeżenia

  • Jeśli zostaną użyte zarówno argumenty row_num, jak i column_num, funkcja INDEKS zwróci wartość w komórce na stronie przecięcia row_num i column_num.

  • row_num i column_num muszą wskazywać na komórkę znajdującą się w tablicy; w przeciwnym przypadku funkcja indeks zwraca #REF! .

  • Jeśli ustawisz wartość row_num lub column_num na 0 (zero), funkcja INDEKS zwróci tablicę wartości odpowiednio dla całej kolumny lub wiersza. Aby użyć wartości zwróconych jako tablica, wprowadź tę wartość jako formułę tablicową.

    Uwaga: Jeśli masz aktualną wersję programu Microsoft 365, możesz wprowadzić formułę w komórce znajdującej się w lewym rogu zakresu wyjściowego, a następnie nacisnąć klawisz Enter , aby potwierdzić formułę jako dynamiczną formułę tablicową. W przeciwnym razie formułę należy wprowadzić jako starszą formułę tablicową, wybierając zakres wyjściowy, wprowadź formułę w komórce znajdującej się w lewym rogu zakresu wyjściowego, a następnie naciśnij klawisze CTRL + SHIFT + ENTER , aby ją potwierdzić. Program Excel wstawia nawiasy klamrowe na początku i końcu formuły. Aby uzyskać więcej informacji na temat formuł tablicowych, zobacz Wskazówki i przykłady dotyczące formuł tablicowych.

Przykłady

Przykład 1

W tych przykładach zastosowano funkcję INDEKS do znalezienia wartości w komórce na przecięciu wiersza i kolumny.

Skopiuj przykładowe dane z poniższej tabeli i wklej je w komórce A1 nowego arkusza programu Excel. Aby formuły wyświetlały wyniki, zaznacz je, naciśnij klawisz F2, a następnie naciśnij klawisz Enter.

Dane

Dane

Jabłka

Cytryny

Banany

Gruszki

Formuła

Opis

Wynik

=INDEKS(A2:B3;2;2)

Wartość na przecięciu drugiego wiersza i drugiej kolumny w zakresie A2:B3.

Gruszki

=INDEKS(A2:B3;2;1)

Wartość na przecięciu drugiego wiersza i pierwszej kolumny w zakresie A2:B3.

Banany

Przykład 2

W tym przykładzie zastosowano funkcję INDEKS w formule tablicowej do znalezienia wartości w dwóch komórkach określonych w tablicy 2x2.  

Uwaga: Jeśli masz aktualną wersję programu Microsoft 365, możesz wprowadzić formułę w komórce znajdującej się w lewym rogu zakresu wyjściowego, a następnie nacisnąć klawisz Enter , aby potwierdzić formułę jako dynamiczną formułę tablicową. W przeciwnym razie formułę należy wprowadzić jako starszą formułę tablicową, wybierając najpierw dwie puste komórki, wprowadź formułę w komórce znajdującej się w lewej części zakresu wyjściowego, a następnie naciśnij klawisze CTRL + SHIFT + ENTER , aby ją potwierdzić. Program Excel wstawia nawiasy klamrowe na początku i końcu formuły. Aby uzyskać więcej informacji na temat formuł tablicowych, zobacz Wskazówki i przykłady dotyczące formuł tablicowych.

Formuła

Opis

Wynik

=INDEKS({1;2\3;4};0;2)

Wartość znaleziona w pierwszym wierszu, drugiej kolumnie w tablicy. Tablica zawiera wartości 1 i 2 w pierwszym wierszu oraz wartości 3 i 4 w drugim wierszu.

2

Wartość znaleziona w drugim wierszu, drugiej kolumnie w tablicy (tej samej tablicy co powyżej).

4

Początek strony


Formularz odwołania

Opis

Zwraca odwołanie do komórki lezącej na przecięciu określonego wiersza i kolumny. Jeśli odwołanie składa się z nieprzylegających do siebie obszarów, możesz wybrać zaznaczenie, aby je znaleźć.

Składnia

INDEKS(odwołanie;nr_wiersza;[nr_kolumny];[nr_obszaru])

W formie odwołania funkcji indeks występują następujące argumenty:

  • odwołanie    Argument wymagany. Odwołanie do co najmniej jednego zakresu komórek.

    • Jeśli wprowadzasz odwołanie do nieprzylegającego zakresu, w nawiasach należy umieścić odwołanie.

    • Jeśli każdy z obszarów w odwołaniu zawiera tylko jedno wiersza lub kolumnę, odpowiednio argument row_num lub column_num. Na przykład w przypadku odwołania do jednego wiersza należy zastosować funkcję INDEKS(odwołanie; nr_kolumny).

  • row_num    Argument wymagany. Numer wiersza w odwołaniu, z którego zostanie zwrócony wynik w postaci odwołania.

  • column_num    Argument opcjonalny. Numer kolumny w odwołaniu, z której zostanie zwrócony wynik w postaci odwołania.

  • area_num    Argument opcjonalny. Wybiera zakres w odwołaniu, z którego ma zostać zwrócony przecięcie row_num i column_num. Pierwszy zaznaczony lub wprowadzony obszar jest numerowany 1, drugi to 2 itd. Jeśli area_num zostanie pominięty, funkcja indeks używa obszaru 1.  Obszary wymienione tutaj muszą znajdować się w jednym arkuszu.  Jeśli określisz obszary, które nie znajdują się na tym samym arkuszu, to spowoduje to #VALUE! .  Jeśli chcesz użyć zakresów znajdujących się w różnych arkuszach, zaleca się użycie formy tablicowej funkcji indeks i użycie innej funkcji w celu obliczenia zakresu tworzącego tablicę.  Możesz na przykład użyć funkcji wybierz, aby obliczyć zakres, który będzie używany.

Jeśli na przykład argument odwołanie zawiera opis komórek (a1: B4, D1: E4, G1: H4), area_num 1 to zakres a1: B4, area_num 2 jest zakresem D1: E4, a area_num 3 to zakres G1: H4.

Spostrzeżenia

  • Po wybraniu określonego zakresu przez odwołanie i area_num row_num column_num wybierz określoną komórkę: row_num 1 jest pierwszym wierszem w zakresie, column_num 1 jest pierwszą kolumną itd. Odwołanie zwrócone za pomocą indeksu jest przecięciem row_num i column_num.

  • Jeśli ustawisz wartość row_num lub column_num na 0 (zero), funkcja INDEKS zwróci odpowiednio odwołanie do całej kolumny lub wiersza.

  • row_num, column_num i area_num muszą wskazywać komórkę w obrębie odwołania; w przeciwnym przypadku funkcja indeks zwraca #REF! . Jeśli row_num i column_num zostaną pominięte, funkcja INDEKS zwróci obszar w odwołaniu określonym przez area_num.

  • W wyniku działania funkcji INDEKS jest uzyskiwane odwołanie, które jest interpretowane jako takie przez inne formuły. W zależności od formuły, wynik zwracany przez funkcję INDEKS może być używany jako odwołanie lub jako wartość. Na przykład formuła KOMÓRKA("szerokość";INDEKS(A1:B2;1;2)) jest równoznaczna z formułą KOMÓRKA("szerokość";B1). Funkcja KOMÓRKA używa wartości zwróconej przez funkcję INDEKS, traktując ją jako odwołanie do komórki. Z drugiej strony, formuły, takie jak 2*INDEKS(A1:B2;1;2), przekształcają wartość zwracaną przez funkcję INDEKS na liczbę zawartą w komórce B1.

Przykłady

Skopiuj przykładowe dane z poniższej tabeli i wklej je w komórce A1 nowego arkusza programu Excel. Aby formuły wyświetlały wyniki, zaznacz je, naciśnij klawisz F2, a następnie naciśnij klawisz Enter.

Owoce

Cena

Liczba

Jabłka

0,69 zł

40

Banany

0,34 zł

38

Cytryny

0,55 zł

15

Pomarańcze

0,25 zł

art

Gruszki

0,59 zł

40

Migdały

2,80 zł

10

Nerkowce

3,55 zł

art

Orzechy ziemne

1,25 zł

20

Orzechy włoskie

1,75 zł

12

Formuła

Opis

Wynik

=INDEKS(A2:C6;2;3)

Przecięcie drugiego wiersza i trzeciej kolumny w zakresie A2:C6, czyli zawartość komórki C3.

38

=INDEKS((A1:C6;A8:C11);2;2;2)

Przecięcie drugiego wiersza i drugiej kolumny w drugim obszarze zakresu A8:C11, czyli zawartość komórki B9.

1,25

=SUMA(INDEKS(A1:C11;0;3;1))

Suma trzeciej kolumny w pierwszym obszarze zakresu A1:C11, czyli suma wartości w zakresie C1:C11.

216

=SUMA(B2:INDEKS(A2:C6;5;2))

Suma zakresu zaczynającego się w komórce B2 i kończącego się na przecięciu piątego wiersza i drugiej kolumny zakresu A2:A6, czyli suma wartości w zakresie B2:B6.

2,42

Początek strony

Zobacz też

WYSZUKAJ.PIONOWO

PODAJ.POZYCJĘ

ADR.POŚR

Wskazówki i przykłady dotyczące formuł tablicowych

Funkcje wyszukiwania i odwołań (informacje)

Uwaga:  Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Czy możesz dać nam znać, czy te informacje były pomocne? Oto angielskojęzyczny artykuł do wglądu.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×