Formuły i funkcje

SUMA, funkcja

Funkcja SUMA

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Funkcja Suma , jedna z funkcji matematycznych i trygonometrycznych, dodaje wartości. Możesz dodać poszczególne wartości, odwołań do komórek lub zakresów lub kombinację wszystkie trzy.

Na przykład:

  • =SUMA(A2:A10)

  • =SUMA(A2:A10;C2:C10)

Przeglądarka nie obsługuje klipu wideo. Instalowanie dodatku Microsoft Silverlight, Adobe Flash Player lub programu Internet Explorer 9.

SUMA(liczba1;[liczba2];...)

Nazwa argumentu

Opis

liczba1    (wymagany)

Pierwsza liczba, którą chcesz dodać. Liczbą może być na przykład 4, odwołanie do komórki, takie jak B6, lub zakres komórek, taki jak B2:B8.

liczba2–255    (opcjonalny)

Druga liczba, którą chcesz dodać. W ten sposób możesz określić do 255 liczb.

W tej sekcji przedstawimy niektóre najważniejsze wskazówki dotyczące pracy z funkcją Suma. Wiele z tych mogą być stosowane do pracy z innymi funkcjami także.

Metoda =1+2 lub =A+B — mimo że można wprowadzić formułę =1+2+3 lub =A1+B1+C2 i uzyskać całkowicie dokładne wyniki, takie metody są podatne na błędy z kilku powodów:

  1. Literówki — załóżmy, że wprowadzasz znacznie więcej i/lub większe wartości, takie jak w następującym przykładzie:

    • =14598,93+65437,90+78496,23

    Spróbuj Sprawdź, czy wpisy są poprawne. Jest znacznie ułatwia umieszczenie tych wartości w poszczególnych komórkach i za pomocą formuły SUMA. Ponadto można formatować wartości, gdy są w komórkach, dzięki czemu można je bardziej czytelny, a następnie, gdy będą w formule.

    Zamiast używania ustalonych wartości w formułach użyj funkcji SUMA. Formuła w komórce D5 to =SUMA(D2:D4)
  2. Błędy #ARG! spowodowane odwołaniem do tekstu zamiast do liczb

    Jeśli korzystasz z formuły tego typu:

    • =A1+B1+C1 lub =A1+A2+A3

    Przykład nieprawidłowego konstruowania formuły. Formuła w komórce D2 to =A2+B2+C2

    Formuły można podzielić w przypadku wartości nieliczbowe (tekst) w komórkach, które zwróci #VALUE! błąd. Suma ignorowanie wartości tekstowe, a następnie umożliwiają sumę tylko wartości liczbowe.

    Prawidłowa budowa formuły. Zamiast =A2+B2+C2 formuła w komórce D2 to =SUMA(A2:C2)
  3. Błąd #ADR! spowodowany usunięciem wierszy lub kolumn

    Błąd #ADR! spowodowany przez usunięcie kolumny. Formuła zmieniła się na =A2+#ADR!+B2

    Jeśli usuniesz wiersz lub kolumnę, formuła nie zostanie zaktualizowana w celu wykluczenia usuniętego wiersza i zwróci błąd #ADR!, gdy funkcja SUMA zostałaby automatycznie zaktualizowana.

    Funkcja SUMA jest automatycznie dopasowywana dla wstawionych lub usuniętych wierszy i kolumn
  4. Formuły nie spowodują zaktualizowania odwołań podczas wstawiania wierszy lub kolumn

    Formuły =A+B+C nie zostaną zaktualizowane, gdy dodasz wiersze

    Jeśli zostanie wstawiony wiersz lub kolumnę, formuła nie powodują aktualizacji do uwzględnienia dodany wiersz, w którym funkcji Suma zostanie automatycznie zaktualizowany (o ile nie jesteś poza zakresem, do których odwołują się formuły). Jest to szczególnie ważne jeśli oczekujesz formule chcesz zaktualizować, a nie jest zaznaczone, jak spowoduje zamknięcie niekompletna wyników, które mogą nie przechwytywać.

    Przykład przedstawia automatyczne rozszerzanie formuły z =SUMA(A2:C2) na =SUMA(A2:D2) po wstawieniu kolumny
  5. Funkcja SUMA z odwołaniami do poszczególnych komórek w porównaniu do zakresów

    Użycie formuły typu:

    • =SUMA(A1;A2;A3;B1;B2;B3)

    Następuje jednakowo błąd podczas wstawiania lub usuwania wierszy w zakresie odwołania z tych samych powodów. Podobnie najlepiej używać poszczególne zakresy, takich jak:

    • =SUMA(A1:A3;B1:B3),

    które będą aktualizowane podczas dodawania lub usuwania wierszy.

Problem

Co się nie udało

Funkcja SUMA pokazuje ciąg ##### zamiast wyniku.

Sprawdź szerokości kolumn. ### zwykle oznacza, że kolumna jest zbyt wąskie, aby wyświetlić wynik formuły.

Funkcja SUMA pokazuje samą formułę jako tekst, a nie wynik.

Upewnij się, że komórka nie jest sformatowana jako tekst. Zaznacz komórkę lub zakres w danym i użyj klawisze Ctrl + 1 , aby wyświetlić okno dialogowe Formatowanie komórek , a następnie kliknij kartę Liczba i wybierz odpowiedni format. Jeśli komórka była sformatowana jako tekst i nie zmienia się po zmianie formatu, może być konieczne używanie F2 > Enter wymusić formatowanie, aby zmienić.

Funkcja SUMA nie powoduje aktualizacji danych.

Upewnij się, że obliczeń jest ustawiona na Automatyczne. Na karcie formuły przejdź do pozycji Opcje obliczania. Aby wymusić arkusza, tak aby obliczyć umożliwia także F9 .

Upewnij się, że ustawienie Obliczanie ma wartość Automatyczne. Na karcie Formuły przejdź do pozycji Opcje obliczania.

Niektóre wartości nie są dodawane.

Do funkcji można dodać tylko wartości liczbowe z odwołania lub zakresu. Puste komórki, wartości logiczne, takie jak PRAWDA, lub tekst są ignorowane.

Zamiast oczekiwanego wyniku jest wyświetlany błąd #NAZWA?

Zazwyczaj oznacza to, że formuła jest błędnie wpisana. np. =sumy(A1:A10) zamiast =SUMA(A1:A10).

Funkcja SUMA pokazuje liczbę całkowitą, a powinna pokazywać miejsca dziesiętne

Sprawdź formatowanie komórek i upewnij się, że opcja wyświetlania miejsc dziesiętnych jest włączona. Zaznacz odpowiednią komórkę lub zakres i użyj klawiszy Ctrl+1, aby wyświetlić okno dialogowe Formatowanie komórek, a następnie kliknij kartę Liczby i wybierz odpowiedni format, pamiętając o określeniu liczby wyświetlanych miejsc dziesiętnych.

  1. Chcę tylko dodać/odjąć/pomnożyć/podzielić liczby Obejrzyj tę serię klipów wideo: Podstawowe obliczenia w programie Excel lub Używanie programu Excel jako kalkulatora.

  2. Jak wyświetlić więcej/mniejszej liczby miejsc dziesiętnych? Można zmienić format numeru. Zaznacz komórkę lub zakres w danym i wyświetlić okno dialogowe Formatowanie komórek , a następnie kliknij kartę liczby i wybierz format, który ma, pamiętając wskazać liczbę miejsc dziesiętnych, które mają za pomocą klawiszy Ctrl + 1 .

  3. Jak dodawać lub odejmować godziny? Możesz dodawać i odejmować godziny na kilka różnych sposobów. Aby na przykład otrzymać różnicę między godzinami 8:00 i 12:00 na potrzeby obliczania płac, należy od godziny zakończenia odjąć godzinę rozpoczęcia przy użyciu formuły =("12:00"-"8:00")*24. Program Excel oblicza godziny w postaci ułamków dnia, więc należy pamiętać o pomnożeniu przez 24, aby uzyskać całkowitą liczbę godzin. W pierwszym przykładzie za pomocą formuły =((B2-A2)+(D2-C2))*24 obliczyliśmy liczbę godzin od początku do końca pomniejszoną o przerwę obiadową (łącznie 8,5 godziny).

    Jeśli chcesz po prostu dodać godziny i minuty i wyświetlić je w ten sposób, możesz je zsumować bez mnożenia przez 24. Dlatego w drugim przykładzie użyliśmy formuły =SUMA(A6:C6), ponieważ potrzebna jest tylko łączna liczba godzin i minut na przydzielone zadania (5:36, czyli 5 godzin i 36 minut).

    Obliczanie godzin

    Aby uzyskać więcej informacji, zobacz: Dodawanie lub odejmowanie godzin

  4. Jak się różnicę między datami? Podobnie jak w przypadku godzin, możliwość dodawania i odejmowania dat. Oto przykład często inwentaryzacji liczbę dni między dwiema datami. Jest tak proste jak = B2 A2. Klucz do pracy z zarówno dat i godzin jest z zakończenia Data i godzina rozpoczęcia, a następnie Odejmij rozpocząć daty/godziny.

    Obliczanie różnic między datami

    Aby uzyskać więcej sposobów pracy z datami, zobacz: Obliczanie liczby dni między dwiema datami

  5. Jak zsumować tylko widoczne komórki? Czasami, gdy wiersze zostały ukryte ręcznie lub użyto Autofiltru do wyświetlania tylko określonych danych, chcemy zsumować tylko widoczne komórki. Można wtedy użyć funkcji SUMY.CZĘŚCIOWE. Jeśli używasz wiersza sumy w tabeli programu Excel, dowolna funkcja wybrana z listy rozwijanej wiersza Suma zostanie automatycznie wprowadzona jako suma częściowa. Więcej informacji na temat sumowania danych w tabeli programu Excel.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Dowiedz się więcej o Suma

Funkcja suma.Jeżeli dodaje tylko wartości spełniające pojedyncze kryterium

Funkcja suma.warunków dodaje tylko wartości, które spełniają wiele kryteriów.

Funkcja LICZ.Jeżeli zlicza tylko wartości spełniające pojedyncze kryterium

LICZ.warunki, funkcja zlicza tylko wartości, które spełniają wiele kryteriów.

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Znajdowanie i poprawianie błędów w formułach

Skróty klawiaturowe w programie Excel dla systemu Windows

Skróty klawiaturowe w programie Excel dla komputerów Mac

Funkcje matematyczne i trygonometryczne

Funkcje programu Excel (lista alfabetyczna)

Funkcje programu Excel (według kategorii)

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×