Eksportowanie danych kształtu do bazy danych

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Jeśli kształty zawierają dane, może zostać uruchomiony Kreator eksportu bazy danych, aby utworzyć tabelę bazy danych, która zawiera dane.

Różnica między Kreator eksportu bazy danych i okno dialogowe, otwieranym za pomocą polecenia Eksportuj do bazy danych to, że za pomocą kreatora można wyeksportować wszystkie kształty na warstwie. Jeśli nie chcesz wyeksportować, warstwy, możesz znaleźć więcej Usprawniona przy użyciu polecenia Eksportuj do bazy danych.

Za pomocą Kreatora eksportu bazy danych

  1. Na karcie Widok > Dodatki > Kształty dodatkowe > Kreator eksportu bazy danych.

  2. Postępuj zgodnie z instrukcjami na stronach kreatora.

    Porady: 

    • Dane kształtu, które są wyświetlane na liście nazwy komórek są poprzedzone Właściwości, np.

    • Po uruchomieniu Kreatora eksportu bazy danych, aby wyeksportować dane kształtu, przechowuje informacje dotyczące eksportowania na stronie rysunku. Jeśli możesz wprowadzić zmiany do kształtów i chcesz ponownie wyeksportuj dane, kliknij prawym przyciskiem myszy stronę rysunku, a następnie wybierz pozycję Eksportuj tabelę bazy danych.

Przy użyciu polecenia Eksportuj do bazy danych

  1. Na karcie Widok > Dodatki > Kształty dodatkowe > Eksportowanie do bazy danych.

  2. Wybierz tabelę bazy danych, której chcesz użyć.

    • Jeśli źródło danych znajduje się w lokalizacji innej niż domyślna, kliknij przycisk Przeglądaj, aby odszukać plik.

    • Aby utworzyć nowe źródło danych, kliknij przycisk Utwórz. Postępuj zgodnie z kreatora Tworzenie nowego źródła danych. Po kliknięciu przycisku Zakończ zostanie wyświetlone okno dialogowe Ustawienia ODBC. Stamtąd możesz wybrać istniejącej bazy danych lub Utwórz nowy. Później utworzysz tabeli w bazie danych.

      Uwagi: 

      • Jeśli korzystasz z programu Excel jako źródła danych, możesz wybrać istniejący skoroszyt, ale nie można utworzyć nowego za pomocą kreatora.

      • Jeśli wybierzesz skoroszytu programu Excel, należy wyczyść pole wyboru tylko do odczytu w oknie dialogowym Wybieranie skoroszytu.

  3. Jeśli baza danych obsługuje właścicieli, na liście właściciela, kliknij nazwę właściciela, aby filtrować listę właścicieli tabeli. Tabela bazy danych zostanie utworzona nazwę, której używasz do logowania się do bazy danych.

  4. Jeśli jest dostępnych wiele baz danych, na liście Kwalifikator kliknij bazę danych, której chcesz użyć.

    Porada: Jeśli korzystasz z programu Access lub Excel, nazwa i lokalizacja bazy danych, do której zostaną wyeksportowane dane są wymienione tutaj.

  5. Na liście Tabela kliknij tabelę bazy danych, której chcesz użyć. Aby utworzyć nową tabelę, wpisz jej nazwę.

  6. Aby zmienić sposób eksportowania danych z komórek arkusza ShapeSheet, wykonaj następujące czynności:

    Dodawanie komórki arkusza ShapeSheet do listy eksportu

    1. Kliknij pozycję Dodaj.

    2. Wybierz komórkę arkusza ShapeSheet, którą chcesz wyeksportować.

    3. W polu Szacowanie jako wybierz typ danych dla wartości przechowywanej w polu bazy danych.

    4. Wybierz pole bazy danych, do którego zostaną skopiowane dane kształtu.

    5. Określ typ danych bazy danych, długość pola i liczbę miejsc dziesiętnych pola bazy danych.

    Zmodyfikować sposób eksportowania danych komórki arkusza ShapeSheet

    1. Zaznacz nazwę komórki i kliknij przycisk Modyfikuj.

    2. Zmień sposób eksportowania danych.

    Usuwanie komórki arkusza ShapeSheet z listy eksportu

    Zaznacz nazwę komórki i kliknij przycisk Usuń.

Za pomocą Kreatora eksportu bazy danych

  1. W menu Narzędzia wskaż polecenie Dodatki, wskaż pozycję Kształty dodatkowe, a następnie kliknij Kreator eksportu bazy danych.

  2. Postępuj zgodnie z instrukcjami na stronach kreatora.

    Porady: 

    • Dane kształtu, które są wyświetlane na liście nazwy komórek są poprzedzone Właściwości, np.

    • Po uruchomieniu Kreatora eksportu bazy danych, aby wyeksportować dane kształtu, przechowuje informacje dotyczące eksportowania na stronie rysunku. Jeśli możesz wprowadzić zmiany do kształtów i chcesz ponownie wyeksportuj dane, kliknij prawym przyciskiem myszy stronę rysunku, a następnie wybierz pozycję Eksportuj tabelę bazy danych.

Przy użyciu polecenia Eksportuj do bazy danych

  1. W menu Narzędzia wskaż polecenie Dodatki, a następnie wskaż pozycję Kształty dodatkowe, a następnie kliknij Eksportowanie do bazy danych.

  2. Wybierz tabelę bazy danych, której chcesz użyć.

    • Jeśli źródło danych znajduje się w lokalizacji innej niż domyślna, kliknij przycisk Przeglądaj, aby odszukać plik.

    • Aby utworzyć nowe źródło danych, kliknij przycisk Utwórz. Postępuj zgodnie z kreatora Tworzenie nowego źródła danych. Po kliknięciu przycisku Zakończ zostanie wyświetlone okno dialogowe Ustawienia ODBC. Stamtąd możesz wybrać istniejącej bazy danych lub Utwórz nowy. Później utworzysz tabeli w bazie danych.

      Uwagi: 

      • Jeśli korzystasz z programu Microsoft Office Excel jako źródła danych, możesz wybrać istniejący skoroszyt, ale nie można utworzyć nowego za pomocą kreatora.

      • Jeśli wybierzesz skoroszytu programu Excel, należy wyczyść pole wyboru tylko do odczytu w oknie dialogowym Wybieranie skoroszytu.

  3. Jeśli baza danych obsługuje właścicieli, na liście właściciela, kliknij nazwę właściciela, aby filtrować listę właścicieli tabeli. Tabela bazy danych zostanie utworzona nazwę, której używasz do logowania się do bazy danych.

  4. Jeśli jest dostępnych wiele baz danych, na liście Kwalifikator kliknij bazę danych, której chcesz użyć.

    Porada: Jeśli korzystasz z programu Microsoft Office Access lub Excel, nazwa i lokalizacja bazy danych, do której zostaną wyeksportowane dane są wymienione tutaj.

  5. Na liście Tabela kliknij tabelę bazy danych, której chcesz użyć. Aby utworzyć nową tabelę, wpisz jej nazwę.

  6. Aby zmienić sposób eksportowania danych z komórek arkusza ShapeSheet, wykonaj następujące czynności:

    Dodawanie komórki arkusza ShapeSheet do listy eksportu

    1. Kliknij pozycję Dodaj.

    2. Wybierz komórkę arkusza ShapeSheet, którą chcesz wyeksportować.

    3. W polu Szacowanie jako wybierz typ danych dla wartości przechowywanej w polu bazy danych.

    4. Wybierz pole bazy danych, do którego zostaną skopiowane dane kształtu.

    5. Określ typ danych bazy danych, długość pola i liczbę miejsc dziesiętnych pola bazy danych.

    Zmodyfikować sposób eksportowania danych komórki arkusza ShapeSheet

    1. Zaznacz nazwę komórki i kliknij przycisk Modyfikuj.

    2. Zmień sposób eksportowania danych.

    Usuwanie komórki arkusza ShapeSheet z listy eksportu

    Zaznacz nazwę komórki i kliknij przycisk Usuń.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×