Dzielenie bazy danych programu Access

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Jeśli baza danych jest współużytkowana przez kilku użytkowników w sieci, należy rozważyć jej podzielenie. Podzielenie udostępnionej bazy danych może poprawić jej wydajność i zmniejszyć ryzyko uszkodzenia pliku bazy danych.

Po podzieleniu bazy danych można się zdecydować na przeniesienie wewnętrznej bazy danych lub na użycie innej wewnętrznej bazy danych. Używaną wewnętrzną bazę danych można zmienić za pomocą Menedżera tabel połączonych.

Uwagi: 

  • Dzielenie bazy danych różni się od archiwizowania bazy danych. W tym temacie nie opisano sposobów archiwizowania danych. Dane archiwizuje się przez okresowe przenoszenie starszych rekordów do innej bazy danych z tego powodu, że rozmiar pliku bazy danych zbyt szybko zbliża się do swojego limitu lub użytkownik chce utrzymać niewielki rozmiar pliku bazy danych oraz uporządkowaną organizację danych według okresu. W pewnych sytuacjach dane można archiwizować przez podzielenie bazy danych. Aby uzyskać więcej informacji, zobacz artykuł w trybie online Archiwizowanie danych programu Access.

  • W razie podziału bazy danych sieci Web znajdujące się w niej tabele sieci Web nie zostaną przeniesione do bazy wewnętrznej, ale nie będą też dostępne z poziomu powstałej bazy zewnętrznej.

W tym artykule

Omówienie

Przed rozpoczęciem

Dzielenie bazy danych

Rozpowszechnianie zewnętrznej bazy danych

Zmienianie używanej wewnętrznej bazy danych

Omówienie

Podczas dzielenia baza danych jest umieszczana w dwóch plikach — wewnętrznej bazie danych zawierającej tabele danych oraz zewnętrznej bazie danych zawierającej wszystkie inne obiekty bazy danych, takie jak kwerendy, formularze i raporty. Każdy użytkownik pracuje z danymi za pomocą lokalnej kopii zewnętrznej bazy danych.

Do dzielenia bazy danych służy Kreator rozdzielacza bazy danych. Po podzieleniu bazy danych należy rozpowszechnić zewnętrzną bazę danych wśród użytkowników.

Przestroga:  Aby chronić dane, jeśli bazy danych ma wielu użytkowników, zaleca się nie udostępniaj kopii bazy danych, która zawiera łącza do list programu SharePoint. Jeśli łączysz się do tabeli, która jest lista programu SharePoint tworzy możliwości dla każdego złośliwego użytkownika zmienić docelowy łącza i potencjalnie modyfikowanie uprawnień w witrynie programu SharePoint, tak jak niezaszyfrowanym informacje o połączeniu dla tabel połączonych.

Zalety dzielenia bazy danych

Zalety podzielenia bazy danych są następujące:

  • Zwiększona wydajność    Wydajność bazy danych zwykle zwiększa się w znacznym stopniu, ponieważ przez sieć są wysyłane tylko dane. W udostępnionej bazie danych, która nie jest podzielona, przez sieć są wysyłane same obiekty bazy danych — tabele, kwerendy, formularze, raporty, makra i moduły — a nie tylko dane.

  • Większa dostępność    Ponieważ przez sieć są wysyłane tylko dane, transakcje bazy danych, takie jak edycje rekordów, są wykonywane szybciej, dzięki czemu dane są w wyższym stopniu dostępne do edycji.

  • Ulepszone zabezpieczenia    Jeśli wewnętrznej bazy danych są przechowywane na komputerze z systemem plików NTFS, możesz ochrona danych za pomocą funkcji zabezpieczeń NTFS. Ponieważ użytkownikom dostęp do wewnętrznej bazy danych przy użyciu tabel połączonych, jest mniejsze prawdopodobieństwo, że intruzów można uzyskania nieautoryzowanego dostępu do danych przez kradzieżom zewnętrzną bazę danych lub stanowiące jako uwierzytelniony użytkownik. Jeśli nie ma pewności, jakiego systemu plików korzysta z serwera plików, poproś administratora systemu. Jeśli masz uprawnienia administratora na serwerze plików, można uruchomić ręcznie określić systemu plików za pomocą polecenia msinfo32.

    Jak sprawdzić system plików za pomocą polecenia msinfo32?

    1. Kliknij przycisk Start, a następnie kliknij polecenie Uruchom.

    2. W oknie dialogowym Uruchamianie wpisz polecenie msinfo32, a następnie kliknij przycisk OK.

    3. W obszarze Podsumowanie systemu kliknij symbol plus obok pozycji Składniki.

    4. W obszarze Składniki kliknij symbol plus obok pozycji Magazyn, a następnie kliknij pozycję Dyski. W prawym panelu okna dialogowego zostaną wyświetlone informacje o dostępnych dyskach.

  • Większa niezawodność    Jeśli użytkownik napotka problem i baza danych zostanie nieoczekiwanie zamknięta, uszkodzenie pliku bazy danych będzie zwykle ograniczone do kopii zewnętrznej bazy danych, która została otworzona przez użytkownika. Ponieważ użytkownik uzyskuje dostęp do danych w wewnętrznej bazie danych tylko za pomocą tabel połączonych, ryzyko uszkodzenia pliku wewnętrznej bazy danych jest znacznie mniejsze.

  • Elastyczne środowisko projektowania    Ponieważ każdy użytkownik pracuje z kopią lokalną zewnętrznej bazy danych, może niezależnie projektować kwerendy, formularze, raporty i inne obiekty bazy danych, nie zakłócając pracy innym użytkownikom. Podobnie można opracować i rozpowszechnić nową wersję zewnętrznej bazy danych bez zakłócania dostępu do danych przechowywanych w wewnętrznej bazie danych.

Początek strony

Przed rozpoczęciem

Przed podzieleniem bazy danych należy rozważyć następujące kwestie:

  • Przed podzieleniem bazy danych zawsze należy wykonać jej kopię zapasową. Jeśli użytkownik podzieli bazę danych, a następnie zdecyduje, że nie chce, aby baza danych była podzielona, może przywrócić oryginał z kopii zapasowej.

  • Dzielenie bazy danych może trwać długi czas. Należy powiadomić użytkowników, aby nie korzystali z bazy danych podczas jej dzielenia. Jeśli inny użytkownik zmieni dane podczas dzielenia bazy danych, te zmiany nie zostaną odzwierciedlone w wewnętrznej bazie danych.

    Porada: Jeśli inny użytkownik zmieni dane podczas dzielenia bazy danych, można zaimportować nowe dane do wewnętrznej bazy danych po zakończeniu operacji dzielenia.

  • Chociaż podzielenie bazy danych jest jednym ze sposobów udostępniania danych, każdy użytkownik korzystający z bazy danych musi mieć program Microsoft Office Access w wersji zgodnej z formatem pliku wewnętrznej bazy danych. Jeśli na przykład plik wewnętrznej bazy danych jest w formacie accdb, użytkownicy nie mogą uzyskiwać dostępu do jej danych za pomocą programu Access 2003.

  • Można używać starszym formacie pliku programu Access do wewnętrznej bazy danych, jeśli używasz funkcji, które nie są już obsługiwane. Na przykład, jeśli korzystasz z strony dostępu do danych (DAPs); nadal można ich używać w przypadku wewnętrznej bazy danych w starszym formacie pliku, który obsługuje DAPs. Następnie służy na nowy format pliku z zewnętrzną bazę danych tak, aby użytkownicy mają dostęp do korzyści wynikających z nowych formatów. Należy zauważyć, że nie można zmienić danych na stronie dostępu do danych za pomocą programu Access 2010 lub nowszy.

Początek strony

Dzielenie bazy danych

  1. Na komputerze utwórz kopię bazy danych, którą chcesz podzielić. Rozpocznij od pliku bazy danych znajdującego się na lokalnym dysku twardym, a nie w udziale sieciowym. Jeśli plik bazy danych jest obecnie udostępniany z lokalnego dysku twardego, możesz go na nim pozostawić.

  2. Otwórz kopię bazy danych znajdującą się na lokalnym dysku twardym.

  3. Na karcie Narzędzia bazy danych w grupie Przenoszenie danych kliknij Bazę danych programu Access. Zostanie uruchomiony Kreator rozdzielacza bazy danych.

  4. Kliknij pozycję Podziel bazę danych.

  5. W oknie dialogowym Utwórz wewnętrzną bazę danych określ nazwę, typ pliku i lokalizację wewnętrznej bazy danych.

    Uwagi: 

    • Należy rozważyć użycie nazwy proponowanej w programie Access. Dzięki temu oryginalna nazwa pliku zostanie zachowana. Ponadto w tej nazwie jest zawarta informacja, że baza danych jest wewnętrzną bazą danych, ponieważ są w niej wstawione litery _be tuż przed rozszerzeniem nazwy pliku.

    • Nie należy zmieniać typu pliku, chyba że niektórzy użytkownicy będą uzyskiwać dostęp do danych za pomocą starszej wersji programu Access.

    • W polu Nazwa pliku przed nazwą pliku można wprowadzić ścieżkę do lokalizacji sieciowej. Jeśli na przykład lokalizacja sieciowa wewnętrznej bazy danych to \\serwer1\udzial1\, a nazwa pliku wewnętrznej bazy danych to MojaBD_be.accdb, w polu Nazwa pliku można wpisać \\serwer1\udzial1\MojaBD_be.accdb.

    • Wybrana lokalizacja musi być dostępna dla wszystkich użytkowników, którzy będą korzystać z bazy danych. Ponieważ mapowania dysków mogą być różne, należy określić ścieżkę UNC lokalizacji bez korzystania z zamapowanej litery dysku.

  6. Po zakończeniu pracy kreator wyświetli komunikat z potwierdzeniem.

Baza danych jest teraz podzielona. Zewnętrzną bazą danych jest plik, od którego cała operacja została rozpoczęta (kopia oryginalnej udostępnionej bazy danych), a wewnętrzna baza danych znajduje się w lokalizacji sieciowej określonej w kroku 5 tej procedury.

Ograniczanie możliwości wprowadzania zmian w projekcie zewnętrznej bazy danych

Aby ograniczyć możliwości wprowadzania zmian w zewnętrznej bazie danych, która będzie rozpowszechniana wśród użytkowników, rozważ zapisanie jej jako skompilowanego pliku binarnego (pliku accde). Skompilowany plik binarny jest plikiem aplikacji bazy danych zapisanym z całym skompilowanym kodem języka Visual Basic Access (VBA). W skompilowanym pliku binarnym programu Access nie pozostaje żaden kod źródłowy języka VBA. Użytkownicy nie mogą zmieniać projektu obiektów w pliku accde.

  1. Otwórz plik zewnętrznej bazy danych (accdb), który chcesz zapisać jako skompilowany plik binarny (accde).

  2. Kliknij pozycję Plik > Zapisz jako > Utwórz plik ACCDE > Zapisz jako.

    Jeśli korzystasz z programu Access 2007 na karcie Narzędzia bazy danych w grupie Narzędzia bazy danych kliknij przycisk Utwórz plik ACCDE.

  3. W oknie dialogowym Zapisywanie jako przejdź do folderu, w którym chcesz zapisać plik, wpisz nazwę pliku w polu Nazwa pliku i kliknij przycisk Zapisz.

Początek strony

Rozpowszechnianie zewnętrznej bazy danych

Po podzieleniu bazy danych należy rozpowszechnić zewnętrzną bazę danych wśród użytkowników, aby mogli zacząć korzystać z tej bazy.

Przestroga:  Aby chronić dane, jeśli bazy danych ma wielu użytkowników, zaleca się nie udostępniaj kopii bazy danych, która zawiera łącza do list programu SharePoint. Jeśli łączysz się do tabeli, która jest lista programu SharePoint tworzy możliwości dla każdego złośliwego użytkownika zmienić docelowy łącza i potencjalnie modyfikowanie uprawnień w witrynie programu SharePoint, tak jak niezaszyfrowanym informacje o połączeniu dla tabel połączonych.

Wykonaj jedną z następujących czynności:

  • Wyślij wiadomość e-mail do użytkowników bazy danych i dołącz do niej plik zewnętrznej bazy danych. Umieść w tej wiadomości wszelkie instrukcje ułatwiające użytkownikom natychmiastowe rozpoczęcie korzystania z zewnętrznej bazy danych.

  • Zapisz plik zewnętrznej bazy danych w lokalizacji sieciowej, do której mają dostęp wszyscy użytkownicy bazy danych, a następnie wyślij użytkownikom wiadomość e-mail z informacją o tej lokalizacji sieciowej oraz ze wszelkimi innymi instrukcjami, które mogą być potrzebne w celu uzyskania dostępu do bazy danych.

  • Rozpowszechnij plik zewnętrznej bazy danych, używając w tym celu nośnika wymiennego, takiego jak dysk CD-ROM czy dysk USB. Jeśli instalujesz ten plik samodzielnie, możesz go przetestować, aby upewnić się, że działa. Jeśli to użytkownicy muszą instalować ten plik, dołącz dokument wyjaśniający czynności, które należy wykonać w celu zainstalowania pliku, oraz zawierający informacje o osobach, z którymi należy się skontaktować w przypadku wystąpienia problemów.

Początek strony

Zmienianie używanej wewnętrznej bazy danych

Korzystając z Menedżera tabel połączonych, można przenieść wewnętrzną bazę danych lub użyć innej wewnętrznej bazy danych.

W celu przeniesienia wewnętrznej bazy danych najpierw należy skopiować ją do nowej lokalizacji, a następnie wykonać poniższą procedurę.

  1. Na karcie Dane zewnętrzne w grupie Importowanie i łączenie kliknij pozycję Menedżer tabel połączonych.

    Jeśli używasz programu Access 2007 na karcie Narzędzia bazy danych w grupie Narzędzia bazy danych kliknij pozycję Menedżer tabel połączonych.

  2. W Menedżerze tabel połączonych zaznacz tabele, które znajdują się w bieżącej wewnętrznej bazie danych.

    Porada: W przypadku braku połączeń z innymi bazami danych należy kliknąć przycisk Zaznacz wszystko.

  3. Zaznacz pole wyboru Zawsze monituj o nową lokalizację, a następnie kliknij przycisk OK.

  4. Przejdź do nowej bazy danych i wybierz ją.

Początek strony

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×