Drukowanie tabeli przestawnej

Uwaga:  Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Drukowanie tabeli przestawnej sposób, w jaki ma być często wymaga przy użyciu kombinacji funkcji drukowania dla arkuszy i tabel przestawnych. Aby korzystać z tych funkcji, musisz mieć tylko jeden raport w arkuszu lub należy ustawić obszar wydruku, która zawiera tylko jeden raport.

Porada: Aby uzyskać najlepsze wyniki, postępuj zgodnie z instrukcjami zawartymi w poniższych sekcjach w podanej kolejności.

Jeśli masz więcej niż jeden raport w formie tabeli przestawnej w arkuszu, ustaw obszar wydruku tak, aby zawierał tylko raport, których chcesz wydrukować.

  1. Kliknij tabelę przestawną.

  2. Na karcie Analiza w grupie Akcje kliknij przycisk Wybierz, a następnie kliknij Całą tabelę przestawną.

  3. Na karcie Układ strony w grupie Ustawienia strony kliknij przycisk Obszar wydruku, a następnie kliknij polecenie Ustaw obszar wydruku.

    Ustaw obszar wydruku

Widok układu strony jest przydatny do przygotowywania danych do wydruku. Na przykład zawiera linijki umożliwiające mierzenie szerokości i wysokości danych oraz pozwala zmieniać orientację strony, dodawać lub zmieniać nagłówki i stopki, ustawiać marginesy do drukowania, a także ukrywać lub wyświetlać nagłówki wierszy i kolumn.

  1. Na karcie Widok w grupie Widoki skoroszytu kliknij przycisk Układ strony.

    Porada: Możesz również kliknąć pozycję Widok układu strony Obraz przycisku na pasku stanu.

  2. Dostosuj układ strony.

Można powtarzać etykiety wierszy i kolumn raportu na każdej drukowanej stronie jako tytuły wydruku. Gdy układ raportu jest zmieniany, tak że etykiety są wyświetlane w innych wierszach i kolumnach arkusza, nowe wiersze i kolumny etykiet są powtarzane automatycznie podczas następnego drukowania raportu.

  1. Na karcie Układ strony w grupie Ustawienia strony kliknij pozycję Tytuły wydruku.

    Tytuły wydruku

  2. W oknie dialogowym Ustawienia strony upewnij się, że pola wyboru U góry powtarzaj wiersze i Z lewej powtarzaj kolumny są wyczyszczone.

  3. Zamknij okno dialogowe Ustawienia strony.

  4. Na karcie Analiza w grupie Tabela przestawna kliknij pozycję Opcje.

  5. W oknie dialogowym Opcje tabeli przestawnej kliknij kartę Drukowanie, a następnie zaznacz pole wyboru Ustaw tytuły wydruku.

  6. Jeśli w raporcie jest więcej niż jedna etykieta wiersza i na każdej stronie mają być powtarzane elementy etykiety wiersza zewnętrznego, zaznacz pole wyboru Powtórz etykiety wierszy na każdej drukowanej stronie.

Jeśli raport ma wiele etykiet wierszy i podział strony znajduje się w obrębie grupy elementów etykiet wierszy, możesz ustawić raport tak, aby automatycznie powtarzał etykiety elementów etykiet zewnętrznych u góry następnej strony raportu. W raporcie z co najmniej dwoma etykietami wierszy wszystkie oprócz skrajnej prawej etykiety są etykietami wierszy zewnętrznych. W poniższym przykładzie raport jest ustawiony tak, aby elementy Wschód i Kw. 2 z etykiet wierszy zewnętrznych Region i Kw. zostały wydrukowane na następnej stronie za podziałem strony.

Drukowanie raportu w formie tabeli przestawnej

1. Podział strony wewnątrz grupy elementów.

2. Etykiety elementów z etykiet wierszy zewnętrznych są powtórzone na stronie 2.

  1. Kliknij prawym przyciskiem myszy etykietę wiersza zewnętrznego zawierającą elementy, które chcesz wydrukować na osobnych stronach, a następnie kliknij pozycję Ustawienia pola w menu skrótów.

  2. W oknie dialogowym Ustawienia pola kliknij kartę Układ i drukowanie.

  3. Zaznacz pole wyboru Wstaw podział strony po każdym elemencie.

W przypadku, gdy chcesz wprowadzić dodatkowe zmiany podziały stron jest dobrym pomysłem, aby zapoznać się z całą tabelę przestawną w Podgląd podziału stron.

  • Na karcie Widok w grupie Widoki skoroszytu kliknij przycisk Podgląd podziału stron.

    Możesz wstawiać nowe ręczne podziały stron oraz przenosić i usuwać automatyczne podziały stron. Aby uzyskać więcej informacji, zobacz Dodawanie, usuwanie lub przenoszenie podziałów stron.

Przyciski rozwijania i zwijania można wydrukować lub nie. Aby zdecydować, czy przyciski rozwijania i zwijania mają zostać wydrukowane, wykonaj następujące czynności:

  • Aby wyświetlanie lub ukrywanie rozwijania i zwijania przycisków w arkuszu, na karcie Analiza w grupie Pokazywanie/ukrywanie kliknij pozycję przycisków +/-.

  • Aby wyświetlić lub ukryć przyciski rozwijania i zwijania w drukowanym raporcie, wykonaj następujące czynności:

    1. Na karcie Analiza w grupie Tabela przestawna kliknij pozycję Opcje.

    2. Kliknij kartę Drukowanie, a następnie zaznacz lub wyczyść pole wyboru Drukuj przyciski rozwijania/zwijania podczas wyświetlania w tabeli przestawnej.

      Uwaga: W przypadku tego pola wyboru wymagane jest włączenie polecenia Przyciski +/- w grupie Pokazywanie/ukrywanie na karcie Opcje.

  1. Aby sprawdzić wersję ostateczną układ wydruku, kliknij Plik > Drukuj i zobaczyć podgląd.

    Skrót klawiaturowy Możesz także nacisnąć klawisze CTRL+F2.

    Dostosować ostateczne stosownie do potrzeb. Aby uzyskać więcej informacji zobacz Wyświetlanie podglądu stron arkusza przed drukowaniem.

  2. Jeśli podgląd wygląda poprawnie, kliknij pozycję Drukuj.

Jeśli masz więcej niż jeden raport w formie tabeli przestawnej w arkuszu, ustaw obszar wydruku tak, aby zawierał tylko raport, których chcesz wydrukować.

  1. Kliknij tabelę przestawną.

  2. Na karcie Opcje w grupie Akcje kliknij polecenie Zaznacz, a następnie kliknij opcję Cała tabela przestawna.

    obraz Wstążki programu Excel

  3. Na karcie Układ strony w grupie Ustawienia strony kliknij przycisk Obszar wydruku, a następnie kliknij polecenie Ustaw obszar wydruku.

    Obraz Wstążki programu Excel

Widok układu strony jest przydatny do przygotowywania danych do wydruku. Na przykład zawiera linijki umożliwiające mierzenie szerokości i wysokości danych oraz pozwala zmieniać orientację strony, dodawać lub zmieniać nagłówki i stopki, ustawiać marginesy do drukowania, a także ukrywać lub wyświetlać nagłówki wierszy i kolumn.

  1. Na karcie Widok w grupie Widoki skoroszytu kliknij przycisk Układ strony.

    Obraz Wstążki

    Porada: Możesz również kliknąć pozycję Widok układu strony Obraz przycisku na pasku stanu.

  2. Dostosuj układ strony.

Można powtarzać etykiety wierszy i kolumn raportu na każdej drukowanej stronie jako tytuły wydruku. Gdy układ raportu jest zmieniany, tak że etykiety są wyświetlane w innych wierszach i kolumnach arkusza, nowe wiersze i kolumny etykiet są powtarzane automatycznie podczas następnego drukowania raportu.

  1. Na karcie Układ strony w grupie Ustawienia strony kliknij pozycję Tytuły wydruku.

    Obraz Wstążki programu Excel

  2. W oknie dialogowym Ustawienia strony upewnij się, że pola wyboru U góry powtarzaj wiersze i Z lewej powtarzaj kolumny są wyczyszczone.

  3. Zamknij okno dialogowe Ustawienia strony.

  4. Na karcie Opcje w grupie Tabela przestawna kliknij przycisk Opcje.

    Obraz Wstążki programu Outlook

  5. W oknie dialogowym Opcje tabeli przestawnej kliknij kartę Drukowanie, a następnie zaznacz pole wyboru Ustaw tytuły wydruku.

  6. Jeśli w raporcie jest więcej niż jedna etykieta wiersza i na każdej stronie mają być powtarzane elementy etykiety wiersza zewnętrznego, zaznacz pole wyboru Powtórz etykiety wierszy na każdej drukowanej stronie.

Jeśli raport ma wiele etykiet wierszy i podział strony znajduje się w obrębie grupy elementów etykiet wierszy, możesz ustawić raport tak, aby automatycznie powtarzał etykiety elementów etykiet zewnętrznych u góry następnej strony raportu. W raporcie z co najmniej dwoma etykietami wierszy wszystkie oprócz skrajnej prawej etykiety są etykietami wierszy zewnętrznych. W poniższym przykładzie raport jest ustawiony tak, aby elementy Wschód i Kw. 2 z etykiet wierszy zewnętrznych Region i Kw. zostały wydrukowane na następnej stronie za podziałem strony.

Drukowanie raportu w formie tabeli przestawnej

1. Podział strony wewnątrz grupy elementów.

2. Etykiety elementów z etykiet wierszy zewnętrznych są powtórzone na stronie 2.

  1. Kliknij prawym przyciskiem myszy etykietę wiersza zewnętrznego zawierającą elementy, które chcesz wydrukować na osobnych stronach, a następnie kliknij pozycję Ustawienia pola w menu skrótów.

  2. W oknie dialogowym Ustawienia pola kliknij kartę Układ i drukowanie.

  3. Zaznacz pole wyboru Wstaw podział strony po każdym elemencie.

W przypadku, gdy chcesz wprowadzić dodatkowe zmiany podziały stron jest dobrym pomysłem, aby zapoznać się z całą tabelę przestawną w Podgląd podziału stron.

  • Na karcie Widok w grupie Widoki skoroszytu kliknij przycisk Podgląd podziału stron.

    Obraz Wstążki

    Porada: Możesz również kliknąć pozycję Podgląd podziału stron Obraz przycisku na pasku stanu.

    Możesz wstawiać nowe ręczne podziały stron oraz przenosić i usuwać automatyczne podziały stron. Aby uzyskać więcej informacji, zobacz Dodawanie, usuwanie lub przenoszenie podziałów stron.

Przyciski rozwijania i zwijania można wydrukować lub nie. Aby zdecydować, czy przyciski rozwijania i zwijania mają zostać wydrukowane, wykonaj następujące czynności:

  • Aby wyświetlić lub ukryć przyciski rozwijania i zwijania w arkuszu, na karcie Opcje w grupie Pokazywanie/ukrywanie kliknij przycisk Przyciski +/-.

    Obraz Wstążki programu Outlook

  • Aby wyświetlić lub ukryć przyciski rozwijania i zwijania w drukowanym raporcie, wykonaj następujące czynności:

    1. Na karcie Opcje w grupie Tabela przestawna kliknij przycisk Opcje.

      Obraz Wstążki programu Outlook

    2. Kliknij kartę Drukowanie, a następnie zaznacz lub wyczyść pole wyboru Drukuj przyciski rozwijania/zwijania podczas wyświetlania w tabeli przestawnej.

      Uwaga: W przypadku tego pola wyboru wymagane jest włączenie polecenia Przyciski +/- w grupie Pokazywanie/ukrywanie na karcie Opcje.

  1. Aby sprawdzić wersję ostateczną układ wydruku, wykonaj następujące czynności:

    • Program Excel 2010: Kliknij pozycję plik > Drukuj.

    • Programu Excel 2007: Kliknij Przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , kliknij strzałkę obok pozycji Drukuj, a następnie kliknij pozycję Podgląd wydruku.

    Skrót klawiaturowy Możesz także nacisnąć klawisze CTRL+F2.

    Dostosować ostateczne stosownie do potrzeb. Aby uzyskać więcej informacji zobacz Wyświetlanie podglądu stron arkusza przed drukowaniem.

  2. Jeśli podgląd wygląda poprawnie, kliknij pozycję Drukuj.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×