Dodawanie, usuwanie i przełączanie widoków (stron) w formularzu

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Projektując różne widoki w formularzu, można udostępnić użytkownikom różne metody przeglądania danych, zależne na przykład od typu tworzonego formularza bądź typu użytkownika korzystającego z formularza. Przykładowe możliwości wynikające ze stosowania wielu widoków:

  • Duży, złożony formularz, taki jak długa ankieta, można uprościć, dzieląc go na wiele stron, po których użytkownicy nawigują, klikając przyciski Dalej i Wstecz.

  • Ten sam formularz można prezentować w różnych wersjach różnym użytkownikom na podstawie ich ról w organizacji. Na przykład na potrzeby przetwarzania roszczeń ubezpieczeniowych można utworzyć widoki ubezpieczonego, agenta i rzeczoznawcy.

  • Można utworzyć widok formularza do druku.

We wszystkich widokach formularza programu InfoPath używane są te same dane. Oznacza to, że jeśli formularz ma dwa widoki i w jednym z nich znajduje się pole tekstowe adresu e-mail, można skopiować to pole do drugiego widoku. Gdy użytkownik wpisze swój adres e-mail w jednym widoku, adres zostanie automatycznie udostępniony w drugim widoku.

W tym artykule

Wprowadzenie do widoków

Sposób interakcji z użytkownikiem

Uwagi dotyczące projektowania

Grupa Widoki na karcie Projekt strony

Dodawanie widoku

Usuwanie widoku

Zmienianie widoku domyślnego

Zmienianie nazwy widoku

Dodawanie przycisku przeznaczonego do przełączania widoków

Wyświetlanie widoku za pomocą reguły ładowania formularza

Wprowadzenie do widoków

Sposób interakcji z użytkownikiem

Domyślnie użytkownicy formularza mogą przełączać widoki, wybierając odpowiedni z nich w grupie Widoki/Widoki strony na wstążce. Na liście wymienione są nazwy wszystkich widoków, a aktywny widok jest wyróżniony. Na liście nie ma tylko tych widoków, dla których w oknie dialogowym Właściwości widoku wyczyszczono pole wyboru Pokaż w menu Widok podczas wypełniania tego formularza.

Jeśli żadna z widoków jest zaznaczona, w grupie Widoki strony na karcie Narzędzia główne nie będą wyświetlane pole wyboru Pokaż w menu Widok podczas wypełniania tego formularza. To jest przydatne w sytuacjach, gdy nie chcesz, użytkownicy będą mieli dostęp do widoków niż ten, który zamierzasz je do wypełniania. Na przykład formularza, który jest używana do zbierania opinii na temat kandydatów może mieć trzy różne role użytkowników skojarzone z nim — jedną dla pracowników działu, jedną dla kandydatów i dla menedżerów. Dla każdej z ról użytkowników można zaprojektować trochę inny widok formularza.

Uwaga: Ukrywanie widoków przed użytkownikami nie jest funkcją zabezpieczeń. Użytkownicy potrafiący uzyskać dostęp do samych danych XML mogą wyświetlić te dane.

Aby uniemożliwić osobom prowadzącym rozmowy kwalifikacyjne przełączanie się do widoków dla pracowników działu personalnego i dla menedżerów, podczas projektowania tych widoków można otworzyć okno dialogowe Właściwości widoku i wyczyścić pole wyboru Pokaż w menu Widok podczas wypełniania tego formularza.

Uwaga: W oknie dialogowym Opcje formularza możliwość przełączanie widoków można wyłączyć dla użytkowników, którzy Wypełnij formularz w przeglądarce sieci Web. Kliknij kartę plik, kliknij pozycję informacje, kliknij polecenie Opcje formularza, a następnie w sekcji Przeglądarki sieci Web, wyczyść pole wyboru widoków.

Środowisko przełączania widoków można dostosować, dodając do formularza przyciski do przełączania widoków zgodnie z opisem podanym w dalszej części tego artykułu.

Uwagi dotyczące projektowania

Zazwyczaj podczas projektowania nowego widoku należy wykonać następujące zadania:

  1. Zaplanowanie widoku.

Zaplanowanie poszczególnych widoków i ich współdziałania z uwzględnieniem następujących zagadnień:

  • Który widok powinien być wyświetlany przy pierwszym uruchomieniu formularza?

  • Czy użytkownicy potrzebują wielu widoków? Jak będą się między nimi przełączać?

  • Czy którykolwiek z widoków powinien być tylko do odczytu?

  • Czy użytkownicy będą drukować jakieś widoki z formularza programu InfoPath?

  • Wypełnienie widoku.

W nowym widoku dodanym do formularza zastosowany jest szablon układu strony. W celu nadania formularzowi struktury można dodać tabele układu za pomocą karty Wstawianie na wstążce, natomiast używając grupy Formanty na karcie Narzędzia główne, można dodać formanty.

Ponadto do nowego widoku można dodać formanty współużytkujące pola z formantami zastosowanymi w innych widokach przez przeciągnięcie odpowiednich pól z okienka zadań Pola.

  1. Dostosowanie środowiska nawigacji.

W jaki sposób użytkownicy mają nawigować po formularzu? Czy użytkownik zorientuje się, do czego służą domyślne polecenia do przełączania widoków? Czy domyślne polecenia są wystarczające, czy też należy umożliwić użytkownikom przełączanie się między widokami przez kliknięcie przycisku wyświetlanego bezpośrednio w formularzu? Czy po kliknięciu przycisku przez użytkownika ma być używany interfejs użytkownika z kartami, czy przyciski Dalej i Wstecz? Czy w przypadku widoków wydruków warto umożliwić użytkownikom jednoczesne drukowanie wszystkich widoków, czy drukowanie tylko aktywnego widoku?

Grupa Widoki na karcie Projekt strony

Na wstążce na karcie Projekt strony znajduje się grupa Widoki, za pomocą której można dodawać i usuwać widoki oraz przełączać się między nimi. Aby dostosować ustawienia i działanie wybranego widoku, należy kliknąć przycisk Właściwości w celu otwarcia okna dialogowego Właściwości widoku.

Ponadto można utworzyć widok wydruku i skojarzyć go z istniejącym widokiem: najpierw należy utworzyć widok wydruku i skonfigurować wyświetlanie go na potrzeby drukowania formularza, a następnie skojarzyć go z istniejącym widokiem w oknie Właściwości widoku. Ponadto w oknie dialogowym Właściwości widoku na kartach Ustawienia strony i Ustawienia wydruku można skonfigurować niestandardowe opcje drukowania widoku wydruku, takie jak nagłówki, stopki czy marginesy stron.

Początek strony

Dodawanie widoku

Poniższa procedura służy do dodawania widoków do formularza.

  1. Kliknij kartę Projekt strony i w grupie Widoki kliknij pozycję Nowy widok.

  2. Wpisz nazwę widoku i kliknij przycisk OK.

Dodawanie, usuwanie i przełączanie widoków w formularzu

  1. Aby otworzyć okno dialogowe Właściwości widoku, kliknij kartę Projekt strony i w grupie Widoki kliknij pozycję Właściwości.

  2. W oknie dialogowym Właściwości widoku zmień lub określ ustawienia bądź opcje widoku, a następnie kliknij przycisk OK.

Dodawanie, usuwanie i przełączanie widoków w formularzu

  1. W obszarze roboczym zaprojektuj widok, dodając do niego tabele układu i formanty.

Jeśli chcesz utworzyć nowy widok na podstawie istniejącego widoku projektu, otwórz istniejący widok, naciśnij Klawisze CTRL + A, aby zaznaczyć cały tekst w widoku i naciśnij Klawisze CTRL + C, aby skopiować zaznaczenie do Schowka. Wybierz nowy widok na liście Widok w grupie Widoki, na karcie Projekt strony, usuń zawartość wstępnie wypełnione w widoku, a następnie naciśnij klawisze CTRL + V, aby wkleić zaznaczenie do nowego widoku.

Początek strony

Usuwanie widoku

Usuniętego widoku nie można odzyskać ani przywrócić. Po usunięciu widoku domyślnego w formularzu, który ma tylko jeden widok, w programie InfoPath jest automatycznie tworzony nowy widok domyślny. Po usunięciu widoku domyślnego z formularza o wielu widokach program InfoPath ustawi jako widok domyślny następny widok na liście Widok na karcie Projekt strony w grupie Widoki.

  1. Na karcie Projekt strony w grupie Widoki z listy Widok wybierz widok do usunięcia.

  2. Na karcie Projekt strony w grupie Widoki kliknij pozycję Usuń.

  3. Po wyświetleniu monitu dotyczącego usunięcia widoku kliknij przycisk Tak.

Początek strony

Zmienianie widoku domyślnego

Każdy formularz ma widok domyślny. Ten widok jest wyświetlany użytkownikom po otwarciu przez nich formularza utworzonego na podstawie danego formularza. W przypadku utworzenia widoków niestandardowych formularza można określić, który z dostępnych widoków ma być widokiem domyślnym dla użytkowników.

  1. Na karcie Projekt strony w grupie Widoki z listy Widok wybierz widok, który ma być widokiem domyślnym.

  2. Na karcie Projekt strony w grupie Widoki kliknij pozycję Właściwości.

  3. Zaznacz pole wyboru Ustaw jako widok domyślny i kliknij przycisk OK.

Jeśli formularz ma tylko jeden widok, automatycznie jest on widokiem domyślnym.

Początek strony

Zmienianie nazwy widoku

  1. Na karcie Projekt strony w grupie Widoki z listy Widok wybierz widok, którego nazwę chcesz zmienić.

  2. Na karcie Projekt strony w grupie Widoki kliknij pozycję Właściwości.

  3. W oknie dialogowym Właściwości widoku wpisz nową nazwę w polu tekstowym Nazwa widoku i kliknij przycisk OK.

Uwaga: Zmiana nazwy widoku skojarzonego z kodem niestandardowym może spowodować, że kod ten nie będzie działał zgodnie z oczekiwaniami. Aby rozwiązać ten problem, należy znaleźć w kodzie wszystkie odwołania do starej nazwy tego widoku i zaktualizować je zgodnie z nową nazwą widoku.

Początek strony

Dodawanie przycisku przeznaczonego do przełączania widoków

Widoki są często projektowane do współdziałania z regułami. Reguły umożliwiają automatyzowanie określonych zadań w reakcji na zdarzenia lub akcje inicjowane przez osobę wypełniającą formularz. Można na przykład utworzyć regułę przełączającą widoki w wyniku kliknięcia przycisku, wstawić do formularza przycisk i skojarzyć z nim tę regułę.

Bardziej szczegółowo w formularza roszczeń ubezpieczeniowych, możesz utworzyć otwartym szczegółowego widoku danych roszczeń po kliknięciu przycisku Pokaż podsumowanie. W widoku podsumowania użytkowników można następnie kliknij przycisk Pokaż szczegóły, aby powrócić do widoku bardziej szczegółowe. Analogicznie jeśli masz bardzo długa formularza, można podzielić je na wiele widoków i dodawania dalej i Wstecz przycisków lub kartach nawigacji , aby umożliwić użytkownikom poruszanie się po formularzu.

  1. Wstaw przyciski w poszczególnych widokach.

Do wykonania poniższej procedury potrzebny jest formularz z dwoma istniejącymi widokami.

  1. Na karcie Projekt strony w grupie Widoki z listy Widok wybierz widok, do którego chcesz dodać przycisk.

  2. Umieść kursor w formularzu w obszarze, gdzie chcesz wstawić przycisk.

  3. Na karcie Narzędzia główne w grupie Formanty wybierz pozycję Przycisk.

  4. Na wstążce w obszarze Narzędzia formantów kliknij kartę Właściwości.

  5. W polu Etykieta wpisz nazwę przycisku i kliknij przycisk OK.

  • Utwórz regułę przełączającą widoki.

    1. Zaznacz przycisk.

    2. W obszarze Narzędzia formantów na karcie Właściwości w grupie Reguły kliknij pozycję Dodaj regułę.

      Dodawanie, usuwanie i przełączanie widoków w formularzu

    3. Wybierz pozycję Po kliknięciu tego przycisku, a następnie z listy Akcje wybierz pozycję Przełącz widoki.

    4. W polu tekstowym Widok wybierz widok, który ma być wyświetlany po kliknięciu tego przycisku, a następnie kliknij przycisk OK.

      Dodawanie, usuwanie i przełączanie widoków w formularzu

  • Powtarzaj kroki 1 i 2 w celu utworzenia kolejnych przycisków i odpowiadających im reguł dla poszczególnych widoków.

  • Po dodaniu przycisków do widoków i utworzeniu niezbędnych reguł zaleca się przetestowanie formularza w celu upewnienia się, że działa on zgodnie z oczekiwaniami.

  • Na karcie Narzędzia główne w grupie Formularz kliknij pozycję Podgląd.

  • Klikaj przyciski, aby upewnić się, że widoki są przełączane zgodnie z oczekiwaniami.

    W oknie podglądu wyświetlany jest widok, w którym ostatnio pracowano, chyba że utworzono regułę przełączającą widok na podstawie roli użytkownika podczas ładowania formularza.

Uwaga: W widokach tylko do odczytu przyciski nie są dostępne. Nawigację w widokach tylko do odczytu, takich jak Widok wyświetlania formularza listy programu SharePoint przy użyciu przycisku obraz, a następnie wyczyść pole wyboru Ukryj przycisk obrazu w widoki tylko do odczytu w oknie dialogowym właściwości formantu w oknie Właściwości na karcie wstążki.

Początek strony

Wyświetlanie widoku za pomocą reguły ładowania formularza

Widok wyświetlany po otwarciu formularza przez użytkownika może być dostosowany do tego użytkownika lub innych kryteriów. W przypadku projektowania formularza uwzględniającego role użytkowników i zawierającego wiele widoków dobrym rozwiązaniem może być wyświetlanie widoku zależnego od roli przypisanej użytkownikowi. W tym celu można zastosować regułę wyświetlającą konkretny widok po otwarciu formularza bazującego na danym formularzu przez użytkownika z przypisaną określoną rolą.

Role użytkowników można używać tylko w formularzach przeznaczonych dla InfoPath filler. Aby przełączyć widoki oparte na członkostwa w grupach dla sieci web włączone formularzy, rozważ utworzenie reguły Ładowania formularza korzystającego z metody getUserMemberships Usługi sieci Web profilu użytkownika, aby określić członkostwo użytkownika.

W tej procedurze założono, że w formularzu zdefiniowano rolę użytkownika. Jeśli w formularzu w ogóle nie ma ról użytkowników, przed rozpoczęciem tej procedury należy dodać rolę użytkownika za pomocą karty Dane.

  1. Na karcie Dane w grupie Reguły kliknij pozycję Ładowanie formularza.

  2. Kliknij pozycję Nowa, kliknij pozycję Akcja, a następnie w polu tekstowym Szczegóły dla wprowadź nazwę reguły.

  3. Aby formularz ładował widok na podstawie roli użytkownika, kliknij łącze w sekcji Warunek. Na pierwszej liście kliknij pozycję Bieżąca rola użytkownika i wybierz rolę użytkownika.

Można wybrać inne opcje, zależnie od warunków, jakie mają wpływać na sposób ładowania formularza.

Dodawanie, usuwanie i przełączanie widoków w formularzu

  1. Kliknij przycisk OK.

  2. Kliknij przycisk Dodaj i wybierz pozycję Przełącz widoki.

Dodawanie, usuwanie i przełączanie widoków w formularzu

  1. Na liście Widoki kliknij odpowiedni widok i kliknij przycisk OK.

Początek strony

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×