Dodawanie połączenia danych w bazie danych programu Microsoft SQL Server

Uwaga:  Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Pomocniczego połączenia danych można dodać do szablonu formularza, który wykonuje kwerendę bazy danych programu Microsoft SQL Server. Pomocniczego połączenia danych nie można dodać do szablonu formularza, który przesyła danych formularza do bazy danych. Jeśli chcesz przesyłanie danych formularza do bazy danych za pomocą pomocniczego połączenia danych, należy użyć pomocniczego połączenia danych do usługi sieci Web, która odpowiada z tą bazą danych. Łącza do dodatkowych informacji o dodawaniu pomocniczego połączenia danych do usługi sieci Web, w sekcji Zobacz też.

Aby można było dodać pomocniczego połączenia danych do bazy danych, wykonaj następujące czynności:

Krok 1: Dodawanie pomocniczego połączenia danych do szablonu formularza    Spowoduje to utworzenie pomocnicze źródło danych z odpowiednich pól i grup według tak, że dane są przechowywane w bazie danych. Można również skonfigurować szablon formularza, aby umożliwić formularzy dla tego połączenia danych po pierwszym otwarciu formularza.

Krok 2: Konfigurowanie szablonu formularza w celu połączenia danych za pomocą    Jeśli chcesz, aby użytkownicy mogli korzystać z tego połączenia danych po otwarciu formularza, możesz dodać regułę lub przycisku do szablonu formularza, aby zezwolić użytkownikom na pobieranie danych z tego połączenia danych.

W tym artykule

Omówienie

Przed rozpoczęciem

Krok 1: Dodawanie pomocniczego połączenia danych

Krok 2: Konfigurowanie szablonu formularza do używania połączenia danych

Omówienie

Po utworzeniu szablonu formularza, oparty na zewnętrznym źródłem danych programu Microsoft Office InfoPath tworzy głównym połączenie danych do tego źródła danych zewnętrznych. Program InfoPath tworzy następnie głównego źródła danych dla szablonu formularza oparte na tak, że dane są przechowywane w zewnętrznym źródle danych. Jednak z zewnętrznym źródłem danych używane w głównego połączenia danych może nie ma wartości, które mają być umieszczone w formantach w szablonie formularza. Te wartości mogą istnieć w innym zewnętrznym źródłem danych, takich jak inną bazę danych programu SQL Server. Aby uzyskać wartości z innego źródła danych zewnętrznych, możesz dodać pomocniczego połączenia danych do szablonu formularza.

Pomocniczego połączenia danych jest połączenia danych, które możesz dodać do szablonu formularza. To połączenie danych może być połączenie danych kwerendy lub połączenia przesyłania danych. Połączenie danych kwerendy można dodać do szablonu formularza, tylko jako pomocniczego połączenia z bazą danych programu SQL Server. Możesz dodać to połączenie danych tylko wtedy, gdy potrzebne są dane z zewnętrznego źródła danych innego niż w głównego połączenia danych. Nie możesz dodać połączenia przesyłania danych do bazy danych programu SQL Server jako pomocniczego połączenia danych.

Po dodaniu połączenia danych kwerendy do bazy danych programu InfoPath tworzy pomocniczej źródło danych z pól i grup, które odpowiadają w sposób przechowywania danych w bazie danych. Struktura danych w pomocnicze źródło danych musi być zgodna tak, że dane są przechowywane w tabelach bazy danych, nie można zmodyfikować pola lub grupy w pomocnicze źródło danych. Możesz skonfigurować każdego połączenia danych zapytania, aby zapisać wyniki, tak aby użytkownicy mają dostęp do danych, gdy ich formularza nie jest połączony z siecią. W zależności od rodzaju danych można wyświetlić wyniki kwerendy tylko wtedy, gdy użytkownicy są połączeni z siecią.

Uwaga dotycząca zabezpieczeń: Jeśli korzystasz z pomocniczego połączenia danych do pobierania danych poufnych z zewnętrznego źródła danych, można wyłączyć tę funkcję w celu ochrony danych przed nieautoryzowanym użyciem w przypadku, gdy komputer jest utraconych lub kradzież. Jeśli wyłączysz tę funkcję, dane będą dostępne tylko wtedy, gdy użytkownik jest połączony z siecią.

Po dodaniu połączenia danych kwerendy do szablonu formularza domyślnie formularze, które są oparte na tym szablonie formularza za pomocą połączenia danych po otwarciu przez użytkownika. Można również skonfigurować szablonu formularza za pomocą kwerendy połączenia danych w jednym z następujących sposobów:

  • Dodawanie reguły    Można skonfigurować regułę przy każdym wystąpieniu warunku w regule za pomocą połączenia danych kwerendy.

  • Przycisk Dodaj    Możesz dodać przycisk do szablonu formularza, który można kliknąć, aby pobrać dane przy użyciu kwerendy połączenia danych.

  • Używanie kodu niestandardowego    Jeśli nie możesz dodawać reguły lub przycisku, możesz za pomocą kodu niestandardowego pobieranie danych przy użyciu kwerendy połączenia danych. Za pomocą kodu niestandardowego wymaga dewelopera utworzyć niestandardowy kod.

Początek strony

Zanim rozpoczniesz

Przed dodaniem pomocniczego połączenia danych w bazie danych programu SQL Server do szablonu formularza z administratorem bazy danych jest potrzebny następujące informacje:

  • Nazwa serwera z bazy danych, którego będziesz używać za pomocą tego szablonu formularza.

  • Nazwa bazy danych, którego będziesz używać za pomocą tego szablonu formularza.

  • Uwierzytelnianie, wymagane przez bazę danych. Baza danych można określić, jak użytkownicy mogą uzyskiwać dostęp do bazy danych za pomocą uwierzytelniania Microsoft Windows lub uwierzytelnianie programu SQL Server.

  • Nazwa tabeli zawierającej dane, które chcesz wysłać do formularza. To jest tabela podstawowa. Jeśli zamierzasz użyć więcej niż jednej tabeli w bazie danych, należy nazwiska innych osób, tabele podrzędne. Należy również nazw pól w tabelach podrzędne mające relacje do pól w tabeli podstawowej.

  • Czy można bezpiecznie przechowywać wyniki kwerend w formularzu w trybie offline.

Początek strony

Krok 1: Dodawanie pomocniczego połączenia danych

  1. W menu Narzędzia kliknij polecenie Połączenia danych.

  2. W oknie dialogowym Połączenia danych kliknij przycisk Dodaj.

  3. W Kreatorze połączenia danych kliknij przycisk Utwórz nowe połączenie, kliknij opcję Odbierz dane, a następnie kliknij przycisk Dalej.

  4. Na następnej stronie kreatora kliknij bazy danych (Microsoft SQL Server lub Microsoft Office Access tylko), a następnie kliknij przycisk Dalej.

  5. Na następnej stronie kreatora kliknij przycisk Wybierz bazę danych.

  6. W oknie dialogowym Wybieranie źródła danych kliknij Nowe źródło.

  7. Na liście Jakiego rodzaju źródła danych chcesz nawiązać połączenie kliknij pozycję Microsoft SQL Server, a następnie kliknij przycisk Dalej.

  8. W polu Nazwa serwera wpisz nazwę serwera z bazą danych.

  9. W obszarze poświadczenia logowania wykonaj jedną z następujących czynności:

    • Jeśli baza danych określa, kto ma dostęp na podstawie poświadczeń używanych w sieci Microsoft Windows, kliknij pozycję Użyj uwierzytelniania systemu Windows.

    • Jeśli baza danych określa, kto ma dostęp na podstawie określonej nazwy użytkownika i hasła, pobranego z administratorem bazy danych, kliknij opcję Użyj następujących nazwę użytkownika i hasło, a następnie wpisz swoją nazwę użytkownika i hasło w polu Nazwa użytkownika i Hasło pola.

  10. Kliknij przycisk Dalej.

  11. Na następnej stronie kreatora na liście Wybierz bazę danych, która zawiera dane, które chcesz kliknij bazę danych, którą chcesz użyć, zaznacz pole wyboru Połącz z określonej tabeli, kliknij nazwę tabeli podstawowej i kliknij przycisk Dalej.

  12. Na następnej stronie kreatora, w polu Nazwa pliku wpisz nazwę pliku, w którym przechowywane są informacje o połączeniu danych.

  13. Aby zapisać te ustawienia, kliknij przycisk Zakończ.

  14. Dodawanie innych tabel, których chcesz użyć w połączeniu danych kwerendy.

    Jak to zrobić?

    1. Kliknij przycisk Dodaj tabeli.

    2. W oknie dialogowym Dodawanie tabeli lub kwerendy kliknij nazwę tabeli podrzędnej, a następnie kliknij przycisk Dalej. Program InfoPath próbuje ustawić relacje dopasowując nazwy pól w obu tabelach. Jeśli nie chcesz używać sugerowane relacji, wybierz relację, a następnie kliknij Usuwanie relacji. Aby dodać relację, kliknij pozycję Dodaj relację. W oknie dialogowym Dodaj relację kliknij nazwę każdego pola pokrewne w odpowiedniej kolumnie, a następnie kliknij przycisk OK.

    3. Kliknij przycisk Zakończ.

    4. Aby dodać dodatkowe podrzędne tabel, powtórz te kroki.

  15. Kliknij przycisk Dalej.

  16. Aby udostępnić wyniki kwerendy połączenia danych, gdy formularz nie jest połączony z siecią, zaznacz pole wyboru Przechowaj kopię danych w szablonie formularza.

    Uwaga dotycząca zabezpieczeń: Zaznaczenie tego pola wyboru przechowuje dane na komputerze użytkownika, gdy formularz używa tego połączenia danych. Jeśli formularz poufne dane z tego połączenia danych, można wyłączyć tę funkcję w celu ochrony danych w przypadku, gdy komputer jest utraconych lub kradzież.

  17. Kliknij przycisk Dalej.

  18. Na następnej stronie kreatora wpisz opisową nazwę dla tego połączenia danych pomocniczej. Jeśli chcesz formularza w celu odbioru danych automatycznie, gdy formularz jest otwarty, zaznacz pole wyboru automatycznie Pobierz dane po otwarciu formularza.

Początek strony

Krok 2: Konfigurowanie szablonu formularza do używania połączenia danych

Chcesz formularze na podstawie tego szablonu formularza dla tego połączenia danych po otwarciu formularza, można dodać regułę do szablonu formularza, który używa tego połączenia danych w określonych warunkach, czy można dodać przycisk do szablonu formularza, że użytkownicy mogą polecenie k dla tego połączenia danych.

Dodawanie reguły

Szablon formularza, aby pobrać dane z kwerendy połączenia danych, gdy spełnienia warunku reguły można dodać regułę. W poniższej procedurze przyjęto, że utworzono połączenie danych kwerendy dla szablonu formularza i skonfigurowano formantu w szablonie formularza, aby wyświetlić dane z tego połączenia danych.

  1. Jeśli szablon formularza zawiera wiele widoków, kliknij nazwę widoku, w menu Widok, aby przejść do widoku z formantem, w którym chcesz wyświetlić dane z pomocnicze źródło danych.

  2. Kliknij dwukrotnie formant, do którego chcesz dodać regułę.

  3. Kliknij kartę Dane.

  4. W obszarze Sprawdzanie poprawności i reguły kliknij przycisk reguły.

  5. W oknie dialogowym reguły kliknij przycisk Dodaj.

  6. W polu Nazwa wpisz nazwę reguły.

  7. Aby określić warunek, kiedy będzie uruchamiane reguły, kliknij przycisk Ustaw warunek, a następnie wprowadź warunek. Reguła zostanie uruchomiona, gdy wystąpi warunek. Jeśli warunek nie jest ustawiona, reguła zostanie uruchomiona, gdy użytkownik zmieni się wartość w formancie i przenosi własnego kursor poza tego formantu.

  8. Kliknij pozycję Dodaj akcję.

  9. Na liście akcji kliknij kwerendy przy użyciu połączenia danych.

  10. Na liście połączenia danych kliknij połączenie danych kwerendy, którego chcesz użyć, a następnie kliknij przycisk OK, aby zamknąć poszczególne otwarte okna dialogowe.

  11. Aby sprawdzić wprowadzone zmiany, kliknij pozycję Podgląd na pasku narzędzi Standardowy lub naciśnij klawisze CTRL+SHIFT+B.

Dodawanie przycisku

Formant przycisku można dodać do szablonu formularza, który użytkownicy mogą kliknąć, aby pobieranie danych z połączenia danych kwerendy.

  1. Jeśli szablon formularza zawiera wiele widoków, kliknij nazwę widoku, w menu Widok, aby przejść do widoku z formantem, w którym chcesz wyświetlić dane z pomocnicze źródło danych.

  2. Jeśli okienko zadań Kontrolki nie jest widoczne, kliknij pozycję Więcej kontrolek w menu Wstawianie lub naciśnij klawisze ALT + I, a następnie klawisz C.

  3. Przeciągnij formant przycisku na szablonie formularza.

  4. Kliknij dwukrotnie formant przycisku, który właśnie dodany do szablonu formularza.

  5. Kliknij kartę Ogólne.

  6. Na liście akcji kliknij przycisk Odśwież.

  7. W polu Etykieta wpisz nazwę, która ma być wyświetlany na przycisku w szablonie formularza.

  8. Kliknij przycisk Ustawienia.

  9. W oknie dialogowym odświeżanie kliknij jedno pomocnicze źródło danych.

  10. Na liście Wybierz pomocnicze źródło danych kliknij pomocnicze źródło danych skojarzonego z kwerendy połączenia danych.

  11. Klikaj przyciski OK, aby zamknąć poszczególne otwarte okna dialogowe.

  12. Aby sprawdzić wprowadzone zmiany, kliknij pozycję Podgląd na pasku narzędzi Standardowy lub naciśnij klawisze CTRL+SHIFT+B.

Początek strony

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×