Dodawanie połączenia danych do usługi sieci Web

Uwaga:  Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Co najmniej jeden pomocniczych połączeń danych można dodać do szablonu formularza, który może kwerendy lub przesyłanie danych do usługi sieci Web.

W tym artykule

Omówienie

Informacje dotyczące zgodności

Przed rozpoczęciem

Dodawanie połączenia danych kwerendy

Dodawanie połączenia przesyłania danych

Omówienie

Pomocniczego połączenia danych jest wszystkie połączenia danych z zewnętrznego źródła danych dodany do szablonu formularza. To połączenie danych różni się od głównego połączenia danych utworzony podczas projektowania szablonu formularza na podstawie bazy danych, usługi sieci Web lub ustawień w bibliotece połączeń. Możesz dodać pomocniczego połączenia danych tylko wtedy, gdy nie można kwerendy lub przesyłania danych głównego połączenia danych.

Po dodaniu pomocniczego połączenia danych do szablonu formularza danych kwerendy, program Microsoft Office InfoPath tworzy pomocniczej źródło danych z pola danych oraz grupy odpowiadający schemat XML usługi sieci Web. Struktura danych w pomocnicze źródło danych musi być zgodna schematu XML, nie można zmodyfikować istniejące pola lub grupy w pomocnicze źródło danych. Po dodaniu połączenia przesyłania danych do szablonu formularza skonfigurować szablon formularza, aby umożliwić użytkownikom przesyłanie danych formularza, a następnie skonfiguruj opcje przesyłania formularzy, które są oparte na szablonie formularza.

Początek strony

Informacje dotyczące zgodności

Nie można skonfigurować połączenia przesyłania danych w szablon formularza zgodny z przeglądarką umożliwia użytkownikom przesyłanie zmiany informacji wraz z ich danych formularza do usługi sieci Web, która akceptuje DataSet ADO.NET firmy Microsoft. Zmienianie informacji o składa się z zmian, które użytkownik wprowadza dane przechowywane w bazie danych. Baza danych używa usługi sieci Web do połączenia z bazą danych użytkowników. ADO.NET umożliwia zmienianie informacji o dowiedzieć się, jak zaktualizować dane w bazie danych. Poproś administratora usługi sieci Web, czy usługi sieci Web wymaga Zmień informacje o aktualizacji bazy danych. Jeśli tak, czy projektowanie szablonu formularza, którego formularze można wypełniać tylko za pomocą programu InfoPath.

Początek strony

Zanim rozpoczniesz

Przed dodaniem pomocniczego połączenia danych do szablonu formularza jest potrzebny następujące informacje dotyczące administratora usługi sieci Web:

  • Lokalizacja usługi sieci Web.

  • Sprawdzanie usługi sieci Web używanego dokumentu i literałów styl kodowania. Program InfoPath mogą używać tylko dokumentu i literałów usług sieci Web styl.

  • Nazwa operację usługi sieci Web, która będzie Wyślij dane do lub odbierać dane z formularzy opartych na tym szablonie formularza.

Początek strony

Dodawanie połączenia danych kwerendy

Aby zezwolić użytkownikom zbadać danych z usługi sieci Web przy użyciu szablonu formularza, należy wykonać następujące czynności w szablonie formularza:

  1. Dodawanie pomocniczego połączenia danych.

  2. Konfigurowanie szablonu formularza do używania pomocniczego połączenia.

Krok 1: Dodawanie pomocniczego połączenia danych

  1. W menu Narzędzia kliknij polecenie Połączenia danych.

  2. W oknie dialogowym Połączenia danych kliknij przycisk Dodaj.

  3. W Kreatorze połączenia danych kliknij przycisk Utwórz nowe połączenie, kliknij opcję Odbierz dane, a następnie kliknij przycisk Dalej.

  4. W obszarze, z której chcesz się odbierania danych kliknij pozycję Usługa sieci Web, a następnie kliknij przycisk Dalej.

  5. Na następnej stronie kreatora wpisz lokalizację usługi sieci Web, a następnie kliknij przycisk Dalej.

    Uwaga: Jeśli chcesz wyszukać usługi sieci Web przy użyciu serwera uniwersalny odnajdowanie opis i Integration (UDDI), kliknij przycisk Przeszukaj zasoby, wprowadź adres URL serwera UDDI, który chcesz wyszukać, określ, czy wyszukiwanie według dostawcy lub usługa pod warunkiem, wprowadź słowo kluczowe wyszukiwania, a następnie kliknij przycisk Wyszukaj. Usługi sieci Web, które są zgodne z słowo kluczowe wyszukiwania pojawią się na liście wyników wyszukiwania. Wybierz usługę sieci Web, którego chcesz użyć, a następnie kliknij przycisk OK.

  6. Na liście Wybierz operacji na następnej stronie kreatora kliknij operację usługi sieci Web, która zwraca dane w formularzu, a następnie kliknij przycisk Dalej.

  7. Jeśli Kreator połączenia danych napotka nieznany element w schemacie usługi sieci Web, następnej stronie kreatora może wymagać określenie wartości przykładowych dla każdego parametru określić, jaki pola lub grupy, aby dodać do głównego źródła danych.

    Jak to zrobić?

    1. Wybierz parametr w tabeli Parametry, a następnie kliknij Ustaw przykładową wartość.

    2. W polu wartość próbki wpisz wartość, że użytkownika może użyć dla tego pola, a następnie kliknij przycisk OK.

    3. Powtórz te czynności dla każdego parametru w tabeli Parametry, a następnie kliknij przycisk Dalej.

    Szczegóły techniczne

    Po skonfigurowaniu połączenia danych z usługi sieci Web w Kreatorze połączenia danych programu Microsoft Office InfoPath nawiązuje połączenie z usługą sieci Web i żąda pliku Web Service Description Language (WSDL). Plik języka WSDL zawiera schematu używane przez usługę sieci Web. Usługa sieci Web odpowiada na żądanie, wysyłając ten plik do programu InfoPath. Program InfoPath używa informacji w tym pliku dodać odpowiednie pola i grupy do pomocnicze źródło danych w szablonie formularza. Jeśli program InfoPath znajdzie typu nieznany element w pliku WSDL, InfoPath używa przykładowych danych w celu określenia definicji typu nieznany element i następnie dodaje odpowiednich pól i grup pomocnicze źródło danych.

  8. Jeśli chcesz wyników kwerendy, aby był dostępny, gdy formularz nie jest połączony z siecią, zaznacz pole wyboru Przechowaj kopię danych w szablonie formularza.

    Uwaga dotycząca zabezpieczeń: Zaznaczenie tego pola wyboru przechowuje wyników kwerendy w szablonie formularza. Ponieważ dane są przechowywane w szablonie formularza, jest dostępny w formularzach, które wypełniania przez użytkowników, nawet jeśli ich komputery nie są połączone z siecią. Jeśli występują poufne dane z tego połączenia danych, można wyłączyć tę funkcję w celu ochrony danych w przypadku, gdy komputer jest utraconych lub kradzież.

  9. Kliknij przycisk Dalej.

  10. Na następnej stronie kreatora wpisz opisową nazwę połączenia danych kwerendy.

  11. Aby włączyć formularzy opartych na tym szablonie formularza, aby automatycznie odbierać dane po otwarciu, zaznacz pole wyboru automatycznie Pobierz dane po otwarciu formularza.

  12. Zweryfikuj poprawność informacji w sekcji Podsumowanie, a następnie kliknij przycisk Zakończ.

  13. Kliknij przycisk Zamknij.

Krok 2: Konfigurowanie pomocniczego połączenia danych za pomocą szablonów formularzy

Po dodaniu połączenia danych kwerendy do szablonu formularza domyślnie formularze, które są oparte na tym szablonie formularza za pomocą połączenia danych po otwarciu przez użytkownika. Można również skonfigurować szablonu formularza za pomocą kwerendy połączenia danych w jednym z następujących sposobów:

  • Dodawanie reguły    Można skonfigurować regułę przy każdym wystąpieniu warunku w regule za pomocą połączenia danych kwerendy.

  • Przycisk Dodaj    Możesz dodać przycisk do szablonu formularza, który można kliknąć, aby pobrać dane przy użyciu kwerendy połączenia danych.

  • Używanie kodu niestandardowego    Jeśli nie możesz dodawać reguły lub przycisku, możesz za pomocą kodu niestandardowego pobieranie danych przy użyciu kwerendy połączenia danych. Za pomocą kodu niestandardowego wymaga dewelopera utworzyć niestandardowy kod.

Dodawanie reguły

Szablon formularza, aby pobrać dane z kwerendy połączenia danych, gdy spełnienia warunku reguły można dodać regułę. W poniższej procedurze przyjęto, że utworzono połączenie danych kwerendy dla szablonu formularza i skonfigurowano formantu w szablonie formularza, aby wyświetlić dane z tego połączenia danych.

  1. Jeśli szablon formularza zawiera wiele widoków, kliknij nazwę widoku, w menu Widok, aby przejść do widoku z formantem, w którym chcesz wyświetlić dane z pomocnicze źródło danych.

  2. Kliknij dwukrotnie formant, do którego chcesz dodać regułę.

  3. Kliknij kartę Dane.

  4. W obszarze Sprawdzanie poprawności i reguły kliknij przycisk reguły.

  5. W oknie dialogowym reguły kliknij przycisk Dodaj.

  6. W polu Nazwa wpisz nazwę reguły.

  7. Aby określić warunek, kiedy będzie uruchamiane reguły, kliknij przycisk Ustaw warunek, a następnie wprowadź warunek. Reguła zostanie uruchomiona, gdy wystąpi warunek. Jeśli warunek nie jest ustawiona, reguła zostanie uruchomiona, gdy użytkownik zmieni się wartość w formancie i przenosi własnego kursor poza tego formantu.

  8. Kliknij pozycję Dodaj akcję.

  9. Na liście akcji kliknij kwerendy przy użyciu połączenia danych.

  10. Na liście połączenia danych kliknij połączenie danych kwerendy, którego chcesz użyć, a następnie kliknij przycisk OK, aby zamknąć poszczególne otwarte okna dialogowe.

  11. Aby sprawdzić wprowadzone zmiany, kliknij pozycję Podgląd na pasku narzędzi Standardowy lub naciśnij klawisze CTRL+SHIFT+B.

Dodawanie przycisku

Formant przycisku można dodać do szablonu formularza, który użytkownicy mogą kliknąć, aby pobieranie danych z połączenia danych kwerendy. W poniższej procedurze przyjęto, że utworzono połączenie danych kwerendy dla szablonu formularza.

  1. Jeśli szablon formularza zawiera wiele widoków, kliknij nazwę widoku, w menu Widok, aby przejść do widoku z formantem, w którym chcesz wyświetlić dane z pomocnicze źródło danych.

  2. Jeśli okienko zadań Kontrolki nie jest widoczne, kliknij pozycję Więcej kontrolek w menu Wstawianie lub naciśnij klawisze ALT + I, a następnie klawisz C.

  3. Przeciągnij formant przycisku na szablonie formularza.

  4. Kliknij dwukrotnie przycisk, który właśnie dodany do szablonu formularza.

  5. Kliknij kartę Ogólne.

  6. Na liście akcji kliknij przycisk Odśwież.

  7. W polu Etykieta wpisz nazwę, która ma być wyświetlany na przycisku w szablonie formularza.

  8. Kliknij przycisk Ustawienia.

  9. W oknie dialogowym odświeżanie kliknij jedno pomocnicze źródło danych.

  10. Na liście Wybierz pomocnicze źródło danych kliknij pomocnicze źródło danych skojarzonego z kwerendy połączenia danych, a następnie kliknij przycisk OK, aby zamknąć poszczególne otwarte okna dialogowe.

  11. Aby sprawdzić wprowadzone zmiany, kliknij pozycję Podgląd na pasku narzędzi Standardowy lub naciśnij klawisze CTRL+SHIFT+B.

Początek strony

Dodawanie połączenia przesyłania danych

Aby umożliwić użytkownikom przesyłanie formularzy opartych na szablonie formularza do usługi sieci Web, najpierw dodać pomocniczego połączenia danych do szablonu formularza, który przesyła dane, a następnie skonfiguruj szablon formularza, aby umożliwić użytkownikom przesyłanie danych formularza.

Krok 1: Dodawanie pomocniczego połączenia danych

  1. W menu Narzędzia kliknij polecenie Połączenia danych.

  2. W oknie dialogowym Połączenia danych kliknij przycisk Dodaj.

  3. W Kreatorze połączenia danych kliknij przycisk Utwórz nowe połączenie, kliknij Przesyłanie danych, a następnie kliknij przycisk Dalej.

  4. W obszarze, jak chcesz przesłać dane kliknij do usługi sieci Web, a następnie kliknij przycisk Dalej.

  5. Na następnej stronie kreatora wpisz lokalizację usługi sieci Web miejsce, w którym użytkownicy będą przesyłanie ich danych, a następnie kliknij Dalej.

    Uwaga: Jeśli chcesz wyszukać usługi sieci Web przy użyciu serwera uniwersalny odnajdowanie opis i Integration (UDDI), kliknij przycisk Przeszukaj zasoby, wprowadź adres URL serwera UDDI, który chcesz wyszukać, określ, czy wyszukiwanie według dostawcy lub usługa pod warunkiem, wprowadź słowo kluczowe wyszukiwania, a następnie kliknij przycisk Wyszukaj. Usługi sieci Web, które są zgodne z słowo kluczowe wyszukiwania pojawią się na liście wyników wyszukiwania. Wybierz usługę sieci Web, którego chcesz użyć, a następnie kliknij przycisk OK.

  6. Na liście Wybierz operacja kliknij operację usługi sieci Web, który będzie odbioru danych formularza, a następnie kliknij przycisk Dalej.

  7. Na następnej stronie kreatora Aby zaznaczyć danych w formularzu, aby przesłać dla każdego parametru usługę sieci Web, wykonaj jedną z następujących czynności:

    Przesyłanie danych do pola lub grupy

    1. Na liście parametrów kliknij parametr usługi sieci Web, która pobiera dane z formularza.

    2. W obszarze Opcje parametrów kliknij pola lub grupy.

    3. Kliknij przycisk Modyfikuj Obraz przycisku .

    4. W oknie dialogowym Wybieranie pola lub grupy kliknij pole lub grupę, których chcesz przesłać dane, a następnie kliknij przycisk OK.

    5. W oknie dialogowym Dołączanie kliknij pozycję tekst i elementy podrzędne, aby przesłać tylko dane w tej dziedzinie oraz elementy podrzędne pola lub grupy, lub kliknij pozycję poddrzewo XML, włącznie z zaznaczonym elementem przesłania nazwę pola danych w polu, a elementy podrzędne w wybranej grupie lub polu.

    Przesyłanie wszystkich danych w formularzu

    1. Na liście parametrów kliknij parametr usługi sieci Web, która pobiera dane z formularza.

    2. W obszarze Opcje parametrów kliknij cały formularz (dokument XML włącznie z instrukcjami przetwarzania).

    Przesyłanie danych w postaci ciągu

    1. Na liście parametrów kliknij parametr usługi sieci Web, która pobiera dane z formularza.

    2. W obszarze Opcje parametrów kliknij cały formularz (dokument XML włącznie z instrukcjami przetwarzania).

    3. Zaznacz pole wyboru Prześlij dane jako ciąg.

      Uwaga: Zazwyczaj możesz wybrać tego pola wyboru umożliwia przesyłanie danych podpisanych cyfrowo. W większości przypadków wyczyść to pole wyboru.

    Uwaga techniczna dotyczące zestawu danych ADO.NET obiektów

    Jeśli usługa sieci Web wymaga obiektu zestawu danych ADO.NET, wybierz węzeł zestawu danych podczas konfigurowania tego połączenia danych. Jeśli używasz innego typu węzeł do połączenia danych usługi sieci Web, która wymaga obiektu zestawu danych ADO.NET Akcja przesyłania nie powiedzie się.

  8. Kliknij przycisk Dalej.

  9. Na następnej stronie kreatora wpisz nazwę połączenia przesyłania danych.

  10. Zweryfikuj poprawność informacji w sekcji Podsumowanie, a następnie kliknij przycisk Zakończ.

  11. Kliknij przycisk Zamknij.

Po dodaniu pomocniczej przesyłanie połączenia danych, musisz skonfigurować umożliwia użytkownikom przesyłanie połączenie danych przesyłania danych wprowadzonych do formularza za pomocą tego szablonu formularza.

Krok 2: Włącz przesyłanie w szablonie formularza

Po skonfigurowaniu szablon formularza, aby umożliwić użytkownikom przesyłanie danych formularza programu InfoPath dodaje przycisk Prześlij do przesyłania poleceń z menu plik w formularzu i pasku narzędzi Standardowy. Można także dostosować opcje przesyłania dla szablonu formularza w następujący sposób:

  • Zmienianie tekstu wyświetlanego na polecenie Prześlij i przycisk Prześlij.

  • Zmienianie skrótu klawiaturowego dla przycisku Prześlij i polecenie Prześlij.

  • Tworzenie niestandardowego wiadomości do wyświetlenia dla użytkowników, podczas przesyłania formularzy.

  • Określ, czy Pozostaw formularz otwarty, zamknij formularz, lub Otwórz inny pusty formularz po przesłaniu formularza.

  • W menu Narzędzia kliknij polecenie Opcje przesyłania.

  • W oknie dialogowym Opcje przesyłania zaznacz pole wyboru Zezwalaj użytkownikom na przesyłanie tego formularza, kliknij przycisk Wyślij danych formularza do jednego miejsca docelowego, a następnie na liście kliknij Usługi sieci Web.

  • Na liście Wybierz połączenie danych dla przesyłania kliknij nazwę połączenia przesyłania danych z usługi sieci Web utworzonej w poprzednich krokach.

    1. Aby zmienić nazwę przycisku Prześlij, który pojawia się na pasku narzędzi Standardowy, a polecenie Prześlij, który pojawia się w menu plik, podczas wypełniania formularza, wpisz nową nazwę w polu Podpis w przesyłania Opcje okno dialogowe.

      Porada: Jeśli chcesz przypisać skrót klawiaturowy do tego przycisku i polecenia, wpisz handlowe "i" (&) przed znakiem, który ma być używany jako skrót klawiaturowy. Na przykład aby przypisać klawisze ALT + B, jako skrót klawiaturowy dla przycisku Prześlij i polecenia, wpisz & przycisk Prześlij.

  • Jeśli nie chcesz używać polecenia Prześlij lub przycisk Zatwierdź na pasku narzędzi Standardowy, podczas wypełniania formularza użytkownicy, wyczyść pole wyboru Pokaż polecenie Prześlij i przycisk Prześlij.

    1. Domyślnie po użytkownikom przesyłanie formularzy programu InfoPath zachowuje formularz otwarty i zostanie wyświetlony komunikat, aby wskazać, jeśli formularz został pomyślnie przesłany. Aby zmienić to zachowanie domyślne, kliknij przycisk Zaawansowane, a następnie wykonaj jedną z następujących czynności:

      • Aby zamknąć formularz lub Utwórz nowy pusty formularz po przesłaniu wypełniony formularz, kliknij opcję, która ma na liście po przesyłanie.

      • Aby utworzyć niestandardowe wiadomości, który wskazuje, jeśli formularz został pomyślnie przesłany, zaznacz pole wyboru Użyj niestandardowych wiadomości, a następnie wpisz wiadomości w polach w przypadku powodzenia i niepowodzenia.

        Porada: Poinstruuj użytkowników za pomocą wiadomości w polu w przypadku awarii co należy zrobić, jeśli nie można ich przesłać formularz. Na przykład można sugerują, że użytkownicy zapisywać formularze i skontaktować się z osobą Aby uzyskać dodatkowe instrukcje.

      • Jeśli nie chcesz wyświetlać wiadomości, gdy użytkownik przesyła formularz, wyczyść pole wyboru Pokaż sukcesów i porażek wiadomości.

Początek strony

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×