Dodawanie i usuwanie dodatków w programie Excel

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Dodatki udostępniają opcjonalne polecenia i funkcje programu Microsoft Excel. Domyślnie dodatki nie są natychmiast dostępne w programie Excel, więc musisz najpierw zainstalować i (w kilku przypadkach) aktywować te dodatki, aby można było z nich korzystać.

Szukasz informacji na temat dodatków pakietu Office opartych na kodzie HTML, CSS i JS? Jeśli jesteś, zobacz pobieranie dodatku pakietu Office dla programu Excel.

Niektóre dodatki są wbudowane w program Excel, takie jak Solver i dodatek Analysis ToolPak. Inne dodatki są dostępne w centrum pobierania i należy je najpierw pobrać i zainstalować. Wreszcie istnieją Dodatki tworzone przez osoby trzecie, takie jak programista w organizacji lub dostawca rozwiązań oprogramowania. Mogą to być Dodatki COM, dodatki Visual Basic for Applications (VBA) i dodatki biblioteki DLL. Te dodatki muszą być również zainstalowane, aby można było z nich korzystać.

Większość dodatków można podzielić na trzy różne typy:

  • Dodatki programu Excel    Obejmuje to zazwyczaj pliki dodatków programu Excel (. xlam), programu Excel 97-2003 Add-in (xla) lub biblioteki DLL (. XLL) lub są dodatkami do automatyzacji. Niektóre dodatki programu Excel, takie jak Solver i Analysis ToolPak, mogą być dostępne po zainstalowaniu programu Excel lub pakietu Microsoft Office. Zazwyczaj te dodatki wystarczy aktywować, aby można było z nich korzystać.

  • Dodatki do pobrania    Dodatkowe Dodatki dla programu Excel można pobrać i zainstalować z pobranych plików w witrynie Office.com.

  • Dodatki niestandardowe    Deweloperzy i dostawcy rozwiązań zwykle projektują Dodatki niestandardowego modelu COM (Component Object Model), dodatki automatyzacyjne, dodatki VBA i dodatki programu XLL. Aby można było z nich korzystać, muszą być zainstalowane.

Po zainstalowaniu lub aktywowaniu dodatku dostęp do dodatku i jego poleceń mogą być dostępne w jednej z następujących lokalizacji:

  • Karta dane . Po zainstalowaniu i aktywowaniu dodatków Analysis ToolPak i dodatku Solver polecenia analizy danych i Solver są dostępne w grupie Analiza .

    Przycisk Analiza danych w grupie Analiza danych

  • Karta formuły . Po zainstalowaniu i uaktywnieniu narzędzi do waluty euro w grupie rozwiązania są wyświetlane polecenia Konwersja euro i Formatowanie euro .

    Pozycje Konwersja euro i Formatowanie euro

  • Karta Dodatki . Inne dodatki można dodać do karty Dodatki . Ta karta zostanie dodana do wstążki podczas instalowania i aktywacji pierwszego dodatku wyświetlanego na karcie Dodatki . Jeśli karta Dodatki nie jest widoczna, należy zamknąć i ponownie uruchomić program Excel.

Inne dodatki, takie jak karta wprowadzenie, są dostępne w innych miejscach w programie Excel, takich jak karta na Wstążce lub za pomocą makr lub menu dostosowanych.

Ważne: Jeśli jesteś deweloperem oprogramowania, możesz skorzystać z tej procedury, aby zainstalować lub usunąć program automatyzacji przed zaprojektowaniem programów instalacyjnych i usuwających dodatek.

Aby aktywować dodatek programu Excel    

  1. Kliknij kartę Plik, kliknij pozycję Opcje, a następnie kliknij kategorię Dodatki.

  2. W polu Zarządzaj kliknij pozycję Dodatki programu Excel, a następnie kliknij przycisk Przejdź.

    Zostanie wyświetlone okno dialogowe Dodatki .

  3. W polu dostępne dodatki zaznacz pole wyboru obok dodatku, który chcesz uaktywnić, a następnie kliknij przycisk OK.

Jeśli nie możesz znaleźć dodatku, który chcesz uaktywnić w polu dostępne dodatki , może być konieczne jego zainstalowanie.

Aby zainstalować dodatek programu Excel    

  • Aby zainstalować dodatek, który jest zazwyczaj instalowany z programem Excel, na przykład dodatek Solver lub Analysis ToolPak, uruchom program instalacyjny dla programu Excel lub pakietu Microsoft Office i wybierz opcję Zmień , aby zainstalować dodatek. Po ponownym uruchomieniu programu Excel dodatek powinien pojawić się w polu dostępne dodatki .

  • Niektóre dodatki programu Excel są zlokalizowane na komputerze i można je zainstalować lub aktywować, klikając pozycję Przeglądaj (w oknie dialogowym Dodatki ), aby zlokalizować dodatek, a następnie kliknąć przycisk OK.

  • Niektóre dodatki programu Excel wymagają uruchomienia pakietu instalacyjnego. Może być konieczne pobranie lub skopiowanie pakietu instalacyjnego na komputer (pakiet instalacyjny to zazwyczaj plik z rozszerzeniem nazwy pliku msi), a następnie uruchom go.

  • Inne dodatki, które nie są dostępne na twoim komputerze, mogą być pobierane i instalowane za pośrednictwem przeglądarki sieci Web z poziomu plików do pobrania lub z innych witryn w Internecie lub na serwerze w organizacji. Postępuj zgodnie z instrukcjami konfiguracji dotyczącymi pobierania, zależnie od potrzeb.

Aby dezaktywować dodatek programu Excel    

  1. Kliknij kartę Plik, kliknij pozycję Opcje, a następnie kliknij kategorię Dodatki.

  2. W polu Zarządzaj kliknij pozycję Dodatki programu Excel, a następnie kliknij przycisk Przejdź.

  3. W polu dostępne dodatki wyczyść pole wyboru obok dodatku, który chcesz dezaktywować, a następnie kliknij przycisk OK.

    W wielu przypadkach, gdy dezaktywujesz dodatek, jest on usuwany z grupy na Wstążce. W przypadku usunięcia dodatku z wstążki może być konieczne ponowne uruchomienie programu Excel.

    Uwaga    Wyłączenie dodatku nie powoduje usunięcia go z komputera. Aby usunąć dodatek z komputera, należy go odinstalować.

Aby usunąć dodatek programu Excel    

Ważne: Jeśli dodatek programu Excel został pierwotnie zainstalowany z sieciowego serwera plików lub z folderu udostępnionego, może być konieczne usunięcie dodatku z tej lokalizacji. Jeśli dodatek programu Excel został zainstalowany z dysku CD i dysk CD został zmapowany na nową literę dysku po zainstalowaniu dodatku, należy ponownie zainstalować dodatek z dysku CD. Jeśli używasz dodatków programu Excel z dysku CD, musisz odinstalować Dodatki programu Excel, a następnie ponownie je zainstalować z dysku CD.

  1. Kliknij kartę plik , a następnie kliknij pozycję Zakończ.

  2. W panelu sterowania kliknij pozycję programy i funkcje (Windows 7 i Windows Vista) lub Dodaj/Usuń programy (Windows XP).

  3. Wykonaj jedną z następujących czynności:

    • Jeśli program Excel został zainstalowany jako część pakietu Microsoft Office, kliknij pozycję Microsoft Office na liście zainstalowanych programów, a następnie kliknij przycisk Zmień .

    • Jeśli program Excel został zainstalowany oddzielnie, kliknij nazwę programu na liście zainstalowanych programów, a następnie kliknij przycisk Zmień .

    • Jeśli dodatek został zainstalowany z centrum pobierania, kliknij nazwę programu na liście zainstalowanych programów, a następnie kliknij przycisk Odinstaluj .

  4. Postępuj zgodnie z instrukcjami wyświetlanymi w programie instalacyjnym.

Ważne: Jeśli jesteś deweloperem oprogramowania, możesz skorzystać z tej procedury, aby zainstalować lub usunąć program automatyzacji przed zaprojektowaniem programów instalacyjnych i usuwających dodatek. Jeśli nie jesteś deweloperem, nie musisz korzystać z tej procedury. Jeśli chcesz zainstalować i usunąć instrukcje dotyczące instalacji i usuwania, skontaktuj się z administratorem systemu, który dostarczył dodatek.

Dodawanie dodatku COM

  1. Kliknij kartę Plik, kliknij pozycję Opcje, a następnie kliknij kategorię Dodatki.

  2. W oknie Zarządzanie kliknij pozycję Dodatki COM, a następnie kliknij przycisk Przejdź.

    Zostanie wyświetlone okno dialogowe Dodatki COM .

  3. W polu dostępne dodatki zaznacz pole wyboru obok dodatku, który chcesz zainstalować, a następnie kliknij przycisk OK.

    Porada    Jeśli dodatku, którego chcesz użyć, nie ma na liście w polu dostępne dodatki , kliknij pozycję Dodaj, a następnie Znajdź odpowiedni dodatek.

Usuwanie dodatku COM

  1. Kliknij kartę Plik, kliknij pozycję Opcje, a następnie kliknij kategorię Dodatki.

  2. W oknie Zarządzanie kliknij pozycję Dodatki COM, a następnie kliknij przycisk Przejdź.

    Zostanie wyświetlone okno dialogowe Dodatki COM .

  3. W polu dostępne dodatki wyczyść pole wyboru obok dodatku, który chcesz usunąć, a następnie kliknij przycisk OK.

    Uwaga    Spowoduje to usunięcie dodatku z pamięci, ale zachowuje jego nazwę na liście dostępnych dodatków. Nie powoduje usunięcia dodatku z komputera.

  4. Aby usunąć dodatek COM z listy dostępnych dodatków, a następnie usunąć dodatek z komputera, kliknij jego nazwę w polu dostępne dodatki , a następnie kliknij przycisk Usuń.

Uwaga: Jeśli jesteś deweloperem oprogramowania, możesz skorzystać z tej procedury, aby zainstalować lub usunąć program automatyzacji przed zaprojektowaniem programów instalacyjnych i usuwających dodatek. Jeśli nie jesteś deweloperem, nie musisz korzystać z tej procedury. Jeśli chcesz zainstalować i usunąć instrukcje dotyczące instalacji i usuwania, skontaktuj się z administratorem systemu, który dostarczył dodatek.

  1. Kliknij kartę Plik, kliknij pozycję Opcje, a następnie kliknij kategorię Dodatki.

  2. W polu Zarządzaj kliknij pozycję Dodatki programu Excel, a następnie kliknij przycisk Przejdź.

    Zostanie wyświetlone okno dialogowe Dodatki .

  3. Aby zainstalować dodatek automatyzacji, w polu dostępne serwery automatyzacji kliknij pozycję Automatyzacja, a następnie kliknij odpowiedni dodatek.

    Porada    Jeśli odpowiedniego dodatku nie ma na liście, kliknij przycisk Przeglądaj, Znajdź odpowiedni dodatek, a następnie kliknij przycisk OK.

  4. Aby usunąć dodatek automatyzacji, musisz usunąć go z rejestru. Aby uzyskać szczegółowe informacje, skontaktuj się z administratorem systemu.

Niektóre dodatki są wbudowane w program Excel, takie jak Solver i dodatek Analysis ToolPak. Inne dodatki są dostępne w centrum pobierania i należy je najpierw pobrać i zainstalować. Wreszcie istnieją Dodatki tworzone przez osoby trzecie, takie jak programista w organizacji lub dostawca rozwiązań oprogramowania. Mogą to być Dodatki COM, dodatki Visual Basic for Applications (VBA) i dodatki biblioteki DLL. Te dodatki muszą być również zainstalowane, aby można było z nich korzystać.

Większość dodatków można podzielić na trzy różne typy:

  • Dodatki programu Excel    Obejmuje to zazwyczaj pliki dodatków programu Excel (. xlam), programu Excel 97-2003 Add-in (xla) lub biblioteki DLL (. XLL) lub są dodatkami do automatyzacji. Niektóre dodatki programu Excel, takie jak Solver i Analysis ToolPak, mogą być dostępne po zainstalowaniu programu Excel lub pakietu Microsoft Office. Zazwyczaj te dodatki wystarczy aktywować, aby można było z nich korzystać.

  • Dodatki do pobrania    Dodatkowe Dodatki dla programu Excel można pobrać i zainstalować z pobranych plików w witrynie Office.com.

  • Dodatki niestandardowe    Deweloperzy i dostawcy rozwiązań zwykle projektują Dodatki niestandardowego modelu COM (Component Object Model), dodatki automatyzacyjne, dodatki VBA i dodatki programu XLL. Aby można było z nich korzystać, muszą być zainstalowane.

Po zainstalowaniu lub aktywowaniu dodatku dostęp do dodatku i jego poleceń mogą być dostępne w jednej z następujących lokalizacji:

  • Karta dane . Po zainstalowaniu i aktywowaniu dodatków Analysis ToolPak i dodatku Solver polecenia analizy danych i Solver są dostępne na karcie dane na Wstążce.

  • Karta Narzędzia główne . Inne dodatki można dodać do karty Narzędzia główne .

Inne dodatki, takie jak karta wprowadzenie, są dostępne w innych miejscach w programie Excel, takich jak karta na Wstążce lub za pomocą makr lub menu dostosowanych.

Ważne: Jeśli jesteś deweloperem oprogramowania, możesz skorzystać z tej procedury, aby zainstalować lub usunąć program automatyzacji przed zaprojektowaniem programów instalacyjnych i usuwających dodatek.

Aby uaktywnić wstępnie zainstalowany dodatek programu Excel    

  1. W menu Narzędzia wybierz pozycję Dodatki.

  2. W polu dostępne dodatki zaznacz pole wyboru obok dodatku, który chcesz aktywować, a następnie kliknij przycisk OK.

Aby zainstalować dodatek programu Excel    

  • Niektóre dodatki programu Excel są zlokalizowane na komputerze i można je zainstalować lub aktywować, klikając pozycję Przeglądaj (w oknie dialogowym Dodatki powyżej), aby zlokalizować dodatek, a następnie kliknąć przycisk OK.

  • Niektóre dodatki programu Excel wymagają uruchomienia pakietu instalacyjnego. Może być konieczne pobranie lub skopiowanie pakietu instalacyjnego na komputer (pakiet instalacyjny to zazwyczaj plik z rozszerzeniem nazwy pliku msi), a następnie uruchom go.

  • Inne dodatki, które nie są dostępne na twoim komputerze, mogą być pobierane i instalowane za pośrednictwem przeglądarki sieci Web z poziomu plików do pobrania lub z innych witryn w Internecie, na serwerze w organizacji lub za pomocą opcji wbudowanego sklepu w programie Excel. Postępuj zgodnie z instrukcjami konfiguracji dotyczącymi pobierania, zależnie od potrzeb.

    Aby zainstalować dodatki ze sklepu Store

    1. Kliknij kartę Wstawianie na Wstążce.

    2. Kliknij przycisk sklep .

    3. Użyj pól Kategorie lub Wyszukaj , aby znaleźć dodatki.

    4. Kliknij przycisk Dodaj , aby zainstalować dodatek.

      Uwaga: Niektóre dodatki trzeba zakupić.

Aby usunąć dodatek programu Excel    

  1. Kliknij kartę Wstawianie , a następnie kliknij pozycję Mojedodatki.

  2. W dodatkach pakietu Officekliknij menu 3 kropki obok dodatku.

  3. Kliknij przycisk Usuń.

  4. Przeczytaj powiadomienie dotyczące innych urządzeń i kliknij przycisk Usuń.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×