Dodawanie danych do kształtów

Uwaga:  Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Rysunek programu Microsoft Office Visio może być czymś o wiele więcej niż tylko obrazem ― umożliwia także organizowanie danych i pobieranie ich podczas tworzenia raportu.

W tym artykule omówiono najlepsze sposoby ręcznego dodawania danych do zaznaczonych kształtów, sposób tworzenia zestawu danych do wielokrotnego użycia, które można zastosować do wielu kształtów na rysunku, oraz sposób dodawania danych do kształtu wzorca.

Uwaga: Poniższe procedury dotyczą zarówno programu Microsoft Office Visio Professional 2007, jak i programu Microsoft Office Visio Standard 2007. W przypadku korzystania z programu Visio Professional można automatycznie importować dane, dodawać dane do kształtów oraz wyświetlać dane na kształtach przy użyciu grafiki związanej z danymi. Aby dowiedzieć się, które wydanie programu Visio jest używane, należy w menu Pomoc kliknąć polecenie Microsoft Office Visio — informacje.

Co chcesz zrobić?

Dodawanie danych do zaznaczonych kształtów

Tworzenie zestawu pól danych do wielokrotnego użycia

Dodawanie pól danych do kształtu wzorca

Dodawanie danych do zaznaczonych kształtów

Aby dodać dane do kształtów, które już są na rysunku, należy dodać do kształtów najpierw pola danych, a następnie wartości.

Porada: Poniższa procedura stanowi najprostszy sposób dodawania danych do kształtów. Jeśli jednak należy dodać takie same dane do wielu kształtów, warto wziąć pod uwagę jeden ze sposobów alternatywnych opisanych w innych sekcjach tego artykułu.

Jaka jest różnica między polem danych a wartością?

  • Pole danych jest oznaczoną etykietą komórką, w której mogą być przechowywane wartości.

  • Wartość jest tekstem lub liczbą w komórce tabeli bazy danych, arkusza lub — w tym przypadku — kształtu.

Oto przykład, w którym widać okno Dane kształtu zawierające pola i wartości dla kształtu Decyzja z wzornika Podstawowy schemat blokowy. W tym przypadku pola to Stawka godzinowa, Wymagany dostęp do sieci oraz Czas trwania kontraktu, a wartości to 49 zł, Tak i 3 tygodnie.

Shape Data window showing fields and values.

Dodawanie pól danych do zaznaczonych kształtów

  1. Zaznacz kształt lub kształty, do których chcesz dodać dane.

  2. Kliknij zaznaczenie prawym przyciskiem myszy, wskaż polecenie Dane w menu skrótów, a następnie kliknij polecenie Dane kształtu.

  3. Kiedy zostanie wyświetlony komunikat z pytaniem, czy chcesz teraz zdefiniować dane, kliknij przycisk Tak.

    Uwaga: Jeśli kształt zawiera już pola danych, ten komunikat nie zostanie wyświetlony.

  4. W oknie dialogowym Definiowanie danych kształtu wpisz etykietę pola.

  5. Aby utworzyć następne pole, kliknij przycisk Nowa i powtórz krok 4.

  6. Po zdefiniowaniu wszystkich pól danych kliknij przycisk OK.

    Zostanie wyświetlone okno dialogowe Dane kształtu zawierające dodane pola.

Dodawanie wartości do pól danych

  1. W menu Widok kliknij polecenie Okno Dane kształtu.

  2. Zaznaczaj każdy kształt pojedynczo i wpisuj wartości w polach danych w oknie Dane kształtu.

    Uwaga: Zawartość okna Dane kształtu przedstawia tylko dane dotyczące zaznaczonego kształtu.

Początek strony

Tworzenie zestawu pól danych do wielokrotnego użycia

Można utworzyć zestaw pól danych możliwy do zastosowania zarówno do kształtów już istniejących na rysunku, jak i do kształtów, które zostaną umieszczone na rysunku później.

  1. W menu Widok kliknij polecenie Okno Dane kształtu.

  2. Kliknij prawym przyciskiem myszy dowolne miejsce w oknie Dane kształtu, a następnie kliknij polecenie Zestawy danych kształtu.

  3. W oknie Zestawy danych kształtu kliknij polecenie Dodaj.

  4. W oknie dialogowym Dodawanie zestawu danych kształtu wpisz nazwę zestawu danych.

  5. Wybierz opcję Utwórz nowy zestaw, a następnie kliknij przycisk OK.

    Zestaw danych zostanie wyświetlony w kolumnie Nazwa w oknie Zestawy danych kształtu.

    Uwaga: Możesz także kliknąć jedną z innych opcji, jeśli chcesz zmienić istniejący zestaw danych.

  6. W kolumnie Nazwa kliknij nowy zestaw danych, a następnie kliknij polecenie Definiuj.

  7. W oknie dialogowym Definiowanie danych kształtu wpisz etykietę pola.

  8. Aby utworzyć następne pole, kliknij przycisk Nowa, a następnie powtórz krok 7.

  9. Po zdefiniowaniu wszystkich pól danych kliknij przycisk OK.

  10. Aby zastosować zestaw danych do kształtów zaznaczonych na rysunku, zaznacz zestaw w oknie Zestawy danych kształtu, a następnie kliknij przycisk Zastosuj.

    Porada: Aby zobaczyć nowe pola w jednym z kształtów, do których zostały zastosowane, zaznacz kształt, a następnie popatrz do okna Dane kształtu.

Początek strony

Dodawanie pól danych do kształtu wzorca

Jeśli za każdym razem, gdy jest używany określony kształt, ma być do niego dodawany ten sam zestaw danych kształtu, można zaoszczędzić czas, dodając pola danych do kopii wzorca tego kształtu. Można na przykład dodać pola danych, takie jak nazwisko lub numer pracownika, do wzorca kształtu osoby.

  1. Kliknij prawym przyciskiem myszy wzorzec, do którego chcesz dodać dane kształtu, wskaż polecenie Dodaj do moich kształtów, a następnie kliknij polecenie Dodaj do nowego wzornika.

    Uwaga: Jeśli już istnieje wzornik niestandardowy, można dodać do niego wzorzec i nie trzeba tworzyć nowego wzornika.

  2. W oknie dialogowym Zapisywanie jako wpisz nazwę nowego wzornika, a następnie kliknij przycisk Zapisz.

  3. W menu Plik wskaż polecenie Kształty, wskaż polecenie Moje kształty, a następnie kliknij wzornik zawierający skopiowany wzorzec.

  4. Kliknij prawym przyciskiem myszy pasek tytułu nowego wzornika, a następnie kliknij polecenie Edytuj wzornik w menu skrótów.

  5. Kliknij prawym przyciskiem myszy kształt, który przed chwilą został dodany do wzornika, wskaż polecenie Edytuj wzorzec, a następnie kliknij polecenie Edytuj kształt wzorca.

  6. W oknie edycji kształtu kliknij kształt prawym przyciskiem myszy, wskaż polecenie Dane, a następnie kliknij polecenie Dane kształtu.

  7. Kiedy zostanie wyświetlony komunikat z pytaniem, czy chcesz teraz zdefiniować dane, kliknij przycisk Tak.

    Uwaga: Jeśli kształt już zawiera pola danych, ten komunikat nie zostanie wyświetlony. Należy wówczas wykonać pozostałe kroki procedury.

  8. W oknie dialogowym Definiowanie danych kształtu wpisz nazwę pola i uzupełnij wszelkie inne potrzebne informacje. W tym momencie możesz na przykład zmienić typ danych lub dodać monit dotyczący kształtu.

  9. Aby utworzyć następne pole, kliknij przycisk Nowa i powtórz krok 8.

  10. Po zdefiniowaniu wszystkich pól danych kliknij przycisk OK.

    Zostanie wyświetlone okno dialogowe Dane kształtu zawierające dodane pola.

    Uwaga: Aby wprowadzić zmiany w polach, kliknij przycisk Definiuj i powtórz krok 8.

  11. Aby zamknąć okno edycji kształtu, w menu Plik kliknij polecenie Zamknij.

  12. Kiedy zostanie wyświetlony komunikat z pytaniem, czy chcesz zaktualizować kształt, kliknij przycisk Tak.

  13. Kiedy zostanie wyświetlony jeszcze jeden komunikat z pytaniem, czy chcesz zapisać zmiany we wzorniku, kliknij przycisk Tak.

Początek strony

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×