Dodawanie łączników między kształtami

Dodawanie łączników między kształtami

Program Visio ułatwia łączenie kształtów na rysunku. Za pomocą funkcji autołączenia możesz łączyć kształty podczas ich dodawania, a istniejące kształty możesz łączyć przy użyciu narzędzia Łącznik. Możesz również zmieniać kształty wyświetlane na minipasku narzędzi oraz włączać i wyłączać autołączenie.

Automatyczne łączenie kształtu

Łączenie kształtów znajdujących się już na stronie

Tworzenie połączenia z kształtem na innej stronie

Zmienianie wyglądu łącznika za pomocą motywów

Używanie alternatywnych kształtów łączników

Zmienianie kształtów na minipasku narzędzi Autołączenie

Włączanie i wyłączanie autołączenia

Automatyczne łączenie kształtu

Jednym ze sposobów łączenia kształtów jest automatyczne łączenie w programie Visio podczas dodawania kształtu do strony. Ta opcja jest szczególnie przydatna podczas tworzenia schematu blokowego.

  1. Upewnij się, że jest aktywny tryb autołączenia. Na karcie Widok w grupie Ułatwienia wizualne upewnij się, że jest wybrana pozycja Autołączenie.

  2. Przeciągnij kształt z okienka Kształty na stronę.

  3. Przytrzymaj wskaźnik myszy na kształcie, aż wokół niego pojawią się strzałki autołączenia.

    Gdy autołączenie jest aktywne, zatrzymaj wskaźnik myszy na kształcie, aby wyświetlić strzałki połączenia.
  4. Przytrzymaj wskaźnik na strzałce w kierunku, który chcesz dodać do kształtu.

    Umieszczenie wskaźnika myszy na strzałce autołączenia spowoduje wyświetlenie paska narzędzi z kształtami, które można dodać.

    Zostanie wyświetlony minipasek narzędzi zawierający pierwsze cztery szybkie kształty, które znajdują się obecnie we wzorniku Szybkie kształty. Gdy wskażesz kształt na pasku narzędzi, program Visio wyświetli podgląd tego kształtu na stronie.

  5. Kliknij kształt, który chcesz dodać.

  6. Jeśli chcesz kontynuować, wskaż strzałkę autołączenia na nowo dodanym kształcie w celu dodania innego kształtu, który również zostanie automatycznie połączony.

    Umieszczenie wskaźnika myszy na nowo dodanym kształcie spowoduje wyświetlenie strzałek autołączenia służących do dodawania kolejnego kształtu.

Początek strony

Łączenie kształtów znajdujących się już na stronie

Porada: Polecenia w grupie Narzędzia na karcie Narzędzia główne umożliwiają przełączanie programu Visio w różne stany lub tryby, co czasami może wydawać się niejasne. Używaj klawiatury, aby łatwo przełączać między narzędziami Wskaźnik Wybieranie obiektów (naciśnij klawisze Ctrl+1) i Łącznik Obraz przycisku (naciśnij klawisze Ctrl+3). Niezależnie od używanego narzędzia (takiego jak Blok tekstu lub Punkt połączenia) możesz nacisnąć kilka razy klawisz Esc, aby ponownie wybrać narzędzie Wskaźnik.

  1. Na karcie Narzędzia główne w grupie Narzędzia kliknij pozycję Łącznik Obraz przycisku lub naciśnij klawisze Ctrl+3.

  2. Kliknij dowolny kształt i przeciągnij łącznik do innego kształtu.

  3. Po zakończeniu kliknij pozycję Wskaźnik — narzędzie Wybieranie obiektów na karcie Narzędzia główne w grupie Narzędzia lub naciśnij klawisze Ctrl+1.

Narzędzie Łącznik umożliwia łączenie kształtów połączeniem punktowym po obu końcach.

Ewentualnie można dodać do wstążki polecenie Połącz kształty i użyć go do połączenia wielu kształtów w kolejności, w jakiej je zaznaczono.

Porada: Przydatne polecenia, które nie są jeszcze widoczne na wstążce, można dodać, klikając pozycję Plik > Opcje > Dostosuj Wstążkę.

Początek strony

Tworzenie połączenia z kształtem na innej stronie

Łączniki można tworzyć tylko między kształtami na tej samej stronie. W celu utworzenia połączenia z kształtem na innej stronie użyj kształtu Odwołanie międzystronicowe, aby utworzyć hiperlink między jedną stroną a drugą, lub dodaj hiperlink i akcję dwukrotnego kliknięcia do dowolnego kształtu, aby można było przejść do innej strony w tym samym dokumencie.

Używanie odwołania międzystronicowego

  1. Otwórz wzornik Podstawowy schemat blokowy , a następnie przeciągnij kształt Odwołanie międzystronicowe na bieżącą stronę.

    Kształt Odwołanie międzystronicowe
  2. W oknie dialogowym Odwołanie międzystronicowe wybierz pozycję OK, aby dodać kształt do bieżącej strony i nowo utworzonej strony.

  3. Na nowej stronie kontynuuj tworzenie diagramu.

  4. Aby zmienić wygląd kształtu Odwołanie międzystronicowe, kliknij ten kształt prawym przyciskiem myszy, a następnie wybierz pozycję Wychodzący, Przychodzący, Okrąg lub Strzałka.

Aby przejść między stronami, kliknij dwukrotnie kształt Odwołanie międzystronicowe na jednej ze stron. Aby uzyskać więcej informacji, zobacz Okno dialogowe Odwołanie międzystronicowe.

Używanie hiperlinku i dwukrotnego kliknięcia

  1. Kliknij prawym przyciskiem myszy dowolny kształt lub naciśnij klawisze CTRL+K, a następnie wybierz pozycję Hiperłącze.

  2. Kliknij przycisk Przeglądaj obok pola Podadres, a następnie kliknij listę rozwijaną obok pozycji Strona, aby wybrać stronę.

    Okno dialogowe Hiperlink

    Uwaga: Dla hiperlinku można także określić nazwę kształtu na stronie docelowej. Kliknij kartę Deweloper, a następnie wybierz pozycję Nazwa kształtu. Użyj domyślnej nazwy w polu Nazwa lub edytuj ją i kliknij przycisk OK.

  3. Aby ustawić akcję dwukrotnego kliknięcia dla kształtu, kliknij kartę Deweloper, a następnie wybierz pozycję Zachowanie.

  4. Kliknij kartę Dwukrotne kliknięcie, wybierz opcję Przejdź do strony, a następnie kliknij listę rozwijaną, aby wybrać stronę.

    Akcja dwukrotnego kliknięcia w programie Visio

    Uwaga: Zrób to po ukończeniu edytowania nazw stron, ponieważ nie są one aktualizowane tutaj automatycznie.

Początek strony

Zmienianie wyglądu łącznika za pomocą motywów

Domyślnym wyglądem łączników mogą być proste linie, jednak można je tak zaprojektować, aby współgrały z motywami, które dodają ozdobniki, takie jak groty strzałek. Wbudowane motywy można stosować z poziomu galerii Motywy na karcie Projektowanie.

Uwagi: 

  • Aby wyświetlić więcej ozdobników, kliknij kartę Projektowanie. W grupie Warianty kliknij strzałkę listy rozwijanej, a następnie wybierz pozycję Łączniki.

Używanie alternatywnych kształtów łączników

Do łączenia kształtów można używać dowolnych kształtów łączników, na przykład dostępnych we wzorniku Więcej kształtów > Kształty dodatkowe > Łączniki, zamiast domyślnego kształtu Łącznik dynamiczny. Te kształty łączników można przeciągać i upuszczać na stronę lub wybrać do używania za pomocą narzędzi Łącznik i Połącz kształty. Można też ich użyć po prostu do zastąpienia istniejących łączników.

  1. Otwórz wzornik zawierający alternatywne kształty łączników.

  2. Zaznacz na stronie istniejące łączniki do zastąpienia.

  3. Na karcie Narzędzia główne w grupie Edytowanie kliknij pozycję Zmień kształt, a następnie wybierz odpowiedni kształt łącznika.

Uwaga: Funkcja Zmień kształt została wprowadzona w programie Visio 2013, ale narzędzia Łącznik i Połącz kształty zostały wprowadzone przed programem Visio 2007.

Początek strony

Zmienianie kształtów na minipasku narzędzi Autołączenie

Kształty na minipasku narzędzi pochodzą ze wzornika Szybkie kształty diagramu. Minipasek narzędzi zawiera maksymalnie cztery kształty. Możesz dostosować kształty wyświetlane na minipasku narzędzi. W poniższej procedurze użyto pozycji Diagram podstawowy jako przykładu.

  1. Domyślnie minipasek narzędzi zawiera cztery pierwsze kształty z wzornika, który jest umieszczony bezpośrednio po wzorniku Szybkie kształty. Oto na przykład cztery pierwsze kształty wzornika Podstawowy.

    Minipasek narzędzi z domyślnymi kształtami podstawowymi
  2. Aby wyświetlić inne kształty na minipasku narzędzi dla określonego wzornika, możesz zmieniać kolejność kształtów, przeciągając je na początek wzornika. Na przykład możesz przeciągnąć kształty Gwiazda 4-ramienna, Gwiazda 5-ramienna, Gwiazda 6-ramienna i Gwiazda 7-ramienna na początek wzornika Podstawowy.

    Minipasek narzędzi z nowymi kształtami podstawowymi
  3. Możesz również zmienić kolejność wzorników, przeciągając je wyżej lub niżej w okienku Kształty. Podzestaw tych kształtów jest wyświetlany we wzorniku Szybkie kształty (w tej samej kolejności co w okienku Kształty). Jeśli na przykład przeciągniesz wzornik Kształty dekoracyjne tak, aby umieścić go bezpośrednio po wzorniku Szybkie kształty w okienku Kształty, spowoduje to zmianę sekwencji we wzorniku Szybkie kształty.

    Minipasek narzędzi z innym wzornikiem określonym przez zmianę kolejności

    Uwaga: Po zamknięciu i ponownym otwarciu diagramu domyślna kolejność wzorników w okienku Kształty jest automatycznie przywracana i odzwierciedlana we wzorniku Szybkie kształty.

  4. Aby użyć innego wzornika jako podstawy dla minipaska narzędzi, we wzorniku Szybkie kształty wybierz kształt z podzestawu kształtów dla wzornika. Na przykład wybierz pozycję Diagram Venna we wzorniku Wykresy i kształty matematyczne.

    Minipasek narzędzi z nowym wzornikiem określonym przez wybór

Porada: Aby przywrócić domyślną sekwencję kształtów we wzorniku, kliknij prawym przyciskiem myszy nazwę wzornika w okienku Kształty, a następnie wybierz pozycję Resetuj wzornik.

Uwaga: Nie wszystkie wzorniki zawierają kształty, których można używać na minipasku narzędzi. Na przykład kształty z wzornika Strzałki nie są wyświetlane na minipasku narzędzi.

Początek strony

Włączanie i wyłączanie autołączenia

Autołączenie można włączać i wyłączać dla bieżącego rysunku lub jako ustawienie domyślne dla wszystkich rysunków programu Visio.

Włączanie i wyłączanie autołączenia dla aktywnego diagramu

  • Na karcie Widok w grupie Ułatwienia wizualne zaznacz lub wyczyść zaznaczenie pola wyboru Autołączenie.

    Zaznacz lub wyczyść pole wyboru Autołączenie na karcie Widok, aby aktywować lub dezaktywować autołączenie.

Jeśli pole wyboru Autołączenie jest niedostępne, sprawdź, czy funkcja autołączenia została wyłączona dla wszystkich diagramów, wykonując poniższą procedurę.

Włączanie i wyłączanie autołączenia dla wszystkich diagramów

  1. Kliknij kartę Plik, a następnie kliknij pozycję Opcje.

  2. W obszarze Opcje programu Visio kliknij pozycję Zaawansowane.

  3. W obszarze Opcje edycji wybierz pozycję Włącz autołączenie, aby włączyć autołączenie. Aby wyłączyć autołączenie, wyczyść pole wyboru Autołączenie.

    Zaznacz lub wyczyść pole wyboru Włącz autołączenie, aby aktywować lub dezaktywować autołączenie dla wszystkich diagramów i rysunków.
  4. Kliknij przycisk OK.

Początek strony

Łączenie kształtów za pomocą autołączenia

Jednym ze sposobów łączenia kształtów jest automatyczne łączenie w programie Visio podczas dodawania kształtów do rysunku. Ta opcja jest szczególnie przydatna podczas tworzenia schematu blokowego.

Poniższa procedura umożliwia dodanie do rysunku kształtu, który następnie program Visio automatycznie łączy z istniejącym kształtem.

Używanie autołączenia podczas przeciągania kształtów na stronę

  1. Przeciągnij kształt z wzornika na stronę rysunku i umieść go w pobliżu innego kształtu.

    Kształt umieszczony w pobliżu innego kształtu

  2. Przytrzymując naciśnięty przycisk myszy, przesuń wskaźnik na jeden z niebieskich trójkątów. Kolor trójkąta zmieni się na ciemnoniebieski.

    Zatrzymanie wskaźnika na jednym z niebieskich trójkątów powoduje zmianę jego koloru na ciemnoniebieski.

  3. Zwolnij przycisk myszy. Kształt zostanie umieszczony na stronie rysunku, a między dwoma kształtami zostanie dodany i przyklejony łącznik.

    Kształt zostanie umieszczony na stronie rysunku, a między dwoma kształtami zostanie dodany i przyklejony łącznik.

Porada: Jeśli nie lubisz przeciągania kształtów, możesz uzyskać taki sam efekt, wybierając kształt we wzorniku, zatrzymując wskaźnik na kształcie na rysunku i klikając jeden z niebieskich trójkątów wyświetlanych obok tego kształtu.

Używanie autołączenia z kształtami umieszczonymi wcześniej na stronie

  1. Zatrzymaj wskaźnik na kształcie, z którego chcesz utworzyć połączenie.

    Wskaźnik ustawiony na kształcie, z którego jest tworzone połączenie.

  2. Umieść wskaźnik myszy na niebieskim trójkącie umieszczonym najbliżej kształtu, z którym chcesz utworzyć połączenie.

    Wskaźnik umieszczony nad niebieskim trójkątem najbliższym kształtowi, do którego połączenie ma zostać utworzone.

    Kolor trójkąta zmieni się na ciemnoniebieski i pojawi się czerwona ramka wokół kształtu, z którym chcesz utworzyć połączenie.

    Uwaga: Jeśli nie pojawia się czerwona ramka wokół kształtu, z którym chcesz utworzyć połączenie, może to oznaczać, że kształt znajduje się za daleko. Przesuń kształt bliżej i spróbuj ponownie albo użyj narzędzia Łącznik.

  3. Kliknij niebieski trójkąt. Zostanie dodany łącznik przyklejony do obu kształtów.

    Kształt zostanie umieszczony na stronie rysunku, a między dwoma kształtami zostanie dodany i przyklejony łącznik.

Włączanie lub wyłączanie autołączenia

Funkcję autołączenia można włączyć lub wyłączyć we wszystkich rysunkach programu Visio lub tylko w bieżącym rysunku. Dla wszystkich rysunków:

  1. W menu Narzędzia kliknij pozycję Opcje.

  2. Kliknij kartę Ogólne.

  3. W opcjach Okno rysunku zaznacz pole wyboru Włącz autołączenie.

Tylko dla bieżącego rysunku:

  • Na pasku narzędzi Standardowy kliknij narzędzie Autołączenie.

    Uwaga: Jeśli kliknięcie narzędzia Autołączenie nie powoduje włączenia autołączenia, upewnij się, że jest zaznaczone pole wyboru Włącz autołączenie w oknie dialogowym Opcje.

Łączenie kształtów za pomocą narzędzia Łącznik

Jednym z najbardziej elastycznych sposobów dodawania i przyklejania łączników jest rysowanie ich przy użyciu narzędzia Łącznik Obraz przycisku na pasku narzędzi Standardowy.

  1. Kliknij narzędzie Łącznik Obraz przycisku na pasku narzędzi Standardowy.

  2. Wykonaj jedną z następujących czynności:

    • Aby łącznik pozostawał przyklejony do określonego punktu na kształcie, przeciągnij od punktu połączenia Obraz punktu połączenia — niebieski znak X na pierwszym kształcie do punktu połączenia na drugim kształcie. Po połączeniu kształtów punkty końcowe łącznika zmienią kolor na czerwony. Jest to nazywane połączeniem punkt-punkt. W przypadku połączenia punkt-punkt łącznik pozostaje przyklejony do tych samych punktów połączeń podczas przesuwania jednego z kształtów.

    • Aby umożliwić przesuwanie łącznika do najbliższego dostępnego punktu połączenia, przytrzymaj narzędzie Łącznik na środku pierwszego kształtu, aż wokół tego kształtu pojawi się czerwona ramka. Przytrzymaj naciśnięty przycisk myszy i przeciągnij do środka drugiego kształtu. Gdy wokół drugiego kształtu pojawi się czerwona ramka, zwolnij przycisk myszy. Jest to nazywane połączeniem kształt-kształt. W przypadku połączenia kształt-kształt łącznik pozostaje przyklejony do obu kształtów (jest przesuwany do najbliższych dostępnych punktów połączeń, gdy przesuwasz dowolny z kształtów). Jeśli nie są dostępne żadne punkty połączeń, łącznik jest przesuwany do najbliższych boków.

      Uwaga: Możesz również tworzyć połączenia między kształtami, w których jeden koniec łącznika jest połączony z punktem połączenia, a drugi koniec łącznika jest połączony z kształtem (i na odwrót).

  3. Kliknij narzędzie Wskaźnik Przycisk wskaźnika na pasku narzędzi Standardowy, aby wrócić do normalnego edytowania.

    Uwagi: 

    • Aby dodać łącznik z jednego kształtu do kilku kształtów, musisz dodać kilka łączników (nie istnieje „rozgałęziony” kształt łącznika).

    • Jeśli próbujesz utworzyć połączenie punkt-punkt i masz trudności z przyklejeniem łącznika dokładnie w wybranym miejscu, wypróbuj inne ustawienia przyciągania i przyklejania:

    • W menu Narzędzia kliknij pozycję Przyciąganie i przyklejanie, a następnie na karcie Ogólne wybierz odpowiednie opcje.

      Gdy przyklejasz łącznik do geometrii kształtu, uchwytu kształtu lub wierzchołka kształtu, dodawany jest automatycznie punkt połączenia, jeśli jeszcze nie istnieje.

Przełączanie między połączeniami kształtów i punktów

Łączniki można przyklejać między jednym punktem na kształcie a innym punktem na innym kształcie albo między całym kształtem a innym całym kształtem. Można też tworzyć połączenia, w których jeden koniec łącznika jest przyklejony do punktu na kształcie, a drugi koniec łącznika jest przyklejony do całego kształtu.

  1. Przeciągnij punkt końcowy łącznika w miejsce oddalone od kształtu.

  2. Wykonaj jedną z następujących czynności:

    • Aby przykleić punkt końcowy łącznika do punktu połączenia na kształcie, przeciągnij ten punkt końcowy do jednego z punktów połączeń kształtu, tak aby pojawiła się czerwona ramka wokół punktu połączenia.

    • Aby przykleić punkt końcowy łącznika do całego kształtu, przeciągnij punkt końcowy do środka kształtu, tak aby pojawiła się czerwona ramka wokół całego kształtu.

Zobacz też

Dodawanie i edytowanie tekstu łączników

Tworzenie łącznika niestandardowego

Przyklejanie lub odklejanie łączników

Szkolenia dotyczące programu Visio

All you need to know about Visio desktop connectors — Visio team blog (Wszystko, co trzeba wiedzieć o łącznikach w wersji klasycznej programu Visio — blog zespołu programu Visio)

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×