Co to jest Autozapis?

Przycisk przełączania funkcji Autozapis w pakiecie Office

Autozapis to nowa funkcja dostępna w programie Excel, Word i PowerPoint dla subskrybentów usługi Office 365. Gdy pracujesz, dzięki tej funkcji Twój plik jest automatycznie zapisywany co kilka sekund. 

Autozapis jest włączony domyślnie w usłudze Office 365, gdy plik jest przechowywany w usłudze OneDrive, OneDrive dla Firm lub SharePoint Online. 

Porada: Korzystasz z polecenia Plik > Zapisz jako po wprowadzeniu zmian w oryginalnym dokumencie lub szablonie? Jeśli tak, to zalecamy skorzystanie z opcji Plik > Zapisz kopię zanim wprowadzisz zmiany. Dzięki temu Autozapis nie zastąpi oryginalnego pliku plikiem ze zmianami. Jeśli Autozapis zastąpi oryginalny plik wersją ze zmianami, zobacz poniższą sekcję „Nie chcę zapisywać wprowadzonych zmian. Jak je cofnąć?”.

W systemie Windows Autozapis jest dostępny w programach Excel, Word i PowerPoint dla subskrybentów usługi Office 365. Oto niektóre często zadawane pytania dotyczące tej funkcji.

Możesz przywrócić poprzednią wersję pliku za pomocą Historii wersji. 

Kursor klikający nazwę pliku, Zobacz wszystkie wersje

W górnej części okna kliknij nazwę pliku, a następnie kliknij pozycję Historia wersji. Przejrzyj daty i godziny, aby znaleźć wersję, którą chcesz przywrócić, a następnie kliknij pozycję Otwórz wersję. Otworzy się drugie okno z daną wersją pliku. Aby przywrócić tę wersję, kliknij przycisk Przywróć. Aby uzyskać więcej informacji o historii wersji, zobacz Wyświetlanie historycznych wersji plików pakietu Office.

Gdy otworzysz plik i wprowadzisz pierwsze zmiany, funkcja Autozapis zapisuje te zmiany, a do historii wersji zostaje dodana nowa wersja pliku. Pomimo, że Autozapis regularnie zapisuje wprowadzone zmian w pliku, nowe wersje są dodawane do historii wersji okresowo (co około 10 minut) przez resztę sesji edycji.

Jeśli jesteś właścicielem pliku, możesz skonfigurować go tak, aby zawsze otwierał się w trybie tylko do odczytu. Gdy inne osoby otworzą plik z takim ustawieniem, nie będą mogły zapisać zmian w dokumencie, chyba że włączą edytowanie. Aby włączyć to ustawienie w przypadku danego pliku, przejdź do Plik > Informacje > Chroń dokument > Zawsze otwieraj tylko do odczytu. Aby wyłączyć to ustawienie później, po prostu powtórz ten proces.

Została wybrana kontrolka Chroń dokument, odsłaniając opcję Zawsze otwieraj tylko do odczytu.

Istnieją inne sposoby zabezpieczania pliku przed edytowaniem. Jeśli plik znajduje się w usłudze OneDrive, możesz zmienić uprawnienia do niego. Jeśli plik znajduje się w programie SharePoint, możesz skonfigurować bibliotekę tak, aby wymagać wyewidencjonowania.

Plik > Zapisz kopię

Polecenia Zapisz jako nie ma w menu Plik, gdy otwierasz dokument z usługi OneDrive, OneDrive dla Firm lub SharePoint Online. W takich przypadkach zamiast niego w menu Plik pojawia się polecenie Zapisz kopię.

Często używasz polecenia Zapisz jako? Wiele osób przyzwyczaiło się, że pracują nad plikiem, a następnie za pomocą polecenia Plik > Zapisz jako zachowują zmiany w kopii, a nie w oryginale. Jednak gdy funkcja Autozapis jest włączona, zmiany są stale zapisywane w oryginale. Dlatego zalecamy użycie polecenia Plik > Zapisz kopię od razu, jeśli chcesz zastosować zmiany do kopii, a nie do oryginału.

Jeśli jesteś subskrybentem usługi Office 365 i masz najnowsze wersje programów Excel, Word, PowerPoint dla systemu Windows, funkcja Autozapis jest dostępna w lewym górnym rogu na pasku tytułu. Pamiętaj, że jeśli masz konto służbowe lub szkolne, administrator może decydować, którą wersję pakietu Office możesz zainstalować, i może nie być to najnowsza wersja. Aby uzyskać więcej informacji, zobacz Kiedy uzyskam najnowsze funkcje w pakiecie Office 365?

Jeśli nie jesteś subskrybentem, nie martw się. Jest jeszcze funkcja Autoodzyskiwanie. Autoodzyskiwanie zapewnia ochronę plików w razie awarii. Jeśli plik zostanie otwarty ponownie po awarii, w okienku Odzyskiwanie dokumentów będzie widoczna wersja pliku z najnowszymi zmianami. Aby uzyskać więcej informacji na temat włączania tej funkcji, zobacz Zapewnianie ochrony plików w razie awarii.

Oczywiście zawsze możesz też zapisać plik ręcznie tak jak zwykle, naciskając klawisze CTRL + S, klikając przycisk Zapisz lub poprzez Plik > Zapisz.

Autozapis jest włączony w przypadku edytowania plików przechowywanych w usłudze OneDrive, OneDrive dla Firm lub SharePoint Online. Jeśli plik jest zapisany w innej lokalizacji (lub nie został jeszcze zapisany), Autozapis jest wyłączony. Tak się stanie, jeśli Twój plik znajduje się w witrynie lokalnej programu SharePoint lub na serwerze plików bądź jest zapisany w ścieżce lokalnej, na przykład C:\.

Istnieją też inne przyczyny, dla których funkcja Autozapisu może być wyłączona. Oto niektóre typowe przyczyny jej wyłączenia:

  • Plik został przygotowany w starszym formacie takim jak .xls, .ppt lub .doc.

  • Plik znajduje się w folderze lokalnym usługi OneDrive, a synchronizacja usługi OneDrive jest wstrzymana.

  • Plik jest synchronizowany za pomocą starszej wersji klienta synchronizacji OneDrive. Aby uzyskać więcej informacji o aktualizowaniu usługi OneDrive, zobacz Wprowadzenie do nowego klienta synchronizacji usługi OneDrive w systemie Windows.

  • Plik został osadzony w innym pliku pakietu Office.

  • Prezentacja znajduje się w trybie pokazu slajdów.

Jeśli korzystasz z programu Excel i spróbowano wykonać powyższe czynności, być może masz plik zawierający funkcje nieobsługiwane przez funkcję Autozapis. Wykonaj co najmniej jedną z następujących czynności, aby ją włączyć:

  • Wyłączenie funkcji Skoroszyt udostępniony. To starsza metoda udostępniania. Ma wiele ograniczeń i została zastąpiona przez funkcję współtworzenia.

  • Usunięcie z pliku szyfrowania przy użyciu hasła, jeśli to możliwe: w tym celu przejdź do pozycji Plik > Informacje > Chroń skoroszyt. Następnie usuń hasło i kliknij przycisk OK.

  • Usunięcie ograniczeń dostępu, jeśli to możliwe: w tym celu przejdź do pozycji Plik > Informacje > Chroń skoroszyt > Ogranicz dostęp i kliknij pozycję Dostęp nieograniczony.

  • Jeśli w programie SharePoint otwierasz migawkę skoroszytu, wybierz otworzenie pliku zamiast migawki.

  • Wyłącz ustawienie Odśwież dane podczas otwierania pliku dla wszystkich tabel i tabel przestawnych w pliku. Zaznacz tabelę lub tabelę przestawną, a następnie wybierz pozycję Narzędzia tabel > Projektowanie > Odśwież > Właściwości połączenia. Następnie wyczyść pole wyboru Odśwież dane podczas otwierania pliku.

  • Dezaktywuj dodatek powodujący wyłączenie funkcji Autozapis. Wybierz pozycję Plik > Opcje > Dodatki > Dodatki programu Excel > Przejdź, a następnie wyczyść pole wyboru dodatku.

Można to zrobić w prosty sposób poprzez wyłączenie funkcji Autozapis przed wprowadzeniem swoich zmian. Jeśli zmiany mają być tymczasowe i nie chcesz ich zapisywać, zamknij plik. Gdy zostanie wyświetlony monit o zapisanie, kliknij pozycję Nie. Jeśli zdecydujesz, że chcesz zapisać zmiany, wystarczy włączyć Autozapis z powrotem.

Jeśli nie chcesz cały czas zapisywać zmian i nie chcesz ich pokazywać innym, możesz wyłączyć Autozapis. Gdy wszystko będzie już gotowe, kliknij pozycję Zapisz (lub naciśnij klawisze CTRL + S), aby zapisać zmiany i pokazać je wszystkim innym osobom pracującym nad plikiem. (Możesz też z powrotem włączyć Autozapis, aby zapisać i udostępnić swoje zmiany).

Domyślnie funkcja Autozapis jest zawsze włączona dla plików znajdujących się na platformie Microsoft Cloud. Jeśli jednak wyłączysz Autozapis dla pojedynczego pliku, program zapamięta to ustawienie i pozostawi tę funkcję wyłączoną za każdym razem, gdy otworzysz ten plik. Jeśli ponownie ją włączysz w odniesieniu do danego pliku, również przy następnych uruchomieniach funkcja ta będzie włączona.

Gdy funkcja Autozapis jest wyłączona, funkcja Autoodzyskiwanie nadal działa w razie wystąpienia awarii systemu, gdy plik jest otwarty. Aby uzyskać więcej informacji, zobacz Zapewnianie ochrony plików w razie awarii.

Jeśli wyłączysz Autozapis w odniesieniu do pojedynczego pliku, program zapamięta, że ta funkcja ma być wyłączona za każdym razem, gdy otworzysz ten plik. Jeśli włączysz ją ponownie w odniesieniu do danego pliku, w przypadku kolejnego otwarcia tego pliku funkcja ta również będzie włączona.

Jeśli chcesz wyłączyć Autozapis domyślnie dla wszystkich plików, przejdź do Plik > Opcje > Zapisz i odznacz pole wyboru obok pozycji Domyślnie zapisuj automatycznie pliki usług OneDrive i SharePoint Online w aplikacji <application>.

Okno dialogowe Plik > Opcje > Zapisywanie z wyświetlonym polem wyboru do włączania lub wyłączania autozapisu

Uruchom ponownie aplikację Word (lub dowolną aplikację, w której się znajdujesz), a zmiana zostanie zastosowana.

Uwagi: 

  • Jeśli Autozapis ma być domyślnie wyłączony dla wszystkich aplikacji pakietu Office, takich jak PowerPoint i Excel, musisz powtórzyć te czynności dla każdego z tych programów.

  • Jeśli pojedyncze pliki mają być nadal zapisywane automatycznie, możesz otworzyć te pliki i ręcznie włączyć dla nich ponownie Autozapis.

Na komputerach Mac, Autozapis jest dostępny w programach Excel, Word i PowerPoint dla subskrybentów usługi Office 365. Oto niektóre często zadawane pytania dotyczące tej funkcji.

Możesz przywrócić poprzednią wersję pliku. Spowoduje to ustanowienie starszej wersji jako bieżącej. Kliknij pozycję Plik > Przeglądaj historię wersji. W okienku Historia wersji przejrzyj daty i godziny, aby znaleźć wersję, którą chcesz przywrócić, a następnie kliknij pozycję Otwórz wersję. Zostanie otwarte drugie okno. Aby przywrócić tę wersję, kliknij przycisk Przywróć.

Jeśli plik znajduje się w usłudze OneDrive, możesz zmienić uprawnienia do niego. Jeśli plik znajduje się w programie SharePoint, możesz skonfigurować bibliotekę tak, aby wymagać wyewidencjonowania.

Polecenia Zapisz jako nie ma w menu Plik, gdy otwierasz dokument z usługi OneDrive, OneDrive dla Firm lub SharePoint Online. W takich przypadkach zamiast niego w menu Plik pojawia się polecenie Zapisz kopię.

Często używasz polecenia Zapisz jako? Wiele osób przyzwyczaiło się, że pracują nad plikiem, a następnie za pomocą polecenia Plik > Zapisz jako zachowują zmiany w kopii, a nie w oryginale. Jednak gdy funkcja Autozapis jest włączona, zmiany są stale zapisywane w oryginale. Dlatego zalecamy użycie polecenia Plik > Zapisz kopię od razu, jeśli chcesz zastosować zmiany do kopii, a nie do oryginału.

Funkcja Autozapis jest widoczna w lewym górnym rogu, jeśli jesteś subskrybentem usługi Office 365 i masz zainstalowane najnowsze wersje programów Excel, Word i PowerPoint dla pakietu Office 365. Pamiętaj, że jeśli masz konto służbowe lub szkolne, administrator może decydować, którą wersję pakietu Office możesz zainstalować, i może nie być to najnowsza wersja. Aby uzyskać więcej informacji, zobacz Kiedy uzyskam najnowsze funkcje w pakiecie Office 365?.

Jeśli nie jesteś subskrybentem, nie martw się. Jest jeszcze funkcja Autoodzyskiwanie. Autoodzyskiwanie zapewnia ochronę plików w razie awarii. Jeśli otworzysz plik ponownie po awarii, w okienku Odzyskiwanie dokumentów wyświetli się wersja pliku z Twoimi ostatnimi zmianami. Aby uzyskać więcej informacji na temat włączania tej funkcji, zobacz Odzyskiwanie plików w pakiecie Office dla komputerów Mac.

Autozapis jest włączony w przypadku edytowania plików przechowywanych w usłudze OneDrive, OneDrive dla Firm lub SharePoint Online. Jeśli plik jest zapisany w innej lokalizacji (lub nie został jeszcze zapisany), funkcja Autozapis jest wyłączona. Tak się stanie, jeśli Twój plik znajduje się w witrynie lokalnej programu SharePoint, na serwerze plików lub jest zapisany w folderze lokalnym na komputerze.

Ponadto musisz otworzyć plik z menu Plik w programie Word, Excel lub PowerPoint, aby aktywować funkcję Autozapisu.

Uwaga: Jeśli Twoje menu Plik > Otwórz wygląda jak na poniższym obrazie, należy kliknąć przycisk Lokalizacje online, a następnie wybrać plik usługi OneDrive lub programu SharePoint w tym miejscu, aby funkcja Autozapisu działała. Menu Plik > Otwórz z widokiem „Na tym komputerze Mac”.

Istnieją też inne przyczyny, dla których funkcja Autozapisu może być wyłączona. Poniżej przedstawiono typowe przyczyny jej wyłączenia:

  • Plik jest w starszym formacie, na przykład xls, ppt lub doc.

  • Plik znajduje się w folderze lokalnym usługi OneDrive, a synchronizacja usługi OneDrive jest wstrzymana.

  • Plik został osadzony w innym pliku pakietu Office.

  • Prezentacja znajduje się w trybie pokazu slajdów.

Jeśli korzystasz z programu Excel i spróbowano wykonać powyższe czynności, być może masz plik zawierający funkcje nieobsługiwane przez funkcję Autozapis. Wykonaj co najmniej jedną z następujących czynności, aby ją włączyć:

  • Wyłączenie funkcji Skoroszyt udostępniony. To starsza metoda udostępniania. Ma wiele ograniczeń i została zastąpiona przez funkcję współtworzenia.

  • Usunięcie z pliku szyfrowania przy użyciu hasła, jeśli to możliwe: w tym celu na karcie Recenzja kliknij pozycję Chroń skoroszyt. Następnie usuń hasło i kliknij przycisk OK.

  • Usunięcie ograniczeń dostępu, jeśli to możliwe: Przejdź do pozycji Plik > Ogranicz uprawnienia > Bez ograniczeń.

  • Jeśli w programie SharePoint otwierasz migawkę skoroszytu, wybierz otworzenie pliku zamiast migawki.

  • Wyłącz ustawienie Odśwież dane podczas otwierania pliku dla wszystkich tabel i tabel przestawnych w pliku. Zaznacz tabelę lub tabelę przestawną, a następnie przejdź do karty Tabela. Kliknij pozycję Odśwież > Właściwości połączenia i wyczyść pole wyboru Odśwież dane podczas otwierania pliku.

  • Dezaktywuj dodatek powodujący wyłączenie funkcji Autozapis. Wybierz pozycję Narzędzia > Dodatki programu Excel i wyczyść pole wyboru dodatku.

Można to zrobić w prosty sposób poprzez wyłączenie funkcji Autozapis przed wprowadzeniem swoich zmian. Jeśli zdecydujesz się zapisać zmiany, po prostu z powrotem włącz funkcję Autozapis. Jeśli nie chcesz zapisać zmian, zamknij plik. Gdy zostanie wyświetlony monit o zapisanie, kliknij pozycję Nie.

Jeśli nie chcesz cały czas zapisywać ani pokazywać innym wprowadzonych zmian, możesz wyłączyć funkcję Autozapis. Potem, gdy wszystko będzie gotowe, kliknij pozycję Zapisz, aby wprowadzone zmiany były widoczne dla innych osób pracujących nad plikiem. Możesz również z powrotem włączyć przełącznik Autozapis, aby zapisać i udostępnić swoje zmiany.

Domyślnie funkcja Autozapisu jest zawsze Włączona dla plików znajdujących się w chmurze. Jednak jeśli Wyłączysz Autozapis dla pliku, program zapamięta ten wybór i pozostawi funkcję Autozapisu wyłączoną za każdym razem, gdy ponownie otworzysz ten plik. Jeśli ponownie ją włączysz w odniesieniu do danego pliku, również przy następnych uruchomieniach funkcja ta będzie włączona.

Gdy funkcja Autozapis jest wyłączona, funkcja Autoodzyskiwanie nadal działa w razie wystąpienia awarii systemu, gdy plik jest otwarty. Aby uzyskać więcej informacji, zobacz Automatyczne zapisywanie i odzyskiwanie plików.

Jeśli wyłączysz Autozapis w odniesieniu do pojedynczego pliku, program zapamięta, że ta funkcja ma być wyłączona za każdym razem, gdy otworzysz ten plik. Jeśli włączysz ją ponownie w odniesieniu do danego pliku, w przypadku kolejnego otwarcia tego pliku funkcja ta również będzie włączona.

Jeśli chcesz wyłączyć funkcję Autozapis domyślnie dla wszystkich plików przejdź do pozycji Word > Preferencje > Zapisz i wyczyść pole wyboru obok pozycji Domyślnie włącz Autozapis.

Nie. Jednak możesz Wyłączyć Autozapis dla pliku, a program zapamięta ten wybór i pozostawi funkcję Autozapis wyłączoną za każdym razem, gdy ponownie otworzysz ten plik. Jeśli ponownie Włączysz ją dla pliku, ten wybór zostanie zapamiętany dla tego pliku.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×