Co nowego w programie Excel 2010

Uwaga:  Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

W tym artykule opisano nowe i udoskonalone funkcje programu Microsoft Excel 2010.

W tym artykule

Korzystanie z właściwych narzędzi w odpowiednim czasie

Ulepszona wstążka

Widok Microsoft Office Backstage

Narzędzia do zarządzania skoroszytami

Nowe sposoby uzyskiwania dostępu do skoroszytów

Aplikacja Microsoft Excel Online

Aplikacja Excel Mobile 2010 dla telefonu Windows Phone 7

Szybkie, wydajne porównania na podstawie list danych

Wykresy przebiegu w czasie

Ulepszone tabele przestawne

Fragmentatory

Poprawione formatowanie warunkowe

Zaawansowana analiza bezpośrednio z pulpitu

Dodatek Power Pivot dla programu Excel

Udoskonalony dodatek Solver

Lepsza dokładność funkcji

Większe możliwości filtrowania

64-bitowa wersja programu Excel

Ulepszenia wydajności

Tworzenie lepszych wizualnie skoroszytów

Udoskonalone wykresy

Obsługa równań

Więcej motywów

Wklejanie z podglądem na żywo

Udoskonalone narzędzia do edycji obrazów

Nowe sposoby współpracy w skoroszytach

Współtworzenie skoroszytów

Ulepszone Usługi programu Excel

Sprawdzanie ułatwień dostępu

Udoskonalone narzędzia językowe

Rozszerzanie skoroszytów na nowe sposoby

Udoskonalone funkcje programowania

Obsługa wysokiej wydajności

Korzystanie z właściwych narzędzi w odpowiednim czasie

Nowe i ulepszone funkcje pomagają poprawić produktywność, lecz tylko pod warunkiem, że wiadomo, gdzie ich szukać, gdy są potrzebne. Podobnie jak w innych programach pakietu Microsoft Office 2010 w programie Excel 2010 dostępny jest interfejs Microsoft Office Fluent, obejmujący wizualny system narzędzi i poleceń, który można dostosować.

Ulepszona wstążka

Wstążka pojawiła się po raz pierwszy w programie Excel 2007. Ten element interfejsu ułatwia znajdowanie poleceń i funkcji, które wcześniej były ukryte w skomplikowanych menu i na paskach narzędzi. Mimo że w programie Excel 2007 było można dostosowywać pasek narzędzi Szybki dostęp, użytkownik nie mógł dodawać własnych kart ani grup na wstążce. W programie Excel 2010 można tworzyć własne karty i grupy oraz zmieniać nazwy i kolejność wbudowanych kart i grup.

Niestandardowa karta na wstążce

Dowiedz się więcej o dostosowywaniu wstążki.

Microsoft Office Backstage

Po kliknięciu karty Plik zostanie otwarty widok Backstage, w którym można tworzyć nowe pliki, otwierać istniejące pliki, zapisywać, wysyłać i drukować pliki, a także włączać ich ochronę i wyświetlać podgląd. Dostępne są tu także opcje programu Excel i wiele innych funkcji.

Karta Informacje w widoku Backstage

Dowiedz się więcej.

Narzędzia do zarządzania skoroszytami

W programie Excel 2010 są dostępne narzędzia, które pomagają w ochronie i udostępnianiu zawartości, a także w zarządzaniu nią.

  • Odzyskiwanie starszych wersji    Teraz można odzyskać wersje plików, które zostanie zamknięty bez zapisywania. Jest to pomocne w przypadku, gdy zapomnisz ręcznie zapisać, gdy zapiszesz zmiany, które nie powinny, aby zapisać, lub gdy użytkownik chce powrócić do wcześniejszej wersji tego skoroszytu. Dowiedz się więcej o odzyskiwanie plików pakietu Office.

  • Widok chroniony    W programie Excel 2010 dostępny jest widok chroniony, który umożliwia podejmowanie bardziej świadomych decyzji zapobiegających narażeniu komputera na ewentualne ryzyko. Dokumenty pochodzące ze źródeł internetowych są domyślnie otwierane w widoku chronionym. W takiej sytuacji na pasku komunikatów wyświetlane jest ostrzeżenie wraz z opcją umożliwiającą włączenie edytowania. Można wybrać określone źródła dokumentów, dla których będzie włączany widok chroniony. Można także wybrać określone typy plików, które będą otwierane w widoku chronionym niezależnie od ich pochodzenia. Dowiedz się więcej o widoku chronionym.

  • Zaufane dokumenty    Zadaniem funkcji zaufanych dokumentów jest ułatwienie otwierania skoroszytów i innych dokumentów, w których może występować zawartość aktywna, taka jak połączenia danych lub makra. Teraz wystarczy, że raz potwierdzisz, iż zawartość aktywna skoroszytu jest bezpieczna. Program Excel 2010 zapamiętuje zaufane skoroszyty i nie wyświetla monitów przy ich ponownym otwieraniu. Dowiedz się więcej o zaufanych dokumentach.

Nowe sposoby uzyskiwania dostępu do skoroszytów

Obecnie możesz uzyskiwać dostęp do swoich plików i pracować z nimi z dowolnej lokalizacji — w pracy, w domu i w podróży.

Aplikacja Microsoft Excel Online

Aplikacja Excel Online umożliwia korzystanie z programu Excel również w przeglądarce internetowej, dzięki czemu ze skoroszytami można pracować bezpośrednio w witrynie, w której są przechowywane. Aplikacja Excel Online należy do zestawu aplikacji Microsoft Office Online i jest dostępna w ramach usługi OneDrive oraz w organizacjach, w których skonfigurowano aplikacje Office Online w programie SharePoint 2010.

W aplikacji Excel Online można wykonywać następujące czynności:

  • Wyświetlanie skoroszytu w przeglądarce    Kliknięcie skoroszytu w celu otwarcia go w aplikacji Excel Online powoduje wyświetlenie go w trybie widoku. Można w nim sortować i filtrować dane, rozwijać tabele przestawne w celu obserwowania relacji i trendów danych, ponownie obliczać wartości i wyświetlać różne arkusze.

  • Edytowanie skoroszytu w przeglądarce    Dzięki aplikacji Excel Online wszystko, co jest potrzebne, aby uzyskać dostęp do skoroszytów, to przeglądarka. Twoi współpracownicy mogą z Tobą pracować niezależnie od wersji programu Excel, której używają. Kliknięcie skoroszytu programu Excel zapisanego w witrynie programu SharePoint lub w usłudze OneDrive powoduje otwarcie go bezpośrednio w przeglądarce. Skoroszyty w przeglądarce wyglądają tak samo jak w programie Excel. Można edytować arkusze w przeglądarce, korzystając ze znajomego interfejsu programu Excel. Podczas edycji w przeglądarce można zmieniać dane, wprowadzać lub edytować formuły i stosować podstawowe opcje formatowania w arkuszu kalkulacyjnym. Można także pracować w tym samym skoroszycie jednocześnie z innymi osobami.

Dowiedz się więcej o aplikacji Excel Online.

Aplikacja Excel Mobile 2010 dla telefonu Windows Phone 7

Użytkownicy telefonów Windows Phone 7 mogą pracować z plikami za pomocą pakietu Microsoft Office Mobile 2010 w dowolnym miejscu — w pracy, w domu i w podróży. Aplikacja Excel Mobile 2010 jest częścią pakietu Office Mobile i jest od razu dostępna na telefonie w centrum Office, nie trzeba więc nic pobierać ani instalować — można od razu przystąpić do pracy.

Skoroszyt programu Excel otwarty na telefonie

Przy użyciu aplikacji Excel Mobile można wyświetlać i edytować skoroszyty zapisane w pamięci telefonu, otrzymane jako załączniki do wiadomości e-mail i przechowywane w witrynie programu SharePoint 2010 za pomocą aplikacji SharePoint Workspace Mobile 2010. W razie edytowania skoroszytu za pośrednictwem aplikacji SharePoint Workspace Mobile po powrocie do trybu online można zapisać wprowadzone zmiany z powrotem w witrynie programu SharePoint.

Arkusze kalkulacyjne można tworzyć, aktualizować i błyskawicznie ponownie obliczać przy użyciu wielu narzędzi znanych już z wersji klasycznej programu Excel:

  • Przełączanie się między arkuszami lub wykresami w skoroszycie za pomocą widoku konspektu.

  • Sortowanie i filtrowanie arkuszy oraz zarządzanie nimi.

  • Dodawanie i edytowanie tekstu i liczb.

  • Dodawanie komentarzy.

Dowiedz się więcej o pakiecie Office Mobile 2010 dla telefonu Windows Phone 7.

Szybkie, wydajne porównania na podstawie list danych

W programie Excel 2010 są dostępne nowe funkcje, takie jak wykresy przebiegu w czasie i fragmentatory, a także ulepszenia tabel przestawnych i innych istniejących funkcji, które pomagają identyfikować wzorce lub trendy w danych.

Wykresy przebiegu w czasie

Wykresy przebiegu w czasie — niewielkie wykresy mieszczące się w komórce — umożliwiają wizualne podsumowywanie trendów danych. Wykresy tego rodzaju przedstawiają trendy na niewielkiej przestrzeni i dzięki temu są szczególnie użyteczne w pulpitach nawigacyjnych lub innych miejscach, w których niezbędne jest pokazanie migawki informacji biznesowych w przejrzystej formie graficznej. Na poniższej ilustracji pokazano, że dzięki wykresom przebiegu w czasie w kolumnie Trend wystarczy jeden rzut oka, aby się zorientować, jakie wyniki miały poszczególne działy w maju.

Wykresy przebiegu w czasie użyte do przedstawienia trendów danych sprzedaży

Dowiedz się więcej.

Ulepszone tabele przestawne

Tabele przestawne są teraz prostsze w obsłudze i lepiej reagują. Podstawowe ulepszenia:

  • Ulepszenia wydajności    Wielowątkowość w programie Excel 2010 przyspiesza pobieranie, sortowanie i filtrowanie danych w tabelach przestawnych.

  • Etykiety tabeli przestawnej    Obecnie istnieje możliwość Wypełnij w dół etykiet w tabeli przestawnej. Można również powtarzaj etykiet w tabeli przestawnej, aby wyświetlić element podpisy pól zagnieżdżonych w wszystkich wierszy i kolumn.

  • Ulepszone filtrowanie    Nowych fragmentatorów można używać do szybkiego filtrowania danych w tabeli przestawnej jednym kliknięciem przycisku i do wyświetlania zastosowanych filtrów bez otwierania dodatkowych menu. Ponadto nowe pole wyszukiwania w interfejsie filtru umożliwia błyskawiczne znajdowanie potrzebnych informacji wśród tysięcy (a nawet milionów) elementów w tabelach przestawnych.

  • Obsługa zapisywania danych w źródle    Program Excel 2010 pozwala zmieniać wartości w obszarze wartości tabeli przestawnej OLAP i zapisywać je w module usług Analysis Services na serwerze OLAP. Funkcji zapisywania danych w źródle można także używać w trybie warunkowym, a następnie zapisać zmiany lub cofnąć je, jeśli nie są już potrzebne. Funkcja działa z każdym dostawcą OLAP obsługującym instrukcję UPDATE CUBE.

  • Funkcja Pokaż wartości jako    Funkcja Pokaż wartości jako zawiera wiele nowych, automatyczne obliczenia, takie jak % sumy wiersza nadrzędnego, % sumy kolumny nadrzędnej, % sumy elementu nadrzędnego, % sumę bieżącą, Pozycja od najmniejszych do największych i Porządkuj od największych do najmniejszych.

  • Poprawa wykresu przestawnego    Teraz łatwiej interakcyjna Obsługa raportów w formie wykresu przestawnego. W szczególności łatwiej można filtrować dane bezpośrednio w formie wykresu przestawnego i zmieniać układ wykresu przestawnego, dodawanie i usuwanie pól. Podobnie za pomocą jednego kliknięcia, można ukryć wszystkie przyciski pól w raporcie wykresu przestawnego.

Dowiedz się więcej o zmianach tabel przestawnych.

Fragmentatory

Fragmentatory to kontrolki wizualne umożliwiające szybkie filtrowanie danych w tabeli przestawnej w interakcyjny i intuicyjny sposób. Po wstawieniu fragmentatora można za pomocą przycisków szybko segmentować i filtrować dane, aby było wyświetlane tylko to, co jest potrzebne. Ponadto po zastosowaniu w tabeli przestawnej więcej niż jednego filtru nie ma już potrzeby otwierania listy, aby się dowiedzieć, które filtry zostały zastosowane. Taka informacja jest widoczna na ekranie we fragmentatorze. Fragmentatory można sformatować tak, aby pasowały do formatowania skoroszytu, i z łatwością wielokrotnie używać ich w innych tabelach przestawnych, wykresach przestawnych i funkcjach modułów.

Fragmentator wyświetlany u góry tabeli przestawnej

Dowiedz się więcej.

Poprawione formatowanie warunkowe

Formatowanie warunkowe ułatwia wyróżnianie interesujących komórek lub zakresów komórek, podkreślanie nietypowych wartości i wizualizowanie danych za pomocą pasków danych, skal kolorów i zestawów ikon. Program Excel 2010 jest znacznie elastyczniejszy w zakresie formatowania warunkowego:

  • Nowe zestawy ikon    Zestawy ikon, które po raz pierwszy pojawiły się w programie Office Excel 2007, służą do wyświetlania ikon dla różnych kategorii danych na podstawie określonych wartości progowych. Można na przykład użyć zielonej strzałki w górę, aby przedstawić wyższe wartości, żółtej strzałki skierowanej w bok, aby przedstawić średnie wartości, oraz czerwonej strzałki skierowanej w dół, aby przedstawić niskie wartości. W programie Excel 2010 jest dostępnych więcej zestawów ikon, w tym trójkąty, gwiazdki i kwadraty. Można też łączyć i dopasowywać ikony z różnych zestawów oraz łatwiej usuwać ikony z widoku — na przykład można wyświetlać ikony jedynie dla dużych wartości zysku i pomijać je przy wartościach z zakresu średniego i niskiego.

    Przykład wyświetlania ikon jedynie wysokich wartości

  • Więcej opcji pasków danych    Program Excel 2010 jest wyposażony w nowe opcje formatowania pasków danych. W paskach danych można stosować ciągłe wypełnienia i obramowania albo ustawiać kierunek od prawej do lewej zamiast od lewej do prawej. Ponadto paski danych dla wartości ujemnych pojawiają się po przeciwnej stronie osi w stosunku do wartości dodatnich, tak jak pokazano na ilustracji.

    Przykład pasków danych z wartościami ujemnymi

  • Inne ulepszenia    Podczas określania kryteriów reguł warunkowych lub dotyczących sprawdzania poprawności danych można teraz odwoływać się do wartości w innych arkuszach skoroszytu.

Dowiedz się więcej o formatowaniu warunkowym.

Zaawansowana analiza bezpośrednio z pulpitu

Niezależnie od tego, czy pracujesz w domu, czy w biurze, musisz mieć dostęp do swoich danych i możliwość ich analizowania: pozwala to zyskać nowe spojrzenie na pewne sprawy i pomaga w podejmowaniu trafniejszych decyzji — a im wykonasz zadanie, tym lepiej. W programie Excel 2010 są dostępne nowe, ulepszone narzędzia do analizy, dzięki którym jest to możliwe.

Dodatek Power Pivot dla programu Excel

Jeśli konieczne jest analizowanie dużych ilości danych, można pobrać dodatek Microsoft SQL Server Power Pivot dla programu Excel, który powoduje pojawienie się karty Power Pivot na wstążce programu Excel.

Okno dodatku PowerPivot dla programu Excel 2010

Za pomocą dodatku Power Pivot dla programu Excel można importować miliony wierszy danych z wielu źródeł do jednego skoroszytu programu Excel, tworzyć relacje między niejednorodnymi danymi, tworzyć kolumny obliczeniowe i miary przy użyciu formuł, tworzyć tabele i wykresy przestawne, a następnie wykonywać bardziej szczegółowe analizy danych, aby ułatwić podejmowanie właściwych decyzji — a wszystko to bez pomocy działu informatycznego.

Dowiedz się więcej o dodatku Power Pivot dla programu Excel.

Udoskonalony dodatek Solver

Program Excel 2010 zawiera nową wersję dodatku Solver, umożliwiającego znajdowanie optymalnych rozwiązań dla analizy warunkowej. Najnowsza wersja dodatku Solver cechuje się udoskonalonym interfejsem użytkownika i zawiera nowe funkcje, takie jak tryb pracy ewolucyjnej oparty na algorytmach genetycznych korzystających z dowolnych funkcji programu Excel, nowe opcje optymalizacji globalnej, udoskonalone metody programowania liniowego i optymalizacji nieliniowej oraz nowe raporty liniowości i dopuszczalności. Poza tym dodatek Solver jest teraz dostępny w wersji 64-bitowej.

Aby uzyskać dodatkową pomoc związaną z dodatkiem Solver od firmy Frontline Systems, zobacz Pomoc dodatku Solver pod adresem www.solver.com.

Lepsza dokładność funkcji

Po uwzględnieniu opinii społeczności akademickiej, inżynierskiej i naukowej w programie Excel 2010 udostępniono zestaw precyzyjniejszych funkcji statystycznych i innych. Ponadto niektóre istniejące funkcje otrzymały nowe nazwy, lepiej opisujące ich działanie.

  • Ulepszenia w zakresie dokładności    Zoptymalizowano szereg funkcji, aby poprawić ich dokładność. Na przykład program Excel 2010 zwraca dokładniejsze wyniki dla rozkładów beta i chi-kwadrat.

  • Spójniejsze funkcje    Zmieniono nazwy niektórych funkcji statystycznych, tak aby były spójniejsze z definicjami funkcji społeczności naukowej oraz z innymi nazwami funkcji programu Excel. Nowe nazwy funkcji także lepiej opisują ich działanie. Mimo tych zmian nazw, skoroszyty utworzone we wcześniejszych wersjach programu Excel wciąż będą działać, ponieważ oryginalne funkcje nadal istnieją w kategorii Zgodność.

    Funkcje w programie Excel 2010

Dowiedz się więcej.

Większe możliwości filtrowania

Oprócz fragmentatorów opisanych wcześniej w tym artykule program Excel 2010 udostępnia nowe funkcje ułatwiające sortowanie i filtrowanie danych.

  • Nowy filtr wyszukiwania    Podczas filtrowania tabel programu Excel, tabel przestawnych i wykresów przestawnych dostępne jest nowe pole wyszukiwania, przy użyciu którego można wyszukiwać niezbędne dane na długich listach. Aby na przykład znaleźć określony produkt w katalogu zawierającym ponad 100 000 pozycji, należy zacząć wpisywać szukany termin. Odpowiednie elementy zostaną błyskawicznie wyświetlone na liście. Wyniki można zawęzić przez usunięcie zaznaczenia elementów, które nie są potrzebne.

    Pole wyszukiwania w liście filtrów

  • Filtrowanie i sortowanie niezależnie od lokalizacji    Podczas przewijania długich tabel programu Excel nagłówki tabeli zastępują zwykłe nagłówki arkusza u góry kolumn. Przyciski Autofiltru pozostają teraz widoczne razem z nagłówkami tabeli w kolumnach tabeli, dzięki czemu można szybko sortować i filtrować dane bez przewijania aż do początku tabeli.

    Autofiltry widoczne w nagłówkach kolumn tabeli programu Excel

    Dowiedz się więcej.

64-bitowa wersja programu Excel

Program Excel 2010 jest dostępny w wersji 64-bitowej. Oznacza to, że zaawansowani użytkownicy i analitycy mogą tworzyć większe i bardziej zaawansowane skoroszyty. Wersja 64-bitowa umożliwia korzystanie z pamięci fizycznej (RAM) o pojemności ponad 2 GB (32-bitowa wersja programu Excel nie może przekraczać tego limitu).

Ulepszenia wydajności

Udoskonalenia wydajności wprowadzone w programie Excel 2010 zapewniają wydajniejszą interakcję z danymi. Niektóre wprowadzone udoskonalenia:

  • Ogólne udoskonalenia    W odpowiedzi na opinie klientów w programie Excel 2010 wprowadzono liczne udoskonalenia wydajności w różnych obszarach. Między innymi program Excel 2010 lepiej reaguje podczas przenoszenia i zmieniania rozmiaru wykresów, pracy w widoku układu strony oraz interakcji z kształtami w arkuszu.

  • Obsługa dużych zestawów danych    Program Excel 2010 wydajniej obsługuje skoroszyty zawierające olbrzymie ilości danych. Przejawia się to zwłaszcza w skróceniu czasu niezbędnego do wykonania typowych czynności w dużych zestawach danych, na przykład filtrowania i sortowania danych, kopiowania i wklejania ich z jednego arkusza do drugiego oraz kopiowania formuł przy użyciu funkcji wypełnienia.

  • Udoskonalenia w obsłudze procesorów wielordzeniowych    Udoskonalenia wielowątkowości w programie Excel 2010 pomagają przyspieszyć pobieranie, sortowanie i filtrowanie danych w tabelach przestawnych i tabelach programu Excel. Ponadto otwieranie i zapisywanie dużych plików odbywa się szybciej niż w starszych wersjach programu.

  • Szybsze obliczenia    Jeśli w najważniejszych procesach biznesowych organizacji skoroszyty odgrywają kluczową rolę, szybkość wykonywania obliczeń nie powinna być wąskim gardłem. Szybsze wykonywanie obliczeń w programie Excel 2010 jest możliwe dzięki obsłudze asynchronicznych funkcji zdefiniowanych przez użytkownika, które mogą działać równolegle bez konieczności wprowadzenia wielu wątków obliczeń w programie Excel. Jest to przydatne podczas importowania danych do arkuszy przy użyciu niestandardowych sposobów oraz w scenariuszach z procesami o wysokiej wydajności.

Tworzenie lepszych wizualnie skoroszytów

Niezależnie od ilości przetwarzanych danych, istotny jest dostęp do narzędzi, które pozwalają eksplorować i przekazywać pomysły w atrakcyjnej formie graficznej, na przykład na wykresach, diagramach, obrazach lub zrzutach ekranowych.

Udoskonalone wykresy

W programie Excel 2010 praca z wykresami jest łatwiejsza. Niektóre wprowadzone udoskonalenia:

  • Nowe ograniczenia wykresów    W programie Excel 2010 usunięto ograniczenie liczby punktów danych, które można utworzyć na wykresie. Ta liczba jest teraz ograniczona tylko ilością dostępnej pamięci. Dzięki temu użytkownicy, zwłaszcza naukowcy, mogą w wydajniejszy sposób analizować duże zestawy danych i przedstawiać je w formie graficznej.

  • Szybki dostęp do opcji formatowania    W programie Excel 2010 można w błyskawiczny sposób uzyskiwać dostęp do opcji formatowania przez dwukrotne kliknięcie elementu wykresu.

  • Rejestrowanie makr dotyczących elementów wykresów    W programie Office Excel 2007 zarejestrowanie makra podczas formatowania wykresu lub innego obiektu nie powoduje wygenerowania kodu makra. Natomiast w programie Excel 2010 można używać rejestratora makr do rejestrowania zmian formatowania wykresów i innych obiektów.

Dowiedz się więcej o tworzeniu wykresu.

Obsługa równań

Za pomocą nowych narzędzi do edycji równań w programie Excel 2010 można wstawiać w arkuszach popularne równania matematyczne lub tworzyć własne równania, korzystając z biblioteki symboli matematycznych. Można także wstawiać nowe równania w polach tekstowych i innych kształtach. Najlepiej rozpocząć, klikając strzałkę obok przycisku Równanie w grupie Symbole na karcie Wstawianie.

Wstępnie sformatowane równania na liście Równanie

Więcej motywów

W programie Excel 2010 jest dostępnych więcej stylów i motywów niż w poprzednich wersjach programu. Umożliwiają one zastosowanie spójnego, profesjonalnego stylu we wszystkich skoroszytach i innych dokumentach pakietu Microsoft Office. Po wybraniu motywu program Excel 2010 wykonuje czynności niezbędne do zastosowania projektu. Tekst, wykresy, grafiki, tabele i obiekty rysunkowe są zmieniane w celu uwzględnienia wybranego motywu. Dzięki temu wszystkie elementy skoroszytu uzupełniają się wzajemnie pod względem wizualnej formy prezentacji.

Galeria motywów w programie Excel 2010

Dowiedz się więcej o stosowaniu motywów w skoroszytach programu Excel.

Wklejanie z podglądem na żywo

Funkcja wklejania z podglądem na żywo oszczędza czas podczas ponownego używania zawartości w programie Excel 2010 lub innych programach. Przy jej użyciu można przeglądać różne opcje wklejania, takie jak Zachowaj szerokości kolumn źródłowych, Bez obramowania lub Zachowaj formatowanie źródłowe. Podgląd na żywo pozwala zapoznać się z wyglądem, jaki dana zawartość będzie miała po rzeczywistym wklejeniu jej do arkusza. Ustawienie wskaźnika myszy na opcjach wklejania powoduje wyświetlenie menu zawierającego elementy zmieniane w zależności od kontekstu i pasujące najlepiej do ponownie wykorzystywanej zawartości. Etykietki ekranowe zawierają dodatkowe informacje, które pomagają w podjęciu właściwej decyzji.

Opcje w menu Podgląd wklejania

Udoskonalone narzędzia do edycji obrazów

Przedstawianie pomysłów w programie Excel 2010 nie zawsze sprowadza się do prezentowania liczb lub wykresów. Jeśli trzeba użyć zdjęć, rysunków lub grafik SmartArt do wizualnej prezentacji, można skorzystać z następujących funkcji:

  • Zrzuty ekranu    Szybko wykonać zrzut ekranu i dodaj go do skoroszytu, a następnie użyj narzędzia na karcie Narzędzia obrazów do edytowania i poprawiania zrzut ekranu. Dowiedz się więcej o zrzutów ekranu.

    Przycisk Zrzut ekranu

  • Układy grafiki SmartArt nowy    Nowe układy obrazów możesz określić opowieści za pomocą fotografii. Na przykład umożliwia układ obrazów podpisami pokazanie obrazów z i wyglądających podpisów pod. Dowiedz się więcej o grafikach SmartArt.

  • Korekty obrazu    W programie można precyzyjnie sterować kolorami obrazu lub dostosowywać jego jasność, kontrast i ostrość — wszystko bez użycia dodatkowego oprogramowania do edycji fotografii. Dowiedz się więcej o korektach obrazów.

  • Nowe i ulepszone efekty artystyczne    Można stosować różne efekty artystyczne na obrazie, aby wyglądał jak szkic, rysunek lub obraz malowany. Nowe efekty artystyczne to między innymi: Szkic ołówkiem, Rysunek — linie, Gąbka akwarelowa, Bąbelki mozaikowe, Szyby, Pastele — wygładzone, Zawinięcie w folię, Fotokopia, Pociągnięcia pędzlem i wiele innych. Dowiedz się więcej o dodawaniu efektów.

  • Lepsza kompresja i lepsze przycinanie    Teraz można lepiej dostosować kompromis między jakością a kompresją obrazu, co pozwala na podejmowanie właściwych decyzji zależnie od zamierzonego sposobu użycia skoroszytu (druk, ekran, poczta e-mail). Dowiedz się więcej o przycinaniu i kompresji obrazu.

Nowe sposoby współpracy w skoroszytach

Program Excel 2010 oferuje ulepszone sposoby publikowania, edytowania i udostępniania skoroszytów innym osobom w organizacji.

Współtworzenie skoroszytów

Dzięki aplikacji Excel Online, wchodzącej w skład pakietu aplikacji Office Online, różne osoby mogą teraz edytować skoroszyt w tym samym czasie z różnych lokalizacji. Jeśli pracujesz w małej firmie lub w domu albo w placówce oświatowej, wystarczy bezpłatne konto usługi Windows Live, które umożliwia jednoczesne tworzenie skoroszytów razem z innymi osobami. Użytkownicy korporacyjni korzystający z technologii programu Microsoft SharePoint 2010 mogą też używać tej funkcji w obrębie firmowej zapory.

Ulepszone Usługi programu Excel

Jeśli w organizacji skoroszyty programu Excel były wcześniej udostępniane przy użyciu rozwiązania Usługi programu Excel w witrynach programu SharePoint Server, warto zapoznać się z następującymi udoskonaleniami:

  • Udoskonalony interfejs użytkownika    Do większych widocznych zmian należy możliwość odświeżania poszczególnych elementów strony po ich zmodyfikowaniu zamiast odświeżania całej strony oraz paski przewijania ułatwiające przewijanie arkusza.

  • Lepsza integracja z funkcjami programu SharePoint 2010    W tej wersji rozwiązania Usługi programu Excel udoskonalono integrację z ważnymi funkcjami programu SharePoint 2010, między innymi zabezpieczeniami, zarządzaniem zawartością, kontrolą wersji, zarządzaniem połączeniami danych i funkcjami zarządzania usługami. Ponadto rozwiązanie Usługi programu Excel jest lepiej zintegrowane z wbudowanymi funkcjami analizy biznesowej programu SharePoint.

  • Udoskonalona obsługa funkcji skoroszytów    Jeśli skoroszyt utworzony we wcześniejszych wersjach programu zawierał nieobsługiwane funkcje, to jego otwarcie w przeglądarce było niemożliwe. W obecnej wersji skoroszyt programu Excel jest w takiej sytuacji w większości przypadków otwierany w przeglądarce. Ponadto rozwiązanie Usługi programu Excel obsługuje więcej funkcji programu Excel, między innymi nowe funkcje programu Excel 2010, takie jak wykresy przebiegu w czasie i fragmentatory.

  • Więcej możliwości opracowywania aplikacji    Programiści i inni użytkownicy mogą korzystać z nowych narzędzi, na przykład interfejsu programowania aplikacji REST, do tworzenia aplikacji biznesowych.

Dowiedz się więcej na temat Usług programu Excel.

Sprawdzanie ułatwień dostępu

Nowe narzędzie Sprawdzanie ułatwień dostępu w programie Excel 2010 umożliwia znajdowanie i rozwiązywanie problemów utrudniających pracę ze skoroszytem osobom niepełnosprawnym. Funkcję sprawdzania ułatwień dostępu można otworzyć przez kliknięcie karty Plik, kliknięcie pozycji Wyszukaj problemy, a następnie kliknięcie pozycji Sprawdź ułatwienia dostępu. Błędy i ostrzeżenia są wyświetlane w okienku zadań. Można je przejrzeć i sprawdzić, które z nich wymagają wyeliminowania.

Poza użyciem funkcji sprawdzania ułatwień dostępu do wielu obiektów w arkuszu, na przykład do tabel programu Excel i tabel przestawnych, można dodawać tekst alternatywny. Te informacje są użyteczne dla osób niedowidzących, które mogą nie widzieć całego obiektu lub jego części.

Dowiedz się więcej.

Udoskonalone narzędzia językowe

W oknie dialogowym Opcje programu Excel użytkownicy wielojęzyczni mogą szybko ustawiać preferencje dotyczące języka edycji, wyświetlania, etykietek ekranowych i Pomocy. Zmiana ustawień języka w programie Excel powoduje automatyczną zmianę tych ustawień we wszystkich aplikacjach pakietu Microsoft Office 2010. Jeśli nie ma zainstalowanego niezbędnego oprogramowania lub układu klawiatury, zostanie wyświetlone odpowiednie powiadomienie wraz z linkami umożliwiającymi szybkie rozwiązanie problemów.

Dowiedz się więcej o ustawianiu preferencji językowych.

Rozszerzanie skoroszytów na nowe sposoby

Jeśli zajmujesz się opracowywaniem niestandardowych rozwiązań skoroszytów, możesz korzystać z nowych sposobów rozszerzania tych rozwiązań.

Udoskonalone funkcje programowania

Udoskonalenia dla programistów:

  • Zmiany w zestawie XLL SDK    Zestaw XLL Software Development Kit (SDK) obsługuje teraz wywoływanie nowych funkcji arkuszy, opracowywanie asynchronicznych funkcji zdefiniowanych przez użytkownika, opracowywanie bezpiecznych dla klastrów funkcji zdefiniowanych przez użytkownika, które można przekazywać do klastrów obliczeniowych, i tworzenie 64-bitowych dodatków XLL.

  • Udoskonalenia języka VBA    Program Excel 2010 zawiera liczne funkcje, które umożliwiają migrację pozostałych makr programu Excel 4.0 do języka VBA. Udoskonalenia obejmują lepszą wydajność metod związanych z drukowaniem i właściwości wykresów, które przedtem nie były dostępne w języku VBA.

  • Więcej możliwości rozszerzania interfejsu użytkownika    Użytkownicy, którzy zajmują się opracowywaniem niestandardowych rozwiązań skoroszytów, mogą programowo dostosowywać wstążkę i nowy widok Backstage, korzystając z większej liczby opcji. Na przykład można programowo aktywować karty na wstążce i spowodować, aby karty niestandardowe zachowywały się podobnie jak wbudowane karty kontekstowe, czyli pojawiały się tylko w przypadku określonych zdarzeń. Ponadto można powiększać i pomniejszać niestandardowe grupy wstążki wraz ze zmianą rozmiaru wstążki i dostosowywać menu kontekstowe przy użyciu zaawansowanych kontrolek. Widok Backstage można także uzupełniać o niestandardowe elementy interfejsu użytkownika i inne obiekty.

  • Zmiany w zestawie Open XML SDK    Zestaw Open XML SDK 2.0 obsługuje obecnie obiekty na poziomie schematu (obok obsługi obiektów na poziomach częściowych wprowadzonej w zestawie Open XML SDK 1.0). Dzięki temu łatwiej jest programowo manipulować skoroszytami i innymi dokumentami poza aplikacjami klasycznymi pakietu Office 2010, na przykład w ramach rozwiązania opartego na serwerze.

Dowiedz się więcej o funkcjach dla deweloperów.

Obsługa wysokiej wydajności

Wiele organizacji korzysta z klastrów o wysokiej wydajności (HPC, High Performance Computing), które pozwalają zwiększyć skalę obliczeń. Na przykład firma finansowa może używać klastrów obliczeniowych do przyspieszenia długookresowych, wymagających intensywnych obliczeń modeli finansowych. Program Excel 2010 umożliwia integrację z klastrami HPC. Gdy obsługiwany klaster jest dostępny, użytkownicy mogą skonfigurować program Excel do używania tego klastra przez wybranie łącznika i skonfigurowanie nazwy do użycia w opcjach Zaawansowane w oknie dialogowym Opcje programu Excel.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×