Automatyzacja zdarzeń uruchamiania przy użyciu makra

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Jeśli chcesz uruchomić określonych akcji każdym otwarciu bazy danych programu Access lub aplikacji sieci web programu Access, należy utworzyć makro AutoExec w bazie danych pulpitu lub makra przy uruchamianiu w aplikacji sieci web programu Access. Na przykład w bazie danych pulpitu makra AutoExec może automatycznie maksymalizowanie okna aplikacji, blokowanie okienko nawigacji i otworzyć określony raport zawsze podczas otwierania bazy danych.

W tym temacie

Tworzenie makra AutoExec w bazie danych dla komputerów stacjonarnych

Tworzenie makra przy uruchamianiu w aplikacji sieci web programu Access

Tworzenie makra AutoExec w bazie danych dla komputerów stacjonarnych

Uruchamia makro AutoExec (makro nadawanie nazwy AutoExec) przed innymi makr i modułów w bazie danych. Jeśli masz już utworzony makro, które ma ma nastąpić po uruchomieniu bazy danych, po prostu zmienić nazwę makra AutoExeci będzie działać przy następnym otwarciu bazy danych. W przeciwnym razie wykonaj poniższe czynności, aby utworzyć makro:

  1. Kliknij kolejno pozycje Tworzenie > Makro.

    Przycisk Makro na karcie Tworzenie.

  2. Z listy rozwijanej u góry Konstruktora makr wybierz akcję, którą chcesz wykonać. Jeśli trzeba, wpisz odpowiednie wartości w polach argumentów.

    • Jeśli nie możesz znaleźć potrzebnej akcji, upewnij się, że pozycja Pokaż wszystkie akcjena karcie Projektowanie jest zaznaczona. Spowoduje to rozszerzenie listy akcji, których możesz używać, ale na liście znajdą się również akcje, których uruchomienie będzie możliwe jedynie w przypadku, gdy baza danych otrzyma status zaufanej. Aby uzyskać więcej informacji, zobacz Podejmowanie decyzji o ustawianiu bazy danych jako zaufanej.

  3. Powtórz krok 2 dla każdej dodatkowej akcji, którą chcesz wywoływać. Akcje możesz też wyszukać w wykazie akcji, a następnie kliknąć dwukrotnie lub przeciągnąć do makra.

  4. Kliknij przycisk Zapisz, a następnie w oknie dialogowym Zapisywanie jako wpisz nazwę AutoExec.

  5. Kliknij przycisk OK, a następnie zamknij Konstruktora makr. Makro będzie od tej pory uruchamiane przy każdym otwarciu bazy danych.

Aby uzyskać więcej informacji na temat tworzenia makr, zobacz artykuł Tworzenie makra interfejsu użytkownika (UI).

Uwaga: 

Początek strony

Tworzenie makra przy uruchamianiu w aplikacji sieci web programu Access

Makra przy uruchamianiu w aplikacjach sieci web programu Access wykonuje jest taka sama funkcja jako makra AutoExec w bazie danych pulpitu, ale nie jest wyświetlana w okienku nawigacji jako nazwane makro. Ponadto zamiast uruchamiania podczas otwierania bazy danych w kliencie programu Access, jest uruchamiane podczas otwierania aplikacji sieci web w przeglądarce. Nie można pomijać logiczny makra zdefiniowane w makra przy uruchamianiu podczas otwierania aplikacji sieci web w przeglądarce.

Oto jak utworzyć takie makro:

  1. Otwórz aplikację sieci web w programie Access. Jeśli wyświetlasz go w przeglądarce, kliknij pozycję Ustawienia > Dostosuj w programie Access.

  2. Kliknij kartę Narzędzia główne > Zaawansowane > na początku makra.

    Polecenie Makro Przy uruchamianiu na wstążce

    Program Access otworzy projektanta makr. Jeśli makra przy uruchamianiu już istnieje, program Access wyświetli ją. W przeciwnym razie zostanie wyświetlona makra puste miejsce, w którym można rozpocząć dodawanie akcji.

  3. Wybierz akcje z listy rozwijanej Dodaj nową akcję lub wyszukaj je w wykazie akcji, a następnie kliknij dwukrotnie lub przeciągnij je do makra.

    Porada:  Wykaz akcji zawiera krótkie opisy poszczególnych akcji, co pozwala poznać ich przeznaczenie.

  4. Jeśli trzeba, wpisz odpowiednie wartości w polach argumentów dodawanych akcji.

  5. Kliknij pozycję Plik > Zamknij.

  6. Kliknij kartę Narzędzia główne > Uruchom aplikację, a na Start uruchomienie makra po otwarciu aplikacji sieci web w przeglądarce.

Aby uzyskać więcej informacji o tworzeniu makr w aplikacji sieci web programu Access zobacz Dostosowywanie widoku przez utworzenie użytkownika interfejsu makra.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×