Znajdowanie i zamienianie tekstu lub innych danych w dokumencie programu Word

Znajdowanie i zamienianie tekstu lub innych danych w dokumencie programu Word

Program Word oferuje kilka opcji wyszukiwania określonej zawartości w dokumencie. Można wyszukiwać i zamieniać elementy, takie jak tekst, obrazy, podpisy, zakładki i określone typy formatowania, na przykład akapity lub podziały stron. Można użyć polecenia Przejdź do, aby przejść do konkretnego wystąpienia zawartości w dokumencie. Można też poszerzyć wyszukiwanie przy użyciu symboli wieloznacznych, kodów lub wyrażeń regularnych w celu znalezienia wyrazów lub fraz zawierających określone znaki lub kombinacje znaków.

Uwagi : 

  • Obecnie aplikacja Word Online udostępnia tylko podstawowe funkcje znajdowania i zamieniania. Aby korzystać z zaawansowanych funkcji znajdowania i zamieniania, takich jak polecenie Przejdź do, symbole wieloznaczne, kody i wyrażenia regularne oraz wyszukiwanie obiektów i formatowania, otwórz dokument w aplikacji klasycznej Word.

  • Część treści tego tematu może nie dotyczyć niektórych języków.

Znajdowanie i zamienianie

Możesz szybko wyszukać każde wystąpienie określonego wyrazu lub frazy.

  1. Na karcie Narzędzia główne w grupie Edytowanie wybierz pozycję Znajdź. Możesz też nacisnąć klawisze CTRL+F na klawiaturze.

    Opcja Znajdź na karcie Narzędzia główne

    Zostanie wyświetlone okienko Nawigacja.

    Okienko nawigacji
  2. W polu wyszukiwania wpisz tekst, który chcesz znaleźć. Wszystkie wystąpienia znalezionego tekstu zostaną wyróżnione w dokumencie i wyświetlone w okienku Nawigacja.

    Wyniki wyszukiwania wyróżnione w dokumencie i okienku nawigacji
  3. Wyniki można przeglądać za pomocą strzałek w górę i w dół.

Uwaga : Jeśli wprowadzisz zmianę w dokumencie i wyniki wyszukiwania znikną, kliknij strzałkę w dół poniżej pola wyszukiwania, aby ponownie wyświetlić listę wyników.

  1. Na karcie Narzędzia główne w grupie Edytowanie wybierz pozycję Zamień. Możesz też nacisnąć klawisze CTRL+H na klawiaturze.

    Wyróżniona opcja Zamień na karcie Narzędzia główne

  2. W polu Znajdź wpisz tekst, którego wystąpienie chcesz znaleźć i zamienić.

  3. W polu Zamień na wpisz tekst, na który chcesz zamienić wyszukiwany tekst.

    Znajdowanie i zamienianie tekstu

  4. Wybierz pozycję Znajdź następny i wykonaj jedną z następujących czynności:

    • Aby zamienić wyróżniony tekst, kliknij pozycję Zamień.

    • Aby zamienić wszystkie wystąpienia tekstu w dokumencie, kliknij pozycję Zamień wszystko.

    • Aby pominąć to wystąpienie tekstu i przejść do następnego wystąpienia, kliknij pozycję Znajdź następny.

    Karta Zamienianie w oknie dialogowym Znajdowanie i zamienianie

    Uwaga : W aplikacji Word Online nie ma przycisku Znajdź następny. Aby zamienić poszczególne wystąpienia wyróżnionego tekstu, przeglądaj wyniki przy użyciu strzałki w górę i strzałki w dół.

Aby wyszukać obiekty, takie jak tabele, grafiki, komentarze, przypisy dolne, przypisy końcowe lub równania, wykonaj następujące czynności:

  1. Na karcie Narzędzia główne w grupie Edytowanie kliknij pozycję Znajdź. Możesz też nacisnąć klawisze CTRL+F na klawiaturze.

    Opcja Znajdź na karcie Narzędzia główne

    Zostanie wyświetlone okienko Nawigacja.

    Okienko nawigacji
  2. Kliknij strzałkę po prawej stronie pola wyszukiwania, a następnie wybierz odpowiednią opcję z listy.

    Lista opcji wyszukiwania obiektów

    Wyniki wyszukiwania są wyświetlane poniżej okienka wyszukiwania.

  3. Wybierz wynik, aby wyświetlić go w dokumencie, lub przejrzyj wszystkie wyniki, klikając strzałki.

Szukasz okna dialogowego Znajdowanie i zamienianie?

Aby przeprowadzić wyszukiwanie zaawansowane przy użyciu okna dialogowego Znajdowanie i zamienianie, wykonaj jedną z następujących czynności:

  • Na karcie Narzędzia główne w grupie Edytowanie wybierz strzałkę obok przycisku Znajdź, a następnie wybierz pozycję Znajdowanie zaawansowane.

    lub

  • W okienku Nawigacja kliknij strzałkę po prawej stronie pola wyszukiwania, a następnie wybierz pozycję Znajdowanie zaawansowane.

W oknie dialogowym Znajdowanie i zamienianie kliknij pozycję Więcej, aby przejść do opcji wyszukiwania szczegółowego.

Uwaga :  Aby uzyskać dostęp do mniejszego zestawu zaawansowanych opcji wyszukiwania, takich jak Uwzględnij wielkość liter lub Znajdź tylko całe wyrazy, w okienku nawigacji wybierz strzałkę z prawej strony pola wyszukiwania, a następnie wybierz pozycję Opcje.

Możesz wyszukać i zamienić lub usunąć formatowanie znaków w dokumencie. Na przykład możesz wyszukać określony wyraz lub frazę i zmienić jej kolor czcionki lub wyszukać określone formatowanie, takie jak pogrubienie lub wyróżnienie, i zmienić je.

  1. Na karcie Narzędzia główne w grupie Edytowanie wybierz pozycję Zamień. Możesz też nacisnąć klawisze CTRL+H na klawiaturze.

    Wyróżniona opcja Zamień na karcie Narzędzia główne

  2. Jeśli nie widzisz przycisku Formatuj, kliknij przycisk Więcej.

    Przycisk Więcej

  3. Aby wyszukać tekst z określonym formatowaniem, wpisz tekst w polu Znajdź. Aby znaleźć tylko formatowanie, pozostaw to pole puste.

  4. Kliknij przycisk Formatuj, a następnie wybierz formatowanie, które chcesz znaleźć i zamienić. Aby na przykład znaleźć wyróżniony tekst, kliknij przycisk Formatuj > Wyróżnienie. Aby znaleźć pogrubiony tekst, kliknij pozycję Format > Czcionka, a następnie w oknie dialogowym Znajdź czcionkę wybierz pozycję Pogrubienie na liście Styl czcionki.

  5. Kliknij pole Zamień na, kliknij przycisk Formatuj, a następnie wybierz odpowiednie formatowanie zgodnie z opisem w kroku 4.

    Uwaga : Jeśli chcesz także zamienić tekst, wpisz tekst zamienny w polu Zamień na.

  6. Aby znaleźć i zamienić każde wystąpienie określonego formatowania, kliknij pozycję Znajdź następny, a następnie kliknij pozycję Zamień. Aby zamienić wszystkie wystąpienia określonego formatowania, kliknij pozycję Zamień wszystko.

Możesz wyszukiwać i zamieniać znaki specjalne i elementy dokumentów, takie jak tabulatory, znaczniki akapitów (znaki powrotu karetki) i ręczne podziały stron. Na przykład możesz znaleźć wszystkie podwójne interlinie (dwa znaczniki akapitu) i zamienić je na pojedyncze interlinie (jeden znacznik akapitu).

Porada : Aby wyświetlić ukryte symbole formatowania, takie jak spacje, znaczniki akapitów i podziały stron, kliknij pozycję w grupie Akapit na karcie Narzędzia główne.

  1. Na karcie Narzędzia główne w grupie Edytowanie kliknij strzałkę obok przycisku Znajdź , a następnie kliknij polecenie Znajdowanie zaawansowane.

    Opcja Znajdowanie zaawansowane w menu Znajdź

  2. Jeśli nie widzisz przycisku Specjalne, kliknij przycisk Więcej.

    Przycisk Więcej

  3. Kliknij przycisk Specjalne, a następnie kliknij odpowiedni element.

  4. Jeśli chcesz zamienić element, kliknij kartę Zamień, a następnie wpisz zamiennik danego elementu w polu Zamień na.

  5. Aby znaleźć i zamienić każde wystąpienie określonego elementu, kliknij pozycję Znajdź następny, a następnie kliknij pozycję Zamień. Aby zamienić wszystkie wystąpienia określonego elementu, kliknij pozycję Zamień wszystko.

Znajdowanie przy użyciu polecenia Przejdź do

  1. Na karcie Narzędzia główne w grupie Edytowanie kliknij strzałkę obok przycisku Znajdź, a następnie kliknij polecenie Przejdź do.

    Opcja Przejdź do w menu Znajdź

  2. W polu Przejdź do kliknij typ elementu.

  3. Wykonaj jedną z następujących czynności:

    • Aby przejść do określonego elementu, wpisz odpowiednie informacje identyfikujące element w polu Wprowadź typ elementu, a następnie kliknij przycisk Przejdź do.

    • Aby przejść do następnego lub poprzedniego elementu określonego typu, pozostaw pole Wprowadź puste, a następnie kliknij przycisk Następny lub Poprzedni.

Wyszukiwanie przy użyciu symboli wieloznacznych

Symbole wieloznaczne umożliwiają wyszukiwanie tekstu. Możesz na przykład użyć symbolu gwiazdki (*) do wyszukania ciągu znaków (na przykład ciąg „s*d” umożliwia znalezienie wyrazów „sąd” i „samochód”).

  1. Na karcie Narzędzia główne w grupie Edytowanie kliknij strzałkę obok przycisku Znajdź , a następnie kliknij polecenie Znajdowanie zaawansowane.

    Opcja Znajdowanie zaawansowane w menu Znajdź

  2. Zaznacz pole wyboru Użyj symboli wieloznacznych.

    Jeśli pole wyboru Użyj symboli wieloznacznych nie jest widoczne, kliknij przycisk Więcej.

    Przycisk Więcej

  3. Wykonaj jedną z następujących czynności:

    • Aby wybrać symbol wieloznaczny z listy, kliknij przycisk Specjalne, kliknij symbol wieloznaczny, a następnie wpisz resztę tekstu w polu Znajdź. Aby uzyskać więcej informacji, zobacz tabelę Symbole wieloznaczne określające elementy, które mają być znajdowane i zamieniane poniżej.

    • Wpisz symbol wieloznaczny bezpośrednio w polu Znajdź. Aby uzyskać więcej informacji, zobacz tabelę Symbole wieloznaczne określające elementy, które mają być znajdowane i zamieniane poniżej.

  4. Jeśli chcesz zamienić element, kliknij kartę Zamień, a następnie wpisz zamiennik danego elementu w polu Zamień na.

  5. Kliknij przycisk Znajdź następny lub Znajdź wszystkie, a następnie przycisk Zamień. Ewentualnie kliknij przycisk Zamień wszystko, aby zamienić wszystkie wystąpienia danego elementu.

    Uwaga :  Aby anulować trwające wyszukiwanie, naciśnij klawisz ESC.

Za pomocą nawiasów ( ) można tworzyć grupy symboli wieloznacznych i tekstu w polu Znajdź. Za pomocą symbolu \n w polu Zamień na można następnie użyć wyników poszczególnych wyrażeń.

Symbol wieloznaczny \n służy do znajdowania wyrażeń i zamieniania ich na inne wyrażenia. Można na przykład wpisać (Kowalczyk) (Michał) w polu Znajdź i \2 \1 w polu Zamień na. Program Word znajdzie wystąpienie frazy Kowalczyk Michał i zamieni je na frazę Michał Kowalczyk.

  • Gdy pole wyboru Użyj symboli wieloznacznych jest zaznaczone, program Word wyszukuje tylko wystąpienia dokładnie takiego tekstu, jaki został podany. Pola wyboru Uwzględnij wielkość liter oraz Znajdź tylko całe wyrazy są niedostępne (wyszarzone), aby wskazać, że te opcje są automatycznie włączone. Nie można wyłączyć tych opcji.

  • Aby wyszukać znak, który jest zdefiniowany jako symbol wieloznaczny, wpisz przed nim ukośnik odwrotny (\). Aby na przykład znaleźć znak zapytania, wpisz \?, natomiast aby znaleźć ukośnik odwrotny (nazywany często znakiem anulowania), wpisz \\.

  • W celu grupowania symboli wieloznacznych i tekstu oraz wskazywania kolejności interpretacji wyrażenia można zastosować nawiasy. Można na przykład wpisać znaki <(ko)*(ek)>, aby wyszukać wyrazy „kotek” i „kołek”.

Aby znaleźć

Wpisz

Przykład

Dowolny pojedynczy znak, w tym znaki interpunkcyjne i spację

?

k?t umożliwia znalezienie wyrazów kat, kot i ciągu k t.

Jeden z podanych znaków

[ ]

l[ei]n umożliwia znalezienie wyrazów len i lin.

Dowolny pojedynczy znak z podanego zakresu

[-]

[b-m]aczki umożliwia znalezienie wyrazów baczki, kaczki i maczki. Zakresy muszą być podane w porządku rosnącym.

Początek wyrazu

<

<(inter) umożliwia znalezienie wyrazów interesujący i interdyscyplinarny, ale nie „sprinter”.

Koniec wyrazu

>

(ek)> umożliwia znalezienie wyrazów kominek i dzwonek, ale nie sekcja.

Wyrażenie

()

Program Word zapamiętuje wyniki kombinacji wyszukiwań przeznaczone do użycia w operacji zamieniania.

Dowolny pojedynczy znak z wyjątkiem znaków z zakresu podanego w nawiasach

[!x-z]

l[!o-z]k umożliwia znalezienie wyrazów lak i lęk, ale nie lok czy luk.

Dokładnie n wystąpień poprzedzającego znaku lub wyrażenia

{n}

ran{2}a umożliwia znalezienie wyrazu ranna, ale nie rana.

Co najmniej n wystąpień poprzedzającego znaku lub wyrażenia

{n,}

ran{1,}a umożliwia znalezienie wyrazów rana i ranna.

Od n do m wystąpień poprzedzającego znaku lub wyrażenia

{n,m}

10{1,3} umożliwia znalezienie wyników 10, 100 i 1000.

Jedno lub więcej powtórzeń poprzedniego znaku lub wyrażenia

@

cen@a umożliwia znalezienie wyrazów cena i cenna.

Dowolny ciąg znaków, w tym znaki interpunkcyjne i spację

*

s*y umożliwia znalezienie wyrazów smutny, sprzedany i wyrażenia starannie przebadany.

Znajdowanie liter, formatowania, pól lub znaków specjalnych przy użyciu kodów

Aby znaleźć

Wpisz

Znacznik akapitu ( Znacznik akapitu )

^p (nie działa w polu Znajdź, gdy opcja Użyj symboli wieloznacznych jest włączona) lub ^13

Znak tabulacji ( Znak tabulacji )

^t lub ^9

Znak ASCII

^ nnn, gdzie nnn to kod znaku

Znak ANSI

^0 nnn, gdzie 0 oznacza zero, a nnn to kod znaku

Pauza (—)

^+

Półpauza (–)

^=

Znak daszka

^^

Ręczny podział wiersza ( Ręczny podział wiersza )

^l lub ^11

Podział kolumny

^n lub ^14

Podział sekcji lub strony

^12 (podczas zamieniania powoduje wstawienie podziału strony)

Ręczny podział strony

^m (służy także do znajdowania lub zamieniania podziałów sekcji, gdy opcja Użyj symboli wieloznacznych jest włączona)

Spacja nierozdzielająca ( spacja nierozdzielająca )

^s

Łącznik nierozdzielający ( Łącznik nierozdzielający )

^~

Łącznik opcjonalny ( Łącznik opcjonalny )

^-

Aby znaleźć

Wpisz

Dowolny znak

^?

Dowolna cyfra

^#

Dowolna litera

^$

Obraz lub grafika (tylko w tekście)

^g

Znacznik przypisu dolnego

^f lub ^2

Znacznik przypisu końcowego

^e

Pole (gdy kody pól są widoczne)

^ d lub ^ 19 lub ^ 21

Komentarze (gdy komentarze są w tekście)

^a lub ^5

Podział sekcji

^b

Biały znak

^w (dowolna spacja lub dowolna kombinacja spacji zwykłych i nierozdzielających oraz znaków tabulacji)

Aby znaleźć

Wpisz

Zawartość Schowka systemu Microsoft Windows

^c

Znajdowanie i zamienianie tekstu za pomocą wyrażeń regularnych (zaawansowane)

Wiele zadań znajdowania i zamiany można zautomatyzować za pomocą symboli wieloznacznych, tworząc wyrażenia regularne, które są połączeniami tekstu dosłownego i symboli wieloznacznych. Tekst dosłowny wskazuje tekst, który musi się znajdować w ciągu docelowym. Symbole wieloznaczne wskazują tekst, który może się zmieniać w ciągu docelowym. Za pomocą wyrażeń regularnych można na przykład znaleźć i usunąć zduplikowane wiersze w dużej tabeli lub transponować listę imion i nazwisk (zmienić kolejność z „imię nazwisko” na „nazwisko imię”).

Oto przykładowa procedura zastosowania wyrażeń regularnych. W krokach zawartych w tej sekcji opisano sposób korzystania z wyrażenia regularnego służącego do transpozycji imion i nazwisk. Pamiętaj, aby wyrażenia regularne zawsze uruchamiać w oknie dialogowym Znajdowanie i zamienianie. Zwróć też uwagę na to, że jeśli wyrażenie nie działa zgodnie z oczekiwaniami, możesz nacisnąć klawisze CTRL+Z w celu cofnięcia wprowadzonych zmian, a następnie użyć innego wyrażenia.

  1. Uruchom program Word i otwórz nowy, pusty dokument.

  2. Skopiuj do niego następujące imiona i nazwiska.

    Tomasz Bochenek

    Aneta Olecka

    Joanna Rybka

    Dominik Dubicki

  3. Na karcie Narzędzia główne w grupie Edytowanie kliknij pozycję Zamień, aby otworzyć okno dialogowe Znajdowanie i zamienianie.

    Wyróżniona opcja Zamień na karcie Narzędzia główne

  4. Jeśli pole wyboru Użyj symboli wieloznacznych nie jest widoczne, kliknij przycisk Więcej, a następnie zaznacz to pole wyboru. Jeśli to pole wyboru nie jest zaznaczone, program Word traktuje symbole wieloznaczne jak zwykły tekst.

  5. Wpisz poniższe znaki w polu Znajdź. Pamiętaj o wstawieniu spacji między dwoma zestawami nawiasów, ale nie dodawaj jej na końcu.

    (<*>) (<*>)

  6. W polu Zamień na wpisz następujące znaki. Pamiętaj o wstawieniu spacji między przecinkiem i drugim ukośnikiem.

    \2, \1

  7. Zaznacz imiona i nazwiska, a następnie kliknij przycisk Zamień wszystko. Program Word wykona transpozycję imion i nazwisk, rozdzielając je przecinkami w następujący sposób:

    Bochenek, Tomasz

    Olecka, Aneta

    Rybka, Joanna

    Dubicki, Dominik

Treść dokumentu określa większą część (ale nie całość) struktury wyrażeń regularnych. W powyższym przykładzie każdy element (imię i nazwisko) zawierał dwa wyrazy. Jeśli element zawiera dwa wyrazy i inicjał drugiego imienia, należy użyć innego wyrażenia.

Poniżej przedstawiono dokładną analizę każdego z wyrażeń:

W pierwszym wyrażeniu, (<*>) (<*>):

  • Gwiazdka (*) zwraca wszystkie znaki wyrazu.

  • Znaki mniejszości i większości (< >) oznaczają początek i koniec każdego wyrazu. Dzięki nim funkcja wyszukiwania zwraca pojedynczy wyraz.

  • Nawiasy i spacja między nimi rozdzielają wyrazy na odrębne grupy: (pierwszy wyraz) (drugi wyraz). Nawiasy wskazują także kolejność interpretacji wyrażenia przez funkcję wyszukiwania.

Inaczej mówiąc, wyrażenie oznacza: „znajdź oba wyrazy”.

W drugim wyrażeniu, \2, \1:

  • Ukośnik (\) wraz z liczbami działa jako symbol zastępczy. Ukośnika można także użyć w celu znalezienia innych symboli wieloznacznych. Więcej informacji na ten temat zawiera kolejna sekcja.

  • Przecinek po pierwszym symbolu zastępczym powoduje wstawienie odpowiedniego znaku interpunkcyjnego między transponowanym imieniem i nazwiskiem.

Inaczej mówiąc, wyrażenie oznacza: „napisz drugi wyraz, dodaj przecinek, napisz pierwszy wyraz”.

W poniższych przykładach przedstawiono kilka sposobów używania symboli wieloznacznych i wyrażeń regularnych w programie Word. Listę dostępnych symboli wieloznacznych zawiera powyższa sekcja Symbole wieloznaczne określające elementy, które mają być znajdowane i zamieniane.

Przykład 1. Transpozycja imion i nazwisk rozdzielonych inicjałami drugiego imienia

Przykład 2. Transpozycja dat

Przykład 3. Dodawanie lub usuwanie kropek w zwrotach grzecznościowych

Przykład 4. Znajdowanie zduplikowanych akapitów lub wierszy


Przykład 1. Transpozycja imion i nazwisk rozdzielonych inicjałami drugiego imienia

W tym przykładzie użyto połączenia symboli wieloznacznych oraz kodów znaków w celu transponowania imion i nazwisk, między którymi znajdują się inicjały drugiego imienia. Aby uzyskać więcej informacji na temat kodów znaków, zobacz powyższą sekcję Znajdowanie liter, formatowania, pól lub znaków specjalnych przy użyciu kodów.

Wykonując te czynności, pamiętaj o następujących kwestiach:

  • Aby użyć tego wyrażenia w przypadku imion i nazwisk znajdujących się w tabeli, musisz najpierw przekonwertować tę tabelę na tekst.

  • Jeśli tabela zawiera więcej niż jedną kolumnę, skopiuj kolumnę zawierającą imiona i nazwiska do pustego dokumentu i tam przekonwertuj ją na tekst.

  • Po wykonaniu transpozycji imion i nazwisk przekonwertuj tekst z powrotem na tabelę. Następnie możesz usunąć oryginalną kolumnę i zastąpić ją zmienionymi danymi.

Najpierw przygotuj dane przykładowe:

  1. Jeśli program Word nie jest uruchomiony, uruchom go i utwórz nowy, pusty dokument.

  2. Wstaw pustą tabelę do dokumentu. Ta tabela powinna mieć jedną kolumnę i cztery wiersze.

  3. Pojedynczo skopiuj następujące imiona i nazwiska i wklej je do pustych komórek tabeli:

    Jan Maciej Bator
    Aneta B. Olecka
    Joanna Z. Rybka
    Dominik Dubicki

    Tabela powinna wyglądać mniej więcej tak:

    Jan Maciej Bator

    Aneta B. Olecka

    Joanna Z. Rybka

    Dominik Dubicki

  4. Zaznacz tabelę i w obszarze Narzędzia tabel na karcie Układ w grupie Dane kliknij pozycję Konwertuj na tekst.

  5. Jako separator tekstu wybierz Znaczniki akapitów, a następnie kliknij pozycję OK.

Teraz wykonaj transpozycję imion i nazwisk:

  1. Na karcie Narzędzia główne w grupie Edytowanie kliknij pozycję Zamień, aby otworzyć okno dialogowe Znajdowanie i zamienianie.

  2. Zaznacz pole wyboru Użyj symboli wieloznacznych (jeśli to pole jest niewidoczne, kliknij przycisk Więcej), a następnie wpisz poniższe wyrażenie w polu Znajdź:

    (*) ([! ]@)^13

    Pamiętaj o wstawieniu spacji między dwoma zestawami nawiasów i po wykrzykniku. Działanie znaku oznaczonego kodem ^13 wyjaśniono w następnej sekcji.

  3. W polu Zamień na wpisz następujące wyrażenie:

    \2, \1^p

  4. Zaznacz listę imion i nazwisk, a następnie kliknij przycisk Zamień wszystko. Program Word wykona transpozycję imion i nazwisk oraz drugich imion lub ich inicjałów w następujący sposób:

    Bator, Jan Maciej
    Olecka, Aneta B.
    Rybka, Joanna Z.
    Dubicki, Dominik

Przekonwertuj zmieniony tekst z powrotem na tabelę:

  1. Zaznacz listę transponowanych imion i nazwisk.

  2. Na karcie Wstawianie w grupie Tabele kliknij przycisk Tabela, a następnie kliknij polecenie Konwertuj tekst na tabelę.

  3. W oknie dialogowym Konwertowanie tekstu na tabelę w obszarze Separatory tekstu kliknij pozycję Akapity, a następnie kliknij pozycję OK.

Szczegółowy opis transpozycji z inicjałami drugiego imienia

Poniżej przedstawiono analizę działania poszczególnych części wyrażenia, zaczynając od wyrażenia w polu Znajdź.

Całe wyrażenie służy do wyszukiwania dwóch grup wzorców: pierwszego imienia i inicjału drugiego imienia (lub pełnego drugiego imienia) oraz nazwiska. Fragment (*) umożliwia znalezienie wszystkich pierwszych imion. Zwróć uwagę na spację występującą po tym fragmencie.

Następujący fragment wyrażenia dotyczy nazwisk:

([! ]@)^13

Wykrzyknik służy do wykluczania znaku podanego w nawiasach kwadratowych. W tym przypadku fragment [! ] oznacza „znajdź wszystko oprócz spacji”. Ma to na celu usunięcie spacji sprzed nazwiska.

Znak @ służy do znajdowania jednego lub kilku wystąpień poprzedniego znaku, więc jego użycie ma na celu usunięcie wszystkich spacji sprzed nazwiska.

Aby określić, w którym miejscu kończy się nazwisko, użyjemy znaku ^13 w celu wyszukania znacznika akapitu na końcu każdego wiersza. Jednak znacznik akapitu nie będzie ponownie używany, więc musimy ująć pozostałą część wyrażenia w nawiasy.

Aby sprawdzić działanie tego wyrażenia, ponownie skopiuj imiona i nazwiska do dokumentu testowego (rozdzielając je znacznikami akapitu), a następnie przeprowadź wyszukiwanie, wpisując wyrażenie ([! ]@)^13 w polu Znajdź. Wyszukiwanie zwróci wszystkie nazwiska.

Ponieważ wyszukiwanie jest ponownie rozpoczynane na początku kolejnego wiersza, zostanie użyty symbol wieloznaczny gwiazdki (*) w celu dopasowania całego tekstu od tego punktu do początku kolejnego nazwiska.

Ponieważ spacja nie będzie ponownie używana na początku nazwiska, musimy użyć nawiasów w celu wykluczenia jej z dwóch grup:

(*) ([! ]@)^13

Ważne : Podczas używania kodu znaku ^13 należy zachować ostrożność. Zwykle do wyszukania znacznika akapitu można użyć kodu znaku ^p. Jednak ten kod nie działa w przypadku wyszukiwania z symbolami wieloznacznymi. Zamiast tego należy użyć kodu zastępczego ^13. Chociaż kod znaku ^p nie działa w przypadku wyszukiwania z symbolami wieloznacznymi, należy go używać w operacjach zamiany z symbolami wieloznacznymi. Znak ^p zawiera informacje o formatowaniu, a znak ^13 ich nie zawiera. Ponadto do znaku ^13 nie można przypisać informacji o stylu. Błędne użycie kodu ^13 w operacji zamiany może spowodować przekonwertowanie dokumentu na plik, którego nie można formatować.

Operacja zamiany (\2 \1) powoduje transpozycję. Znaki \2, w polu Zamień na określają, że najpierw zostanie zapisany drugi wzorzec, a po nim zostanie dopisany przecinek. Znaki \1^p określają, gdzie zostanie zapisany pierwszy wzorzec oraz powodują dopisanie na końcu znacznika akapitu.


Przykład 2. Transpozycja dat

Wyrażenia regularne przedstawione w tym przykładzie służą do konwertowania dat z formatu europejskiego na format używany w Stanach Zjednoczonych.

  1. Skopiuj następującą datę w języku angielskim w formacie europejskim i wklej ją do dokumentu: 28th May 2003 (28 maja 2003).

  2. Otwórz okno dialogowe Znajdowanie i zamienianie, a następnie wpisz następujące wyrażenie w polu Znajdź:

    ([0-9]{1;2})([dhnrst]{2}) (<[ADFJMNOS]*>) ([0-9]{4})

    Pamiętaj o wstawieniu spacji między następującymi nawiasami: 2}) (<[ oraz *>) ([0.

  3. W polu Zamień na wpisz następujące wyrażenie:

    \3 \1, \4

    Pamiętaj o wstawieniu spacji między zestawami znaków.

  4. Kliknij przycisk Zamień wszystko.

    Funkcja wyszukiwania zamieni datę 28th May, 2003 na zapisaną w formacie May 28, 2003.

Szczegółowy opis transpozycji dat

Najpierw opiszemy wyrażenie w polu Znajdź. W tym wyrażeniu datę rozbito na cztery wzorce oznaczone nawiasami. Poszczególne wzorce zawierają składniki potrzebne do zapisania dowolnej daty w formacie użytym w przykładzie. Od lewej do prawej:

  • Zakres cyfr [0-9] określa jednocyfrową liczbę z pierwszego wzorca. Ponieważ data może składać się z dwóch cyfr, musimy ustawić możliwość zwrócenia daty jednocyfrowej lub dwucyfrowej: {1;2}. Dlatego pierwszy wzorzec wygląda następująco: ([0-9]{1;2}).

    Drugi wzorzec zawiera przyrostki liczebników porządkowych. Przyrostki liczebników porządkowych (angielskie) to „th”, „nd”, „st” i „rd” (np. „eight”, „8th” — ósmy; „second”, „2nd” — drugi; „first”, „1st” — pierwszy; „third”, „3rd” — trzeci), więc musimy dodać te litery do zakresu [dhnrst]. Przyrostki liczebników porządkowych składają się z dwóch liter, co także należy zaznaczyć: ([dhnrst]{2}).

  • Następnie w wyrażeniu znajduje się spacja, literały oraz symbole wieloznaczne służące do znalezienia nazwy miesiąca. Wszystkie nazwy miesięcy (angielskie) rozpoczynają się od następujących liter: ADFJMNOS. Nie wiadomo, ile liter po pierwszej wielkiej literze ma nazwa miesiąca, więc po pierwszej literze umieścimy gwiazdkę (*). Ważna jest tylko nazwa miesiąca, więc ograniczymy wynik do pojedynczego wyrazu za pomocą znaków większości i mniejszości. Trzeci wzorzec wygląda następująco: (<[ADFJMNOS]*>).

  • Na końcu jest wyszukiwany rok. Używany jest ten sam zakres cyfr, ale tym razem wynik jest ograniczany do czterech cyfr ([0-9]{4}).

Zwróć uwagę na to, że w polu Zamień na zapisano tylko trzy z czterech wzorców. Pominięto angielskie przyrostki liczebników porządkowych (np. „th”), ponieważ nie występują w formacie używanym w Stanach Zjednoczonych. Aby pozostawić te przyrostki, wpisz wyrażenie \3 \1\2, \4 w polu Zamień na. W tym przypadku spację wstawiamy tylko po cyfrze 3 i po przecinku.

W dacie miesiąc może być także zapisany przy użyciu liczby, na przykład 28/05/03. W takim przypadku do wyszukania musimy użyć następującego wyrażenia:

([0-9]{1;2})/([0-9]{1;2})/([0-9]{2})

Do zamiany tej daty musimy użyć następującego wyrażenia:

\3/\1/\2

Jeśli data jest zapisana w formacie 28/05/2003, musimy użyć cyfry {4} zamiast cyfry {2} w ostatnim wzorcu.

Używanie separatorów list w wyrażeniach regularnych

W poprzednim przykładzie użyto następującego argumentu w celu znalezienia jednocyfrowych lub dwucyfrowych dat: {1;2}. W tym przypadku dwie wartości są rozdzielone średnikiem. Należy jednak pamiętać, że ustawienia regionalne systemu Windows determinują użycie określonego separatora. Jeśli w ustawieniach regionalnych jako separator listy określono przecinek, należy go używać zamiast średnika.

Aby sprawdzić, jakiego separatora listy używa system operacyjny, wykonaj poniższe czynności:

  1. Otwórz Panel sterowania. (W systemie Windows 8 lub nowszej wersji systemu Windows kliknij przycisk Start, a następnie kliknij polecenie Panel sterowania. W systemie Windows 7 kliknij przycisk Start, a następnie kliknij polecenie Panel sterowania).

  2. Kliknij pozycję Zegar, język i region.

  3. Kliknij pozycję Zmień format daty, godziny lub liczb, a następnie kliknij pozycję Ustawienia dodatkowe.

  4. Kliknij kartę Liczby, a następnie znajdź pozycję Separator listy.


Przykład 3. Dodawanie lub usuwanie kropek w zwrotach grzecznościowych

W niektórych krajach zwroty grzecznościowe i tytuły (dr, mgr itd.) zawierają kropkę, a w niektórych nie. W tym przykładzie wyjaśniono, jak dodać kropkę po tytule lub ją usunąć. Od tego momentu zakłada się, że wiesz, jak używać okna dialogowego Znajdowanie i zamienianie.

To wyrażenie umożliwia znalezienie skrótów dr i mgr, które nie zawierają kropki:

<([dm][ gr ]{1;2})( )

Należy zauważyć, że w wyrażeniu użyto drugiego wzorca zawierającego tylko spację. Spacja znajduje się za tytułem, jeśli nie ma tam kropki. Poniższe wyrażenie służy do dodania kropki:

\1.\2

Aby wykonać odwrotną operację, wyszukaj następujące wyrażenie:

<([dm][ gr ]{1;2}).

Zamień wynik wyszukiwania, korzystając z następującego wyrażenia:

\1


Przykład 4. Znajdowanie zduplikowanych akapitów lub wierszy

Przed użyciem tego wyrażenia najlepiej posortuj listę w celu umieszczenia zduplikowanych wierszy obok siebie. Usuń także wszystkie znaczniki pustych akapitów. Czasami puste akapity są używane do rozdzielania bloków tekstu:

Jan Maciej Bator¶

Jan Maciej Bator¶

Aneta B. Olecka¶

W takim przypadku należy usunąć te akapity w następujący sposób:

Jan Maciej Bator¶
Jan Maciej Bator¶
Aneta B. Olecka¶

W celu usunięcia pustych akapitów można użyć dowolnej metody. Poniżej przedstawiono wyrażenie służące do znalezienia dwóch kolejnych znaków akapitu. Przeprowadź wyszukiwanie za pomocą następującego wyrażenia (znak @ umożliwia powtórzenie operacji znajdowania i zamieniania oraz usunięcie wszystkich pustych wierszy):

(^13)\1@

Wynik zamień na następujące wyrażenie:

^p

Poniżej przedstawiono sposoby zamieniania tekstu. Następujące wyrażenie umożliwia znalezienie dowolnej sekwencji dwóch kolejnych identycznych akapitów:

(*^13)\1

To wyrażenie umożliwia także znalezienie większych powtórzonych fragmentów tekstu zakończonych znakiem akapitu. Można na przykład wyszukać to wyrażenie dla następującej listy:

Jan Maciej Bator¶
Aneta B. Olecka¶
Jan Maciej Bator¶
Aneta B. Olecka¶
Joanna Z. Rybka¶

Wyszukiwanie zwróci cztery pierwsze wiersze i zostanie zatrzymane po zmianie wzorca. Wynik będzie inny w przypadku wyszukania tego wyrażenia na tej liście:

Jan Maciej Bator¶
Jan Maciej Bator
Aneta B. Olecka¶
Aneta B. Olecka¶

W powyższym przypadku zostaną zwrócone tylko dwa pierwsze akapity. 

Aby wyszukać większą liczbę identycznych elementów, dodaj więcej symboli zastępczych. Na przykład poniższe wyrażenie umożliwia znalezienie trzech kolejnych identycznych akapitów:

(*^13)\1\1

W tym samym celu można także użyć nawiasów klamrowych. Poniższe przykładowe wyrażenia służą do znalezienia odpowiednio dwóch i trzech identycznych akapitów:

(*^13){2} (*^13){3}

Można także wyszukać dwa lub trzy identyczne akapity:

(*^13){2;3}

Istnieje także możliwość wyszukania co najmniej dwóch identycznych akapitów:

(*^13){2;}

Każde z tych wyrażeń można zamienić na następujący ciąg:

\1

Ponadto operację znajdowania i zamieniania można powtarzać w celu zamienienia wszystkich zduplikowanych akapitów w dokumencie, a także można dodać symbol wieloznaczny @ w celu automatycznego powtarzania operacji:

(*^13)\1@

Za pomocą tej metody możesz także zamieniać zduplikowane wiersze w tabeli. Aby to zrobić, najpierw usuń wszystkie scalone komórki, a następnie posortuj tabelę w celu umieszczenia zduplikowanych komórek obok siebie. Następnie przekonwertuj tabelę na tekst. W tym celu w menu Tabela wskaż polecenie Konwertuj, a następnie kliknij pozycję Tabela na tekst. W przypadku wyświetlenia monitu o ogranicznik użyj tabulatora. Po wykonaniu operacji zamieniania przekonwertuj tekst z powrotem na tabelę.

Więcej przykładów

Aby poznać więcej przykładów dotyczących używania wyrażeń regularnych w programie Word, zobacz Znajdowanie i zamienianie znaków przy użyciu symboli wieloznacznych w witrynie często zadawanych pytań do specjalistów MVP.

Zobacz też

Konfigurowanie lub wyłączanie automatycznego formatowania (autoformatowania) tekstu

Usuwanie numerów stron

Usuwanie strony w programie Word

Wstawianie symboli

Znajdowanie i zamienianie tekstu lub formatowania w programie Word dla komputerów Mac

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×