Zmienianie typu zadania używanego przez program Project do obliczania czasu trwania zadania

Przy obliczaniu czas trwaniazadanie oraz ich data zakończenia (lub data rozpoczęcia w przypadku harmonogramu projektu utworzonego na podstawie daty zakończenia, a nie daty rozpoczęcia projektu) w programie Project jest używany jeden z trzech typ zadania.

W tym artykule

Omówienie typów zadań

Usuwanie z zadań planowania według nakładu pracy

Zmienianie typu zadania

Omówienie typów zadań

W programie Project są używane trzy typy zadań: zadanie o stałej liczbie jednostek, zadanie o stałej ilości pracy oraz zadanie o stałym czasie trwania. W programie Project domyślnym typem zadania jest stała liczba jednostek.

Typ zadania ma wpływ na sporządzanie harmonogramu w momencie edycji jednego z trzech poniższych elementów.

Zadanie

Korekta jednostek

Korekta czasu trwania

Korekta pracy

Zadanie o stałej liczbie jednostek

Czas trwania jest obliczany ponownie.

Praca jest obliczana ponownie.

Czas trwania jest obliczany ponownie.

Zadanie o stałej pracy

Czas trwania jest obliczany ponownie.

Jednostki są obliczane ponownie.

Czas trwania jest obliczany ponownie.

Zadanie o stałym czasie trwania

Praca jest obliczana ponownie.

Praca jest obliczana ponownie.

Jednostki są obliczane ponownie.

Przykłady wpływu typów zadań na zmianę wartości liczbowych

Zadanie o stałej liczbie jednostek zostało przydzielone jednej jednostki zasobu w pełnym wymiarze czasu pracy, dostępnego 8 godzin dziennie. Przewidywany czas trwania zadania to 10 dni, czyli 80 godzin praca.

  • Jeśli w wykonywaniu zadania będzie mógł pomóc inny zasób w pełnym wymiarze czasu pracy, w programie Project zostanie ponownie obliczony czas trwania zadania. Do zadania będą przydzielone dwie jednostki z pięciodniowym czasem trwania i 80 godzinami pracy.

  • Jeśli okaże się, że na wykonanie zadania jest 8 dni, a nie 10, w programie Project zostanie ponownie obliczona praca zadania. Czas trwania zadania wyniesie 8 dni, liczba godzin pracy wyniesie 64 i zostanie przydzielona jedna jednostka zasobu.

  • Jeśli okaże się, że do wykonania zadania jest potrzebnych 20 godzin dodatkowej pracy, w programie Project zostanie obliczony ponownie czas trwania zadania. Liczba godzin pracy dla zadania wyniesie 100, czas trwania wyniesie 12,5 dnia i do zadania zostanie przydzielona jedna jednostka zasobu.

Inny przykład: to samo zadanie, ale o pracy stałej. To oznacza, że na zadanie może zostać przeznaczony tylko określony procent pracy: nie więcej, nie mniej. W tym przykładzie do zadania jest przydzielony jeden zasób w pełnym wymiarze czasu pracy, dostępny 8 godzin dziennie, i czas trwania zadania wynosi 10 dni, a liczba godzin pracy — 80.

  • Jeśli w wykonywaniu zadania będzie mógł pomóc inny zasób w pełnym wymiarze czasu pracy, w programie Project zostanie obliczony ponownie czas trwania zadania. Do zadania będą przypisane dwie jednostki, czas trwania wyniesie 5 dni, a liczba godzin pracy — 80.

  • Jeśli okaże się, że na wykonanie zadania jest 8 dni, a nie 10, w programie Project zostaną obliczone ponownie jednostki zasobów zadania. Aby wykonać zadanie w 80 godzin w ciągu 8 dni, do zadania musi zostać przydzielona 1,25 jednostki zasobu. Jednostka przydzielona do zasobu będzie alokowana w 125 procentach. Należy przypisać inny zasób do konta dla dodatkowej dwudziestopięcioprocentowej alokacji.

  • Jeśli okaże się, że do wykonania zadania jest potrzebnych 20 godzin dodatkowej pracy, w programie Project zostanie obliczony ponownie czas trwania zadania. Liczba godzin pracy dla zadania wyniesie 100, czas trwania wyniesie 12,5 dnia i do zadania zostanie przydzielona jedna jednostka zasobu.

Ostatni przykład: to samo zadanie, ale o stałym czasie trwania. Oznacza to, że zadanie musi zostać wykonane w określonym czasie. Również w tym przykładzie do zadania jest przydzielony jeden zasób w pełnym wymiarze czasu pracy, dostępny 8 godzin dziennie. Czas trwania zadania wynosi 10 dni, a liczba godzin pracy — 80.

  • Jeśli w wykonywaniu zadania będzie mógł pomóc inny zasób w pełnym wymiarze czasu pracy, w programie Project zostanie obliczona ponownie praca przypisana każdemu zasobowi. Gdy tylko jeden zasób będzie przydzielony do zadania, ten zasób będzie mieć 80 godzin pracy na wykonanie zadania. Gdy do zadania zostanie przydzielony drugi zasób, każdy zasób będzie mieć 40 godzin pracy w ciągu 10 dni na wykonanie zadania, przy całkowitej liczbie 80 godzin pracy. Dzięki dodaniu drugiego zasobu można skorygować alokację obu jednostek do 50%, tak aby w 50 procentach były dostępne do pracy nad innymi zadaniami.

  • Jeśli okaże się, że na wykonanie zadania jest 8 dni, a nie 10, w programie Project zostanie obliczona ponownie praca zadania. Czas trwania zadania wyniesie 8 dni, liczba godzin pracy — 64 i do zadania będzie przydzielona jedna jednostka zasobu.

  • Jeśli okaże się, że do wykonania zadania jest potrzebnych 20 godzin dodatkowej pracy, w programie Project zostaną obliczone ponownie jednostki zasobów zadania, tak aby dodatkowa praca nadal mogła zostać wykonana w ciągu 10 dni. Liczba godzin pracy dla zadania wyniesie 100, czas trwania — 10 dni i do zadania będzie przydzielona 1,25 jednostki zasobu. Jednostka zasobu przydzielona do zadania będzie alokowana w 125 procentach. Należy przypisać do konta inny zasób dla dodatkowej dwudziestopięcioprocentowej alokacji.

Uwaga : Ponieważ przydziały zasoby kosztowe nie mają wartości dla pracy lub jednostek, wartości te nie będą obliczane ponownie, kiedy zostanie zmodyfikowana data rozpoczęcia lub zakończenia zadania. Daty także nie są obliczane ponownie w przypadku przydziału zasobu kosztowego, ponieważ nie można modyfikować pracy ani jednostek.

Początek strony

Usuwanie z zadań planowania według nakładu pracy

Gdy zostanie przydzielony zasoby, harmonogram zadania jest układany dla wszystkich zadań zgodnie z formułą Czas trwania = Praca/Jednostki. Dla każdego zadania można wybrać część równania, która zostanie obliczona w programie Project, określając typ zadania. Przy przydzielaniu osób do zadania lub usuwaniu ich z niego w programie Project zostanie odpowiednio wydłużony lub skrócony czas trwania zadania na podstawie liczby zasobów przydzielonych do niego, a całkowita praca w zadaniu pozostanie bez zmian. Ta metoda nosi nazwę planowanie według nakładu pracy i jest stosowana w programie Project jako domyślna podczas przydzielania zasobów do zadania.

Mimo że metoda planowania według nakładu pracy może działać w większości scenariuszy, może być konieczna zmiana tego zachowania na dokładniej odzwierciedlające efekt dodania lub usunięcia zasobów z konkretnego zadania. Na przykład można zobaczyć zwiększenie całkowitej pracy powstałe w wyniku przydzielenia do zadania dodatkowych osób.

Uwaga : Z zadań o pracy stałej nie można usunąć metody planowania według nakładu pracy. Zadania charakteryzujące się pracą stałą nie mają elastycznych wartości praca i dlatego zawsze są planowane według nakładu pracy.

  1. W menu Widok kliknij polecenie Wykres Gantta.

  2. Kliknij wiersz zadania, w którego przypadku metoda planowania według nakładu pracy ma nie być użyta.

    Aby zmienić do 10 zadań jednocześnie, należy nacisnąć i przytrzymać klawisz CTRL, a następnie kliknąć wiersze poszczególnych zadań. Jeśli zadania zostaną wyświetlone w kolejności jedno po drugim, należy kliknąć pierwsze zadanie, nacisnąć i przytrzymać klawisz SHIFT, a następnie kliknąć ostatnie zadanie, aby zaznaczyć cały blok zadań.

  3. Kliknij przycisk Informacje o zadaniu Obraz przycisku , a następnie kliknij kartę Zaawansowane.

  4. Wyczyść pole wyboru Wg nakładu pracy.

Planując według nakładu pracy, należy pamiętać o następujących zasadach:

  • Obliczenia według nakładu pracy są wykonywane dopiero po wstępnym przydzieleniu do zadania pierwszych zasobów. Po przydzieleniu tych zasobów wartość pracy nie zmienia się, ponieważ zasoby są przydzielane lub usuwane w ramach tego samego zadania.

  • Jeśli przypisany typ zadania to Stała liczba jednostek, przydzielenie dodatkowych zasobów spowoduje skrócenie czasu trwania zadania.

  • Jeśli przypisany typ zadania to Stały czas trwania, przydzielenie dodatkowych zasobów spowoduje zmniejszenie poszczególnych wartości jednostek dla zasobów.

  • Jeśli przypisany typ zadania to Praca stała, przydzielenie dodatkowych zasobów spowoduje skrócenie czasu trwania zadania.

  • W przypadku zadań sumarycznych i wstawionych projektów nie można stosować ustawienia Wg nakładu pracy.

Początek strony

Zmienianie typu zadania

  1. W menu Widok kliknij polecenie Wykres Gantta.

  2. Kliknij zadanie, które ma zostać zmienione.

  3. Kliknij przycisk Informacje o zadaniu Obraz przycisku , a następnie kliknij kartę Zaawansowane.

  4. Na liście Typ zadania kliknij typ zadania, który ma zostać zmieniony.

Uwaga : 

  • Jeżeli zostanie kliknięta pozycja Praca stała na liście Typ zadania, nie można zmienić ustawienia zadania Wg nakładu pracy. W zadaniach o pracy stałej wartość pracy nie jest elastyczna i dlatego zawsze są one planowane według nakładu pracy.

  • Typ każdego zadania można wyświetlać i zmieniać bezpośrednio w widoku przez wstawienie pola Typ. Należy kliknąć kolumnę po prawej stronie miejsca, w którym ma zostać wstawiona nowa kolumna, kliknąć menu Wstaw, a następnie kliknąć polecenie Kolumna. Na liście Nazwa pola należy kliknąć przycisk Typ.

  • Aby zmienić strukturę hierarchiczną zadania lub podzadania w ramach struktury konspektu projektu, zamiast zmieniać typ zadania, należy zwiększyć lub zmniejszyć jego wcięcie.

  • Aby nałożyć obostrzenia dotyczące sposobu obliczania dat rozpoczęcia i zakończenia przez program Project, należy ustawić ograniczenie zadania, a nie zmienić typ zadania.

Początek strony

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×