Zliczanie znaków w komórkach w programie Excel 2016 dla komputerów Mac

Jeśli chcesz zliczyć znaki w komórkach, użyj funkcji DŁ. Umożliwia ona zliczanie liter, cyfr, znaków i wszystkich spacji. Na przykład długość tekstu „Dziś jest 25 stopni, więc pójdę popływać” (bez znaków cudzysłowu) wynosi 40 znaków — 31 liter, 2 cyfry, 6 spacji i 1 przecinek.

  • Aby użyć tej funkcji, wprowadź formułę =DŁ(komórka) na pasku formuły i naciśnij klawisz Enter. W tych przykładach określenie komórka oznacza komórkę, dla której jest przeprowadzane obliczenie, na przykład B1.

  • Aby zliczyć znaki w więcej niż jednej komórce, wprowadź formułę, a następnie skopiuj i wklej formułę do innych komórek.

  • Aby zliczyć całkowitą liczbę znaków w kilku komórkach, użyj funkcji SUMA razem z funkcją DŁ. Na przykład =SUMA((DŁ(komórka1);DŁ(komórka2);(DŁ(komórka3)))). W tym przykładzie funkcja DŁ zlicza znaki w każdej komórce, a funkcja SUMA dodaje je do siebie.

  • Aby zliczyć konkretne znaki w komórkach, użyj funkcji DŁ z funkcją PODSTAW. Jeśli na przykład chcesz wiedzieć, ile jest w komórce małych liter „z”, użyj formuły: = DŁ(komórka1)-DŁ(PODSTAW(komórka1;"z";""))

Spróbuj użyć tej funkcji

Wpisz następujące dane do nowego arkusza programu Excel. Rozpocznij w komórce A1.

Ciągi tekstowe

Formuły

Szybki brązowy lis

Szybki brązowy lis przeskoczył

Szybki brązowy lis przeskoczył leniwego psa

Zliczanie znaków w jednej komórce

  1. Kliknij komórkę B2.

  2. W komórce wprowadź formułę =DŁ(A2) i naciśnij klawisz Enter.

Formuła zlicza znaki w komórce A2. Wynik wynosi 18 (łącznie ze wszystkimi spacjami). Ewentualne spacje występujące po kropce końcowej zostaną również zliczone.

Zliczanie znaków w wielu komórkach

  1. Naciśnij klawisze CONTROL+C, aby skopiować komórkę B2.

  2. Naciśnij klawisze CONTROL+V, aby wkleić tę formułę w komórkach B3:B4.

Spowoduje to skopiowanie formuły do komórek B3 i B4 i zliczenie przez funkcję znaków w poszczególnych komórkach (18, 30 i 43).

Zliczanie całkowitej liczby znaków

  1. Kliknij komórkę B6.

  2. W komórce wprowadź formułę =SUMA(DŁ(A2);DŁ(A3);DŁ(A4)) i naciśnij klawisz Enter.

Spowoduje to zliczenie znaków w każdej z trzech komórek i zsumowanie ich (91).

Liczenie wystąpień konkretnych znaków w komórkach

  1. Kliknij komórkę C4.

  2. W tej komórce wpisz =DŁ(A4)-DŁ(PODSTAW(A4;"z";"")) i naciśnij klawisz Enter.

Ta funkcja zlicza małe litery „z” w komórce A4. Wynik wynosi 4.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×