Zliczanie znaków w komórkach

Uwaga:  Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Gdy chcesz zliczyć znaki w komórkach, należy użyć funkcji DŁ— którego liczy liter, cyfr, znaków i wszystkie spacje. Na przykład długość "Jest 98 stopni dzisiaj, więc można będzie go swimming" (bez cudzysłowów) jest 42 znaków — 31 litery, liczby 2, 8 spacje, średnik i apostrofów 2.

Aby użyć funkcji, wprowadź = DŁ (komórki) na pasku formuły, naciśnij klawisz Enter na klawiaturze.

Wiele komórek: Aby zastosować tę samą formułę do wielu komórek, wprowadź formułę w pierwszej komórce a następnie przeciągnij uchwyt wypełnienia w dół (lub wielu) zakres komórek.

Wprowadzanie wielu funkcji DŁ w arkuszu

Aby uzyskać jest całkowita liczba wszystkie znaki w kilku komórkach za pomocą funkcji Suma razem z DŁ. W tym przykładzie funkcja LEN zliczenie znaków w każdej komórce i funkcja SUMA dodaje liczby elementów:

= Suma ((LEN ( cell1 ), długość ( cell2 ), (LEN ( cell3 )) )).

Spróbuj użyć tej funkcji

Oto kilka przykładów pokazujących, jak używać funkcji DŁ.

Skopiuj w poniższej tabeli i wklej je w komórce A1 w arkuszu programu Excel. Przeciągnij formułę z komórki B2 do B4, aby wyświetlić długość tekstu we wszystkich komórkach w kolumnie A.

Ciągi tekstowe

Formuły

Szybki brązowy lis.

=DŁ(A2)

Szybki brązowy lis przeskoczył.

Szybki brązowy lis przeskoczył leniwego psa.

Zliczanie znaków w jednej komórce

  1. Kliknij komórkę B2.

  2. Wprowadź formułę =DŁ(a2).

Formuła zlicza znaki w komórce A2, która sumuje 27 — zawierająca wszystkie spacje i okresu na końcu zdania.

Uwaga: DŁ zlicza spacji za ostatnim znakiem.

Zliczanie znaków w wielu komórkach

  1. Kliknij komórkę B2.

  2. Naciśnij klawisze Ctrl + C, aby Kopiuj komórkę B2, a następnie zaznacz komórki B3 i B4, a następnie naciśnij klawisze Ctrl + V, aby wkleić tę formułę w komórkach B3: B4.

Spowoduje to skopiowanie formuły do komórek B3 i B4 i zliczenie znaków w każdej komórce (20, 27 i 45).

Zliczanie całkowitej liczby znaków

  1. W przykładowym skoroszycie kliknij komórkę B6.

  2. W komórce wprowadź formułę =SUMA(DŁ(A2);DŁ(A3);DŁ(A4)) i naciśnij klawisz Enter.

Spowoduje to zliczenie znaków w każdej z trzech komórek i zsumowanie ich (92).

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×