Zliczanie znaków w komórkach

Jeśli chcesz zliczyć znaki w komórkach, użyj funkcji DŁ. Umożliwia ona zliczanie liter, cyfr, znaków i wszystkich spacji. Na przykład długość tekstu „Dziś jest 25 stopni, więc pójdę popływać” (bez znaków cudzysłowu) wynosi 40 znaków — 31 liter, 2 cyfry, 6 spacji i 1 przecinek.

  • Aby użyć tej funkcji, wprowadź formułę =DŁ(komórka) na pasku formuły i naciśnij klawisz Enter. W tych przykładach określenie komórka oznacza komórkę, dla której jest przeprowadzane obliczenie, na przykład B1.

  • Aby zliczyć znaki w więcej niż jednej komórce, wprowadź formułę, a następnie przeciągnij uchwyt wypełniania wzdłuż lub wszerz zakresu komórek, którego chcesz użyć.

Wprowadzanie wielu funkcji DŁ w arkuszu

  • Aby zliczyć całkowitą liczbę znaków w kilku komórkach, użyj funkcji SUMA razem z funkcją DŁ. Na przykład =SUMA((DŁ(komórka1);DŁ(komórka2);(DŁ(komórka3)))). W tym przykładzie funkcja DŁ zlicza znaki w każdej komórce, a funkcja SUMA dodaje je do siebie.

Spróbuj użyć tej funkcji

Za pomocą przykładów w skoroszycie poniżej możesz dowiedzieć się, jak używać funkcji DŁ.

Skopiuj poniższą tabelę i wklej ją w komórce A1 w arkuszu programu Excel. Przeciągnij formułę z komórki B2 do zakresu B3:B4, aby sprawdzić, jaka jest długość tekstu w komórkach w kolumnie A.

Ciągi tekstowe

Formuły

Szybki brązowy lis

=DŁ(A2)

Szybki brązowy lis przeskoczył

Szybki brązowy lis przeskoczył leniwego psa.

Zliczanie znaków w jednej komórce

  1. W arkuszu Arkusz1 przykładowego skoroszytu kliknij komórkę B2.

  2. W komórce wprowadź formułę =DŁ(A2) i naciśnij klawisz Enter.

Formuła zlicza znaki w komórce A1. Wynik wynosi 45 i ta liczba obejmuje wszystkie spacje. Ewentualne spacje występujące po kropce końcowej zostaną również zliczone.

Zliczanie znaków w wielu komórkach

  1. W przykładowym skoroszycie kliknij komórkę B2.

  2. W komórce wprowadź formułę =DŁ(A2).

  3. Naciśnij klawisze Ctrl+C, aby skopiować komórkę B2, i naciśnij klawisze Ctrl+V, aby wkleić tę formułę w komórkach B3:B4.

Spowoduje to skopiowanie formuły do komórek B3 i B4 i zliczenie przez funkcję znaków w poszczególnych komórkach (18, 30 i 44).

Zliczanie całkowitej liczby znaków

  1. W przykładowym skoroszycie kliknij komórkę B6.

  2. W komórce wprowadź formułę =SUMA(DŁ(A2);DŁ(A3);DŁ(A4)) i naciśnij klawisz Enter.

Spowoduje to zliczenie znaków w każdej z trzech komórek i zsumowanie ich (92).

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×