Zliczanie wystąpień określonej wartości

Załóżmy, że należy sprawdzić, ile razy występuje określona wartość tekstowa lub liczbowa, na przykład:

  • Jeśli zakres zawiera wartości liczbowe 5, 6, 7 i 6, to wartość 6 występuje dwa razy.

  • Jeśli kolumna zawiera wartości „Karwat”, „Dubicki”, „Dubicki” i „Dubicki”, to wartość "Dubicki" występuje trzy razy.

Istnieje kilka sposobów zliczania, ile razy występuje dana wartość.

Co chcesz zrobić?

Zliczanie przy użyciu funkcji, ile razy występuje określona wartość

Szczegóły funkcji

Zliczanie przy użyciu funkcji, ile razy występują różne wartości liczbowe

Szczegóły funkcji

Zliczanie przy użyciu funkcji, ile razy występują różne wartości tekstowe lub liczbowe

Szczegóły funkcji

Zliczanie przy użyciu raportu w formie tabeli przestawnej, ile razy występują różne wartości

Zliczanie przy użyciu funkcji, ile razy występuje określona wartość

Aby wykonać to zadanie, należy użyć funkcji LICZ.JEŻELI.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

Jak skopiować przykład

  1. Utwórz pusty skoroszyt lub arkusz.

  2. Zaznacz przykład w tym temacie Pomocy.

    Uwaga : Nie zaznaczaj nagłówków wierszy ani kolumn.

    Zaznaczanie przykładu w Pomocy

    Zaznaczanie przykładu w Pomocy

  3. Naciśnij klawisze CTRL+C.

  4. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.

  5. Aby przełączać się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisz CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.

1

2

3

4

5

6

7

A

b.

Sprzedawca

Faktura

Michalski

15 000

Michalski

9000

Wieczorek

8 000

Wieczorek

20 000

Michalski

5 000

Dudek

22 500

Formuła:

Opis (wynik)

=LICZ.JEŻELI(A2:A7;"Janik")

Liczba wpisów dla sprzedawcy o nazwisku Janik (3)

=LICZ.JEŻELI(A2:A7;A4)

Liczba wpisów dla sprzedawcy o nazwisku Suyama (2)

=LICZ.JEŻELI(B2:B7;"< 20000")

Liczba faktur o wartości mniejszej niż 20 000 (4)

=LICZ.JEŻELI(B2:B7;">="&B5)

Liczba faktur o wartości równej lub większej niż 20 000 (2)

Szczegóły funkcji

LICZ.JEŻELI

Początek strony

Zliczanie przy użyciu funkcji, ile razy występują różne wartości liczbowych

Załóżmy, że należy ustalić, ilu sprzedawców sprzedało określony produkt w danym regionie lub ile transakcji sprzedaży przekraczających określoną wartość odnotował dany sprzedawca. W tym celu można użyć funkcji JEŻELI i ILE.LICZB.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

Jak skopiować przykład

  1. Utwórz pusty skoroszyt lub arkusz.

  2. Zaznacz przykład w tym temacie Pomocy.

    Uwaga : Nie zaznaczaj nagłówków wierszy ani kolumn.

    Zaznaczanie przykładu w Pomocy

    Zaznaczanie przykładu w Pomocy

  3. Naciśnij klawisze CTRL+C.

  4. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.

  5. Aby przełączać się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisz CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.

1

2

3

4

5

6

7

8

9

10

11

A

B

C

D

Region

Sprzedawca

Typ

Sprzedaż

Południe

Janik

Napoje

3571

Zachód

Lesiak

Nabiał

3338

Wschód

Suyama

Napoje

5122 zł

Północ

Suyama

Nabiał

6239

Południe

Marczak

Bakalie

8677

Południe

Lesiak

Mięso

450 zł

Południe

Lesiak

Mięso

7673

Wschód

Suyama

Bakalie

664

Północ

Lesiak

Bakalie

>1500

Południe

Marczak

Mięso

6596

Formuła

Opis (wynik)

=ILE.LICZB(JEŻELI((A2:A11="Południe")*(C2:C11="Mięso");D2:D11))

Liczba sprzedawców, którzy sprzedali mięso w regionie Południe (3)

=ILE.LICZB(JEŻELI((B2:B11="Stąpor")*(D2:D11>=1000);D2:D11))

Liczba transakcji sprzedaży przekraczających wartość 1000 dla sprzedawcy o nazwisku Stąpor (2)

Uwaga : 

  • Formuła w tym przykładzie musi być wprowadzona w postaci formuły tablicowej. Po skopiowaniu przykładu do pustego arkusza należy zaznaczyć komórkę zawierającą formułę, nacisnąć klawisz F2, a następnie nacisnąć klawisze CTRL+SHIFT+ENTER. Jeżeli formuła nie będzie wprowadzona w postaci formuły tablicowej, to zostanie zwrócony błąd #ARG!

  • Aby te formuły działały, drugim argumentem funkcji JEŻELI musi być liczba.

Szczegóły funkcji

ILE.LICZB

JEŻELI

Początek strony

Zliczanie przy użyciu funkcji, ile razy występują różne wartości tekstowe lub liczbowe

Aby wykonać to zadanie, należy użyć funkcji JEŻELI i SUMA.

  • Przypisz wartość 1 do każdego spełnionego warunku, używając funkcji JEŻELI.

  • Dodaj sumę, używając funkcji SUMA.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

Jak skopiować przykład

  1. Utwórz pusty skoroszyt lub arkusz.

  2. Zaznacz przykład w tym temacie Pomocy.

    Uwaga : Nie zaznaczaj nagłówków wierszy ani kolumn.

    Zaznaczanie przykładu w Pomocy

    Zaznaczanie przykładu w Pomocy

  3. Naciśnij klawisze CTRL+C.

  4. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.

  5. Aby przełączać się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisz CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.

1

2

3

4

5

6

7

A

b.

Sprzedawca

Faktura

Michalski

15 000

Michalski

9000

Wieczorek

8 000

Wieczorek

20 000

Michalski

5 000

Dudek

22 500

Formuła:

Opis (wynik)

=SUMA(JEŻELI((A2:A7="Janik")+(A2:A7="Marczak");1;0))

Liczba faktur dla sprzedawcy o nazwisku Janik lub Marczak (4)

=SUMA(JEŻELI((B2:B7<9000)+(B2:B7>19000);1;0))

Liczba faktur o wartościach mniejszych niż 9000 lub większych niż 19 000 (4)

=SUMA(JEŻELI(A2:A7="Janik";JEŻELI(B2:B7<9000;1;0)))

Liczba faktur dla sprzedawcy o nazwisku Janik i wartości mniejszej niż 9000 (1)

Uwaga : Formuły w tym przykładzie muszą zostać wprowadzone jako formuły tablicowe. Należy zaznaczyć każdą komórkę zawierającą formułę, nacisnąć klawisz F2, a następnie nacisnąć klawisze CTRL+SHIFT+ENTER.

Szczegóły funkcji

JEŻELI

SUMA

Początek strony

Zliczanie przy użyciu raportu w formie tabeli przestawnej, ile razy występują różne wartości

Raportu w formie tabeli przestawnej można używać do wyświetlania sum całkowitych i zliczania wystąpień unikatowych wartości.

  1. Zaznacz kolumnę zawierającą dane. Upewnij się, że kolumna ma nagłówek.

  2. Na karcie Wstawianie w grupie Tabele kliknij przycisk Tabela przestawna.

  3. Zostanie wyświetlone okno dialogowe Tworzenie tabeli przestawnej.

  4. Kliknij opcję Zaznacz tabelę lub zakres.

  5. Umieść raport tabeli przestawnej w nowym arkuszu tak, aby zaczynał się w komórce A1, klikając opcję Nowy arkusz.

  6. Kliknij przycisk OK.

    W lokalizacji określonej na wyświetlonej liście pól tabeli przestawnej zostanie dodany pusty raport tabeli przestawnej.

  7. W sekcji pola u góry listy pól tabeli przestawnej kliknij i przytrzymaj nazwę pola, a następnie przeciągnij pole do pola Etykiety wierszy w sekcji układu znajdującej się u dołu listy pól tabeli przestawnej.

  8. W sekcji pola u góry listy pól tabeli przestawnej kliknij i przytrzymaj tę samą nazwę pola, a następnie ponownie przeciągnij pole do pola Wartości w sekcji układu znajdującej się u dołu listy pól tabeli przestawnej.

Uwaga : Jeśli dane zawierają liczby, raport tabeli przestawnej podsumuje wpisy zamiast je zliczyć. Aby zmienić funkcję podsumowania z funkcji SUMA na funkcję ILE.LICZB, zaznacz komórkę w tej kolumnie, a następnie na karcie Opcje w grupie Aktywne pole kliknij przycisk Ustawienia pola, kliknij kartę Podsumowanie według, kliknij pozycję Licznik i kliknij przycisk OK.

Początek strony

Czy te informacje były pomocne?

Doskonale! Czy chcesz przesłać inne opinie?

Jak możemy to poprawić?

Dziękujemy za opinię!

×