Zliczanie wystąpień określonej wartości

Aby zliczyć wystąpienia wartości tekstowych i liczbowych w zakresie komórek, można skorzystać z szeregu funkcji. Na przykład przy użyciu funkcji LICZ.JEŻELI można zliczyć, jak często występuje określona wartość, co pokazano w poniższym przykładzie.

Przykład

Sprzedawca

Faktura

Myrcha

15 000

Myrcha

9 000

Stąpor

8 000

Stąpor

20 000

Myrcha

5 000

Dyszkiewicz

22 500

Formuła

Opis

Wynik

=LICZ.JEŻELI(A2:A7;"Myrcha")

Liczba wpisów dla sprzedawcy o nazwisku Myrcha (3).

3

=LICZ.JEŻELI(A2:A7;A4)

Liczba wpisów dla sprzedawcy o nazwisku Stąpor (2).

2

=LICZ.JEŻELI(B2:B7;"< 20000")

Liczba faktur o wartości mniejszej niż 20 000 (4).

4

=LICZ.JEŻELI(B2:B7;">="&B5)

Liczba faktur o wartości równej lub większej niż 20 000 (2).

2

Zliczanie wartości na podstawie wielu kryteriów przy użyciu funkcji LICZ.WARUNKI

Funkcja LICZ.WARUNKI jest podobna do funkcji LICZ.JEŻELI z jedną ważna różnicą: funkcja LICZ.WARUNKI umożliwia zastosowanie kryteriów do komórek w wielu zakresach i zliczenie, ile razy wszystkie kryteria zostaną spełnione. Funkcja LICZ.WARUNKI pozwala na użycie maksymalnie 127 par warunków/kryteriów. Składnia funkcji jest następująca:

LICZ.WARUNKI(zakres_kryterium1; kryterium1; [zakres_kryterium2; kryterium2],…)

Przykład

Identyfikator pracownika

Numer regionu

Dział

20552

2

Sprzedaż

21268

2

Finanse

23949

1

Administracja

24522

4

Administracja

28010

3

IT

29546

4

Sprzedaż

31634

3

IT

32131

1

IT

35106

4

Finanse

40499

1

Kadry

42051

1

Sprzedaż

43068

2

Kadry

45382

2

Finanse

47971

1

IT

Formuła

Opis

Wynik

=LICZ.WARUNKI(B2:B15;"2";C2:C15;"Finanse")

Liczba pracowników w regionie 2 i dziale finansowym

2

Pierwszy zakres kryteriów uwzględnia wszystkie numery regionów, a drugi — nazwy działów. Kryterium zastosowanym do pierwszego zakresu jest „2”, a kryterium zastosowanym do drugiego zakresu — „Finanse”. Funkcja LICZ.WARUNKI sprawdza, czy oba kryteria są spełnione.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×