Zliczanie wartości unikatowych wśród duplikatów

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Załóżmy, że chcesz dowiedzieć się, ile unikatowych wartości tekstowe lub liczbowe znajdują się w zakresie. Na przykład, jeśli kolumna zawiera wartości tekst Bradley, Szypuła Szypuła, Szypuła, istnieją dwie wartości unikatowe — Bradley i Szypuła. Jeśli zakres zawiera liczby 5, 6, 7 i 6, wartości unikatowe są 5, 6 i 7.

Aby zliczyć tylko wartości unikatowe, użyj połączenia następujących funkcji, jak pokazano w przykładowym arkuszu poniżej:

  • Aby przypisać wartość 1 do każdego warunku, który zwraca wartość PRAWDA, użyj funkcji JEŻELI.

  • Aby dodać wszystkie wartości unikatowe, użyj funkcji SUMA.

  • Aby zliczyć wartości unikatowe, użyj funkcji CZĘSTOŚĆ. Ta funkcja ignoruje wartości zerowe i tekstowe. Dla pierwszego wystąpienia określonej wartości ta funkcja zwraca liczbę równą liczbie wystąpień danej wartości. Dla każdego kolejnego wystąpienia tej samej wartości funkcja zwraca wartość 0.

  • Aby zwrócić pozycję wartości tekstowej w zakresie, użyj funkcji PODAJ.POZYCJĘ. Funkcja CZĘSTOŚĆ używa wartości wynikowej do oceny odpowiadających wartości tekstowych.

  • Aby znaleźć puste komórki, użyj funkcji . Puste komórki mają długość (liczbę znaków) równą 0.

Przykład

Skopiuj tabelę do komórki A1 w pustym arkuszu programu Excel, aby pracować z przykładowymi formułami używającymi funkcji.

Dane

Dane

986

Bochenek

Szypuła

563

67

789

235

Bochenek

Szypuła

689

789

Szypuła

143

56

237

67

235

Formuła

Opis (wynik)

=SUMA(JEŻELI(CZĘSTOŚĆ(A2:A10;A2:A10)>0;1))

Zlicza unikatowe wartości liczbowe w zakresie komórek A2:A10, z pominięciem komórek pustych i zawierających wartości tekstowe (4)

=SUMA(JEŻELI(CZĘSTOŚĆ(PODAJ.POZYCJĘ(B2:B10;B2:B10;0);PODAJ.POZYCJĘ(B2:B10;B2:B10;0))>0;1))

Zlicza unikatowe wartości liczbowe i tekstowe w zakresie komórek B2:B10 (zakres nie może zawierać komórek pustych) (7)

=SUMA(JEŻELI(CZĘSTOŚĆ(JEŻELI(DŁ(A2:A10)>0;PODAJ.POZYCJĘ(A2:A10;A2:A10;0);"");JEŻELI(DŁ(A2:A10)>0;PODAJ.POZYCJĘ(A2:A10;A2:A10;0);""))>0;1))

Zlicza unikatowe wartości liczbowe i tekstowe w zakresie komórek A2:A10, z pominięciem komórek pustych i zawierających wartości tekstowe (6)

Uwagi : 

  • Formuły w tym przykładzie należy wprowadzać w postaci formuł tablicowych. Zaznacz każdą komórkę zawierającą formułę, naciśnij klawisz F2, a następnie naciśnij klawisze Ctrl + Shift + Enter.

  • Aby wyświetlić krok po kroku wyznaczanie wartości w danej formule, należy zaznaczyć komórkę, w której jest ona umieszczona, a następnie na karcie Formuły w grupie Inspekcja formuł kliknąć polecenie Szacuj formułę.

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×