Zliczanie wartości unikatowych wśród duplikatów

Uwaga:  Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Załóżmy, że chcesz dowiedzieć się, ile unikatowych wartości tekstowe lub liczbowe znajdują się w zakresie. Na przykład, jeśli kolumna zawiera tekst wartości Bochenek, Szypuła Szypuła, Szypuła, istnieją dwie wartości unikatowe — Bochenek i Szypuła. Jeśli zakres zawiera liczby 5, 6, 7 i 6, wartości unikatowe są 5, 6 i 7.

Aby zliczyć tylko wartości unikatowe, użyj połączenia następujących funkcji, jak pokazano w przykładowym arkuszu poniżej:

  • Aby przypisać wartość 1 do każdego warunku, który ma wartość PRAWDA, należy użyć funkcji Jeżeli .

  • Dodanie wszystkich wartości unikatowe, należy użyć funkcji Suma .

  • Aby zliczyć wartości unikatowe, należy użyć częstość, funkcja . Ta funkcja ignoruje tekst i wartości zerowych. Dla pierwszego wystąpienia określonej wartości zwraca liczbę równą liczbie wystąpień danej wartości. Dla każdego wystąpienia tej samej wartości po pierwszym ta funkcja zwraca wartość 0.

  • Zwraca pozycję wartości tekstowej w zakresie, należy użyć funkcji Podaj . CZĘSTOŚĆ, funkcja używa wartość wynikowa ma być obliczona odpowiadające im wartości tekstowych.

  • Aby znaleźć puste komórki, należy użyć funkcji DŁ . Puste komórki mają długość 0 (liczba znaków).

Przykład

Skopiuj tabelę do komórki A1 w pustym arkuszu programu Excel, aby pracować z przykładowymi formułami używającymi funkcji.

Dane

Dane

986

Bochenek

Szypuła

563

67

789

235

Bochenek

Szypuła

689

789

Szypuła

143

56

237

67

235

Formuła

Opis (wynik)

=SUMA(JEŻELI(CZĘSTOŚĆ(A2:A10;A2:A10)>0;1))

Zlicza unikatowe wartości liczbowe w zakresie komórek A2:A10, z pominięciem komórek pustych i zawierających wartości tekstowe (4)

=SUMA(JEŻELI(CZĘSTOŚĆ(PODAJ.POZYCJĘ(B2:B10;B2:B10;0);PODAJ.POZYCJĘ(B2:B10;B2:B10;0))>0;1))

Zlicza unikatowe wartości liczbowe i tekstowe w zakresie komórek B2:B10 (zakres nie może zawierać komórek pustych) (7)

=SUMA(JEŻELI(CZĘSTOŚĆ(JEŻELI(DŁ(A2:A10)>0;PODAJ.POZYCJĘ(A2:A10;A2:A10;0);"");JEŻELI(DŁ(A2:A10)>0;PODAJ.POZYCJĘ(A2:A10;A2:A10;0);""))>0;1))

Zlicza unikatowe wartości liczbowe i tekstowe w zakresie komórek A2:A10, z pominięciem komórek pustych i zawierających wartości tekstowe (6)

Uwagi: 

  • Formuły w tym przykładzie należy wprowadzać w postaci formuł tablicowych. Zaznacz każdą komórkę zawierającą formułę, naciśnij klawisz F2, a następnie naciśnij klawisze Ctrl + Shift + Enter.

  • Aby wyświetlić krok po kroku wyznaczanie wartości w danej formule, należy zaznaczyć komórkę, w której jest ona umieszczona, a następnie na karcie Formuły w grupie Inspekcja formuł kliknąć polecenie Szacuj formułę.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×