Zliczanie liczb lub dat na podstawie warunku

Do zliczania liczb lub dat spełniających kryteria jednego warunku (na przykład: „równe”, „większe niż”, „mniejsze niż”, „większe niż lub równe” albo „mniejsze niż lub równe”) służy funkcja LICZ.JEŻELI. Do zliczania liczb lub dat z danego zakresu (na przykład: większe niż 9000, a jednocześnie mniejsze niż 22 500) można użyć funkcji LICZ.WARUNKI. Można również użyć funkcji SUMA.ILOCZYNÓW.

Przykład

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

A

B

Sprzedawca

Faktura

Dubicki

15 000

Dubicki

9 000

Stąpor

8 000

Stąpor

20 000

Dubicki

5 000

Dyszkiewicz

22 500

Formuła

Opis (wynik)

=LICZ.JEŻELI(B2:B7;">9000")

Funkcja LICZ.JEŻELI umożliwia zliczenie liczby komórek z zakresu B2:B7 zawierających liczby większe niż 9000 (4).

=LICZ.JEŻELI(B2:B7;"<=9000")

Funkcja LICZ.JEŻELI umożliwia zliczenie liczby komórek z zakresu B2:B7 zawierających liczby mniejsze niż 9000 (4).

=LICZ.WARUNKI(B2:B7;">=9000";B2:B7;"<=22500")

Funkcja LICZ.WARUNKI (dostępna w programie Excel 2007 i jego nowszych wersjach) umożliwia zliczenie liczby komórek z zakresu B2:B7 o wartości większej lub równej 9000 i mniejszej lub równiej 22500 (4).

=SUMA.ILOCZYNÓW((B2:B7>=9000)*(B2:B7<=22500))

Funkcja SUMA.ILOCZYNÓW umożliwia zliczenie liczby komórek z zakresu B2:B7 zawierających liczby większe lub równe 9000 i mniejsze lub równe 22500 (4). Można z niej korzystać w programie Excel 2003 i jego starszych wersjach, w których funkcja LICZ.WARUNKI nie jest jeszcze dostępna.

Data

2011-03-11

2010-01-01

2010-12-31

2010-06-30

Formuła

Opis (wynik)

=LICZ.JEŻELI(B14:B17;">2010-01-03")

Umożliwia zliczenie liczby komórek z zakresu B14:B17 z datą późniejszą niż 2010-01-03 (3).

=LICZ.JEŻELI(B14:B17;"2010-12-31")

Umożliwia zliczenie liczby komórek z zakresu B14:B17 z datą równą 2010-12-31 (1). Znak równości nie jest potrzebny w tych kryteriach, więc nie został tu uwzględniony (formuła będzie też działać po dodaniu znaku równości ("=2010-12-31").

=LICZ.WARUNKI(B14:B17;">=2010-01-01";B14:B17;"<=2010-12-31")

Umożliwia zliczenie liczby komórek z zakresu B14:B17 z datą między 2010-01-01 a 2010-12-31 (włącznie) (3).

=SUMA.ILOCZYNÓW((B14:B17>=DATA.WARTOŚĆ("2010-01-01"))*(B14:B17<=DATA.WARTOŚĆ("2010-12-31")))

Umożliwia zliczenie liczby komórek z zakresu B14:B17 z datą między 2010-01-01 a 2010-12-31 (włącznie) (3). W tym przykładzie pokazano, jak korzystać z funkcji zastępującej funkcję LICZ.WARUNKI, która została wprowadzona w programie Excel 2007. Funkcja DATA.WARTOŚĆ konwertuje daty na wartości liczbowe używane przez funkcję SUMA.ILOCZYNÓW.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×