Zaokrąglanie wartości liczbowej do odpowiedniej liczby miejsc dziesiętnych

Zaokrąglanie wartości liczbowej do odpowiedniej liczby miejsc dziesiętnych

Jeśli nie chcesz, aby w komórkach pojawiały się niepotrzebne miejsca dziesiętne, ponieważ powodują wyświetlanie symboli ######, lub jeśli bardzo duża dokładność nie jest potrzebna, zmień format komórek w taki sposób, aby uzyskać odpowiednią liczbę miejsc dziesiętnych.

Jeśli z kolei chcesz zaokrąglić liczbę do najbliższej jednostki głównej, takiej jak tysiące, setki, dziesiątki lub jedności, użyj funkcji w formule.

Użycie przycisku:

  1. Zaznacz komórki, które chcesz sformatować.

  2. Na karcie Narzędzia główne kliknij przycisk Zwiększ liczbę miejsc dziesiętnych lub Zmniejsz liczbę miejsc dziesiętnych, aby pokazać więcej lub mniej cyfr po separatorze dziesiętnym.

Stosowanie wbudowanego formatu liczby:

  1. Na karcie Narzędzia główne w grupie Liczba kliknij strzałkę obok listy formatów liczb, a następnie kliknij pozycję Więcej formatów liczb.

Grupa Liczba na karcie Narzędzia główne

  1. Na liście Kategoria kliknij pozycję Walutowe, Księgowe, Procentowe lub Naukowe w zależności od typu danych.

  2. W polu Miejsca dziesiętne wprowadź liczbę miejsc dziesiętnych, które mają być wyświetlane.

Użycie funkcji w formule:

Zaokrąglij wartość liczbową do odpowiedniej liczby cyfr za pomocą funkcji ZAOKR. Ta funkcja ma tylko dwa argumenty (argumenty to dane potrzebne do uruchomienia formuły).

  • Pierwszy argument jest liczbą, którą chcesz zaokrąglić (może być odwołaniem do komórki lub cyfrą).

  • Drugi argument to liczba cyfr, do której chcesz zaokrąglić liczbę.

Załóżmy, że komórka A1 zawiera liczbę 823,7825. Aby ją zaokrąglić do najbliższej jednostki:

  • Tysiąc e

    • Wpisz =ZAOKR(A1;-3), co wyniesie 1000

    • Liczba 823,7825 jest bliżej liczby 1000 niż liczby 0 (0 jest wielokrotnością liczby 1000).

    • Użyj tutaj liczby ujemnej, ponieważ zaokrąglanie ma się odbywać po lewej stronie separatora dziesiętnego. To samo dotyczy kolejnych dwóch formuł umożliwiających zaokrąglanie do setek i dziesiątek.

  • Setki

    • Wpisz =ZAOKR(A1;-2), co wyniesie 800

    • Liczba 800 jest bliżej liczby 823,7825 niż liczby 900. Wydaje się, że wiesz już, na czym to polega.

  • Dziesiąt ki

    • Wpisz =ZAOKR(A1;-1), co wyniesie 820

  • Jedno ści

    • Wpisz =ZAOKR(A1;0), co wyniesie 824

    • Zaokrąglij liczbę do najbliższej pojedynczej cyfry przy użyciu zera.

  • Części dziesięt ne

    • Wpisz =ZAOKR(A1;1), co wyniesie 823,8

    • Zaokrąglij wartość liczbową do określonej liczby miejsc dziesiętnych przy użyciu liczby dodatniej. To samo dotyczy kolejnych dwóch formuł umożliwiających zaokrąglanie do części setnych i tysięcznych.

  • Części set ne

    • Wpisz =ZAOKR(A1;2), co wyniesie 823,78

  • Części tysięcz ne

    • Wpisz =ZAOKR(A1;3), co wyniesie 823,783

Zaokrąglij liczbę w górę przy użyciu funkcji ZAOKR.GÓRA. Działa ona tak samo jak funkcja ZAOKR, z tym że liczba jest zawsze zaokrąglana w górę. Jeśli chcesz na przykład zaokrąglić liczbę 3,2 w górę do zera miejsc dziesiętnych, wpisz:

  • =ZAOKR.GÓRA(3,2;0), co wyniesie 4.

Zaokrąglij liczbę w dół przy użyciu funkcji ZAOKR.DÓŁ. Działa ona tak samo jak funkcja ZAOKR, z tym że liczba jest zawsze zaokrąglana w dół. Jeśli chcesz na przykład zaokrąglić liczbę 3,14159 w dół do trzech miejsc dziesiętnych, wpisz:

  • =ZAOKR.DÓŁ(3,14159;3), co wyniesie 3,141.

Porada :  Aby uzyskać więcej przykładów i poeksperymentować z przykładowymi danymi w skoroszycie Excel Online, zobacz artykuły dotyczące funkcji ZAOKR, ZAOKR.GÓRA i ZAOKR.DÓŁ.

Możesz ustawić domyślny separator dziesiętny dla liczb w obszarze Opcje programu Excel.

  1. Kliknij pozycję Opcje (program Excel 2010 do programu Excel 2016) lub przycisk pakietu Microsoft Office Obraz przycisku pakietu Office > Opcje programu Excel (Excel 2007).

  2. W kategorii Zaawansowane w obszarze Opcje edycji zaznacz pole wyboru Automatycznie wstaw przecinek dziesiętny.

  3. W polu Miejsca wpisz liczbę dodatnią dla cyfr z prawej strony przecinka dziesiętnego lub liczbę ujemną dla cyfr z lewej strony przecinka dziesiętnego.

    Uwaga : Na przykład w przypadku wprowadzenia liczby 3 w polu Miejsca i wpisania następnie w komórce liczby 2834 wartość będzie wynosić 2,834. Jeśli w polu Miejsca zostanie wprowadzona liczba -3, a następnie zostanie wpisana w komórce liczba 283, wartość będzie równa 283 000.

  4. Kliknij przycisk OK.

    Na pasku stanu zostanie wyświetlony wskaźnik Stała liczba miejsc dziesiętnych.

  5. Kliknij komórkę w arkuszu, a następnie wpisz żądaną liczbę.

    Uwaga : Dane wpisane przed zaznaczeniem pola wyboru Stała liczba miejsc dziesiętnych nie ulegną zmianie.

  • Aby tymczasowo zastąpić opcję stałej liczby miejsc dziesiętnych, wpisz przecinek dziesiętny podczas wpisywania liczby.

  • Aby usunąć przecinek dziesiętny z liczb, które już zostały wprowadzone ze stałymi miejscami dziesiętnymi, wykonaj następujące czynności:

    1. Kliknij pozycję Opcje (program Excel 2010 do programu Excel 2016) lub przycisk pakietu Microsoft Office Obraz przycisku pakietu Office > Opcje programu Excel (Excel 2007).

    2. W kategorii Zaawansowane w obszarze Opcje edycji usuń zaznaczenie pola wyboru Automatycznie wstaw przecinek dziesiętny.

    3. W pustej komórce wpisz liczbę, na przykład 10, 100 lub 1000, w zależności od liczby miejsc dziesiętnych, które chcesz usunąć.

      Na przykład wpisz w komórce 100, jeśli liczby zawierają dwa miejsca dziesiętne i chcesz je przekształcić w liczby całkowite.

    4. Na karcie Narzędzia główne w grupie Schowek kliknij pozycję Kopiuj Obraz przycisku lub naciśnij klawisze CTRL+C.

    5. W arkuszu zaznacz komórki zawierające liczby z miejscami dziesiętnymi, które chcesz zmienić.

    6. Na karcie Narzędzia główne w grupie Schowek kliknij strzałkę poniżej przycisku Wklej, a następnie kliknij polecenie Wklej specjalnie.

    7. W oknie dialogowym Wklejanie specjalne w obszarze Operacje kliknij pozycję Mnożenie.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Zaokrąglanie liczby

Dlaczego liczby są zaokrąglane?

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×