Wyszukiwanie wartości przy użyciu funkcji WYSZUKAJ.PIONOWO, INDEKS i PODAJ.POZYCJĘ

Aby znaleźć wartość na dużej liście, możesz użyć funkcji wyszukiwania. Funkcja WYSZUKAJ.PIONOWO jest powszechnie stosowana, ale funkcja WYSZUKAJ.POZIOMO oraz wspólne użycie funkcji INDEKS i PODAJ.POZYCJĘ może również być dobrym rozwiązaniem.

Poniżej wyjaśniono, jak działa funkcja WYSZUKAJ.PIONOWO i jej argumenty:

=WYSZUKAJ.PIONOWO(<szukana wartość>;<zakres wyszukiwania>;<kolumna>;<przybliżone dopasowanie>)

Przykład: =WYSZUKAJ.PIONOWO(21500;C2:E7;3;FAŁSZ)

  • Pierwszy argument — część funkcji potrzebna do działania funkcji — stanowi szukaną wartość. Może to być odwołanie do komórki (np. B2) lub wartość, taka jak „maj” lub 21500.

  • Drugi argument wskazuje zakres komórek, w których szukana wartość powinna się znajdować.

    Ważne : W przypadku funkcji WYSZUKAJ.PIONOWO kolumna zawierająca szukaną wartość lub szukane odwołanie do komórki musi znajdować się w pierwszej kolumnie od lewej strony w zakresie.

  • Trzeci argument określa kolumnę w zakresie wyszukiwania, która zawiera wartość do wyświetlenia.

Czwarty argument jest opcjonalny, jednak większość osób wprowadza wartość FAŁSZ (lub 0). Dlaczego? W takiej sytuacji funkcja musi wyszukać dokładne dopasowanie. Można nie wprowadzać żadnego argumentu lub wprowadzić wartość PRAWDA, ale jeśli nie zostanie znalezione dokładne dopasowanie, funkcja zwróci najbliższe przybliżone dopasowanie i zwykle większość osób nie chce wyszukiwać przybliżonego dopasowania.

Aby pokazać, dlaczego przybliżone dopasowanie może stanowić poważny problem, załóżmy, że szukasz ceny za części o identyfikatorze 2345768, ale zamieniono dwie liczby i niepoprawnie wpisano w formule następującą wartość: =WYSZUKAJ.PIONOWO(2345678;A1:E7;5). Formuła zwraca cena niewłaściwej części, ponieważ funkcja WYSZUKAJ.PIONOWO znalazła najbliższą liczbę mniejszą lub równą podanej liczbie (2345678). Ten błąd mógł doprowadzić do wystawienia klientowi błędnego rachunku.

Jeśli dla argumentu przybliżonego dopasowania określisz wartość FAŁSZ lub 0 i nie będzie dokładnego dopasowania, formuła zwróci w komórce wartość #N/D zamiast niewłaściwej wartości, co stanowi znacznie mniejszy problem. W tym przypadku wartość #N/D nie oznacza, że błędnie wprowadzono formułę (z wyjątkiem błędnego wpisania numeru). Oznacza ona, że nie znaleziono wartości 2345678, a oczekiwana wartość to 2345768.

W tym przykładzie przedstawiliśmy działanie tej funkcji. Po wprowadzeniu wartości w komórce B2 (pierwszy argument) funkcja WYSZUKAJ.PIONOWO przeszukuje zakres C2:E7 (drugi argument) i zwraca najbliższe przybliżone dopasowanie z trzeciej kolumny w zakresie, czyli kolumny E (trzeci argument).

Typowe zastosowanie funkcji WYSZUKAJ.PIONOWO

W tym przykładzie czwarty argument jest pusty, więc funkcja zwraca przybliżone dopasowanie.

Korzystanie z funkcji WYSZUKAJ.POZIOMO

Gdy nauczysz się korzystać z funkcji WYSZUKAJ.PIONOWO, opanowanie funkcji WYSZUKAJ.POZIOMO nie będzie trudne. Wprowadzasz takie same argumenty, ale wyszukiwanie odbywa się w wierszach, a nie w kolumnach.

Wspólne korzystanie z funkcji INDEKS i PODAJ.POZYCJĘ

Jeśli nie chcesz ograniczać się do wyszukiwania w pierwszej kolumnie od lewej strony, możesz użyć kombinacji funkcji INDEKS i PODAJ.POZYCJĘ. Formuła, która korzysta z tych funkcji razem, jest nieco bardziej złożona niż formuła z funkcją WYSZUKAJ.PIONOWO, ale może oferować więcej możliwości i niektóre osoby zdecydowanie wolą używać kombinacji funkcji INDEKS i PODAJ.POZYCJĘ niż funkcji WYSZUKAJ.PIONOWO.

W tym przykładzie przedstawiono krótką listę, na której szukana wartość (Szczecin) nie znajduje się w pierwszej kolumnie od lewej strony. Dlatego nie można użyć funkcji WYSZUKAJ.PIONOWO. Zamiast niej wyszukamy wartość Szczecin w zakresie B1:B11 przy użyciu funkcji PODAJ.POZYCJĘ. Wartość zostanie znaleziona w wierszu 4. Następnie funkcja INDEKS użyje tej wartości jako argumentu wyszukiwania i znajdzie populację Szczecina w czwartej kolumnie (kolumnie D). Użyta formuła jest wyświetlana w komórce A14.

Wyszukiwanie wartości przy użyciu funkcji INDEKS i PODAJ.WARTOŚĆ

Dodatkowe informacje na temat funkcji wyszukiwania

Początek strony

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×