Wyszukiwanie wartości przy użyciu funkcji WYSZUKAJ.PIONOWO, INDEKS i PODAJ.POZYCJĘ

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Masz listę numerów pokoi w biurze i musisz dowiedzieć się, do których pomieszczeń przypisani są poszczególni pracownicy. Jednak arkusz kalkulacyjny jest ogromny. Jak możesz sobie z tym poradzić? To proste — użyj funkcji wyszukiwania. WYSZUKAJ.PIONOWO i WYSZUKAJ.POZIOMO to dwie najprzydatniejsze z funkcji wyszukiwania, ale równie pomocne są funkcje INDEKS i PODAJ.POZYCJĘ.

Uwaga :  Kreator odnośników używany we wcześniejszych wersjach nie jest dostępny w tej wersji programu Excel.

Oto krótkie przypomnienie, jak używać funkcji WYSZUKAJ.PIONOWO.

=WYSZUKAJ.PIONOWO(B2;C2:E7;3;PRAWDA)

Pierwszy argument — dane potrzebne do działania funkcji — stanowi szukaną wartość. Może to być odwołanie do komórki lub określona wartość, taka jak „maj” lub 21 000. Drugi argument wskazuje zakres komórek, w których szukana wartość powinna się znajdować. W tym przykładzie jest to zakres C2–E7. Trzeci argument określa kolumnę we wskazanym zakresie, która zawiera wartość do wyświetlenia.

Czwarty argument jest opcjonalny i może zawierać wartość Prawda lub Fałsz. Jeśli wprowadzisz wartość PRAWDA lub pozostawisz funkcję bez tego argumentu, w wynikach znajdziesz trafienia przybliżone do wartości wpisanej w pierwszym argumencie. Wprowadzenie wartości FAŁSZ powoduje znalezienie przez funkcję dokładnej wartości pierwszego argumentu. Innymi słowy, pozostawienie funkcji bez czwartego argumentu lub podanie w nim wartości PRAWDA zapewnia większą elastyczność.

W tym przykładzie przedstawiliśmy działanie tej funkcji. Po wprowadzeniu wartości w komórce B2 (pierwszy argument) funkcja WYSZUKAJ.PIONOWO przeszukuje zakres C2–E7 (drugi argument) i zwraca najbliższe przybliżone dopasowanie z trzeciej kolumny w zakresie, czyli kolumny E (trzeci argument).

Typowe zastosowanie funkcji WYSZUKAJ.PIONOWO

Czwarty argument jest pusty, więc funkcja zwraca przybliżone dopasowanie. Wpisanie w tym argumencie wartości FAŁSZ wymaga podania jednej z wartości z kolumn C lub D, aby funkcja w ogóle zwróciła wyniki.

Gdy nauczysz się korzystać z funkcji WYSZUKAJ.PIONOWO, opanowanie funkcji WYSZUKAJ.POZIOMO nie będzie trudne. Wprowadzasz takie same argumenty, ale wyszukiwanie odbywa się w wierszach, a nie w kolumnach.

Spróbuj użyć tej funkcji

Jeżeli chcesz poeksperymentować z funkcjami wyszukiwania zanim użyjesz ich na własnych danych, oto kilka przykładowych danych. Niektórzy lubią używać funkcji WYSZUKAJ.PIONOWO i WYSZUKAJ.POZIOMO, a inni wolą korzystać z połączonych funkcji INDEKS i PODAJ.POZYCJĘ. Wypróbuj każdą metodę i zobacz, która bardziej Ci odpowiada.

Działanie funkcji WYSZUKAJ.PIONOWO

Skopiuj wszystkie komórki w tej tabeli i wklej je w komórce A1 w pustym arkuszu programu Excel.

Wskazówka    Zanim wkleisz dane w programie Excel, ustaw szerokość kolumn od A do C na 250 pikseli i kliknij pozycję Zawijaj tekst (karta Narzędzia główne, grupa Wyrównanie).

Gęstość

Lepkość

Temperatura

0,457

3,55

500

0,525

3,25

400

0,606

2,93

300

0,675

2,75

250

0,746

2,57

200

0,835

2,38

150

0,946

2,17

100

1,09

1,95

50

1,29

1,71

0

Formuła

Opis

Wynik

'=WYSZUKAJ.PIONOWO(1;A2:C10;2)

Wyszukuje wartość 1 w kolumnie A za pomocą dopasowania przybliżonego: znaleziona największa wartość mniejsza niż lub równa 1 w kolumnie A (czyli 0,946) jest używana do określenia wiersza kolumny B, z którego jest zwracana wartość.

=WYSZUKAJ.PIONOWO(1;A2:C10;2)

'=WYSZUKAJ.PIONOWO(1;A2:C10;3;PRAWDA)

Wyszukuje wartość 1 w kolumnie A za pomocą dopasowania przybliżonego: znaleziona największa wartość mniejsza niż lub równa 1 w kolumnie A (czyli 0,946) jest używana do określenia wiersza kolumny C, z którego jest zwracana wartość.

=WYSZUKAJ.PIONOWO(1;A2:C10;3;PRAWDA)

'=WYSZUKAJ.PIONOWO(0,7;A2:C10;3;FAŁSZ)

Wyszukuje wartość 0,7 w kolumnie A za pomocą dopasowania dokładnego: nie istnieje dokładne dopasowanie w kolumnie A, dlatego funkcja zwraca błąd.

=WYSZUKAJ.PIONOWO(0,7;A2:C10;3;FAŁSZ)

'=WYSZUKAJ.PIONOWO(0,1;A2:C10;2;PRAWDA)

Wyszukuje wartość 0,1 w kolumnie A za pomocą dopasowania przybliżonego: wartość 0,1 jest mniejsza niż najmniejsza wartość w kolumnie A, dlatego funkcja zwraca błąd.

=WYSZUKAJ.PIONOWO(0,1;A2:C10;2;PRAWDA)

'=WYSZUKAJ.PIONOWO(2;A2:C10;2;PRAWDA)

Wyszukuje wartość 2 w kolumnie A za pomocą dopasowania przybliżonego: znaleziona w kolumnie A największa wartość mniejsza niż lub równa 2 (czyli 1,29) jest używana do określenia wiersza kolumny B, z którego jest zwracana wartość.

=WYSZUKAJ.PIONOWO(2;A2:C10;2;PRAWDA)

Działanie funkcji WYSZUKAJ.POZIOMO

Skopiuj wszystkie komórki w tej tabeli i wklej je w komórce A1 w pustym arkuszu programu Excel.

Wskazówka    Zanim wkleisz dane w programie Excel, ustaw szerokość kolumn od A do C na 250 pikseli i kliknij pozycję Zawijaj tekst (karta Narzędzia główne, grupa Wyrównanie).

Osie

Łożyska

Śruby

4

4

9

5

7

10

6

8

11

Formuła

Opis

Wynik

'=WYSZUKAJ.POZIOMO("Osie";A1:C4;2;PRAWDA)

Wyszukuje słowo „Osie” w pierwszym wierszu i zwraca wartość z drugiego wiersza, który znajduje się w tej samej kolumnie (kolumnie A).

=WYSZUKAJ.POZIOMO("Osie";A1:C4;2;PRAWDA)

'=WYSZUKAJ.POZIOMO("Łożyska";A1:C4;3;FAŁSZ)

Wyszukuje słowo „Łożyska” w pierwszym wierszu i zwraca wartość z trzeciego wiersza, która znajduje się w tej samej kolumnie (kolumnie B).

=WYSZUKAJ.POZIOMO("Łożyska";A1:C4;3;FAŁSZ)

'=WYSZUKAJ.POZIOMO("Ł";A1:C4;3;PRAWDA)

Wyszukuje „Ł” w pierwszym wierszu i zwraca wartość z trzeciego wiersza, która znajduje się w tej samej kolumnie. Ponieważ nie znaleziono dokładnego dopasowania „Ł”, użyta jest największa wartość w wierszu 1, która jest mniejsza niż „Ł”: „Osie” w kolumnie A.

=WYSZUKAJ.POZIOMO("Ł";A1:C4;3;PRAWDA)

'=WYSZUKAJ.POZIOMO("Sworznie";A1:C4;4)

Wyszukuje słowo „Sworznie” w pierwszym wierszu i zwraca wartość z czwartego wiersza, która znajduje się w tej samej kolumnie (kolumnie C).

=WYSZUKAJ.POZIOMO("Sworznie";A1:C4;4)

'=WYSZUKAJ.POZIOMO(3;{1;2;3\"a";"b";"c"\"d";"e";"f"};2;PRAWDA)

Wyszukuje liczbę 3 w trzywierszowej stałej tablicowej i zwraca wartość z drugiego wiersza w tej samej (w tym przypadku trzeciej) kolumnie. W stałej tablicowej są trzy wiersze wartości oddzielone od siebie ukośnikiem odwrotnym (\). Zwracana jest wartość „c”, ponieważ znajduje się w drugim wierszu i w tej samej kolumnie co liczba 3.

=WYSZUKAJ.POZIOMO(3;{1;2;3\"a";"b";"c"\"d";"e";"f"};2;PRAWDA)

Działanie funkcji INDEKS i PODAJ.POZYCJĘ

W tym przykładzie użyto razem funkcji INDEKS i funkcji PODAJ.POZYCJĘ, aby zwrócić numer najwcześniejszej faktury i odpowiadającą jej datę dla każdego z pięciu miast. Data jest zwracana jako numer, dlatego użyto funkcji TEKST, aby sformatować ją jako datę. Funkcja INDEKS w rzeczywistości używa jako argumentu wyniku funkcji PODAJ.POZYCJĘ. Połączenie funkcji INDEKS i PODAJ.POZYCJĘ jest stosowane dwukrotnie w każdej formule — najpierw, aby zwrócić numer faktury, a następnie, aby zwrócić datę.

Skopiuj wszystkie komórki w tej tabeli i wklej je w komórce A1 w pustym arkuszu programu Excel.

Wskazówka    Zanim wkleisz dane w programie Excel, ustaw szerokość kolumn od A do D na 250 pikseli i kliknij pozycję Zawijaj tekst (karta Narzędzia główne, grupa Wyrównanie).

Faktura

Miasto

Data faktury

Najwcześniejsza faktura wg. miasta, z datą

3115

Warszawa

07.04.12

="Warszawa = "&INDEKS($A$2:$C$33;PODAJ.POZYCJĘ("Warszawa";$B$2:$B$33;0);1)& "; Data faktury: " & TEKST(INDEKS($A$2:$C$33;PODAJ.POZYCJĘ("Warszawa";$B$2:$B$33;0);3);"d/m/yy")

3137

Warszawa

09.04.12

="Poznań = "&INDEKS($A$2:$C$33;PODAJ.POZYCJĘ("Poznań";$B$2:$B$33;0);1)& "; Data faktury: " & TEKST(INDEKS($A$2:$C$33;PODAJ.POZYCJĘ("Poznań";$B$2:$B$33;0);3);"d/m/yy")

3154

Warszawa

11.04.12

="Gdańsk = "&INDEKS($A$2:$C$33;PODAJ.POZYCJĘ("Gdańsk";$B$2:$B$33;0);1)& "; Data faktury: " & TEKST(INDEKS($A$2:$C$33;PODAJ.POZYCJĘ("Gdańsk";$B$2:$B$33;0);3);"d/m/yy")

3191

Warszawa

21.04.12

="Nowy Targ = "&INDEKS($A$2:$C$33;PODAJ.POZYCJĘ("Nowy Targ";$B$2:$B$33;0);1)& "; Data faktury: " & TEKST(INDEKS($A$2:$C$33;PODAJ.POZYCJĘ("Nowy Targ";$B$2:$B$33;0);3);"d/m/yy")

3293

Warszawa

25.04.12

="Rzeszów = "&INDEKS($A$2:$C$33;PODAJ.POZYCJĘ("Rzeszów";$B$2:$B$33;0);1)& "; Data faktury: " & TEKST(INDEKS($A$2:$C$33;PODAJ.POZYCJĘ("Rzeszów";$B$2:$B$33;0);3);"d/m/yy")

3331

Warszawa

27.04.12

3350

Warszawa

28.04.12

3390

Warszawa

01.05.12

3441

Warszawa

02.05.12

3517

Warszawa

08.05.12

3124

Poznań

09.04.12

3155

Poznań

11.04.12

3177

Poznań

19.04.12

3357

Poznań

28.04.12

3492

Poznań

06.05.12

3316

Gdańsk

25.04.12

3346

Gdańsk

28.04.12

3372

Gdańsk

01.05.12

3414

Gdańsk

01.05.12

3451

Gdańsk

02.05.12

3467

Gdańsk

02.05.12

3474

Gdańsk

04.05.12

3490

Gdańsk

05.05.12

3503

Gdańsk

08.05.12

3151

Nowy Targ

09.04.12

3438

Nowy Targ

02.05.12

3471

Nowy Targ

04.05.12

3160

Rzeszów

18.04.12

3328

Rzeszów

26.04.12

3368

Rzeszów

29.04.12

3420

Rzeszów

01.05.12

3501

Rzeszów

06.05.12

Dodatkowe informacje na temat funkcji wyszukiwania

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×