Wymiana (kopiowanie, importowanie, eksportowanie) danych między programami Excel i Access

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Istnieje kilka sposobów wymiany danych między programami Microsoft Office Access i Microsoft Office Excel.

  • Aby przenieść dane z programu Access do programu Excel, można skopiować dane z arkusza danych programu Access i wkleić je do arkusza programu Excel, utworzyć połączenie z bazą danych programu Access w arkuszu programu Excel lub wyeksportować dane programu Access do arkusza programu Excel.

  • Aby przenieść dane z programu Excel do programu Access, można skopiować dane z arkusza programu Excel i wkleić je do arkusza danych programu Access, zaimportować arkusz programu Excel do tabeli programu Access lub utworzyć połączenie z arkuszem programu Excel w tabeli programu Access.

    Uwagi : 

    • Słowo „importowanie” ma różne znaczenie w programie Excel i w programie Access. W programie Excel importowanie oznacza trwałe połączenie z danymi, które można odświeżać, natomiast w programie Access — jednorazowe przeniesienie danych do programu Access bez tworzenia połączenia danych.

    • Skoroszytu programu Excel nie można zapisywać jako bazy danych programu Access. Ani program Excel, ani program Access nie udostępnia funkcji tworzenia bazy danych programu Access z danych programu Excel.

Co chcesz zrobić?

Praca z danymi programu Access w programie Excel

Praca z danymi programu Excel w programie Access

Praca z danymi programu Access w programie Excel

Dane programu Access można przetwarzać w skoroszycie programu Excel, co umożliwia korzystanie z funkcji analizy danych i tworzenia wykresów, elastyczne rozmieszczanie i tworzenie układów danych oraz stosowanie wielu innych funkcji, które są niedostępne w programie Access.

Kopiowanie danych programu Access do programu Excel

Dane można skopiować z widoku arkusza danych w programie Access, a następnie wkleić do arkusza programu Excel.

  1. Uruchom program Access, a następnie otwórz tabelę, kwerendę lub formularz z rekordami, które chcesz skopiować.

  2. Na karcie Narzędzia główne kliknij przycisk Widok, a następnie kliknij polecenie Widok arkusza danych.

  3. Zaznacz rekordy, które chcesz skopiować.

    Aby zaznaczyć określone kolumny, należy przeciągnąć przez przylegające nagłówki kolumn.

  4. Na karcie Narzędzia główne w grupie Schowek kliknij przycisk Kopiuj Obraz przycisku .

    Grupa Schowek na karcie Narzędzia główne

    Skrót klawiaturowy  Można także nacisnąć klawisze CTRL+C.

  5. Uruchom program Excel, a następnie otwórz arkusz, do którego chcesz wkleić dane.

  6. Kliknij w lewym górnym rogu obszaru arkusza, w którym ma się pojawić pierwsza nazwa pola.

    Aby zapobiec zastąpieniu istniejących rekordów podczas wklejania skopiowanych rekordów, należy upewnić się, że po prawej stronie lub poniżej klikniętej komórki w arkuszu nie znajdują się żadne dane.

  7. Na karcie Narzędzia główne w grupie Schowek kliknij przycisk Wklej Obraz przycisku .

    Skrót klawiaturowy  Można też nacisnąć klawisze CTRL+V.

Początek strony

Eksportowanie danych z programu Access do programu Excel

Za pomocą Kreatora eksportu w programie Access można wyeksportować do arkusza programu Excel obiekt bazy danych programu Access, taki jak tabela, kwerenda lub formularz, bądź zaznaczone rekordy w widoku. W trakcie operacji eksportowania można zapisać jej szczegóły do późniejszego użycia, a także zaplanować operację eksportowania tak, aby była wykonywana automatycznie w określonych odstępach czasu.

Poniżej opisano typowe scenariusze eksportowania danych z programu Access do programu Excel:

  • Do przetwarzania danych w dziale lub grupie roboczej, w której pracuje użytkownik, są używane programy Access i Excel. Do przechowywania danych służą bazy danych programu Access, natomiast za pomocą programu Excel użytkownicy analizują dane i rozprowadzają wyniki analiz. Zespół eksportuje dane do programu Excel wtedy, gdy jest to potrzebne, lecz użytkownik chce zwiększyć efektywność tego procesu.

  • Użytkownik od dawna korzysta z programu Access, ale jego menedżer wymaga, aby przygotowywać raporty w programie Excel. Użytkownik kopiuje dane do programu Excel w regularnych odstępach czasu, ale chce zautomatyzować ten proces, aby zaoszczędzić czas.

Aby uzyskać więcej informacji dotyczących eksportowania danych z programu Access do programu Excel, zobacz system Pomocy programu Access.

Początek strony

Tworzenie w programie Excel połączenia z danymi programu Access

Aby wprowadzić odświeżalne dane z programu Access do programu Excel, można utworzyć połączenie z bazą danych programu Access, często przechowywane w pliku połączenia danych pakietu Office (odc), i pobrać wszystkie dane z tabeli lub kwerendy. Główną zaletą tworzenia połączeń z danymi programu Access w porównaniu z importowaniem tych danych jest możliwość okresowego analizowania danych w programie Excel bez konieczności ciągłego kopiowania lub eksportowania danych z programu Access. Po utworzeniu połączenia z danymi skoroszyty programu Excel mogą być automatycznie odświeżane (czyli aktualizowane) na podstawie oryginalnej bazy danych programu Access za każdym razem, gdy baza danych będzie aktualizowana o nowe informacje. Można na przykład aktualizować rozpowszechniany co miesiąc raport programu Excel podsumowujący budżet, tak aby zawierał dane z bieżącego miesiąca.

  1. Kliknij komórkę w miejscu, w którym chcesz umieścić dane z bazy danych programu Access.

  2. Na karcie Dane w grupie Dane zewnętrzne kliknij opcję Z programu Access.

    Grupa Pobieranie danych zewnętrznych na karcie Dane

  3. Na liście Szukaj w zlokalizuj i kliknij dwukrotnie bazę danych, którą chcesz zaimportować.

    W oknie dialogowym Wybieranie tabeli kliknij tabelę lub kwerendę, którą chcesz zaimportować, a następnie kliknij przycisk OK.

  4. W oknie dialogowym Importowanie danych wykonaj następujące czynności:

    • W obszarze Wybierz sposób wyświetlania tych danych wykonaj jedną z następujących czynności:

      • Aby wyświetlić dane w postaci tabela, wybierz opcję Tabela.

      • Aby wyświetlić dane jako raport tabeli przestawnej, wybierz pozycję raport tabeli przestawnej.

      • Aby wyświetlić dane jako raport w formie tabeli przestawnej i wykresu przestawnego, wybierz pozycję raport tabeli przestawnej i wykresu przestawnego.

    • Opcjonalnie kliknij przycisk Właściwości, aby ustawić opcje odświeżania, formatowania i układu dla importowanych danych, a następnie kliknij przycisk OK.

    • W obszarze Gdzie chcesz umieścić dane? wykonaj jedną z następujących czynności:

      • Aby umieścić dane w wybranej lokalizacji, kliknij opcję Istniejący arkusz.

      • Aby umieścić dane w lewym górnym rogu nowego arkusza, kliknij opcję Nowy arkusz.

  5. Kliknij przycisk OK.

    Program Excel umieści zakres danych zewnętrznych w określonej lokalizacji.

Aby uzyskać więcej informacji o nawiązywaniu połączeń z danymi, zobacz Łączenie z danymi zewnętrznymi (importowanie).

Początek strony

Praca z danymi programu Excel w programie Access

Pracując z danymi programu Excel w programie Access, można korzystać z funkcji zarządzania danymi, zabezpieczeń oraz obsługi wielu użytkowników, które są dostępne w programie Access. Dwie spośród wielu użytecznych funkcji programu Access mogą być szczególnie przydatne podczas pracy z danymi programu Excel:

  • Raporty    Jeżeli użytkownik potrafi projektować raporty w programie Access i chce podsumować lub uporządkować dane z programu Excel w postaci raportu tego typu, może utworzyć raport programu Access. Można na przykład tworzyć bardziej elastyczne raporty, takie jak raporty pogrupowane lub podsumowujące, etykiety drukowane i raporty graficzne.

  • Formularze    Jeżeli użytkownik chce użyć formularza, aby znaleźć lub wyświetlić dane w programie Excel, może utworzyć formularz programu Access. Można na przykład utworzyć formularz programu Access, aby wyświetlić pola w kolejności innej niż kolejność kolumn w arkuszu albo wyświetlić długie wiersze danych w bardziej czytelnej postaci na jednym ekranie.

Aby uzyskać więcej informacji o pracy z formularzami i raportami programu Access, zobacz system Pomocy programu Access.

Początek strony

Kopiowanie danych programu Excel do programu Access

Dane można skopiować z widoku arkusza w programie Excel, a następnie wkleić do arkusza danych programu Access.

Uwaga : W przypadku wklejania danych z wielu pól w arkuszu do arkusza danych należy się upewnić, że kolejność kolumn odpowiada kolejności danych, które mają zostać skopiowane. Przy wklejaniu do formularza danych pochodzących z wielu pól program Microsoft Access wkleja dane do pól o takich samych nazwach jak nazwy pól źródłowych, niezależnie od ich kolejności w formularzu. Jeżeli dane do skopiowania zawierają pola, które nie istnieją w formularzu docelowym, w programie Access zostanie wyświetlone pytanie, czy mają zostać wklejone tylko pola z pasującymi nazwami. W przypadku braku pasujących nazw pól program Access wkleja pola zgodnie z kolejnością klawisza Tab w formularzu docelowym, co może nie odpowiadać żądanej kolejności. Jeżeli nazwy pól w obiekcie źródłowym różnią się od nazw pól w obiekcie docelowym, można wkleić dane do arkusza danych zamiast do formularza.

  1. Uruchom program Excel, a następnie otwórz arkusz zawierający dane, które chcesz skopiować.

  2. Zaznacz wiersze, które chcesz skopiować.

  3. Na karcie Narzędzia główne w grupie Schowek kliknij przycisk Kopiuj Obraz przycisku .

    Grupa Schowek na karcie Narzędzia główne

    Skrót klawiaturowy  Można także nacisnąć klawisze CTRL+C.

  4. Uruchom program Access, a następnie otwórz tabelę, kwerendę lub formularz, do którego chcesz wkleić wiersze.

  5. Na karcie Arkusz danych w grupie Widoki kliknij przycisk Widok, a następnie kliknij polecenie Widok arkusza danych.

    Obraz wstążki programu Access

  6. Wykonaj jedną z następujących czynności:

    • Aby zamienić rekordy, zaznacz je, a następnie na karcie Narzędzia główne w grupie Schowek kliknij przycisk Wklej Obraz przycisku .

      Obraz wstążki programu Access

      Skrót klawiaturowy  Można też nacisnąć klawisze CTRL+V.

    • Aby dołączyć dane jako nowe rekordy, na karcie Narzędzia główne w obszarze Schowek kliknij polecenie Dołącz i wklej w menu Edycja.

Początek strony

Importowanie danych z programu Excel do programu Access

Dane programu Excel można zaimportować w celu przechowania w bazie danych programu Access, co umożliwi korzystanie z danych i ich konserwację. Program Access przechowuje zaimportowane dane w nowej lub istniejącej tabeli, natomiast dane w programie Excel nie zmieniają się. Operacja importowania może dotyczyć tylko pojedynczych arkuszy. Aby zaimportować dane z wielu arkuszy, należy powtórzyć operację importowania dla każdego arkusza.

Poniżej opisano typowe scenariusze importowania danych z programu Excel do programu Access:

  • Od dawna używasz programu Excel, ale idąc dalej, chcesz używać programu Access, aby pracować z tymi danymi. Chcesz przenieść dane z arkusza programu Excel do jednej lub wielu nowych baz danych programu Access.

  • W dziale lub grupie jest używany program Access, ale czasem dane są dostarczane w formacie programu Excel i trzeba je połączyć z bazami danych programu Access. Chcesz zaimportować te arkusze programu Excel do bazy danych.

  • Użytkownik zarządza swoimi danymi za pomocą programu Access, ale co tydzień otrzymuje od pozostałych członków zespołu raporty w postaci skoroszytów programu Excel. Trzeba usprawnić proces importowania, aby zagwarantować, że dane będą co tydzień o określonej porze importowane do bazy danych.

Aby uzyskać więcej informacji o importowaniu danych z programu Excel do programu Access, zobacz system Pomocy programu Access.

Początek strony

Tworzenie w programie Access połączenie z danymi programu Excel

Zakres danych programu Excel można połączyć z bazą danych programu Access w postaci tabeli. Tej metody należy użyć, jeżeli zakres danych będzie nadal używany w programie Excel, a jednocześnie powinien być dostępny z poziomu programu Access. Połączenie tego typu można utworzyć z poziomu bazy danych programu Access, lecz nie z poziomu programu Excel.

Podczas tworzenia połączenia z arkuszem lub nazwanym zakresem programu Excel program Access tworzy nową tabelę połączoną z komórkami źródłowymi. Wszystkie zmiany w komórkach źródłowych w programie Excel są odzwierciedlane w połączonej tabeli. Nie można jednak edytować zawartości odpowiedniej tabeli w programie Access. Aby dodać, edytować lub usunąć dane, należy wprowadzić zmiany w pliku źródłowym.

Poniżej opisano typowe scenariusze tworzenia w programie Access połączenia z arkuszem programu Excel:

  • Chcesz w dalszym ciągu przechowywać swoje dane w arkuszach programu Excel, jednak chcesz mieć również dostęp do wydajnych funkcji wykonywania kwerend i raportowania programu Access.

  • W dziale lub grupie jest używany program Access, jednak dane z zewnętrznych źródeł mają postać arkuszy programu Excel. Nie chcesz przechowywać kopii danych zewnętrznych, ale chcesz pracować z programem Access.

Aby uzyskać więcej informacji o tworzeniu w programie Access połączenia z danymi programu Excel, zobacz system Pomocy programu Access.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×