Wykrywanie błędów w formułach

Formuły mogą czasem zwracać wartości błędów oraz dawać niezamierzone wyniki. Poniżej przedstawiono kilka narzędzi, które umożliwiają ustalanie i badanie przyczyn tych błędów oraz opracowywanie rozwiązań.

Uwaga: W tym temacie omówiono techniki, które ułatwiają poprawianie błędów w formułach. Nie jest to pełna lista metod korygowania wszystkich możliwych błędów w formułach. Aby uzyskać pomoc dotyczącą określonych błędów, możesz wyszukać pytania podobne do Twoich na forum społeczności programu Excel lub opublikować własne.

Link do forum społeczności programu Excel

Dowiedz się, jak wprowadzić prostą formułę

Formuły są równaniami służącymi do wykonywania obliczeń na wartościach wprowadzonych w arkuszu. Formuła musi zaczynać się od znaku równości (=). Na przykład następująca formuła powoduje dodanie 1 do 3.

=3+1

Formuła może także zawierać dowolne lub wszystkie z następujących składników: funkcje, odwołania, operatory i stałe.

Składniki formuły

Składniki formuły

  1. Funkcje: funkcje dostępne z programem Excel są formułami opracowanymi do wykonywania określonych obliczeń. Na przykład funkcja PI() zwraca wartość liczby pi: 3,142...

  2. Odwołania: odnoszą się do pojedynczych komórek lub zakresów komórek. A2 zwraca wartość w komórce A2.

  3. Stałe: wartości liczbowe lub tekstowe wprowadzane bezpośrednio w formule, takie jak liczba 2.

  4. Operatory: Operator ^ (daszek) podnosi liczbę do potęgi, a operator * (gwiazdka) mnoży liczby. Użyj operatorów + i –, aby dodawać i odejmować wartości, oraz operatora /, aby je dzielić.

    Uwaga: Niektóre funkcje wymagają podania danych nazywanych argumentami. Argumenty są wartościami, które są używane do obliczeń przez niektóre funkcje. Gdy jest to wymagane, argumenty umieszcza się między nawiasami funkcji (). Funkcja PI nie wymaga żadnych argumentów, dlatego nawias jest pusty. Niektóre funkcje wymagają jednego lub większej liczby argumentów i mogą umożliwiać wprowadzenie dodatkowych argumentów. W celu rozdzielenia argumentów należy użyć przecinka lub średnika (;) w zależności od ustawień lokalizacji.

Na przykład funkcja SUMA wymaga tylko jednego argumentu, ale obsługuje łącznie 255 argumentów.

Funkcja SUMA

Przykład z jednym argumentem: =SUMA(A1:A10)

Przykład z wieloma argumentami: =SUMA(A1:A10; C1:C10)

W poniższej tabeli opisano niektóre z najbardziej typowych błędów popełnianych przez użytkownika podczas wprowadzania formuł i wyjaśniono, jak je poprawić.

Upewnij się, że

Więcej informacji

Każda funkcja rozpoczyna się znakiem równości (=)

Jeśli znak równości zostanie pominięty, informacje wpisane przez użytkownika mogą być wyświetlane jako tekst lub data. Jeśli na przykład wpiszesz SUMA(A1:A10), program Excel wyświetli ciąg tekstowy SUMA (A1:A10) i nie wykona obliczeń. Jeśli wpiszesz 11/2, program Excel wyświetli datę 2-lis (zakładając, że format komórek to Ogólne), zamiast podzielić 11 przez 2.

Liczba wszystkich nawiasów otwierających i zamykających jest zgodna

Należy się upewnić, że każdy nawias ma nawias do pary (otwierający lub zamykający). Podczas używania funkcji w formule należy pamiętać, że każdy nawias powinien być w odpowiednim miejscu — w przeciwnym razie funkcja nie będzie działać poprawnie. Przykładowa formuła =JEŻELI(B5<0);"Nieprawidłowe";B5*1,05) nie będzie działać, ponieważ ma dwa nawiasy zamykające i tylko jeden otwierający (powinien być tylko jeden nawias otwierający i jeden nawias zamykający). Poprawna formuła ma następującą postać: =JEŻELI(B5<0;"Nieprawidłowe";B5*1,05).

Do oznaczenia zakresu użyto dwukropka

Przy odwoływaniu się do zakresu komórek należy oddzielić odwołanie do pierwszej komórki w zakresie od odwołania do ostatniej komórki w zakresie przy użyciu dwukropka (:). Na przykład =SUMA(A1:A5), a nie =SUMA(A1 A5), co zwraca błąd #ZERO!.

Wprowadzono wszystkie wymagane argumenty

Niektóre funkcje mają wymagane argumenty. Ponadto należy się upewnić, że nie wprowadzono zbyt wielu argumentów.

Wprowadzono argumenty poprawnych typów

Niektóre funkcje, na przykład SUMA, wymagają argumentów liczbowych. Inne funkcje, na przykład ZASTĄP, wymagają wartości tekstowej w co najmniej jednym ze swoich argumentów. W przypadku użycia nieprawidłowego typu danych jako argumentu program Excel może zwrócić nieoczekiwane wyniki lub wyświetlić błąd.

Liczba zagnieżdżonych funkcji nie przekracza 64

Można wprowadzić lub zagnieździć maksymalnie 64 poziomy funkcji w funkcji.

Nazwy innych arkuszy są ujęte w pojedynczy cudzysłów

Jeśli formuła odnosi się do wartości lub komórek w innych arkuszach albo skoroszytach, a nazwa innego skoroszytu lub arkusza zawiera spację lub znak inny niż litera, należy ująć tę nazwę w pojedynczy cudzysłów, na przykład =Dane kwartalne’!D3, lub =‘123’!A1.

W przypadku odniesienia do arkusza w formule po jego nazwie znajduje się wykrzyknik (!)

Aby na przykład zwrócić wartość komórki D3 z arkusza Dane kwartalne w tym samym skoroszycie, należy użyć formuły ='Dane kwartalne'!D3.

Dołączono ścieżkę dostępu do skoroszytów zewnętrznych

Należy się upewnić, że każde odwołanie zewnętrzne zawiera nazwę skoroszytu i ścieżkę do niego.

Odwołanie do skoroszytu zawiera jego nazwę i musi być ujęte w nawiasy kwadratowe (Nazwaskoroszytu.xlsx). Odwołanie musi również zawierać nazwę arkusza w tym skoroszycie.

Odwołanie do skoroszytu można dołączyć do formuły nawet wtedy, gdy skoroszyt nie jest otwarty w programie Excel. Należy w tym celu podać pełną ścieżkę do pliku, na przykład =ILE.WIERSZY('C:\Moje dokumenty\[Działania w drugim kwartale.xlsx]Sprzedaż'!A1:A8). Ta formuła zwraca liczbę wierszy w zakresie obejmującym komórki od A1 do A8 w innym skoroszycie (8).

Uwaga: Jeśli pełna ścieżka zawiera znaki spacji (jak w powyższym przykładzie), należy ją ująć w pojedynczy cudzysłów (ten znak należy wstawić na początku ścieżki i po nazwie skoroszytu, przed wykrzyknikiem).

Wprowadzono liczby bez formatowania

Nie wolno formatować liczb wprowadzanych w formułach. Jeśli na przykład chcesz wprowadzić wartość $1.000 (z kropką jako separatorem tysięcy), wprowadź 1000 w formule. Jeśli wprowadzisz kropkę jako część numeru, program Excel będzie ją traktować jako znak kropki. Jeśli chcesz wyświetlać numery z separatorami tysięcy lub milionów albo symbolami walut, sformatuj komórki po wprowadzeniu liczb.

Jeśli na przykład chcesz dodać liczbę 3100 do wartości komórki A3 i wprowadzisz formułę =SUMA(3;100;A3), program Excel doda liczby 3 i 100, a następnie doda tę sumę do wartości z komórki A3, zamiast dodać liczbę 3100 do zawartości komórki A3, co wyraża formuła =SUMA(3100;A3). Jeśli wprowadzisz formułę =MODUŁ.LICZBY(-2;134), program Excel wyświetli błąd, ponieważ funkcja MODUŁ.LICZBY obsługuje tylko jeden argument: =MODUŁ.LICZBY(-2134).

Można zastosować pewne reguły umożliwiające sprawdzanie błędów w formułach. Te reguły nie gwarantują, że arkusz będzie wolny od błędów, ale są przydatne w odnajdywaniu typowych błędów. Każdą z tych reguł można osobno włączać i wyłączać.

Błędy mogą być oznaczane i poprawiane na dwa sposoby: po kolei (podobnie jak w przypadku modułu sprawdzania pisowni) lub natychmiast po ich wystąpieniu w arkuszu podczas wprowadzania danych.

Błąd można naprawić przy użyciu opcji wyświetlanych przez program Excel lub zignorować kliknięciem pozycji Ignoruj błąd. Jeśli zignorujesz błąd w określonej komórce, błąd w tej komórce nie będzie wyświetlany podczas następnego sprawdzania błędów. Możesz jednak zresetować wszystkie uprzednio zignorowane błędy, aby były ponownie wyświetlane.

  1. Kliknij pozycję Plik > Opcje > Formuły.

    W programie Excel 2007 kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office > Opcje programu Excel > Formuły.

  2. W obszarze Sprawdzanie błędów zaznacz pole wyboru Włącz sprawdzanie błędów w tle. W przypadku znalezienia błędu w lewym górnym rogu komórki jest wyświetlany trójkąt.

    Komórka z błędną formułą
  3. Aby zmienić kolor trójkąta oznaczającego wykrycie błędu, wybierz odpowiedni kolor w polu Wskaż błędy przy użyciu koloru.

  4. W obszarze Reguły sprawdzania błędów zaznacz lub wyczyść pola wyboru dowolnych z następujących reguł:

    • Komórki zawierają formuły, które powodują błąd: W formule użyto nieoczekiwanej składni, argumentów lub typów danych. Wartościami błędów mogą być #DZIEL/0!, #N/D!, #NAZWA?, #ZERO!, #LICZBA!, #ADR! i #ARG!. Każda wartość błędu ma inną przyczynę i jest naprawiana w odmienny sposób.

      Uwaga: Jeśli wartość błędu zostanie wprowadzona bezpośrednio w komórce, zostanie zapisana jako wartość błędu, ale nie będzie oznaczona jako błąd. Jeśli jednak do danej komórki odwołuje się formuła w innej komórce, formuła ta zwraca wartość błędu z tej komórki.

    • Niespójna formuła kolumny obliczeniowej w tabelach: Kolumna obliczeniowa może zawierać pojedyncze formuły, które są inne niż formuła głównej kolumny, co powoduje wystąpienie wyjątku. Wyjątki kolumny obliczeniowej są tworzone w następujących sytuacjach:

      • Wpisanie danych innych niż formuła w komórce kolumny obliczeniowej.

      • Wpisanie formuły w komórce kolumny obliczeniowej, a następnie naciśnięcie klawiszy Ctrl+Z lub kliknięcie przycisku Cofnij Przycisk Cofnij na pasku narzędzi Szybki dostęp.

      • Wpisanie nowej formuły w kolumnie obliczeniowej, która już zawiera co najmniej jeden wyjątek.

      • Skopiowanie do kolumny obliczeniowej danych niezgodnych z formułą kolumny obliczeniowej. Jeśli kopiowane dane zawierają formułę, formuła ta zastępuje dane w kolumnie obliczeniowej.

      • Przeniesienie lub usunięcie w innym arkuszu komórki, do której odwołuje się wiersz kolumny obliczeniowej.

    • Komórki zawierające lata przedstawione w postaci dwucyfrowej: Komórka zawiera datę tekstową, która może zostać niepoprawnie zinterpretowana jako błędny wiek, jeśli zostanie użyta w formułach. Na przykład data w formule =ROK("1/1/31") może dotyczyć roku 1931 lub 2031. Tę regułę należy stosować do sprawdzania niejednoznacznych dat tekstowych.

    • Liczby formatowane jako tekst lub poprzedzane apostrofem: Komórka zawiera liczby przechowywane jako tekst. Dzieje się tak zazwyczaj, gdy dane są importowane z innych źródeł. Liczby przechowywane jako tekst mogą powodować nieoczekiwane wyniki sortowania, więc najlepszym rozwiązaniem jest przekonwertowanie ich na liczby. Formuła ‘=SUMA(A1:A10) jest widoczna jako tekst.

    • Formuły niespójne z innymi formułami w regionie: Formuła nie odpowiada wzorcowi innych formuł znajdujących się w pobliżu. W wielu przypadkach formuły, które sąsiadują z innymi formułami, różnią się od nich tylko użytym odwołaniem. W następującym przykładzie czterech sąsiadujących formuł w programie Excel jest wyświetlany błąd obok formuły =SUMA(A10:C10) w komórce D4, ponieważ w sąsiednich formułach występuje przyrost o jeden wiersz, a w tej formule występuje przyrost o 8 wierszy — program Excel oczekuje formuły =SUMA(A4:C4).

      Program Excel wyświetla błąd, jeśli formuła nie pasuje do wzorca sąsiednich formuł

      Jeśli odwołania użyte w formule są niespójne z odwołaniami znajdującymi się w sąsiadujących formułach, program Excel wyświetli błąd.

    • Formuła, która nie uwzględnia komórek w regionie: Formuła może nie dołączać automatycznie odwołań do danych wstawionych między oryginalny zakres danych a komórkę zawierającą formułę. Ta reguła porównuje odwołanie w formule z rzeczywistym zakresem komórek sąsiadujących z komórką zawierającą formułę. Jeśli komórki sąsiadujące zawierają dodatkowe wartości i nie są puste, program Excel wyświetli obok formuły błąd.

      Na przykład program Excel wstawia błąd obok formuły =SUMA(D2:D4), gdy ta reguła jest włączona, ponieważ komórki D5, D6 i D7 sąsiadują z komórkami, do których odwołuje się formuła, oraz z komórką zawierająca formułę (D8) i te komórki zawierają dane, do których powinna odwoływać się formuła.

      Program Excel wyświetla błąd, gdy formuła pomija komórki z zakresu
    • Odblokowane komórki zawierające formuły: Formuła nie jest blokowana w celu ochrony. Domyślnie wszystkie komórki w arkuszu są zablokowane, aby uniemożliwić ich zmianę, gdy arkusz jest chroniony. Może to ułatwić uniknięcie pomyłek, takich jak przypadkowe usunięcie lub zmiana formuł. Ten błąd wskazuje, że komórka została ustawiona jako do odblokowania, ale arkusz nie jest chroniony. Sprawdź, czy komórka ma być zablokowana, czy nie.

    • Formuły odwołujące się do pustych komórek: Formuła zawiera odwołanie do pustej komórki. Jak pokazano w następującym przykładzie, może to spowodować niezamierzone wyniki.

      Załóżmy, że należy obliczyć średnią liczb w następującej kolumnie komórek. Jeśli trzecia komórka jest pusta, nie jest uwzględniana w obliczeniach, a wynik jest równy 22,75. Jeśli trzecia komórka zawiera 0, wynik wynosi 18,2.

      Program Excel wyświetla błąd, gdy formuła odwołuje się do pustych komórek
    • Dane wprowadzone w tabeli są nieprawidłowe: W tabeli jest błąd sprawdzania poprawności. Sprawdź ustawienia sprawdzania poprawności, przechodząc do karty Dane > grupa Narzędzia danych > Sprawdzanie poprawności danych.

  1. Wybierz arkusz, który ma zostać sprawdzony pod kątem błędów.

  2. Jeśli obliczenia w arkuszu były wykonywane ręcznie, naciśnij klawisz F9, aby wykonać obliczenia ponownie.

    Jeśli okno dialogowe Sprawdzanie błędów nie jest wyświetlane, kliknij kartę Formuły > Inspekcja formuł > przycisk Sprawdzanie błędów.

  3. Jeśli poprzednio zignorowano jakiekolwiek błędy, można je sprawdzić ponownie, wykonując następujące czynności: kliknij pozycję Plik > Opcje > Formuły.

    W sekcji Sprawdzanie błędów kliknij pozycję Resetuj zignorowane błędy > OK.

    Sprawdzanie błędów

    Uwaga: Zresetowanie zignorowanych błędów powoduje zresetowanie wszystkich błędów we wszystkich arkuszach w aktywnym skoroszycie.

    Porada: Warto przenieść okno dialogowe Sprawdzanie błędów tuż poniżej paska formuły.

    Przenoszenie okna dialogowego Sprawdzanie błędów poniżej paska formuły
  4. Kliknij jeden z przycisków akcji po prawej stronie okna dialogowego. Dostępne akcje różnią się w zależności od typu błędu.

  5. Kliknij przycisk Dalej.

Uwaga: Jeśli klikniesz opcję Ignoruj błąd, błąd będzie pomijany przy każdym kolejnym sprawdzaniu.

  1. Kliknij przycisk Sprawdzanie błędów Ikona Sprawdzanie błędów , który pojawia się obok komórki, a następnie kliknij odpowiednią opcję. Dostępne polecenia różnią się w zależności od typu błędu, a pierwszy wpis jest opisem błędu.

    Jeśli klikniesz opcję Ignoruj błąd, błąd będzie pomijany przy każdym kolejnym sprawdzaniu.

    Przenoszenie okna dialogowego Sprawdzanie błędów poniżej paska formuły

Jeśli formuła nie może poprawnie obliczyć wyniku, program Excel wyświetla wartość błędu, taką jak #####, #DZIEL/0!, #N/D!, #NAZWA?, #ZERO!, #LICZBA!, #ADR! lub #ARG!. Każdy typ błędu ma inną przyczynę i odmienne rozwiązania.

Poniższa tabela zawiera linki do artykułów zawierających szczegółowe opisy tych błędów oraz krótki opis ułatwiający rozpoczęcie pracy.

Temat

Opis

Naprawianie błędu ####

Program Excel wyświetla ten błąd, gdy kolumna nie jest wystarczająco szeroka, aby wyświetlić wszystkie znaki zawarte w komórce lub komórka zawiera ujemne wartości dat lub godzin.

Na przykład formuła odejmująca datę w przyszłości od daty w przeszłości, taka jak =2008-06-15-2008-07-01, daje w wyniku wartość ujemną daty.

Porada: Spróbuj automatycznie dopasować komórkę, klikając dwukrotnie między nagłówkami kolumn. Jeśli wyświetlany jest błąd ###, ponieważ w programie Excel nie można wyświetlić wszystkich znaków, zostanie rozwiązany.

Błąd #

Naprawianie błędu #DZIEL/0!

Program Excel wyświetla ten błąd, gdy liczba jest dzielona przez zero (0) lub przez komórkę, która nie zawiera wartości.

Porada: Dodawanie funkcji obsługi błędów, takiej jak w poniższym przykładzie, czyli =JEŻELI(C2;B2/C2;0)

Za pomocą funkcji obsługi błędów, takiej jak JEŻELI, można uwzględnić błędy

Naprawianie błędu #N/D!

Program Excel wyświetla ten błąd, gdy wartość dla funkcji lub formuły jest niedostępna.

Jeśli korzystasz z funkcji, takiej jak WYSZUKAJ.PIONOWO, czy dla wyszukiwanej zawartości istnieją zgodne elementy w zakresie wyszukiwania? Zwykle nie istnieją.

Spróbuj użyć funkcji JEŻELI.BŁĄD, aby pomijać błędy #N/D. W tym przypadku można użyć następującej formuły:

=JEŻELI.BŁĄD(WYSZUKAJ.PIONOWO(D2;$D$6:$E$8;2;PRAWDA);0)

Błąd #N/D!

Naprawianie błędu #NAZWA?

Ten błąd jest wyświetlany, gdy program Excel nie rozpoznaje tekstu w formule. Na przykład nazwa zakresu lub funkcji może być wpisana z błędem.

Uwaga: Jeśli korzystasz z funkcji, upewnij się, że nazwa funkcji jest wprowadzona prawidłowo. W tym przypadku nazwa funkcji SUMA jest wpisana z błędem. Usuń literę „e”, a program Excel naprawi błąd.

Program Excel wyświetla błąd #NAZWA?, gdy nazwa funkcji zawiera literówkę

Naprawianie błędu #ZERO!

Program Excel wyświetla ten błąd w przypadku określenia przecięcia dwóch obszarów, które się nie przecinają (nie krzyżują). Operator przecięcia jest znakiem spacji oddzielającym odwołania w formule.

Uwaga: Upewnij się, że zakresy są poprawnie rozdzielone — obszary C2:C3 i E4:E6 nie przecinają się, dlatego po wprowadzeniu formuły =SUMA(C2:C3 E4:E6) jest zwracany błąd #ZERO!. Aby go naprawić, wstaw średnik między zakresami C i E w następujący sposób: =SUMA(C2:C3;E4:E6)

Błąd #ZERO!

Naprawianie błędu #LICZBA!

Program Excel wyświetla ten błąd, gdy formuła lub funkcja zawiera nieprawidłowe wartości liczbowe.

Czy korzystasz z funkcji wykonującej iteracje, na przykład IRR lub RATE? Jeśli tak, błąd #LICZBA! występuje prawdopodobnie dlatego, że funkcja nie może znaleźć wyniku. Informacje na temat procedury rozwiązywania problemu zawiera temat pomocy.

Naprawianie błędu #ADR!

Program Excel wyświetla ten błąd, gdy odwołanie do komórki jest nieprawidłowe. Na przykład przypadkowo mogły zostać usunięte komórki, do których odwoływały się inne formuły, lub mogły zostać wklejone komórki w miejsce komórek, do których odwoływały się inne formuły.

Czy przypadkowo usunięto wiersz lub kolumnę? Usunęliśmy kolumnę B w tej formule, =SUMA(A2;B2;C2), i zobacz, co się stało.

Naciśnij przycisk Cofnij (Ctrl+Z), aby anulować usunięcie, odbuduj formułę, lub użyj odwołania do ciągłego zakresu, w następujący sposób: =SUMA(A2:C2), co spowodowałoby automatyczną aktualizację po usunięciu kolumny B.

Program Excel wyświetla błąd #ADR!, gdy odwołanie do komórki jest nieprawidłowe

Naprawianie błędu #ARG!

Program Excel może wyświetlać ten błąd, jeśli w formule uwzględniono komórki, które zawierają różne typy danych.

Czy używasz operatorów matematycznych (+, -, *, /, ^) z innymi typami danych? Jeśli tak, spróbuj użyć funkcji. W tym przypadku formuła =SUMA(F2:F5) rozwiązałaby problem.

Błąd #ARG!

Gdy komórki nie są widoczne w arkuszu, możesz obserwować je oraz ich formuły na pasku narzędzi Okno czujki. Okno czujki ułatwia przeprowadzanie inspekcji bądź audytu albo potwierdzanie obliczeń formuły i wyników w dużych arkuszach. W przypadku korzystania z okna czujki nie jest konieczne wielokrotne przewijanie arkusza ani przechodzenie do jego różnych części.

Okno czujki umożliwia łatwe monitorowanie formuł użytych w arkuszu

Ten pasek narzędzi może być przenoszony lub dokowany jak każdy inny pasek narzędzi. Na przykład można go zadokować u dołu okna. Pasek narzędzi zawiera informacje o następujących właściwościach komórki: 1) skoroszyt, 2) arkusz, 3) nazwa (jeśli komórka ma odpowiadający nazwany zakres), 4) adres komórki, 5) wartość i 6) formuła.

Uwaga: Można mieć tylko jedną czujkę na komórkę.

Dodawanie komórek do okna czujki

  1. Zaznacz komórki, które chcesz obserwować.

    Aby zaznaczyć wszystkie komórki z formułami w arkuszu, na karcie Narzędzia główne w grupie Edytowanie kliknij przycisk Znajdź i zaznacz (lub naciśnij klawisze Ctrl+G lub Control+G na komputerze Mac) > Przechodzenie do — specjalnie > Formuły.

    Okno dialogowe Przechodzenie do — specjalnie
  2. Na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Okno czujki.

  3. Kliknij przycisk Dodaj czujkę.

    Kliknij pozycję Dodaj czujkę, aby dodać czujkę w arkuszu kalkulacyjnym
  4. Upewnij się, że zaznaczono wszystkie komórki, które chcesz obserwować, a następnie kliknij pozycję Dodaj.

    W oknie Dodawanie czujki wprowadź zakres komórek, które mają być obserwowane
  5. Aby zmienić szerokość kolumny w oknie czujki, przeciągnij obramowanie z prawej strony nagłówka kolumny.

  6. Aby wyświetlić komórkę, której dotyczy wpis w oknie czujki, kliknij dwukrotnie wybrany wpis.

    Uwaga: Formuły z odwołaniami zewnętrznymi do innych skoroszytów są wyświetlane na pasku narzędzi Okno czujki tylko wtedy, gdy te skoroszyty są otwarte.

Usuwanie komórek z okna czujki

  1. Jeśli pasek narzędzi Okno czujki nie jest wyświetlany, na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Okno czujki.

  2. Zaznacz komórki, które chcesz usunąć.

    Aby zaznaczyć wiele komórek, naciśnij klawisz CTRL, a następnie kliknij te komórki.

  3. Kliknij przycisk Usuń czujkę.

    Usuwanie czujki

Czasami trudno jest zrozumieć, jak formuła zagnieżdżona oblicza ostateczny wynik, ponieważ istnieje kilka obliczeń pośrednich i testów logicznych. Jednak za pomocą okna dialogowego Szacowanie formuły można wyświetlić różne części formuły zagnieżdżonej, szacowane w kolejności zgodnej z obliczaniem formuły. Na przykład formuła =JEŻELI(ŚREDNIA(D2:D5)>50;SUMA(E2:E5);0) jest łatwiejsza do zrozumienia, gdy zostaną wyświetlone następujące wyniki pośrednie:

Szacowanie formuły pozwala zobaczyć, jak są szacowane różne części formuły zagnieżdżonej

W oknie dialogowym Szacowanie formuły

Opis

=JEŻELI(ŚREDNIA(D2:D5) > 50;SUMA(E2:E5);0)

Początkowo jest wyświetlana formuła zagnieżdżona. Funkcje ŚREDNIA i SUMA są zagnieżdżone w funkcji JEŻELI.

Zakres komórek D2:D5 zawiera wartości 55, 35, 45 i 25, dlatego wynikiem funkcji ŚREDNIA(D2:D5) jest 40.

= JEŻELI(40>50;SUMA(E2:E5);0)

Zakres komórek D2:D5 zawiera wartości 55, 35, 45 i 25, dlatego wynikiem funkcji ŚREDNIA(D2:D5) jest 40.

=JEŻELI(FAŁSZ;SUMA(E2:E5);0)

Ponieważ 40 nie jest większe niż 50, wyrażenie w pierwszym argumencie funkcji JEŻELI (test_logiczny) ma wartość Fałsz.

Funkcja JEŻELI zwraca wartość trzeciego argumentu (wartość_jeżeli_fałsz). Funkcja SUMA nie jest szacowana, ponieważ jest drugim argumentem funkcji JEŻELI (wartość_jeżeli_prawda) i jest zwracana tylko wtedy, gdy wyrażenie ma wartość Prawda.

  1. Zaznacz komórkę, którą chcesz oszacować. Nie można szacować kilku komórek równocześnie.

  2. Wybierz kartę Formuły > Inspekcja formuł > Szacuj formułę.

  3. Kliknij przycisk Szacuj, aby zbadać wartość podkreślonego odwołania. Wynik szacowania zostanie wyświetlony kursywą.

    Jeśli podkreślona część formuły stanowi odwołanie do innej formuły, kliknij przycisk Wkrocz, aby wyświetlić drugą formułę w polu Oszacowanie. Kliknij przycisk Wyjdź, aby powrócić do poprzedniej komórki i formuły.

    Przycisk Wkrocz jest niedostępny dla odwołania w przypadku drugiego wystąpienia tego odwołania w formule lub gdy formuła odwołuje się do komórki w innym skoroszycie.

  4. Klikaj przycisk Szacuj, aż każda z części formuły zostanie oszacowana.

  5. Aby ponownie wyświetlić oszacowanie, kliknij przycisk Wznów.

  6. Aby zakończyć oszacowanie, kliknij przycisk Zamknij.

Uwagi: 

  • Niektóre części formuł używające funkcji JEŻELI i WYBIERZ nie są szacowane — w takich przypadkach w polu Oszacowanie jest wyświetlany błąd #N/D!.

  • Jeśli odwołanie jest puste, w polu Oszacowanie jest wyświetlana wartość zero (0).

  • Następujące funkcje są obliczane ponownie przy każdej zmianie arkusza i mogą spowodować, że wyniki wyświetlane w oknie dialogowym Szacowanie formuły będą inne niż wyniki widoczne w komórce: LOS, OBSZARY, INDEKS, PRZESUNIĘCIE, KOMÓRKA, ADR.POŚR, WIERSZ, KOLUMNA, TERAZ, DZISIAJ, LOS.ZAKR.

Masz pytanie dotyczące konkretnej kwestii?

Zadaj pytanie na forum społeczności programu Excel

Pomoc w ulepszaniu programu Excel

Masz sugestie dotyczące możliwości ulepszenia następnej wersji programu Excel? Jeśli tak, zapoznaj się z tematami w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Wyświetlanie relacji między formułami a komórkami

Klip wideo: naprawianie niepoprawnych formuł (Excel 2010)

Jak unikać niepoprawnych formuł

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×