Wyświetlanie zaufania przez dodanie podpisu cyfrowego

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Możesz pokazać, że uważasz, że baza danych jest bezpieczna i że jej zawartość może być zaufana, dodając podpis cyfrowy do bazy danych. Dzięki temu osoby korzystające z bazy danych zdecydują, czy ufasz tej osobie i jej treści.

Proces służący do cyfrowego podpisywania bazy danych zależy od tego, czy w bazie danych jest używany nowszy format pliku, na przykład plik ACCDB, czy starszy format, na przykład plik mdb. Jednak oba procesy wymagają użycia certyfikatu zabezpieczeń.

Możesz użyć komercyjnego certyfikatu bezpieczeństwa lub utworzyć własny. W tym temacie wyjaśniono, jak utworzyć własny certyfikat zabezpieczeń.

W tym artykule

Przed rozpoczęciem

Pakowanie, podpisywanie i rozpowszechnianie bazy danych programu Access

Cyfrowe podpisywanie wcześniejszej wersji bazy danych

Przed rozpoczęciem

Aby dodać podpis cyfrowy, musisz najpierw uzyskać lub utworzyć certyfikat zabezpieczeń. Certyfikat zabezpieczeń jest to pióro, którego używasz do cyfrowego podpisywania lub prezentowania, który może być stosowany tylko do tych celów.

Jeśli nie masz certyfikatu zabezpieczeń, możesz utworzyć go za pomocą narzędzia SelfCert (dostępnego w pakiecie Microsoft Office).

Tworzenie certyfikatu z podpisem własnym

  1. W systemie Microsoft Windows kliknij przycisk Start , wskaż polecenie Wszystkie programy, wskaż polecenie Microsoft Office, wskaż polecenie Narzędzia pakietu Microsoft Office, a następnie kliknij polecenie certyfikat cyfrowy dla projektów VBA.

    — lub —

    Przejdź do folderu zawierającego pliki programów pakietu Microsoft Office.

    Musisz zlokalizować plik wykonywalny, SelfCert. exe, a lokalizacja może różnić się w zależności od różnych warunków, takich jak w przypadku korzystania z 32-lub 64-bitowej wersji systemu operacyjnego Windows lub w przypadku korzystania z abonamentu pakietu Office 365.

    Jeśli korzystasz z pakietu Office 2019 lub pakietu Office 2016, wypróbuj jedną z następujących lokalizacji:

    • C:\Program Files\Microsoft Office\Office16

    • C:\Program Files (x86) \Microsoft Office\Office16

    Jeśli korzystasz z pakietu Office 365, wypróbuj jedną z następujących lokalizacji:

    • C:\Program Files\Microsoft Office\root\Office16

    • C:\Program Files (x86)\Microsoft Office\root\Office16

    Jeśli korzystasz z pakietu Office 2013, odszukaj folder Office15, korzystając z powyższych opcji. Jeśli korzystasz z pakietu Office 2010, poszukaj folderu Office14. Jeśli korzystasz z pakietu Office 2007, poszukaj folderu Office12.

    Zlokalizuj odpowiedni folder i kliknij dwukrotnie pozycję SelfCert. exe.

    Zostanie wyświetlone okno dialogowe Tworzenie certyfikatu cyfrowego.

  2. W polu Nazwa certyfikatu wpisz nazwę nowego certyfikatu testowego.

  3. Kliknij dwa razy przycisk OK.

Uwaga: Jeśli nie widzisz polecenia Certyfikat cyfrowy dla projektów VBA lub nie możesz znaleźć pliku SelfCert.exe, być może musisz zainstalować program SelfCert.

Instalowanie programu SelfCert.exe

  1. Uruchom instalacyjny dysk CD pakietu Microsoft Office lub inny nośnik instalacyjny.

  2. W oknie Instalatora kliknij pozycję Dodaj lub usuń funkcje, a następnie kliknij przycisk Kontynuuj.

    Uwaga: Jeśli pracujesz w środowisku, w którym pakiet Microsoft Office został zainstalowany na poszczególnych komputerach przez administratorów, a nie za pomocą dysków CD, wykonaj następujące czynności:

    1. W systemie Microsoft Windows kliknij przycisk Start, a następnie kliknij polecenie Panel sterowania.

    2. Kliknij dwukrotnie pozycję Dodaj lub usuń programy.

    3. Wybierz wersję pakietu Microsoft Office, a następnie kliknij przycisk Zmień.

      Zostanie uruchomiony Instalator.

    4. Kliknij pozycję Dodaj lub usuń funkcje, a następnie kliknij przycisk Kontynuuj.

    5. Wykonaj poniższe czynności.

  3. Rozwiń węzły Microsoft Office i Funkcje wspólne pakietu Office, klikając znajdujące się obok nich znaki plus (+).

  4. Kliknij pozycję Certyfikat cyfrowy dla projektów VBA.

  5. Kliknij pozycję Uruchom z mojego komputera.

  6. Kliknij przycisk Kontynuuj, aby zainstalować składnik.

Możesz używać tylko programu SelfCert, aby tworzyć podpisy do użytku w Twojej organizacji. Aby podpisać cyfrowo bazę danych, a następnie podzielić ją na komercyjny urząd certyfikacji, należy uzyskać komercyjny certyfikat bezpieczeństwa.

Pakowanie, podpisywanie i rozpowszechnianie bazy danych Access

Access ułatwia i ułatwia podpisywanie i rozpowszechnianie bazy danych. Utworzony plik accdb lub accde można spakować, opatrzyć podpisem cyfrowym, a następnie rozpowszechnić w celu udostępnienia innym użytkownikom. Narzędzie Spakuj i podpisz umieszcza bazę danych w pliku wdrażania programu Access (accdc), podpisuje plik, a następnie umieszcza podpisany pakiet w wybranej lokalizacji. Użytkownicy mogą następnie wyodrębniać bazę danych z pakietu i pracować bezpośrednio w bazie danych (nie w pliku pakietu).

Podczas dalszej pracy pamiętaj o następujących kwestiach:

  • Przez spakowanie bazy danych i podpisanie pakietu można przekazać informacje o zaufaniu. Gdy spakujesz i podpiszesz bazę danych, Twój podpis cyfrowy potwierdza, że baza danych nie została zmieniona od chwili utworzenia pakietu.

  • Po wyodrębnieniu bazy danych z pakietu nie ma już połączenia między podpisanym pakietem i wyodrębnioną bazą danych.

  • Narzędzia Package i Sign można używać tylko w przypadku baz danych zapisanych w nowszym formacie plików (accdb, ACCDE,...). Access oferuje również narzędzia do podpisywania i rozpowszechniania baz danych o wcześniejszym formacie pliku. Musisz użyć narzędzia podpisu cyfrowego odpowiedniego dla używanego formatu pliku bazy danych.

  • Do pakietu można dodać tylko jedną bazę danych.

  • Proces cyfrowo podpisuje pakiet zawierający całą bazę danych, a nie tylko makra czy moduły.

  • Proces kompresuje plik pakietu, aby skrócić czas pobierania.

  • Możesz wyodrębnić bazy danych z plików pakietu znajdujących się na serwerach z systemem Windows SharePoint Services 3.0 lub nowszym.

W poniższych sekcjach wyjaśniono, jak utworzyć podpisany plik pakietu oraz jak wyodrębnić bazę danych z podpisanego pliku pakietu i jak z niej korzystać.

Tworzenie podpisanego pakietu

  1. Otwórz bazę danych, którą chcesz spakować i podpisać.

  2. Kliknij pozycję plik _GT_ Zapisz jako > Package i Sign

    Zostanie wyświetlone okno dialogowe Wybieranie certyfikatu.

  3. Wybierz certyfikat cyfrowy, a następnie kliknij przycisk OK.

    Zostanie wyświetlone okno dialogowe Utwórz pakiet podpisany przez program Microsoft Access .

  4. Na liście Zapisz w wybierz lokalizację, w której chcesz umieścić podpisany pakiet bazy danych.

  5. W polu Nazwa pliku wprowadź nazwę dla podpisanego pakietu, a następnie kliknij pozycję Utwórz.

    Program Access utworzy plik accdc i umieści go w wybranej lokalizacji.

Wyodrębnianie i używanie podpisanego pakietu

  1. Kliknij pozycję Plik > Otwórz > Przeglądaj. Zostanie wyświetlone okno dialogowe Otwieranie

  2. W polu Typ pliku wybierz pozycję podpisane pakiety programu Microsoft Access (*. accdc) .

  3. Zlokalizuj folder zawierający plik accdc, wybierz plik, a następnie kliknij przycisk Otwórz.

  4. Wykonaj jedną z następujących czynności:

    • Jeśli certyfikat zabezpieczeń, za pomocą którego podpisano pakiet wdrożenia, został uznany za zaufany, zostanie wyświetlone okno dialogowe Wyodrębnianie bazy danych do. Przejdź do następnego kroku.

    • W przeciwnym razie zostanie wyświetlony poniższy komunikat.

      Wskazówka

      Jeśli baza danych jest zaufana, kliknij pozycję Otwórz. Jeśli wszystkie certyfikaty od tego dostawcy są zaufane, kliknij pozycję Zawsze ufaj zawartości od tego wydawcy. Zostanie wyświetlone okno dialogowe Wyodrębnianie bazy danych do.

      Uwaga: Jeśli podpiszesz pakiet bazy danych za pomocą certyfikatu z podpisem własnym, a następnie podczas otwierania tego pakietu klikniesz pozycję Zawsze ufaj zawartości od tego wydawcy, to pakiety podpisane za pomocą certyfikatów z podpisami własnymi zawsze będą zaufane.

  5. Opcjonalnie na liście Zapisz w wybierz lokalizację, w której chcesz umieścić wyodrębnioną bazę danych, a następnie w polu Nazwa pliku wprowadź inną nazwę dla wyodrębnionej bazy danych.

    Porada: Jeśli wyodrębnisz bazę danych do zaufanej lokalizacji, jej zawartość będzie automatycznie włączana przy każdym otwarciu. Jeśli wybierzesz lokalizację, która nie jest zaufana, pewna część zawartości bazy danych może zostać domyślnie wyłączona.

  6. Kliknij przycisk OK.

W przypadku wątpliwości dotyczących wiarygodności certyfikatu zapoznaj się z artykułem Jak stwierdzić, czy podpis cyfrowy jest wiarygodny, w którym podano ogólne informacje o sprawdzaniu dat i innych pozycji w certyfikacie, ułatwiających potwierdzenie jego ważności.

Początek strony

Cyfrowe podpisywanie wcześniejszej wersji bazy danych

Ważne: Czynności opisane w tej sekcji nie dotyczą baz danych korzystających z jednego z nowych formatów plików.

W przypadku baz danych używających formatów plików mdb lub MDE możesz zastosować podpis cyfrowy do składników w bazie danych. Podpis cyfrowy potwierdza, że wszelkie makra, moduły kodu i inne wykonywalne składniki w bazie danych zostały utworzone przez osobę podpisującą i że nikt ich nie zmienił od chwili podpisania bazy danych.

Aby zastosować podpis do bazy danych, najpierw jest potrzebny certyfikat cyfrowy. Jeśli tworzysz bazy danych do komercyjnego rozpowszechniania, musisz uzyskać certyfikat od komercyjnego urzędu certyfikacji. Urzędy certyfikacji sprawdzają, czy osoby tworzące zawartość (taką jak bazy danych) są godne zaufania.

Jeśli chcesz używać bazy danych do obsługi osobistych lub ograniczonych scenariuszy grup roboczych, Access udostępnia narzędzie do tworzenia certyfikatu z podpisem własnym. W procedurach opisanych w poniższych sekcjach wyjaśniono, jak zainstalować narzędzie o nazwie SelfCert.exe oraz jak za jego pomocą utworzyć certyfikat z podpisem własnym.

Podpisywanie kodu bazy danych

Uwaga: Pamiętaj, że te kroki mają zastosowanie tylko wtedy, gdy korzystasz z baz danych korzystających z jednego z wcześniejszych formatów plików bazy danych, takich jak plik mdb. Aby podpisać nowsze bazy danych, zobacz pakiet sekcji, podpisywanie i rozpowszechnianie bazy danych programu Access.

  1. Otwórz bazę danych, którą chcesz podpisać.

  2. Na karcie Narzędzia bazy danych w grupie Makro kliknij pozycję Visual Basic, aby uruchomić Edytor Visual Basic.

    Skrót klawiaturowy  naciśnij klawisze ALT+F11.

  3. W oknie Eksplorator projektu wybierz bazę danych lub projekt VBA (Visual Basic for Applications), które chcesz podpisać.

  4. W menu Narzędzia kliknij polecenie Podpis cyfrowy.

    Zostanie wyświetlone okno dialogowe Podpis cyfrowy.

  5. Kliknij przycisk Wybierz, aby wybrać certyfikat cyfrowy.

    Zostanie wyświetlone okno dialogowe Wybieranie certyfikatu.

  6. Wybierz certyfikat, który chcesz zastosować.

    Jeśli zostały wykonane kroki opisane w poprzedniej sekcji, wybierz certyfikat utworzony za pomocą narzędzia SelfCert.

  7. Kliknij przycisk OK , aby zamknąć okno dialogowe Wybieranie certyfikatu , a następnie ponownie kliknij przycisk OK , aby zamknąć okno dialogowe podpis cyfrowy .

Porady dotyczące podpisywania starszych wersji baz danych

  • Aby zapobiec przypadkowym modyfikacjom projektu VBA przez innych użytkowników i unieważnieniu jego podpisu, zablokuj projekt VBA przed podpisaniem.

    Uwaga: Zablokowanie projektu VBA nie uniemożliwia innemu użytkownikowi zastąpienia podpisu cyfrowego innym podpisem. Administratorzy korporacyjni mogą ponownie podpisywać szablony i dodatki, aby dokładnie kontrolować, co użytkownicy mogą uruchamiać na komputerach.

  • Podczas cyfrowego podpisywania projektu VBA rozważ uzyskanie sygnatury czasowej, aby inne osoby mogły zweryfikować Twój podpis nawet po wygaśnięciu certyfikatu użytego w przypadku tego podpisu.

Początek strony

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×