Wyświetlanie danych z wielu źródeł w jednym widoku danych

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Większość przedsiębiorstw przechowuje powiązane dane w różnych lokalizacjach. Na przykład informacje o produktach są przechowywane w pliku xml o nazwie produkty.xml, ale informacje o kategoriach produktów są przechowywane w innym pliku xml o nazwie kategorie.xml. Te dwa źródła danych są powiązane ze sobą przez pole o nazwie CategoryID.

Za pomocą programu Microsoft Office SharePoint Designer 2007 można łatwo połączyć źródła danych zawierające powiązane dane, a następnie utworzyć jeden widok danych, w którym będą wyświetlane dane z tych połączonych źródeł danych. Można nawet połączyć różne typy źródeł danych — na przykład plik XML z bazą danych SQL.

W wyniku połączenia źródeł danych powstaje jedno źródło danych, które jest wyświetlane w Bibliotece źródeł danych wraz ze wszystkimi innymi źródłami danych użytkownika. Utworzenie widoku tego połączonego źródła danych przypomina utworzenie dowolnego innego widoku danych. W utworzonym widoku danych połączonego źródła danych można filtrować, sortować, grupować, formatować i wykonywać każdą operację, którą można wykonać w każdym innym widoku danych.

W tym artykule opisano, jak utworzyć dwa przykładowe pliki XML do użycia jako źródła danych, jak połączyć te dwa źródła danych i wreszcie jak utworzyć jeden widok danych, w którym będą wyświetlane dane z obu tych źródeł. W tym artykule plik xml służy jako źródło danych, co umożliwia łatwe utworzenie źródła danych i wykonanie kolejnych czynności. Poniższa procedura jest jednak odpowiednia w przypadku dowolnego źródła danych, w tym baz danych SQL.

Ważne : W tym artykule opisano tworzenie widoków danych w witrynach programu SharePoint umieszczonych na serwerach z programem Windows SharePoint Services 3.0. W przypadku witryny umieszczonej na serwerze, na którym nie ma programu Windows SharePoint Services 3.0, pełny zakres funkcji może być niedostępny.

Aby dowiedzieć się więcej na temat widoków danych, zobacz Tworzenie widoku danych.

W tym artykule

Utwórz dwa pliki XML jako przykładowe źródła danych

Łączenie źródła danych

Tworzenie widoku danych

Sugerowane następne kroki

Tworzenie dwóch plików xml jako przykładowych źródeł danych

Firma Northwind Traders przechowuje listę produktów w formacie XML. Firma przechowuje również listę kategorii. Te dwie listy są skojarzone przez pole o nazwie CategoryID. Łącząc te dwa pliki XML i tworząc jeden widok danych, można łatwo utworzyć listę produktów zorganizowanych według kategorii produktów.

Tworzenie pliku produkty.xml

Jeśli już utworzony plik produkty.XML w celu utworzenia widoku danych, przejdź do następnej sekcji.

  1. W menu Plik kliknij polecenie Otwórz witrynę.

  2. W oknie dialogowym Otwieranie witryny przejdź do witryny programu SharePoint i zaznacz ją, a następnie kliknij przycisk Otwórz.

  3. Gdy zostanie wyświetlony monit, w oknie dialogowym Łączenie z wpisz nazwę użytkownika i hasło, a następnie kliknij przycisk OK.

  4. W menu Plik kliknij polecenie Nowy.

  5. W oknie dialogowym Nowy kliknij dwukrotnie pozycję Plik tekstowy.

  6. Skopiuj poniższe wiersze kodu, zaznaczając je, a następnie naciskając klawisze CTRL+C.

    <?xml version="1.0" encoding="utf-8"?>
    <ProductsRoot>
    <Products>
    <ProductID>1</ProductID>
    <ProductName>Chai</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>10 boxes x 20 bags</QuantityPerUnit>
    <UnitPrice>18</UnitPrice>
    <UnitsInStock>39</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>10</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>2</ProductID>
    <ProductName>Chang</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>24 - 12 oz bottles</QuantityPerUnit>
    <UnitPrice>19</UnitPrice>
    <UnitsInStock>17</UnitsInStock>
    <UnitsOnOrder>40</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>3</ProductID>
    <ProductName>Aniseed Syrup</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>12 - 550 ml bottles</QuantityPerUnit>
    <UnitPrice>10</UnitPrice>
    <UnitsInStock>13</UnitsInStock>
    <UnitsOnOrder>70</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>4</ProductID>
    <ProductName>Chef Anton's Cajun Seasoning</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>48 - 6 oz jars</QuantityPerUnit>
    <UnitPrice>22</UnitPrice>
    <UnitsInStock>53</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>5</ProductID>
    <ProductName>Chef Anton's Gumbo Mix</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>36 boxes</QuantityPerUnit>
    <UnitPrice>21.35</UnitPrice>
    <UnitsInStock>0</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>1</Discontinued>
    </Products>
    </ProductsRoot>
  7. W programie Office SharePoint Designer 2007 umieść punkt wstawiania u góry strony, a następnie naciśnij klawisze CTRL+V, aby wkleić skopiowany kod na stronie.

  8. W menu Plik kliknij polecenie Zapisz jako.

  9. W oknie dialogowym Zapisywanie jako w polu Nazwa pliku wpisz plik produkty.XML.

  10. Na liście Zapisz jako typ kliknij pozycję XML, a następnie kliknij przycisk Zapisz.

Tworzenie pliku kategorie.xml

  1. Jeśli witryna programu SharePoint jest już otwarta, przejdź do kroku 4. W przeciwnym wypadku w menu Plik kliknij polecenie Otwórz witrynę.

  2. W oknie dialogowym Otwieranie witryny przejdź do witryny programu SharePoint i zaznacz ją, a następnie kliknij przycisk Otwórz.

  3. Gdy zostanie wyświetlony monit, w oknie dialogowym Łączenie z wpisz nazwę użytkownika i hasło, a następnie kliknij przycisk OK.

  4. W menu Plik kliknij polecenie Nowy.

  5. W oknie dialogowym Nowy kliknij dwukrotnie pozycję Plik tekstowy.

  6. Skopiuj poniższe wiersze kodu, zaznaczając je, a następnie naciskając klawisze CTRL+C.

    <?xml version="1.0" encoding="utf-8"?>
    <CategoriesRoot>
    <Categories>
    <CategoryID>1</CategoryID>
    <CategoryName>Beverages</CategoryName>
    <Description>Soft drinks, coffees, teas, beer, and ale</Description>
    </Categories>
    <Categories>
    <CategoryID>2</CategoryID>
    <CategoryName>Condiments</CategoryName>
    <Description>Sweet and savory sauces, relishes, spreads, and seasonings</Description>
    </Categories>
    <Categories>
    <CategoryID>3</CategoryID>
    <CategoryName>Confections</CategoryName>
    <Description>Desserts, candies, sweetbreads</Description>
    </Categories>
    <Categories>
    <CategoryID>4</CategoryID>
    <CategoryName>Dairy Products</CategoryName>
    <Description>Cheeses</Description>
    </Categories>
    <Categories>
    <CategoryID>5</CategoryID>
    <CategoryName>Grains/Cereals</CategoryName>
    <Description>Breads, crackers, pasta, and cereal</Description>
    </Categories>
    <Categories>
    <CategoryID>6</CategoryID>
    <CategoryName>Meat/Poultry</CategoryName>
    <Description>Prepared meats</Description>
    </Categories>
    <Categories>
    <CategoryID>7</CategoryID>
    <CategoryName>Produce</CategoryName>
    <Description>Dried fruit and bean curd</Description>
    </Categories>
    <Categories>
    <CategoryID>8</CategoryID>
    <CategoryName>Seafood</CategoryName>
    <Description>Seaweed and fish</Description>
    </Categories>
    </CategoriesRoot>
  7. W programie Office SharePoint Designer 2007 umieść punkt wstawiania u góry strony, a następnie naciśnij klawisze CTRL+V, aby wkleić skopiowany kod na stronie.

  8. W menu Plik kliknij polecenie Zapisz jako.

  9. W oknie dialogowym Zapisywanie jako w polu Nazwa pliku wpisz pliku kategorie.XML.

  10. Na liście Zapisz jako typ kliknij pozycję XML, a następnie kliknij przycisk Zapisz.

Początek strony

Łączenie źródeł danych

Aby utworzyć widok danych, w którym będą wyświetlane dane z wielu źródeł, najpierw należy połączyć źródła danych za pomocą biblioteki źródeł danych. Aby utworzyć listę produktów zorganizowanych według kategorii, należy utworzyć źródło danych, które połączy plik produkty.xml z plikiem kategorie.xml.

  1. W menu Okienka zadań kliknij polecenie Biblioteka źródeł danych.

  2. W okienku zadań Biblioteka źródeł danych kliknij znak plus (+) obok pozycji Połączone źródła, a następnie kliknij pozycję Utwórz nowe połączone źródło.

  3. W oknie dialogowym Właściwości źródła danych kliknij przycisk Konfiguruj połączone źródło.

  4. W Kreatorze łączenia źródeł danych w obszarze Dostępne źródła danych kliknij pozycję kategorie.xml i kliknij przycisk Dodaj. Następnie kliknij pozycję produkty.xml i kliknij przycisk Dodaj.

  5. Kliknij przycisk Dalej.

  6. W obszarze Wybierz typ łącza, który najlepiej odpowiada relacji między wybranymi źródłami kliknij przycisk Połącz zawartość źródeł danych, używając szczegółów źródła danych do wstawienia widoków danych i połączonych widoków podrzędnych.

    Są dostępne dwie opcje: scalanie lub sprzęganie. Dane są scalane, gdy są różne źródła danych z tymi samymi polami, które mają zostać scalone w jedno źródło danych. Dane są sprzęgane, gdy są dwa różne źródła danych, które mają wspólne pole kojarzące jedno źródło danych z drugim źródłem danych. Ponieważ pliki produkty.xml i kategorie.xml to dwa różne źródła danych ze wspólnym polem CategoryID, należy te dwa źródła danych sprzęgnąć.

  7. Kliknij przycisk Zakończ.

  8. W oknie dialogowym Właściwości źródła danych kliknij kartę Ogólne.

  9. W polu Nazwa wpisz Kategorie i produkty.

  10. Kliknij przycisk OK.

    Sekcja połączonych źródeł biblioteki źródeł danych, w której jest wyświetlane nowe źródło danych o nazwie Kategorie i produkty

    W bibliotece źródeł danych w obszarze Połączone źródła można zobaczyć nowe połączone źródło danych.

Początek strony

Tworzenie widoku danych

Teraz, gdy źródła danych są już połączone, można użyć okienka zadań Szczegóły źródła danych w celu utworzenia widoku danych, w którym będą wyświetlane dane z połączonego źródła danych.

Można utworzyć widok danych listy produktów, która jest zorganizowana według kategorii produktów. Dla każdej kategorii w pliku kategorie.xml można wyświetlać produkty danej kategorii z pliku produkty.xml.

Aby utworzyć widok danych, w którym wszystkie produkty będą wyświetlane według kategorii, należy najpierw utworzyć widok pliku kategorie.xml.

Widoki danych są oparte na technologii Microsoft ASP.NET 2.0 . Aby utworzyć widok danych, należy najpierw utworzyć stronę programu ASP.NET (plik aspx). W tym przykładzie zostanie utworzona nowa strona programu ASP.NET, a następnie do tej strony zostanie wstawiony widok danych.

  1. W menu Plik kliknij polecenie Nowy.

  2. W oknie dialogowym Nowy kliknij dwukrotnie pozycję ASPX.

    Zostanie otwarta nowa strona z tagiem FORM.

    Tag form programu ASP.NET

  3. W menu Widok danych kliknij polecenie Wstaw widok danych.

    Na stronie zostanie wyświetlony pusty widok danych i zostanie otwarte okienko zadań Biblioteka źródeł danych.

    Pusty widok danych

    Po wstawieniu widoku danych można rozpocząć dodawanie danych.

  4. W okienku zadań Biblioteka źródeł danych kliknij znak plus (+) obok pozycji Połączone źródła, kliknij pozycję Kategorie i produkty, a następnie kliknij przycisk Pokaż dane.

    Najpierw należy utworzyć widok danych pliku kategorie.xml.

  5. W okienku zadań Szczegóły źródła danych w folderze Categories kliknij pozycję CategoryName. Naciśnij i przytrzymaj klawisz CTRL podczas klikania pozycji Description.

    Dwa pola wybrane w folderze Categories w okienku zadań Szczegóły źródła danych

  6. Kliknij przycisk Wstaw wybrane pola jako, a następnie kliknij polecenie Widok wielu elementów, aby wstawić zaznaczone dane do widoku danych.

    Uwaga : Polecenie Widok jednego elementu powoduje wyświetlanie jednego rekordu w widoku danych. Polecenie Widok wielu elementów powoduje wyświetlanie wielu rekordów z polami w kolumnach i nagłówkami dla każdej kolumny.

    Pola wybrane w okienku zadań Szczegóły źródła danych będą teraz wyświetlane w widoku danych.

    Widok danych z wyświetlanymi rekordami z pliku kategorie.xml

    W następnym kroku zostanie utworzona nowa kolumna, w której będzie wyświetlany widok podrzędny (widok danych wyświetlany wewnątrz komórki innego widoku danych) danych znajdujących się w pliku produkty.xml.

  7. W widoku danych kliknij prawym przyciskiem myszy kolumnę Description, w menu skrótów kliknij polecenie Wstaw, a następnie kliknij pozycję Kolumna z prawej.

  8. Umieść punkt wstawiania wewnątrz komórki w nowej kolumnie.

  9. W okienku zadań Szczegóły źródła danych w folderze Products kliknij pozycję ProductName. Naciśnij i przytrzymaj klawisz CTRL podczas klikania pozycji UnitsInStock, UnitsOnOrder i ReorderLevel.

    Folder Products w okienku zadań Szczegóły źródła danych

  10. Kliknij przycisk Wstaw wybrane pola jako, a następnie kliknij polecenie Dołączony widok podrzędny.

    Dołączony widok podrzędny jest widokiem podrzędnym źródła danych, które jest sprzężone z innym źródłem danych przez wspólne pole. W następnym kroku zostanie połączone pole CategoryID w pliku kategorie.xml z polem CategoryID w pliku produkty.xml.

  11. W oknie dialogowym Dołączanie do widoku podrzędnego w obszarze Categories kliknij pozycję CategoryID. W obszarze Products kliknij pozycję CategoryID, a następnie kliknij przycisk OK.

    Okno dialogowe Dołączanie do widoku podrzędnego

    Pola wybrane w okienku zadań Szczegóły źródła danych są teraz wyświetlane w nowej kolumnie. Ponieważ pola CategoryID są połączone między dwoma źródłami, na liście Beverages są wyświetlane tylko napoje, na liście Condiments są wyświetlane tylko przyprawy i tak dalej.

    Widok danych z wyświetlanym widokiem podrzędnym listy produktów w obrębie skojarzonej kategorii na liście

Początek strony

Sugerowane następne kroki

Widoki danych są funkcjonalnymi widokami dynamicznych źródeł danych, które można w pełni dostosowywać. Utworzony widok danych połączonego źródła danych można dostosowywać tak samo jak każdy inny widok danych. Teraz, gdy są już znane sposoby tworzenia jednego widoku dla danych z wielu źródeł, można poznać inne metody:

  • Filtrowanie danych w widoku danych    Można łatwo filtrowanie danych w widoku danych. Aby uzyskać więcej informacji zobacz Filtrowanie danych w widoku danych.

  • Sortowanie i grupowanie danych w widoku danych     Można szybko sortować lub grupować dane w widoku danych. Aby uzyskać więcej informacji, zobacz Sortowanie i grupowanie danych w widoku danych.

  • Zastosuj formatowanie warunkowe do widoku danych    Możesz zastosować określone formatowanie do widoku danych, gdy dane w widoku danych spełniają określone warunki. Aby uzyskać więcej informacji zobacz Stosowanie formatowanie warunkowe do widoku danych.

  • Tworzenie formuły kolumny w widoku danych    Tak, jak można się z arkuszem kalkulacyjnym, możesz dodać formuły do swojego widoku danych, który przeprowadzać obliczenia na danych i wyświetlić wyniki w oddzielnych kolumnach. Aby uzyskać więcej informacji zobacz Tworzenie kolumny formuły w widoku danych.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×