Wstawianie widoku danych jako formularza

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Formularze są ważną częścią każdej aplikacji sieci Web programu Microsoft SharePoint, w której są zbierane dane od użytkowników. Widoki danych są tworzone za pomocą technologii formularzy ASP.NET, dzięki czemu można je wstawiać zarówno jako widoki danych tylko do odczytu, jak i jako formularze, w których użytkownicy mogą zapisywać dane w źródle danych, używając przeglądarki. Za pomocą programu Microsoft Office SharePoint Designer 2007 można szybko wstawić widok danych jako formularz, co pozwala użytkownikom wprowadzać i zapisywać zmiany w następujących źródłach danych: na listach i w bibliotekach, w połączeniach baz danych, a także w plikach XML. Należy pamiętać, że widok danych wstawiony jako formularz może być używany jedynie dla tych wymienionych źródeł danych.

W tym artykule opisano, w jaki sposób wstawić widok danych jako formularz. Ponadto zaprezentowano tu sposób tworzenia przykładowego pliku XML do użycia jako źródło danych, co pozwoli wykonać kolejne przykładowe czynności.

Ważne : W tym artykule omówiono tworzenie widoku danych w witrynie programu SharePoint znajdującej się na serwerze z uruchomionym programem Windows SharePoint Services 3.0. Ta funkcja nie jest dostępna, jeśli witryna nie znajduje się na serwerze z uruchomionym programem Windows SharePoint Services 3.0.

W tym artykule

Przed rozpoczęciem

Dlaczego wstawianie widoku danych jako formularza?

Tworzenie pliku XML jako źródła danych przykładowych

Wstawianie widoku danych jako formularza

Edytowanie danych za pomocą przeglądarki

Sugerowane następne kroki

Przed rozpoczęciem

Program Office SharePoint Designer 2007 zawiera dwie oddzielne funkcje, które umożliwiają użytkownikom edytowanie danych w widoku danych za pomocą przeglądarki:

  • Wstawianie widoku danych jako formularza    Utworzywszy widok danych, można zdecydować, że ma on zostać wstawiony jako formularz z jednym elementem lub z wieloma elementami. Formularz jest zawsze w trybie edycji i jest wyświetlany z jednym lub z wieloma rekordami. Użytkownicy mogą modyfikować dane i wstawiać nowe rekordy za pomocą przeglądarki, ale nie mogą usuwać rekordów. Jeśli zostanie wybrany formularz z wieloma elementami, użytkownicy będą mogli szybko edytować dane w wielu rekordach jednocześnie.

  • Dodawanie łączy do istniejącego widoku danych     Możesz dodać łącza do istniejącego widoku danych tak, aby użytkownicy mogą edytować, usuwanie i wstawianie rekordów w źródle danych. Użytkownicy kliknij łącze Edytuj rekord, aby umieścić go w trybie edycji. Po dodaniu łącza do widok danych, który został wstawiony jako formularz z łącza Zamień przyciski formularza. Ponadto po dodaniu łącza do widok danych, który został wstawiony jako formularz z widoku danych nie będą już wyświetlane pola formularza domyślnie; dane zostaną wyświetlone tylko w widoku. Aby uzyskać więcej informacji zobacz artykuł Edytowanie, usuwanie i wstawianie rekordów w widoku danych.

Po wstawieniu widoku danych jako formularza można filtrować, sortować i grupować dane, stosować formatowanie warunkowe i tworzyć kolumny formuł. Gdy użytkownicy wprowadzają zmiany do danych, a następnie zapisują te zmiany, wszelkie zastosowane operacje filtrowania i formatowania warunkowego, a także porządek sortowania i kolumna formuły, automatycznie odzwierciedlają zaktualizowane dane. Można też dodać wbudowane akcje formularza do przycisków Zapisz i Anuluj, które są domyślnie wyświetlane w formularzu. Aby uzyskać więcej informacji o wbudowanych akcjach formularza, skorzystaj z łączy dostępnych w sekcji Zobacz też.

Początek strony

Dlaczego warto wstawić widok danych jako formularz?

Widok danych jest dostosowywalnym widokiem źródła danych. Widok danych można wstawić do strony ASPX jako widok lub formularz. Widok danych wstawiony jako widok pozwala formatować sposób prezentacji danych, ale nie pozwala edytować samych danych.

Jednak w przypadku wstawienia tego samego widoku danych jako formularza można edytować dane za pomocą przeglądarki, a wprowadzone zmiany będą zapisywane i przechowywane w oryginalnym źródle danych. Za pomocą programu Office SharePoint Designer 2007 można na podstawie istniejącego źródła danych szybko utworzyć formularz jednego z trzech typów:

  • Formularz z pojedynczym elementem wyświetla jeden rekord jako formularz — każde pole jest wyświetlane w osobnym wierszu, a nazwa pola jest wyświetlana jako nagłówek tego wiersza — co umożliwia edytowanie danych tylko jednego rekordu naraz. Formularz zawiera łącza nawigacji, które można kliknąć, aby wyświetlić następny lub poprzedni rekord.

    Widok danych wstawiony jako formularz z jednym rekordem

  • Formularz z wieloma elementami wyświetla wiele rekordów jako formularz — każde pole jest wyświetlane w osobnej kolumnie, a nazwa pola jest wyświetlana jako nagłówek tej kolumny — co umożliwia szybkie edytowanie danych wielu rekordów, a następnie jednoczesne zapisanie zmian.

    Widok danych wstawiony jako formularz z wieloma rekordami

  • Formularz nowego elementu wyświetla puste pola dla pojedynczego rekordu — każde pole jest wyświetlane w osobnym wierszu, a nazwa pola jest wyświetlana jako nagłówek tego wiersza — co umożliwia dodawanie do źródła danych pojedynczych rekordów danych. W formularz można umieścić wszystkie wymagane pola rekordu, dzięki czemu będzie można zapisywać wszystkie potrzebne dane jednocześnie.

    Widok danych wstawiony jako formularz nowego elementu

Widoki danych wstawione jako formularze można tworzyć dla list i bibliotek programu SharePoint, połączeń baz danych i lokalnych dokumentów XML. Gdy zostanie wstawiony widok danych, program Office SharePoint Designer 2007 pobiera dane ze źródła danych w formie kodu XML (Extensible Markup Language) i wyświetla te dane przy użyciu transformacji XSLT (Extensible Stylesheet Language Transformation). Podobnie jak w przypadku każdego widoku danych, formularz można modyfikować za pomocą programu Office SharePoint Designer 2007.

Gdy zostanie wstawiony widok danych, na stronie można także dodać lub usunąć kolumny, zmienić formatowanie lub zastosować kolory, używając w tym celu narzędzi WYSIWYG w programie Office SharePoint Designer 2007. Podczas formatowania widoku danych przy użyciu tych narzędzi w programie Office SharePoint Designer 2007 kod XSL (Extensible Stylesheet Language) jest wstawiany bezpośrednio do kodu HTML. Kod XSL można edytować bezpośrednio w widoku kodu, ale w programie Office SharePoint Designer 2007 można także używać narzędzi formatowania. Dzięki temu użytkownicy, którzy nie znają języka XSL, mogą go szybko i łatwo zastosować.

Początek strony

Tworzenie pliku xml jako przykładowego źródła danych

Firma Northwind Traders, zajmująca się sprzedażą wyszukanych potraw, prowadzi ewidencję, używając pliku XML. Jeśli stan magazynu jest niski, członek zespołu może się skontaktować z dostawcą odpowiedniego produktu i złożyć zamówienie. Zasugerowano wstawienie widoku danych jako formularza, dzięki czemu członek zespołu składający zamówienie może natychmiast aktualizować jednostki na zamówieniu. W ten sposób pracownicy firmy Northwind Traders zawsze będą mieli dostęp do najbardziej aktualnych informacji na temat ich bieżącego stanu magazynu.

Wykonanie poniższych procedur wymaga używania pliku xml jako źródła danych. Jeśli witryna programu SharePoint nie zawiera pliku xml, należy najpierw utworzyć listę produktów firmy Northwind Traders. Po utworzeniu listy można wstawić widok danych jako formularz w celu zaktualizowania danych zawartych na liście.

Tworzenie pliku produkty.xml

  1. W menu Plik kliknij polecenie Otwórz witrynę.

  2. W oknie dialogowym Otwieranie witryny przejdź do witryny programu SharePoint i zaznacz ją, a następnie kliknij przycisk Otwórz.

  3. Gdy zostanie wyświetlony monit, w oknie dialogowym Łączenie z wpisz nazwę użytkownika i hasło, a następnie kliknij przycisk OK.

  4. W menu Plik kliknij polecenie Nowy.

  5. W oknie dialogowym Nowy na karcie Strona kliknij przycisk Ogólne w skrajnym lewym okienku, a następnie kliknij dwukrotnie pozycję Plik tekstowy w następnym okienku po prawej.

    W witrynie sieci Web zostanie otwarty nowy plik tekstowy.

  6. Skopiuj poniższe wiersze kodu, zaznaczając je, a następnie naciskając klawisze CTRL+C.

    <?xml version="1.0" encoding="utf-8"?>
    <ProductsRoot>
    <Products>
    <ProductID>1</ProductID>
    <ProductName>Chai</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>10 boxes x 20 bags</QuantityPerUnit>
    <UnitPrice>18</UnitPrice>
    <UnitsInStock>39</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>10</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>2</ProductID>
    <ProductName>Chang</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>24 - 12 oz bottles</QuantityPerUnit>
    <UnitPrice>19</UnitPrice>
    <UnitsInStock>17</UnitsInStock>
    <UnitsOnOrder>40</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>3</ProductID>
    <ProductName>Aniseed Syrup</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>12 - 550 ml bottles</QuantityPerUnit>
    <UnitPrice>10</UnitPrice>
    <UnitsInStock>13</UnitsInStock>
    <UnitsOnOrder>70</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>4</ProductID>
    <ProductName>Chef Anton's Cajun Seasoning</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>48 - 6 oz jars</QuantityPerUnit>
    <UnitPrice>22</UnitPrice>
    <UnitsInStock>53</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>5</ProductID>
    <ProductName>Chef Anton's Gumbo Mix</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>36 boxes</QuantityPerUnit>
    <UnitPrice>21.35</UnitPrice>
    <UnitsInStock>0</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>1</Discontinued>
    </Products>
    </ProductsRoot>
  7. W programie Office SharePoint Designer 2007 umieść kursor u góry strony, a następnie naciśnij klawisze CTRL+V, aby wkleić skopiowany kod na stronie.

  8. W menu Plik kliknij polecenie Zapisz jako.

  9. W oknie dialogowym Zapisywanie jako w polu Nazwa pliku wpisz plik produkty.XML.

  10. Na liście Zapisz jako typ kliknij pozycję XML, a następnie kliknij przycisk Zapisz.

Początek strony

Wstawianie widoku danych jako formularza

Podczas wstawiania widoku danych jako formularza przy użyciu okienka zadań Szczegóły źródła danych należy najpierw wstawić widok danych na stronę. Następnie w okienku zadań Biblioteka źródeł danych, które umożliwia zarządzanie dostępnymi źródłami danych dla witryny programu SharePoint, należy zaznaczyć źródło danych. Wówczas zostanie otwarte okienko zadań Szczegóły źródła danych. W okienku zadań Szczegóły źródła danych należy wybrać pola, które mają być wyświetlane, a następnie wstawić je do widoku danych.

Formularze danych są oparte na technologii ASP.NET 2.0. Aby utworzyć widok danych, należy najpierw utworzyć stronę programu ASP.NET (plik aspx). W tym przykładzie zostanie utworzona nowa strona ASP.NET, a następnie zostanie wstawiony widok danych jako formularz przy użyciu okienka zadań Szczegóły źródła danych.

  1. W menu Plik kliknij polecenie Nowy.

  2. W oknie dialogowym Nowy na karcie Strona kliknij opcję Ogólne, a następnie kliknij dwukrotnie pozycję ASPX.

    Zostanie otwarta nowa strona z tagiem FORM.

    Tag form programu ASP.NET

  3. W menu Widok danych kliknij polecenie Wstaw widok danych.

    Na stronie zostanie wyświetlony pusty widok danych i zostanie otwarte okienko zadań Biblioteka źródeł danych.

    Pusty widok danych

    Po wstawieniu widoku danych można rozpocząć dodawanie danych.

  4. W okienku zadań Biblioteka źródeł danych zlokalizuj źródło danych, kliknij je, a następnie kliknij przycisk Pokaż dane.

    W tym przykładzie w obszarze Pliki XML kliknij pozycję produkty.xml, a następnie kliknij przycisk Pokaż dane. Jeśli nagłówek Pliki XML jest zwinięty, kliknij znak plus (+), aby go rozwinąć.

  5. W okienku zadań Szczegóły źródła danych kliknij pola, które chcesz wstawić w widoku danych.

    Porada : Aby zaznaczyć wiele pól, podczas ich klikania przytrzymuj naciśnięty klawisz CTRL.

    W tym przykładzie w folderze FolderGłównyProduktów w obszarze Produkty kliknij pozycję NazwaProduktu. Naciśnij i przytrzymaj klawisz CTRL podczas klikania pozycji StanMagazynu, JednostkiZamawiane i PoziomPonownegoZamówienia.

    Pola zaznaczone w okienku zadań Szczegóły źródła danych

  6. Kliknij przycisk Wstaw wybrane pola jako, a następnie kliknij polecenie Formularz z wieloma elementami, aby wstawić zaznaczone dane do widoku danych jako formularz.

    Uwaga : W formularzu z pojedynczym elementem jest wyświetlany jako formularz tylko jeden rekord. W formularzu z wieloma elementami jest wyświetlanych wiele rekordów — każde pole jest wyświetlane w osobnej kolumnie, a nazwa pola jest wyświetlana jako nagłówek tej kolumny.

    Pola wybrane w okienku Szczegóły źródła danych pojawią się teraz w formularzu.

    Uwaga : Ponieważ w tym przykładzie jest używany plik xml, każde pole w widoku danych jest edytowalne. Jednak w zależności od typu źródła danych jest możliwe, że niektóre pola mogą nie być edytowalne. Jeśli na przykład źródłem danych jest lista programu SharePoint i użytkownik zdecyduje się zawrzeć w formularzu pola systemowe, takie jak Utworzona przez lub Zmodyfikowana przez, te pola nie będą edytowalne.

    Wybrane dane wyświetlone w postaci formularza

    Po wstawieniu widoku danych jako formularza można zmodyfikować czcionki, wyrównać tekst lub zastosować kolory, używając narzędzi WYSIWYG, takich jak pasek narzędzi Formatowanie. Podczas stosowania nowego formatowania do punktu danych w widoku danych program Office SharePoint Designer 2007 stosuje formatowanie do wszystkich danych na tym samym poziomie w kodzie XML, modyfikując arkusz stylów XSLT dołączony do strony. Jeśli na przykład, tak jak na powyższej ilustracji, zostanie zaznaczone pole Chai, a następnie kliknięty przycisk Pogrubienie na pasku narzędzi Formatowanie, program Office SharePoint Designer 2007 zastosuje to samo formatowanie do całej zawartości wyświetlanej w polu NazwaProduktu.

    To samo formatowanie zastosowane do wszystkich danych na tym samym poziomie

  7. W menu Plik kliknij polecenie Zapisz jako. W oknie dialogowym Zapisywanie jako w polu Nazwa pliku wpisz nazwę pliku, a następnie kliknij przycisk Zapisz.

Początek strony

Edytowanie danych za pomocą przeglądarki

Po zapisaniu strony zawierającej formularz można wyświetlić jej podgląd w przeglądarce i zmodyfikować dane w formularzu.

Typy pól i wprowadzanie danych

W przedstawionym przykładzie użyto źródła danych w postaci pliku XML. Ponieważ plik XML jest plikiem tekstowym, nie jest możliwe określenie typów wartości wymaganych dla poszczególnych pól. Nie można na przykład w żaden sposób zapobiec wprowadzeniu i zapisaniu tekstu w polu, które powinno zawierać liczby, takim jak pole JednostkiZamawiane.

Jeśli jednak źródłem danych jest źródło danych SQL, takie jak baza danych czy lista bądź biblioteka programu SharePoint, typy pól mogą być określone w samym źródle danych. W takim przypadku po wprowadzeniu tekstu w polu formularza, dla którego są wymagane wartości liczbowe, i kliknięciu przycisku Zapisz w przeglądarce zostanie wyświetlony komunikat o błędzie wraz z informacją, że nie można wykonać polecenia aktualizacji dla formantu źródła danych. Oznacza to, że w formularzu są wprowadzane wartości, których pole źródła danych nie może zaakceptować. W przypadku otrzymania takiego komunikatu o błędzie należy kliknąć w przeglądarce przycisk Wstecz, a następnie kliknąć w formularzu przycisk Anuluj, aby odrzucić zmiany, lub wprowadzić w polach formularza wartości, które źródło danych może zaakceptować.

Dlatego podczas projektowania formularza w programie Office SharePoint Designer 2007 można zawrzeć tekst w nagłówkach kolumn, jeśli pola wymagają wprowadzenia danych określonego typu.

Korzystanie z formularza w przeglądarce

  1. W programie Office SharePoint Designer 2007 w menu Plik kliknij polecenie Podgląd w przeglądarce, a następnie kliknij typ i rozmiar przeglądarki, których chcesz użyć.

    Skrót klawiaturowy kliknij stronę, którą chcesz wyświetlić podgląd na liście folderów, a następnie naciśnij klawisz F12.

    W przeglądarce zostanie wyświetlona strona z formularzem.

    Formularz z wieloma rekordami, tak jak jest wyświetlany w przeglądarce

  2. Możesz teraz zmodyfikować dowolne informacje wyświetlane w polu formularza w widoku danych. Możesz też zmienić informacje w wielu polach w wielu rekordach jednocześnie. Po zakończeniu modyfikowania danych w formularzu kliknij przycisk Zapisz, aby zapisać zmiany w źródle danych, lub kliknij przycisk Anuluj, aby je odrzucić.

    Do opracowania przykład, w kolumnie ProductName , pole zawierające wyraz Woźniak, umieść kursor na końcu wyrazu Woźniak; raz naciśnij klawisz SPACJA, a następnie wpisz Herbaty skup się. W kolumnie JednostkiZamówione w Woźniak rekordu typu 40. W kolumnie JednostkiZamówione w Jacka Kuchmistrz Cajun Seasoning rekordu, wpisz 35, a następnie kliknij przycisk Zapisz. Formularz ze zaktualizowanymi rekordami wyświetlana w przeglądarce.

    Zostanie wyświetlony formularz danych ze zaktualizowanymi rekordami

Początek strony

Sugerowane nastepne kroki

Widoki danych są funkcjonalnymi widokami dynamicznymi danych, które można w pełni dostosowywać. Teraz, gdy są już znane sposoby wstawiania widoku danych jako formularza, można poznać inne metody:

  • Filtrowanie danych w widoku danych    Można łatwo filtrowanie danych w widoku danych tak, aby dane wyświetlane dokładnie dane, które chcesz wyświetlić. Aby uzyskać więcej informacji zobacz Filtrowanie danych w widoku danych.

  • Sortowanie i grupowanie danych w widoku danych    Można szybko sortować lub grupować dane w widoku danych. Na przykład można łatwo sortować listy w kolejności alfabetycznej. Aby uzyskać więcej informacji, zobacz Sortowanie i grupowanie danych w widoku danych.

  • Zastosuj formatowanie warunkowe do widoku danych    Możesz zastosować określone formatowanie do widoku danych, gdy dane w widoku danych spełniają określone warunki. Aby uzyskać więcej informacji zobacz Stosowanie formatowanie warunkowe do widoku danych.

  • Tworzenie formuły kolumny w widoku danych    Można utworzyć kolumnę obliczeniową, który zostanie wyświetlony wynik obliczeń danych w widoku danych. Można na przykład pomnożyć cena jednostkowa przez liczbę jednostek w magazynie i wyświetlić łączną liczbę elementów w oddzielnych kolumnach. Aby uzyskać więcej informacji zobacz Tworzenie kolumny formuły w widoku danych.

  • Modyfikowanie kolumn w widoku danych    Można szybko i łatwo Dodawanie, usuwanie lub ponowne rozmieszczanie kolumn w widoku danych. Aby uzyskać więcej informacji zobacz Modyfikowanie kolumn w widoku danych.

  • Wyświetlanie przykładowych danych w widoku danych    Przykładowe dane można łatwo wyświetlać w widoku danych.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×