Wstawianie dat w formacie juliańskim

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Określenie „data juliańska” jest niekiedy używane w odniesieniu do daty w formacie, który jest kombinacją bieżącego roku oraz liczby dni, które upłynęły od początku roku. Na przykład dzień 1 stycznia 2007 roku jest reprezentowany przez liczbę 2007001, a dzień 31 grudnia 2007 roku przez liczbę 2007365. Należy zauważyć, że format ten nie jest oparty na kalendarzu juliańskim.

Daty juliańskie są zwykle stosowane w astronomii; jest to system dat seryjnych rozpoczynających się 1 stycznia 4713 p.n.e.

Daty juliańskie można wstawiać na kilka sposobów.

Co chcesz zrobić?

Wprowadzanie bieżącej daty jako daty juliańskiej

Szczegóły funkcji

Konwertowanie daty na datę juliańską

Szczegóły funkcji

Konwertowanie daty na datę juliańską stosowaną w astronomii

Wprowadzanie bieżącej daty jako daty juliańskiej

Do wykonania tego zadania należy użyć funkcji TEKST, DZIŚ i DATA.WARTOŚĆ.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

Jak skopiować przykład

  1. Utwórz pusty skoroszyt lub arkusz.

  2. Zaznacz przykład w tym temacie Pomocy.

    Uwaga : Nie zaznaczaj nagłówków wierszy ani kolumn.

    Zaznaczanie przykładu w Pomocy

    Zaznaczanie przykładu w Pomocy

  3. Naciśnij klawisze CTRL+C.

  4. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.

  5. Aby przełączać się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisz CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.

1

2

3

A

B

Formuła

Opis (wynik)

=TEKST(DZIŚ();"rr")&TEKST((DZIŚ() -DATA.WARTOŚĆ(TEKST(DZIŚ();"rr")&"-01-01")+1);"000")

Bieżący dzień w formacie juliańskim z rokiem wyrażonym dwiema cyframi (zmienne)

=TEKST(DZIŚ();"rrrr")&TEKST((DZIŚ() -DATA.WARTOŚĆ(TEKST(DZIŚ();"rr")&"-01-01")+1);"000")

Bieżący dzień w formacie juliańskim z rokiem wyrażonym czterema cyframi (zmienne)

Uwaga : 

  • Data bieżąca jest pobierana z systemowego zegara komputera.

  • W powyższych formułach rok rozpoczyna się 1 stycznia (01-01). Aby w formułach była używana inna data początkowa, zmień część „01-01” na żądaną datę.

Szczegóły funkcji

DATA.WARTOŚĆ, funkcja

TEKST, funkcja

DZIŚ, funkcja

Początek strony

Konwertowanie daty na datę juliańską

Do wykonania tego zadania należy użyć funkcji TEKST i DATA.WARTOŚĆ.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

Jak skopiować przykład

  1. Utwórz pusty skoroszyt lub arkusz.

  2. Zaznacz przykład w tym temacie Pomocy.

    Uwaga : Nie zaznaczaj nagłówków wierszy ani kolumn.

    Zaznaczanie przykładu w Pomocy

    Zaznaczanie przykładu w Pomocy

  3. Naciśnij klawisze CTRL+C.

  4. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.

  5. Aby przełączać się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisz CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.

1

2

A

Data

2007-06-23

Formuła

Opis (wynik)

=TEKST(A2;"rr")&TEKST((A2-DATA.WARTOŚĆ(TEKST(A2;"rr")&"-01-01")+1);"000")

Powyższa data w formacie juliańskim z rokiem wyrażonym dwiema cyframi (07174)

=TEKST(A2;"rrrr")&TEKST((A2-DATA.WARTOŚĆ(TEKST(A2;"rr")&"-01-01")+1);"000")

Powyższa data w formacie juliańskim z rokiem wyrażonym czterema cyframi (2007174)

Uwaga : W powyższej formule rok rozpoczyna się 1 stycznia (01-01). Aby w formułach była używana inna data początkowa, zmień część „01-01” na żądaną datę.

Szczegóły funkcji

DATA.WARTOŚĆ, funkcja

TEKST, funkcja

Początek strony

Konwertowanie daty na datę juliańską stosowaną w astronomii

Ta formuła działa jedynie w odniesieniu do dat późniejszych niż 01-03-1901 oraz w arkuszach, w których używa się systemu daty 1900.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

Jak skopiować przykład

  1. Utwórz pusty skoroszyt lub arkusz.

  2. Zaznacz przykład w tym temacie Pomocy.

    Uwaga : Nie zaznaczaj nagłówków wierszy ani kolumn.

    Zaznaczanie przykładu w Pomocy

    Zaznaczanie przykładu w Pomocy

  3. Naciśnij klawisze CTRL+C.

  4. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.

  5. Aby przełączać się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisz CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.

1

2

A

Data

2007-06-23

Formuła

Opis (wynik)

=A2+2415018,50

Pierwsza z powyższych dat w formacie juliańskim stosowanym w astronomii (7/28/8619)

Uwaga : Daty można sformatować jako liczby. Należy zaznaczyć komórkę i na karcie Narzędzia główne w grupie Liczba kliknąć strzałkę, a następnie kliknąć pozycję Liczbowe.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×