Wprowadzenie do zabezpieczeń programu Access 2010

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Ten artykuł zawiera omówienie funkcji zabezpieczeń oferowanych przez program Access 2010 oraz objaśnienie sposobu używania narzędzi udostępnianych przez program Access w celu ułatwienia zabezpieczania bazy danych. Zawiera on także linki do bardziej szczegółowej zawartości dotyczącej różnych funkcji zabezpieczeń.

W tym artykule nie omówiono funkcji zabezpieczeń programu SharePoint dostępnych po opublikowaniu bazy danych w sieci Web przy użyciu usług programu Access. Aby uzyskać więcej informacji, zobacz Pomoc programu Microsoft SharePoint Server 2010.

W tym artykule

Co nowego w zabezpieczeniach programu Access

Używanie bazy danych programu Access w zaufanej lokalizacji

Pakowanie, podpisywanie i rozpowszechnianie bazy danych programu Access 2010

Włączanie wyłączonej zawartości podczas otwierania bazy danych

Szyfrowanie bazy danych programu Access za pomocą hasła bazy danych

Jak działają zabezpieczenia w przypadku baz danych z wcześniejszych wersji programu Access otwartych w programie Access 2010

Uruchamianie niebezpiecznych wyrażeń (wyłączanie trybu piaskownicy)

Co nowego w zabezpieczeniach programu Access

Program Access zawiera ulepszony model zabezpieczeń, który pozwala uprościć proces stosowania zabezpieczeń do bazy danych i otwierania bazy danych z włączonymi zabezpieczeniami.

Uwaga : Model i techniki omówione w tym artykule usprawniają zabezpieczenia, jednak najlepszym sposobem ochrony danych programu Access jest przechowywanie tabel na serwerze, takim jak komputer z uruchomionym programem Windows SharePoint Services 3.0 lub Microsoft Office SharePoint Server 2010.

Oto lista nowych funkcji zabezpieczeń programu Access:

Nowości w wersji 2010

  • Nowa technologia szyfrowania    Pakiet Office 2010 oferuje nową technologię szyfrowania, która jest silniejsza, niż w przypadku technologii dostępnej w pakiecie Office 2007.

  • Obsługa produktów do szyfrowania innych firm    Program Access 2010 pozwala na korzystanie z preferowanej przez Ciebie technologii szyfrowania innej firmy. W tym artykule nie omówiono używania produktów innych firm.

Nowości w wersji 2007

  • Możliwość wyświetlania danych nawet wtedy, gdy nie chcesz włączać zawartości bazy danych    W programie Microsoft Office Access 2003 po ustawieniu poziomu zabezpieczeń na Wysoki, przed wyświetleniem danych trzeba było podpisać kod bazy danych i ustawić ją jako zaufaną. Teraz można wyświetlić dane bez określania, czy baza danych jest zaufana.

  • Większa łatwość obsługi    Po umieszczeniu plików baz danych (w nowym formacie pliku programu Access lub we wcześniejszych formatach plików) w zaufanej lokalizacji, na przykład w folderze plików lub w udziale sieciowym określonym jako bezpieczny, pliki będą otwierane i uruchamiane bez wyświetlania komunikatów ostrzegawczych i bez monitów o włączenie wyłączonej zawartości. Bazy danych z wcześniejszych wersji programu Access, takie jak pliki mdb i mde, podpisane cyfrowo przez wydawcę, który został określony jako zaufany, można otwierać w programie Access 2010 i uruchamiać bez konieczności podejmowania decyzji o zaufaniu. Pamiętaj jednak, że kod VBA w podpisanej bazie danych nie będzie uruchamiany, dopóki nie określisz wydawcy jako zaufanego; nie będzie też uruchamiany, jeśli podpis cyfrowy stanie się nieprawidłowy. Podpis staje się nieprawidłowy, jeśli ktoś inny niż osoba, która złożyła podpis, narusza zawartość bazy danych.

    W przypadku wątpliwości dotyczących wiarygodności certyfikatu zapoznaj się z artykułem Jak stwierdzić, czy podpis cyfrowy jest wiarygodny, w którym podano ogólne informacje o sprawdzaniu dat i innych pozycji w certyfikacie w celu potwierdzenia jego ważności.

  • Centrum zaufania     Centrum zaufania to okno dialogowe, za pomocą którego można określać i zmieniać ustawienia zabezpieczeń programu Access. Centrum zaufania służy do tworzenia i zmieniania zaufanych lokalizacji oraz ustawiania opcji zabezpieczeń w programie Access. Te ustawienia mają wpływ na działanie nowych i istniejących baz danych po ich otwarciu w określonym wystąpieniu programu Access. Centrum zaufania obejmuje także reguły oceniania składników w bazie danych i określania, którą bazę danych można bezpiecznie otworzyć oraz czy Centrum zaufania powinno wyłączyć bazę danych i pozostawić decyzję o jej włączeniu użytkownikowi.

    Aby uzyskać ogólne informacje na temat korzystania z Centrum zaufania, zobacz artykuł Przeglądanie ustawień zabezpieczeń i prywatności w Centrum zaufania.

  • Mniej komunikatów ostrzegawczych    We wcześniejszych wersjach programu Access trzeba było zajmować się szeregiem alertów — na przykład związanych z zabezpieczeniami makr i trybem piaskownicy. Po otwarciu pliku accdb, który nie jest jeszcze zaufany, domyślnie jest wyświetlane jedno narzędzie, nazywane paskiem komunikatów.

    Pasek komunikatów

    Jeśli chcesz ustawić bazę danych jako zaufaną, za pomocą paska komunikatów możesz włączyć dowolną wyłączoną zawartość — zapytania funkcjonalne (zapytania, które dodają, usuwają lub zmieniają dane), makra, kontrolki ActiveX, wyrażenia (funkcje, których wynikiem jest jedna wartość) i kod VBA — podczas otwierania bazy danych zawierającej jeden lub więcej takich składników.

  • Nowe sposoby podpisywania i rozpowszechniania plików bazy danych    W programie Access w wersjach starszych niż 2007 certyfikat zabezpieczeń był stosowany do poszczególnych składników bazy danych za pomocą Edytora Visual Basic. Teraz możesz spakować bazę danych, a następnie podpisać i rozpowszechnić ten pakiet.

    Po wyodrębnieniu bazy danych z podpisanego pakietu do zaufanej lokalizacji baza danych będzie otwierana bez wyświetlania paska komunikatów. W przypadku wyodrębnienia bazy danych z podpisanego pakietu do niezaufanej lokalizacji, gdy certyfikat pakietu został ustawiony jako zaufany i podpis jest prawidłowy, baza danych jest otwierana bez wyświetlania paska komunikatów.

    Uwaga : W przypadku spakowania i podpisania bazy danych, która nie jest zaufana lub zawiera nieprawidłowy podpis cyfrowy, przy każdym jej otwarciu trzeba użyć paska komunikatów, aby określić bazę danych jako zaufaną, chyba że zostanie ona umieszczona w zaufanej lokalizacji.

  • Silniejszy algorytm do szyfrowania baz danych w formacie pliku accdb, który korzysta z funkcji hasła bazy danych    Zaszyfrowanie bazy danych powoduje zakodowanie danych w tabelach i uniemożliwia niepożądanym użytkownikom odczytanie danych.

    Uwaga : Jeśli baza danych zostanie zaszyfrowana za pomocą hasła, niezależnie od ustawień aplikacji w bazie danych będzie używane szyfrowanie na poziomie strony. Może to mieć wpływ na dostępność danych w środowisku udostępnionym.

  • Nowa podklasa akcji makr uruchamianych, gdy baza danych jest wyłączona    Te bezpieczniejsze makra zawierają także funkcje obsługi błędów. Makra (również te zawierające akcje wyłączane przez program Access) można też osadzić bezpośrednio w dowolnej właściwości formularza, raportu lub kontrolki, która logicznie współpracowałyby z modułem kodu VBA lub makrem z wcześniejszych wersji programu Access.

Podczas wykonywania opisanych czynności pamiętaj o następujących zasadach:

  • Jeśli otworzysz bazę danych w zaufanej lokalizacji, wszystkie składniki będą uruchamiane bez konieczności podejmowania decyzji o zaufaniu.

  • Po spakowaniu, podpisaniu i wdrożeniu bazy danych za pomocą starszego formatu pliku (mdb lub mde) wszystkie składniki są uruchamiane bez podejmowania decyzji o zaufaniu, jeżeli baza danych zawiera prawidłowy podpis cyfrowy od zaufanego wydawcy, a certyfikat jest zaufany.

  • Jeśli podpiszesz i wdrożysz niezaufaną bazę danych w niezaufanej lokalizacji, Centrum zaufania domyślnie wyłączy tę bazę danych i trzeba ją będzie włączać przy każdym otwarciu.

Program Access i zabezpieczenia na poziomie użytkownika

Program Access nie obsługuje zabezpieczeń na poziomie użytkownika w przypadku baz danych utworzonych w nowym formacie pliku (accdb i accde). Jednak te ustawienia będą nadal działać, jeśli w programie Access 2010 otworzysz bazę danych z wcześniejszych wersji programu Access z zastosowanymi zabezpieczeniami na poziomie użytkownika.

Ważne : Uprawnienia utworzone przy użyciu funkcji zabezpieczeń na poziomie użytkownika nie chronią bazy danych przed użytkownikami mającymi złe zamiary i nie stanowią bariery zabezpieczającej. Tej funkcji należy używać w celu ulepszenia użyteczności bazy danych dla zaufanych użytkowników. Aby ułatwić zabezpieczanie danych, zezwalaj tylko zaufanym użytkownikom na dostęp do pliku bazy danych i powiązanych plików zabezpieczonych na poziomie użytkownika, korzystając z funkcji uprawnień do systemu plików systemu Windows.

Jeśli przekonwertujesz bazę danych z ustawieniami zabezpieczeń na poziomie użytkownika z wcześniejszej wersji programu Access na nowy format pliku, program Access automatycznie usunie wszystkie ustawienia zabezpieczeń, po czym zastosuje reguły dotyczące zabezpieczania plików accdb i accde.

Pamiętaj także, że po każdym otwarciu bazy danych w nowym formacie pliku wszystkie obiekty bazy danych będą widoczne dla innych użytkowników.

Architektura zabezpieczeń programu Access

Aby zrozumieć architekturę zabezpieczeń programu Access, trzeba pamiętać, że baza danych programu Access nie jest plikiem w takim samym znaczeniu jak skoroszyt programu Excel czy dokument programu Word. W rzeczywistości baza danych programu Access jest zestawem obiektów — na przykład tabel, formularzy, zapytań, makr i raportów — które często są między sobą powiązane Jeśli na przykład utworzysz formularz wprowadzania danych, wprowadzanie i przechowywanie danych za pomocą tego formularza będzie możliwe dopiero po powiązaniu (połączeniu) kontrolek formularza z tabelą.

Niektóre składniki programu Access mogą stanowić ryzyko związane z zabezpieczeniami, dlatego w niezaufanej bazie są wyłączone:

  • Zapytania funkcjonalne (zapytania powodujące wstawianie, usuwanie lub zmienianie danych)

  • Makra

  • Niektóre wyrażenia (funkcje, które zwracają pojedynczą wartość)

  • Kod VBA

Aby zagwarantować lepsze zabezpieczenie danych, program Access oraz Centrum zaufania przy każdym otwarciu bazy danych wykonują zestaw czynności sprawdzających zabezpieczenia. Ten proces przebiega następująco:

  • Po otwarciu pliku accdb lub accde program Access przesyła informacje o lokalizacji do Centrum zaufania. Jeśli Centrum zaufania ustali, że lokalizacja jest zaufana, baza danych zostanie uruchomiona jako w pełni funkcjonalna. W przypadku otwarcia bazy danych we wcześniejszym formacie pliku program Access wysyła informacje o lokalizacji i podpisie cyfrowym (jeżeli został on zastosowany) do Centrum zaufania.

    Centrum zaufania sprawdza te informacje, aby ocenić zaufanie dla bazy danych, a następnie przekazuje do programu Access instrukcje dotyczące sposobu otwarcia tej bazy. Program Access wyłącza tę bazę danych lub otwiera ją jako w pełni funkcjonalną.

    Uwaga : Pamiętaj, że ustawienia wybrane przez Ciebie lub administratora systemu w Centrum zabezpieczeń sterują wyborem zaufania podczas otwierania bazy danych w programie Access.

    Aby uzyskać więcej informacji o używaniu Centrum zaufania, zobacz sekcję Zobacz też.

  • Jeśli Centrum zaufania wyłączy zawartość bazy danych, w trakcie otwierania bazy danych zostanie wyświetlony pasek komunikatów.

    Pasek komunikatów

    Aby włączyć zawartość bazy danych, kliknij pozycję Opcje, a następnie wybierz odpowiednie opcje w wyświetlonym oknie dialogowym. Program Access włączy wyłączoną zawartość, a baza danych zostanie ponownie otwarta jako w pełni funkcjonalna. W przeciwnym razie wyłączone składniki nie będą działać.

  • W przypadku otwarcia bazy danych, która została utworzona we wcześniejszym formacie pliku (mdb lub mde) i nie jest podpisana ani zaufana, program Access domyślnie wyłącza każdą wykonywalną zawartość.

Tryb wyłączony

Jeśli Centrum zaufania oceni bazę danych jako niezaufaną, program Access otworzy ją w trybie wyłączonym, co oznacza, że niezależnie od formatu pliku bazy danych cała zawartość wykonywalna zostanie wyłączona.

W trybie wyłączonym program Access wyłącza następujące składniki:

  • Kod VBA, wszystkie odniesienia w kodzie VBA oraz wszystkie niebezpieczne wyrażenia.

  • Niebezpieczne akcje we wszystkich makrach. Za niebezpieczne są uznawane wszystkie czynności, które mogłyby umożliwić użytkownikowi modyfikację bazy danych lub uzyskanie dostępu do zasobów poza bazą danych. Jednak te czynności można niekiedy uznać za bezpieczne. Jeżeli na przykład autor bazy danych jest zaufany, można zaufać wszystkim niebezpiecznym akcjom wykonywanym przez makra.

  • Niektóre typy zapytań:

    • Zapytania funkcjonalne    Zapytania dodające, aktualizujące i usuwające dane.

    • Zapytania DDL (Data Definition Language)    Zapytania używane do tworzenia lub zmieniania obiektów bazy danych, takich jak tabele i procedury.

    • Zapytania przekazujące SQL    Zapytania przesyłające polecenia bezpośrednio do serwera bazy danych obsługującego standard ODBC (Open Database Connectivity). Zapytania przekazujące pracują z tabelami na serwerze bez pośrednictwa aparatu bazy danych programu Access.

  • Kontrolki ActiveX.

Niekiedy otwarcie bazy danych wiąże się z próbą załadowania przez program Access dodatków — programów, które rozszerzają funkcje programu Access lub otwartej bazy danych. Czasami jest także potrzebna możliwość uruchomienia kreatorów służących do tworzenia obiektów w otwartej bazie danych. Po załadowaniu dodatku lub uruchomieniu kreatora program Access przekazuje informacje do Centrum zaufania, które określa dodatkowe ustawienia dotyczące zaufania i włącza lub wyłącza obiekt albo akcję. Jeżeli Centrum zaufania wyłączy bazę danych, a Ty nie zgadzasz się z tą decyzją, prawie zawsze możesz włączyć zawartość za pomocą paska komunikatów. W przypadku dodatków istnieje wyjątek od tej reguły. Jeśli w Centrum zaufania (w okienku Dodatki) zaznaczysz pole wyboru Wymagaj podpisów zaufanego wydawcy w rozszerzeniach aplikacji, program Access wyświetli monit o włączenie dodatku, ale proces będzie się odbywał bez zastosowania paska komunikatów.

Początek strony

Używanie bazy danych programu Access w zaufanej lokalizacji

Po umieszczeniu bazy danych programu Access w zaufanej lokalizacji wszystkie makra, bezpieczne wyrażenia oraz kod VBA są uruchamiane podczas otwierania bazy danych. W trakcie otwierania bazy danych nie trzeba podejmować decyzji o zaufaniu.

Proces używania bazy danych programu Access w zaufanej lokalizacji obejmuje następujące ogólne kroki:

  1. znajdowanie lub tworzenie zaufanej lokalizacji za pomocą Centrum zaufania;

  2. zapisywanie, przenoszenie lub kopiowanie bazy danych programu Access do zaufanej lokalizacji;

  3. otwieranie i używanie bazy danych.

W podanych niżej krokach wyjaśniono, jak znaleźć lub utworzyć zaufaną lokalizację, a następnie dodać do niej bazę danych.

Otwieranie Centrum zaufania

  1. Na karcie Plik kliknij pozycję Opcje.

    Zostanie wyświetlone okno dialogowe Opcje programu Access.

  2. Kliknij pozycję Centrum zaufania i w obszarze Centrum zaufania programu Microsoft Office Access kliknij pozycję Ustawienia Centrum zaufania.

  3. Kliknij pozycję Zaufane lokalizacje i wykonaj jedną z następujących czynności:

    • Zanotuj ścieżkę jednej lub kilku zaufanych lokalizacji.

    • Utwórz nową zaufaną lokalizację. Aby to zrobić, kliknij pozycję Dodaj nową lokalizację, a następnie wybierz opcje w oknie dialogowym Zaufana lokalizacja pakietu Microsoft Office.

Umieszczanie bazy danych w zaufanej lokalizacji

  • Przenieś lub skopiuj plik bazy danych do zaufanej lokalizacji za pomocą ulubionej techniki. Możesz na przykład skopiować lub przenieść plik za pomocą Eksploratora Windows albo otworzyć plik w programie Access i zapisać go w zaufanej lokalizacji.

Otwieranie bazy danych w zaufanej lokalizacji

  • Otwórz plik za pomocą ulubionej techniki. Możesz na przykład kliknąć dwukrotnie plik bazy danych w Eksploratorze Windows. Jeżeli program Access jest uruchomiony, możesz kliknąć polecenie Otwórz na karcie Plik, aby zlokalizować i otworzyć plik.

Początek strony

Pakowanie, podpisywanie i rozpowszechnianie bazy danych programu Access 2010

Program Access ułatwia i przyspiesza podpisywanie oraz rozpowszechnianie bazy danych. Utworzony plik accdb lub accde można spakować, opatrzyć podpisem cyfrowym, a następnie rozpowszechnić w celu udostępnienia innym użytkownikom. Narzędzie Spakuj i podpisz umieszcza bazę danych w pliku wdrażania programu Access (accdc), podpisuje plik, a następnie umieszcza podpisany pakiet w wybranej lokalizacji. Inne osoby mogą następnie wyodrębniać bazę danych z pakietu i pracować bezpośrednio w bazie danych (nie w pliku pakietu).

Podczas dalszej pracy pamiętaj o następujących kwestiach:

  • Przez spakowanie bazy danych i podpisanie pakietu można przekazać informacje o zaufaniu. Gdy spakujesz i podpiszesz bazę danych, Twój podpis cyfrowy potwierdza, że baza danych nie została zmieniona od chwili utworzenia pakietu.

  • Po wyodrębnieniu bazy danych z pakietu nie ma już połączenia między podpisanym pakietem i wyodrębnioną bazą danych.

  • Narzędzia Spakuj i podpisz można używać tylko z bazami danych zapisanymi w formacie pliku accdb, accdc lub accde. Program Access udostępnia też narzędzia do podpisywania i rozpowszechniania baz danych utworzonych w starszym formacie pliku. Musisz użyć narzędzia podpisu cyfrowego odpowiedniego dla używanego formatu pliku bazy danych.

  • Do pakietu można dodać tylko jedną bazę danych.

  • Proces cyfrowo podpisuje pakiet zawierający całą bazę danych, a nie tylko makra czy moduły.

  • Proces kompresuje plik pakietu, aby skrócić czas pobierania.

  • Bazy danych można wyodrębnić z plików pakietów znajdujących się na serwerach programu Windows SharePoint Services 3.0.

W poniższych sekcjach wyjaśniono, jak utworzyć podpisany plik pakietu oraz jak wyodrębnić bazę danych z podpisanego pliku pakietu i jak z niej korzystać.

Tworzenie podpisanego pakietu

  1. Otwórz bazę danych, którą chcesz spakować i podpisać.

  2. Na karcie Plik kliknij pozycję Zapisz i publikuj, a następnie w obszarze Zaawansowane kliknij pozycję Spakuj i podpisz.

    Zostanie wyświetlone okno dialogowe Wybieranie certyfikatu.

  3. Wybierz certyfikat cyfrowy, a następnie kliknij przycisk OK.

    Zostanie wyświetlone okno dialogowe Tworzenie podpisanego pakietu programu Microsoft Office Access.

  4. Na liście Zapisz w wybierz lokalizację, w której chcesz umieścić podpisany pakiet bazy danych.

  5. W polu Nazwa pliku wprowadź nazwę dla podpisanego pakietu, a następnie kliknij pozycję Utwórz.

    Program Access utworzy plik accdc i umieści go w wybranej lokalizacji.

Wyodrębnianie i używanie podpisanego pakietu

  1. Na karcie Plik kliknij pozycję Otwórz.

    Zostanie wyświetlone okno dialogowe Otwieranie.

  2. Jako typ pliku wybierz pozycję Podpisane pakiety programu Microsoft Office Access (*.accdc).

  3. Za pomocą listy Szukaj w znajdź folder zawierający odpowiedni plik accdc, zaznacz ten plik, a następnie kliknij przycisk Otwórz.

  4. Wykonaj jedną z następujących czynności:

    • Jeśli certyfikat zabezpieczeń, za pomocą którego podpisano pakiet wdrożenia, został uznany za zaufany, zostanie wyświetlone okno dialogowe Wyodrębnianie bazy danych do. Przejdź do następnego kroku.

    • W przeciwnym razie zostanie wyświetlony poniższy komunikat.

      Wskazówka

      Jeśli baza danych jest zaufana, kliknij pozycję Otwórz. Jeśli wszystkie certyfikaty od tego dostawcy są zaufane, kliknij pozycję Zawsze ufaj zawartości od tego wydawcy. Zostanie wyświetlone okno dialogowe Wyodrębnianie bazy danych do.

      Uwaga : Jeśli podpiszesz pakiet bazy danych za pomocą certyfikatu z podpisem własnym, a następnie podczas otwierania tego pakietu klikniesz pozycję Zawsze ufaj zawartości od tego wydawcy, to pakiety podpisane za pomocą certyfikatów z podpisami własnymi zawsze będą zaufane.

  5. Opcjonalnie na liście Zapisz w wybierz lokalizację, w której chcesz umieścić wyodrębnioną bazę danych, a następnie w polu Nazwa pliku wprowadź inną nazwę dla wyodrębnionej bazy danych.

    Porada : Jeśli wyodrębnisz bazę danych do zaufanej lokalizacji, jej zawartość będzie automatycznie włączana przy każdym otwarciu. Jeśli wybierzesz lokalizację, która nie jest zaufana, pewna część zawartości bazy danych może zostać domyślnie wyłączona.

  6. Kliknij przycisk OK.

W przypadku wątpliwości dotyczących wiarygodności certyfikatu zapoznaj się z artykułem Jak stwierdzić, czy podpis cyfrowy jest wiarygodny, w którym podano ogólne informacje o sprawdzaniu dat i innych pozycji w certyfikacie, ułatwiających potwierdzenie jego ważności.

Początek strony

Włączanie wyłączonej zawartości podczas otwierania bazy danych

Domyślnie program Access wyłącza całą wykonywalną zawartość w bazie danych, chyba że baza danych jest zaufana lub znajduje się w zaufanej lokalizacji. Podczas otwierania bazy danych program Access wyłącza zawartość i wyświetla pasek komunikatów.

Pasek komunikatów

Także domyślnie program Access nie wyświetla już zestawu modalnych okien dialogowych (okien dialogowych, które wymagają od użytkownika podjęcia decyzji, bez której nie można przejść do następnych czynności) podczas otwierania bazy danych, jak to było w programie Access 2003. Jeśli jednak preferujesz takie zachowanie, możesz dodać klucz rejestru, aby wyświetlać starsze modalne okno dialogowe.

Ustawianie bazy danych jako zaufanej

Niezależnie od zachowania programu Access, podczas otwierania bazy danych pochodzącej od zaufanego wydawcy możesz włączyć wykonywalne składniki znajdujące się w pliku, aby ustawić bazę danych jako zaufaną.

  • Na pasku komunikatów kliknij przycisk Włącz zawartość.

Ważne : Po kliknięciu pozycji Włącz zawartość program Access włączy całą wyłączoną zawartość, w tym potencjalnie złośliwy kod. Jeśli złośliwy kod uszkodzi dane lub komputer, program Access nie będzie mógł naprawić uszkodzeń.

Ukrywanie paska komunikatów

  • Kliknij przycisk Zamknij (X) w górnym rogu paska komunikatów.

    Pasek komunikatów zostanie zamknięty. Przy następnym otwarciu bazy danych zostanie on wyświetlony ponownie, chyba że przeniesiesz bazę danych do zaufanej lokalizacji.

Dodawanie klucza rejestru w celu wyświetlenia modalnych okien dialogowych

Przestroga   Nieprawidłowe edytowanie rejestru może spowodować poważne uszkodzenie systemu operacyjnego wymagające jego ponownej instalacji. Firma Microsoft nie może zagwarantować, że problemy powstałe w wyniku nieprawidłowego edytowania rejestru będzie można rozwiązać. Przed edytowaniem rejestru należy wykonać kopie zapasowe wszystkich ważnych danych. Najnowsze informacje dotyczące używania i ochrony rejestru komputera znajdują się w Pomocy systemu Microsoft Windows.

  1. W systemie Microsoft Windows kliknij przycisk Start, a następnie kliknij polecenie Uruchom.

  2. W oknie dialogowym Otwieranie wpisz ciąg regedit, a następnie naciśnij klawisz ENTER.

    Zostanie uruchomiony Edytor rejestru.

  3. Rozwiń folder HKEY_CURRENT_USER i przejdź do następującego klucza rejestru:

    Software\Microsoft\Office\14.0\Access\Security

  4. W prawym okienku Edytora rejestru kliknij prawym przyciskiem myszy pusty obszar, wskaż polecenie Nowy i kliknij pozycję Wartość DWORD. Zostanie wyświetlona nowa pusta wartość DWORD.

  5. Wpisz następującą nazwę wartości: ModalTrustDecisionOnly.

  6. Kliknij dwukrotnie nową wartość.

    Zostanie wyświetlone okno dialogowe Edytowanie wartości DWORD.

  7. W polu Dane wartości zmień wartość 0 na 1, a następnie kliknij przycisk OK.

  8. Zamknij Edytor rejestru.

Teraz po otwarciu bazy danych z niebezpieczną zawartością zamiast paska komunikatów zostanie wyświetlona seria okien dialogowych. Aby przywrócić pierwotne zachowanie, powtórz powyższe kroki i zamień wartość 1 na 0.

Początek strony

Szyfrowanie bazy danych programu Access za pomocą hasła bazy danych

W narzędziu do szyfrowania dostępnym w programie Access połączono i ulepszono funkcje dwóch starszych narzędzi — kodowania i haseł bazy danych. Zaszyfrowanie bazy danych za pomocą hasła powoduje, że danych nie można odczytać innymi narzędziami i użytkownicy muszą wprowadzić hasło, aby korzystać z bazy danych. W programie Access 2010 zastosowano algorytm szyfrowania silniejszy niż we wcześniejszych wersjach programu Access.

Uwaga : Jeśli w programie Access 2007 bazy danych były szyfrowane za pomocą hasła, możesz zmienić technologię szyfrowania na nową, zapewniającą większe bezpieczeństwo.

Zmienianie technologii szyfrowania zastosowanej w zaszyfrowanej bazie danych programu Access 2007 na nową

Aby zmienić technologię szyfrowania na nową, usuń bieżące hasło bazy danych, a następnie dodaj je z powrotem.

Szyfrowanie za pomocą hasła bazy danych

  1. Otwórz bazę danych, którą chcesz zaszyfrować, w trybie wyłączności.

    Otwieranie bazy danych w trybie wyłączności

    1. Na karcie Plik kliknij pozycję Otwórz.

    2. W oknie dialogowym Otwieranie przejdź do pliku, który chcesz otworzyć, a następnie zaznacz go.

    3. Kliknij strzałkę obok przycisku Otwórz, a następnie kliknij polecenie Otwórz z wyłącznością.

      Otwieranie pliku w trybie wyłączności

  2. Na karcie Plik kliknij pozycję Informacje, a następnie kliknij pozycję Szyfruj przy użyciu hasła.

    Zostanie wyświetlone okno dialogowe Ustawianie hasła bazy danych.

  3. Wpisz hasło w polu Hasło,a następnie wpisz je ponownie w polu Potwierdź.

    Uwagi : 

    • Za pomocą silnych haseł, które łączenie wielkie i małe litery, numery i symbole. Słabych haseł nie można mieszać tych elementów. Silne hasło: Y6dh! et5. Słabym hasłem: House27. Hasła powinny być co najmniej 8 znaków. Lepiej jest hasło, która korzysta z 14 znaków.

    • Zapamiętanie hasła jest bardzo ważne. Zapomnianego hasła firma Microsoft nie może odtworzyć. Zapisane hasła należy przechowywać w bezpiecznym miejscu, z dala od informacji chronionych przez te hasła.

  4. Kliknij przycisk OK.

Odszyfrowywanie i otwieranie bazy danych

  1. Otwórz zaszyfrowaną bazę danych w taki sam sposób, jak inne bazy danych.

    Zostanie wyświetlone okno dialogowe Wymagane hasło.

  2. Wpisz hasło w polu Wprowadź hasło bazy danych, a następnie kliknij przycisk OK.

Usuwanie hasła

  1. Na karcie Plik kliknij pozycję Informacje, a następnie kliknij pozycję Odszyfruj bazę danych.

    Zostanie wyświetlone okno dialogowe Cofanie ustawienia hasła bazy danych.

  2. Wpisz hasło w polu Hasło, a następnie kliknij przycisk OK.

Początek strony

Jak działają zabezpieczenia w przypadku baz danych z wcześniejszych wersji programu Access otwartych w programie Access 2010

Gdy otwierasz bazę danych utworzoną we wcześniejszej wersji programu Access, wszystkie funkcje zabezpieczeń zastosowane do tej bazy danych będą nadal działać. Jeśli na przykład do bazy danych zastosowano zabezpieczenia na poziomie użytkownika, ta funkcja działa w programie Access 2010.

Domyślnie program Access otwiera wszystkie starsze niezaufane bazy danych w trybie wyłączonym i pozostawia je w tym stanie. Wyłączoną zawartość można włączyć przy każdym otwarciu starszej bazy danych. Można również zastosować podpis cyfrowy, używając certyfikatu od zaufanego wydawcy, a także umieścić bazę danych w zaufanej lokalizacji.

Ważne : Czynności opisane w tej sekcji nie mają zastosowania do baz danych używających jednego z nowych formatów plików (accd?).

W przypadku baz danych w starszym formacie pliku do składników w bazie danych można zastosować podpis cyfrowy. Podpis cyfrowy potwierdza, że wszelkie makra, moduły kodu i inne wykonywalne składniki w bazie danych zostały utworzone przez osobę podpisującą i że nikt ich nie zmienił od chwili podpisania bazy danych.

Aby zastosować podpis do bazy danych, najpierw jest potrzebny certyfikat cyfrowy. Jeśli tworzysz bazy danych do komercyjnego rozpowszechniania, musisz uzyskać certyfikat od komercyjnego urzędu certyfikacji. Urzędy certyfikacji sprawdzają, czy osoby tworzące zawartość (taką jak bazy danych) są godne zaufania.

Aby dowiedzieć się więcej na temat urzędów certyfikacji oferujących usługi dla produktów firmy Microsoft, skorzystaj z sekcji Zobacz też.

Jeśli chcesz użyć bazy danych w scenariuszach osobistych lub w scenariuszach z udziałem grupy roboczej o ograniczonym rozmiarze, pakiet Microsoft Office Professional 2007 udostępnia narzędzie do tworzenia certyfikatu z podpisem własnym. W procedurach opisanych w poniższych sekcjach wyjaśniono, jak zainstalować narzędzie o nazwie SelfCert.exe oraz jak za jego pomocą utworzyć certyfikat z podpisem własnym.

Tworzenie certyfikatu z podpisem własnym

  1. Przejdź do folderu, który zawiera pliki programów pakietu Office 2010. Domyślny folder to dysk:\Program Files\Microsoft Office\Office14. W tym folderze odszukaj i kliknij dwukrotnie plik SelfCert.exe.

    Zostanie wyświetlone okno dialogowe Tworzenie certyfikatu cyfrowego.

  2. W polu Nazwa certyfikatu wpisz nazwę nowego certyfikatu testowego.

  3. Kliknij dwa razy przycisk OK.

Uwaga : Jeśli nie widzisz polecenia Certyfikat cyfrowy dla projektów VBA lub nie możesz znaleźć pliku SelfCert.exe, być może musisz zainstalować program SelfCert.

Podpisywanie kodu bazy danych

Uwaga : Pamiętaj, że ta procedura ma zastosowanie tylko podczas używania baz danych, które są w starszym formacie pliku, na przykład w formacie pliku mdb.

  1. Otwórz bazę danych, którą chcesz podpisać.

  2. Na karcie Narzędzia bazy danych w grupie Makro kliknij pozycję Visual Basic, aby uruchomić Edytor Visual Basic.

    Skrót klawiaturowy  naciśnij klawisze ALT+F11.

  3. W oknie Eksplorator projektu wybierz bazę danych lub projekt VBA (Visual Basic for Applications), które chcesz podpisać.

  4. W menu Narzędzia kliknij polecenie Podpis cyfrowy.

    Zostanie wyświetlone okno dialogowe Podpis cyfrowy.

  5. Kliknij przycisk Wybierz, aby wybrać certyfikat cyfrowy.

    Zostanie wyświetlone okno dialogowe Wybieranie certyfikatu.

  6. Wybierz certyfikat, który chcesz zastosować.

    Jeśli zostały wykonane kroki opisane w poprzedniej sekcji, wybierz certyfikat utworzony za pomocą narzędzia SelfCert.

  7. Kliknij przycisk OK, aby zamknąć okno dialogowe Certyfikat z podpisem własnym, a następnie ponownie kliknij przycisk OK, aby zamknąć okno dialogowe Podpis cyfrowy.

Porady dotyczące podpisywania starszych wersji baz danych

  • Aby zapobiec przypadkowym modyfikacjom projektu VBA przez innych użytkowników i unieważnieniu jego podpisu, zablokuj projekt VBA przed podpisaniem.

    Uwaga : Zablokowanie projektu VBA nie uniemożliwia innemu użytkownikowi zastąpienia podpisu cyfrowego innym podpisem. Administratorzy korporacyjni mogą ponownie podpisywać szablony i dodatki, aby dokładnie kontrolować, co użytkownicy mogą uruchamiać na komputerach.

  • Podczas cyfrowego podpisywania projektu VBA rozważ uzyskanie sygnatury czasowej, aby inne osoby mogły zweryfikować Twój podpis nawet po wygaśnięciu certyfikatu użytego w przypadku tego podpisu. Aby uzyskać więcej informacji na temat zabezpieczeń VBA i sygnatur czasowych, zobacz witrynę Microsoft Office Online.

Uwaga : Pamiętaj, że te kroki mają zastosowanie tylko wtedy, gdy w programie Access 2010 są używane bazy danych w starszym formacie pliku.

Instalowanie programu SelfCert.exe

  1. Uruchom instalacyjny dysk CD lub inny nośnik instalacyjny pakietu Office 2010.

  2. W oknie Instalatora kliknij pozycję Dodaj lub usuń funkcje, a następnie kliknij przycisk Kontynuuj.

    Jeśli pracujesz w środowisku, w którym pakiet Microsoft Office został zainstalowany na poszczególnych komputerach przez administratorów, a nie za pomocą dysków CD, wykonaj następujące czynności:

    1. W systemie Microsoft Windows otwórz Panel sterowania.

    2. Kliknij dwukrotnie pozycję Programy i funkcje.

    3. Wybierz pozycję Microsoft Office 2010, a następnie kliknij przycisk Zmień.

      Zostanie uruchomiony Instalator.

    4. Kliknij pozycję Dodaj lub usuń funkcje, a następnie kliknij przycisk Kontynuuj.

    5. Wykonaj poniższe czynności.

  3. Rozwiń węzły Microsoft Office i Funkcje wspólne pakietu Office, klikając znajdujące się obok nich znaki plus (+).

  4. Kliknij pozycję Certyfikat cyfrowy dla projektów VBA.

  5. Kliknij pozycję Uruchom z mojego komputera.

  6. Kliknij przycisk Kontynuuj, aby zainstalować składnik.

  7. Kliknij przycisk Zamknij po zakończeniu instalacji, a następnie wróć do pierwszego zestawu czynności w tej sekcji.

Początek strony

Uruchamianie niebezpiecznych wyrażeń (wyłączanie trybu piaskownicy)

Po dodaniu wyrażenia do bazy danych, a następnie ustawieniu jej jako zaufanej lub umieszczeniu w zaufanej lokalizacji, program Access uruchamia to wyrażenie w środowisku operacyjnym określanym jako tryb piaskownicy. Dzieje się tak zarówno w przypadku baz danych utworzonych w programie Access, jak i wcześniejszych formatów plików. Program Access domyślnie włącza tryb piaskownicy, w którym wszystkie niebezpieczne wyrażenia są wyłączane, nawet jeśli baza danych została ustawiona jako zaufana. Aby uzyskać więcej informacji dotyczących wyrażeń wyłączanych w trybie piaskownicy, zobacz artykuł w witrynie Microsoft Office.com: Tryb piaskownicy usługi wyrażeń programu Microsoft Jet.

Jeśli baza danych została ustawiona jako zaufana i chcesz uruchomić wyrażenie wyłączone przez tryb piaskownicy, możesz zmienić klucz rejestru i wyłączyć tryb piaskownicy. Pamiętaj, że aby wykonać te kroki, najpierw trzeba ustawić bazę danych jako zaufaną.

Poniższy rysunek przedstawia proces decyzji, który pozwala uruchomić niebezpieczne wyrażenia.

Proces decyzyjny dla trybu piaskownicy

Przestroga   Nieprawidłowe edytowanie rejestru może spowodować poważne uszkodzenie systemu operacyjnego wymagające jego ponownej instalacji. Firma Microsoft nie może zagwarantować, że problemy powstałe w wyniku nieprawidłowego edytowania rejestru będzie można rozwiązać. Przed edytowaniem rejestru należy wykonać kopie zapasowe wszystkich ważnych danych. Najnowsze informacje dotyczące używania i ochrony rejestru komputera znajdują się w Pomocy systemu Microsoft Windows.

Jeśli nie znasz rejestru lub nie chcesz zmieniać kluczy rejestru, skontaktuj się z osobą, która potrafi wykonywać te czynności, lub rozważ konwersję bazy danych z wcześniejszej wersji programu Access na nowszy format pliku. Ponadto, aby zmienić wartości rejestru, trzeba mieć uprawnienia administratora na danym komputerze.

Zmienianie klucza rejestru

Ważne : Wykonanie tych czynności umożliwi wszystkim użytkownikom tego komputera uruchamianie niebezpiecznych wyrażeń we wszystkich wystąpieniach programu Access.

  1. W systemie Microsoft Windows kliknij przycisk Start, a następnie kliknij polecenie Uruchom.

  2. W oknie dialogowym Otwieranie wpisz ciąg regedit, a następnie naciśnij klawisz ENTER.

    Zostanie uruchomiony Edytor rejestru.

  3. Rozwiń folder HKEY_LOCAL_MACHINE i przejdź do następującego klucza rejestru:

    \Software\Microsoft\Office\14.0\Access Connectivity Engine\Engines

  4. W prawym okienku edytora rejestru kliknij dwukrotnie wartość SandboxMode.

    Zostanie wyświetlone okno dialogowe Edytowanie wartości DWORD.

  5. W polu Dane wartości zmień wartość z 3 na 2, a następnie kliknij przycisk OK.

  6. Zamknij Edytor rejestru.

Ważne    Pamiętaj, że jeśli baza danych nie zostanie najpierw ustawiona jako zaufana, program Access wyłączy wszystkie niebezpieczne wyrażenia niezależnie od zmian wprowadzonych w tym ustawieniu rejestru.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×