Wprowadzenie do tabel

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Tabele to podstawowe obiekty bazy danych, w których są przechowywane wszystkie informacje lub dane. Na przykład baza danych przedsiębiorstwa może zawierać tabelę Kontakty, w której są przechowywane nazwy, adresy e-mail i numery telefonów dostawców. Ten artykuł zawiera omówienie tabel w programie Access. Przed utworzeniem tabel przeanalizuj wymagania i ustal, jakie tabele będą potrzebne. Aby uzyskać informacje wprowadzające na temat planowania i projektowania baz danych, zobacz Podstawowe informacje o projekcie bazy danych.

W tym artykule

Omówienie

Dodawanie tabeli do bazy danych dla komputerów stacjonarnych

Tabele w aplikacjach sieci web programu Access

Zapisywanie tabeli

Omówienie

Relacyjna baza danych, taka jak baza danych programu Access, zawiera zazwyczaj kilka powiązanych tabel. W dobrze zaprojektowanej bazie danych każda tabela zawiera dane dotyczące określonego tematu, na przykład dane pracowników lub produktów. Tabela zawiera rekordy (wiersze) i pola (kolumny). Pola mają różne typy danych, takie jak tekst, liczby, daty i hiperłącza.

Tabela Klienci w programie Access, na przykładzie której pokazano układ rekordów i pól

  1. Rekord: zawiera określone dane, takie jak informacje o określonym pracownikiem lub produktu.

  2. Pole: zawiera dane o jeden z aspektów temat tabeli, takich jak imię lub adres e-mail.

  3. Wartość pola: każdy rekord ma wartość pola. Na przykład Contoso, Ltd. lub someone@example.com.

Właściwości tabel i pól

Charakterystyka oraz zachowanie tabel i pól jest określane i kontrolowane przez ich właściwości. Właściwości tabeli ustawia się w arkuszu właściwości tabeli, na przykład właściwość Widok domyślny tabeli można ustawić w taki sposób, aby określała domyślny sposób wyświetlania tabeli. Właściwość pola określa pewien aspekt jego zachowania. Właściwości pola można również ustawić w widoku projektu przy użyciu okienka Właściwości pola. Każde pole ma również typ danych określający rodzaj przechowywanych w nim informacji. Typy danych to na przykład wiele wierszy tekstu lub waluta.

Relacje między tabelami

Mimo że w każdej tabeli bazy danych są przechowywane dane dotyczące określonego tematu, tabele relacyjnych baz danych, takie jak tabele w bazach danych programu Access, zwykle zawierają dane dotyczące powiązanych tematów. Baza danych może na przykład zawierać:

  • tabelę klientów obejmującą klientów firmy oraz ich adresy,

  • tabelę produktów obejmującą sprzedawane produkty, w tym ceny i zdjęcia każdego z nich,

  • tabelę zamówień umożliwiającą śledzenie zamówień klientów.

Aby połączyć dane przechowywane w różnych tabelach, należy utworzyć relacje. Relacja jest logicznym połączeniem między dwiema tabelami mającymi wspólne pole.

Klucze

Pola będące częścią relacji tabel są określane jako klucze. Klucz zwykle składa się z jednego pola, ale może składać się z wielu pól. Istnieją dwa rodzaje kluczy:

  • Klucz podstawowy: tabela może mieć tylko jeden klucz podstawowy. Klucz podstawowy składa się z jednego lub więcej pól, które jednoznacznie identyfikować każdy rekord, który jest przechowywany w tabeli. Program Access automatycznie zawiera unikatowy numer identyfikacyjny, o nazwie numer identyfikacyjny, który służy jako klucz podstawowy. Aby uzyskać więcej informacji, zobacz Dodawanie lub zmienianie klucza podstawowego tabeli.

  • Klucz obcy: tabela może mieć jeden lub więcej kluczy obcych. Klucz obcy zawiera wartości odpowiadające wartościom w kluczu podstawowym innej tabeli. Przykładem może być tabela Zamówienia, w której dla każdego zamówienia istnieje numer identyfikacyjny klienta odpowiadający rekordowi w tabeli Klienci. Pole identyfikatora klienta jest kluczem obcym tabeli Zamówienia.

Podstawą relacji między tabelami jest zgodność wartości w polach kluczy. Takie relacje służą do łączenia danych z powiązanych tabel. Załóżmy na przykład, że utworzono tabelę Klienci i tabelę Zamówienia. W tabeli Klienci poszczególne rekordy są identyfikowane przy użyciu pola klucza podstawowego o nazwie Identyfikator.

Aby skojarzyć każde zamówienie z klientem, do tabeli Zamówienia należy dodać pole klucza obcego odpowiadające polu Identyfikator tabeli Klienci, a następnie utworzyć relację między tymi dwoma kluczami. W przypadku dodawania rekordu do tabeli Zamówienia używana wartość identyfikatora klienta będzie pochodzić z tabeli Klienci. Gdy będzie konieczne wyświetlenie informacji o kliencie związanym z określonym zamówieniem, ta relacja umożliwi zidentyfikowanie, które dane z tabeli Klienci odpowiadają poszczególnym rekordom w tabeli Zamówienia.

Relacja między tabelami programu Access widoczna w oknie Relacje
  1. Klucz podstawowy jest identyfikowany przy użyciu ikony obok nazwy pola klucza.

  2. Klucz obcy — Uwaga braku ikonę klucza.

Zalety korzystania z relacji

Przechowywanie danych w osobnych, powiązanych tabelach ma następujące zalety:

  • Spójność    W związku z tym, że każdy element danych jest rejestrowany tylko raz, w jednej tabeli, zmniejsza się prawdopodobieństwo wystąpienia niejednoznaczności lub niespójności. Na przykład nazwa klienta jest przechowywana tylko raz, w tabeli dotyczącej klientów, a nie wielokrotnie (i potencjalnie niespójnie) w tabeli zawierającej dane dotyczące zamówień.

  • Wydajność    Rejestrowanie danych tylko w jednym miejscu zmniejsza użycie miejsca na dysku. Ponadto mniejsze tabele pozwalają udostępniać dane szybciej niż duże. Gdyby oddzielne tabele nie były stosowane w przypadku osobnych tematów, umożliwiłoby to wprowadzanie wartości null (brak danych) i nadmiarowych danych, co z kolei spowodowałoby utratę miejsca i pogorszenie wydajności.

  • Zrozumiałość    Projekt bazy danych jest łatwiejszy do zrozumienia, jeśli dane dla poszczególnych tematów są właściwie rozmieszczone w tabelach.

Początek strony

Dodawanie tabeli do bazy danych programu Access pulpitu

Nową tabelę należy utworzyć, gdy nowe źródło danych nie jest odpowiednie dla istniejących tabel. Istnieje kilka sposobów umożliwiających dodanie tabeli do bazy danych, na przykład utworzenie nowej bazy danych, wstawienie tabeli do istniejącej bazy danych lub zaimportowanie albo połączenie tabeli z innego źródła danych — skoroszytu programu Microsoft Excel, dokumentu programu Microsoft Word, pliku tekstowego, usługi sieci Web czy innej bazy danych. Do utworzonej nowej, pustej bazy danych jest automatycznie wstawiana nowa, pusta tabela. Następnie można wprowadzić dane, aby rozpocząć definiowanie pól.

Aby uzyskać więcej informacji o dodawaniu pole do bazie danych dla komputerów stacjonarnych zobacz artykuł Dodawanie pola do tabeli.

Tworzenie nowej tabeli w nowej bazie danych dla komputerów stacjonarnych

  1. Na karcie Plik kliknij pozycję Nowy > Pusta baza danych dla komputerów stacjonarnych.

  2. W polu Nazwa pliku wpisz nazwę pliku nowej bazy danych.

  3. Aby zapisać bazę danych w innej lokalizacji, kliknij ikonę folderu.

  4. Kliknij przycisk Utwórz.

Po otwarciu nowej bazy danych z nową tabelą o nazwie Tabela1 zmień nazwę tej tabeli w oparciu o typ przechowywanych w niej danych.

Tworzenie tabeli w istniejącej bazie danych

  1. Kliknij kolejno pozycje Plik > Otwórzi jeśli odpowiednia baza danych znajduje się na liście Ostatnio używane, kliknij ją. W innym przypadku możesz użyć jednej z opcji przeglądania, aby zlokalizować odpowiednią bazę danych.

  2. Na karcie Tworzenie kliknij pozycję Tabela.

Nowa tabela zostanie dodana i otwarta w widoku arkusza danych.

Początek strony

Dane zewnętrzne

Użytkownik może tworzyć łącza do różnych zewnętrznych źródeł danych, takich jak inne bazy danych, pliki tekstowe i skoroszyty programu Excel. Łącza z danymi zewnętrznymi mogą być używane w programie Access tak samo jak tabele. W zależności od zewnętrznego źródła danych i sposobu, w jaki utworzono łącze, mogą być dostępne funkcje edytowania danych w połączonej tabeli i tworzenia relacji obejmujących połączoną tabelę. Za pomocą utworzonego łącza nie można jednak zmieniać projektu danych zewnętrznych.

Importowanie lub łączenie w celu utworzenia tabeli

Tabelę można utworzyć przez zaimportowanie lub połączenie danych przechowywanych w innym miejscu. Można zaimportować lub połączyć dane znajdujące się między innymi w arkuszu programu Excel, na liście programu Windows SharePoint Services, w pliku XML, w innej bazie danych programu Access lub w folderze programu Microsoft Outlook.

Podczas importowania danych jest tworzona ich kopia w nowej tabeli w bieżącej bazie danych. Kolejne zmiany danych źródłowych nie będą miały wpływu na zaimportowane dane, a zmiany dotyczące zaimportowanych danych nie będą miały wpływu na dane źródłowe. Po nawiązaniu połączenia ze źródłem danych i zaimportowaniu danych można z nich korzystać, nie mając połączenia ze źródłem. Projekt zaimportowanej tabeli można zmienić.

Utworzenie łącza z danymi powoduje, że w bieżącej bazie danych jest tworzona tabela połączona, reprezentująca aktualizowane na bieżąco łącze z informacjami przechowywanymi w innym miejscu. Zmiana danych w tabeli połączonej powoduje ich zmianę w źródle. Każda zmiana danych w źródle jest widoczna w tabeli połączonej. W przypadku korzystania z tabeli połączonej użytkownik musi mieć możliwość nawiązania połączenia ze źródłem danych. Projektu tabeli połączonej nie można zmienić.

Uwaga : Przy użyciu tabeli połączonej nie można edytować danych w arkuszu programu Excel. Można natomiast zaimportować dane źródłowe do bazy danych programu Access, a następnie utworzyć łącze do niej z poziomu programu Excel. Aby uzyskać więcej informacji na temat tworzenia łączy do programu Access z poziomu programu Excel, należy przeszukać Pomoc programu Excel.

Tworzenie nowej tabeli przez zaimportowanie lub połączenie danych zewnętrznych

  1. Na karcie Dane zewnętrzne w grupie Importowanie i łączenie kliknij jedno z dostępnych źródeł danych.

  2. Postępuj zgodnie z instrukcjami w oknach dialogowych wyświetlanych na poszczególnych etapach.

    Program Access utworzy nową tabelę i wyświetli ją w okienku nawigacji.

Porada :  Można również zaimportować dane z listy programu SharePoint lub utworzyć do niej link. Aby uzyskać więcej informacji, zobacz Importowanie danych z listy programu SharePoint lub łączenie z nią danych.

Początek strony

Tworzenie tabeli przy użyciu witryny programu SharePoint

W bazie danych można utworzyć tabelę w celu zaimportowania danych z listy programu SharePoint lub utworzenia łącza z taką listą. Można również utworzyć nową listę programu SharePoint, korzystając ze wstępnie zdefiniowanego szablonu.

  1. W obszarze Tworzenie kliknij pozycję Listy programu SharePoint i wykonaj jedną z następujących czynności:

  2. Tworzenie listy programu SharePoint na podstawie szablonu

    1. Kliknij pozycję Kontakty, Zadania, Problemy lub Wydarzenia.

    2. W oknie dialogowym Tworzenie nowej listy wpisz adres URL witryny programu SharePoint, w której chcesz utworzyć listę.

    3. Wprowadź nazwę nowej listy oraz jej opis w polach Określ nazwę nowej listy i Opis.

    4. Aby po utworzeniu połączonej tabeli otworzyć ją, zaznacz pole wyboru Otwórz listę po zakończeniu (domyślnie zaznaczone).

  3. Tworzenie nowej listy niestandardowej

    1. Kliknij pozycję Niestandardowa. W oknie dialogowym Tworzenie nowej listy wpisz adres URL witryny programu SharePoint, w której chcesz utworzyć listę.

    2. Wprowadź nazwę nowej listy oraz jej opis w polach Określnazwę nowej listy i Opis.

    3. Aby po utworzeniu połączonej tabeli otworzyć ją, zaznacz pole wyboru Otwórz listę po zakończeniu (domyślnie zaznaczone).

  4. Importowanie danych z istniejącej listy

    1. Kliknij pozycję Istniejąca lista programu SharePoint.

    2. W oknie dialogowym Pobieranie danych zewnętrznych wpisz adres URL witryny programu SharePoint zawierającej dane, które chcesz zaimportować.

    3. Kliknij pozycję Importuj dane źródłowe do nowej tabeli w bieżącej bazie danych, a następnie kliknij przycisk Dalej.

    4. Zaznacz pole wyboru obok każdej listy programu SharePoint, którą chcesz zaimportować.

  5. Łączenie z istniejącą listą

    1. Kliknij pozycję Istniejąca lista programu SharePoint.

    2. W oknie dialogowym Pobieranie danych zewnętrznych — witryna programu SharePoint wpisz adres URL witryny programu SharePoint zawierającej listę, do której chcesz utworzyć łącze.

    3. Kliknij pozycję Połącz ze źródłem danych, tworząc tabelę połączoną, a następnie kliknij przycisk Dalej.

    4. Zaznacz pole wyboru obok każdej listy programu SharePoint, do której chcesz utworzyć łącze.

Początek strony

Tworzenie tabeli przy użyciu usługi sieci Web

W bazie danych można utworzyć tabelę połączoną z danymi w witrynie sieci Web udostępniającej interfejs usługi sieci Web.

Uwaga : Tabele usług sieci Web są dostępne tylko do odczytu.

  1. Na karcie Dane zewnętrzne w grupie Importowanie i łączenie kliknij pozycję Więcej, a następnie kliknij pozycjęUsługi danych.

  2. Jeśli połączenie, którego chcesz użyć, zostało już zainstalowane, przejdź do kroku 5. W przeciwnym razie przejdź do następnego kroku.

  3. Kliknij pozycję Zainstaluj nowe połączenie.

  4. Zaznacz plik połączenia, którego chcesz użyć, a następnie kliknij przycisk OK.

  5. W oknie dialogowym Tworzenie łącza do danych usługi sieci Web rozwiń połączenie, którego chcesz użyć.

  6. Zaznacz tabelę, do której chcesz utworzyć łącze. Program Access wyświetli pola po prawej stronie okna dialogowego.

  7. Opcjonalnie można wpisać nazwę połączonej tabeli w polu Określ nazwę łącza. Program Access użyje tej nazwy w okienku nawigacji.

  8. Kliknij przycisk OK. Program Access utworzy tabelę połączoną.

Początek strony

Ustawianie właściwości tabeli w bazie danych dla komputerów stacjonarnych

Właściwości można ustawić w taki sposób, aby były stosowane do całej tabeli lub do całych rekordów.

  1. Zaznacz tabelę, której właściwości chcesz ustawić.

  2. Na karcie Narzędzia główne w grupie Widoki kliknij pozycję Widok, a następnie kliknij pozycję Widok projektu.

  3. Na karcie Projektowanie w grupie Pokazywanie/ukrywanie kliknij przycisk Arkusz właściwości.

    Grupa Pokazywanie/ukrywanie na karcie Projektowanie w programie Access .

  4. W arkuszu właściwości kliknij kartę Ogólne.

  5. Kliknij pole po lewej stronie właściwości, którą chcesz ustawić, a następnie wprowadź ustawienie tej właściwości. Aby wyświetlić listę właściwości tabeli, kliknij pozycję Dostępne właściwości tabeli.

  6. Naciśnij klawisze CTRL+S, aby zapisać zmiany.

    Właściwość tabeli

    Zastosowanie

    Wyświetl widoki w witrynie programu SharePoint

    Określenie, czy widoki utworzone na podstawie tabeli mogą być wyświetlane w witrynie programu SharePoint.

    Uwaga : Skutki użycia tego ustawienia zależą od ustawienia właściwości bazy danych Wyświetl wszystkie widoki w witrynie programu SharePoint.

    Więcej informacji można uzyskać w sekcji Zobacz też.

    Rozwinięty podarkusz danych

    Rozwijanie wszystkich podarkuszy danych po otwarciu tabeli.

    Wysokość podarkusza danych

    Wykonaj jedną z następujących czynności:

    • Jeśli chcesz, aby okno podarkusza danych było rozwijane w celu wyświetlenia wszystkich wierszy, pozostaw dla tej właściwości ustawienie 0 cm.

    • Jeśli chcesz sterować wysokością podarkusza danych, wprowadź żądaną wysokość w centymetrach.

    Orientacja

    Ustawienie orientacji widoku zgodnie ze sposobem czytania używanego języka — od lewej do prawej lub od prawej do lewej.

    Opis

    Podanie opisu tabeli. Ten opis będzie wyświetlany w etykietkach narzędzi danej tabeli.

    Widok domyślny

    Ustawienie domyślnego widoku używanego po otwarciu tabeli (widok Arkusz danych, Tabela przestawna lub Wykres przestawny).

    Reguła poprawności

    Wprowadzenie wyrażenia, które musi być spełnione przy dodawaniu lub zmienianiu rekordu.

    Tekst reguły sprawdzania poprawności

    Wprowadzenie tekstu komunikatu wyświetlanego w sytuacji, gdy rekord jest niezgodny z wyrażeniem we właściwości Reguła poprawności.

    Filtr

    Zdefiniowanie kryteriów służących do wyświetlania tylko dopasowanych wierszy w widoku arkusza danych.

    Uporządkuj według

    Określenie domyślnego porządku sortowania wierszy w widoku arkusza danych przez wybranie co najmniej jednego pola.

    Nazwa podarkusza danych

    Określenie, czy podarkusz danych powinien być wyświetlany w widoku arkusza danych, a jeśli tak, określenie, z której tabeli lub kwerendy mają pochodzić wiersze podarkusza.

    Podrzędne pola łączące

    Określenie listy pól w tabeli lub kwerendzie, które są używane w podarkuszu danych i są zgodne z właściwością Nadrzędne pola łączące określoną dla danej tabeli.

    Nadrzędne pola łączące

    Określenie listy pól w tabeli, które są zgodne z właściwością Podrzędne pola łączące określoną dla danej tabeli.

    Filtruj przy ładowaniu

    Automatyczne stosowanie kryteriów filtrowania określonych we właściwości Filtr po otwarciu tabeli w widoku arkusza danych (przez ustawienie tej właściwości na wartość Tak).

    Porządkuj przy ładowaniu

    Automatyczne stosowanie kryteriów sortowania określonych we właściwości Uporządkuj według po otwarciu tabeli w widoku arkusza danych (przez ustawienie tej właściwości na wartość Tak).

    Porada : Aby uzyskać więcej miejsca na wprowadzanie lub edytowanie ustawienia w polu właściwości, należy nacisnąć klawisze SHIFT+F2 w celu wyświetlenia okna Powiększenie. Jeśli we właściwości Reguła poprawności jest ustawiane wyrażenie i jest potrzebna pomoc przy jego konstruowaniu, należy kliknąć przycisk Przycisk Konstruktor obok pola właściwości RegułaPoprawności w celu wyświetlenia Konstruktora wyrażeń.

Początek strony

Dodawanie pola do tabeli w bazie danych programu Access pulpitu

Każdy element danych, który ma być śledzony, jest przechowywany w polu. Na przykład w tabeli kontaktów można utworzyć pola Nazwisko, Imię, Numer telefonu i Adres. W tabeli produktów można utworzyć pola Nazwa produktu, Identyfikator produktu i Cena.

Przed utworzeniem pól warto rozdzielić dane na najmniejsze użyteczne elementy. O wiele łatwiej jest później połączyć te dane, niż je rozdzielać. Na przykład zamiast pola Imię i nazwisko warto rozważyć utworzenie osobnych pól dla nazwiska i dla imienia. Dzięki temu będzie można łatwo przeprowadzać wyszukiwanie lub sortowanie według pola Imię, według pola Nazwisko lub według obu tych pól jednocześnie. Jeśli w przypadku określonego elementu danych są planowane operacje raportowania, sortowania, wyszukiwania lub obliczania, należy umieścić ten element w osobnym polu. Aby uzyskać więcej informacji na temat projektowania bazy danych i tworzenia pól, skorzystaj z łączy w sekcji Zobacz też.

Po utworzeniu pola można również ustawić właściwości pola w celu sterowania jego wyglądem i zachowaniem.

Nowe pole w programie Access można utworzyć, wprowadzając dane w nowej kolumnie w widoku arkusza danych. W przypadku tworzenia pola przez wprowadzenie danych w widoku arkusza danych program Access automatycznie przypisuje do tego pola typ danych na podstawie wprowadzonej wartości. Jeśli z wprowadzonych danych nie wynika żaden inny typ danych, program Access ustawia typ danych Tekst. To ustawienie można zmienić w razie potrzeby.

Dodawanie pola przez wprowadzenie danych

Po utworzeniu nowej tabeli lub otwarciu istniejącej tabeli w widoku arkusza danych można dodać pole do tabeli, wprowadzając dane w kolumnie Dodaj nowe pole w arkuszu danych.

Arkusz danych w programie Access z kolumną Dodaj nowe pole

1. Dane należy wprowadzić w pustej kolumnie Dodaj nowe pole.

Aby dodać nowe pole:

  1. Utwórz lub otwórz tabelę w widoku arkusza danych.

  2. W kolumnie Dodaj nowe pole wprowadź nazwę pola, które chcesz utworzyć. Użyj nazwy opisowej, aby można było to pole łatwiej zidentyfikować.

  3. Wprowadź dane w nowym polu.

Początek strony

Ustawianie właściwości pola

Po utworzeniu pola można ustawić właściwości pola w celu sterowania jego wyglądem i zachowaniem.

Ustawiając właściwości pola, można na przykład:

  • sterować wyglądem danych w polu,

  • zapobiec wprowadzaniu niepoprawnych danych w polu,

  • określić wartości domyślne pola,

  • przyspieszyć wyszukiwanie i sortowanie w polu.

Niektóre z dostępnych właściwości można ustawić podczas pracy w widoku arkusza danych. Aby jednak uzyskać dostęp do pełnej listy właściwości pola i móc je ustawiać, należy korzystać z widoku projektu.

Ustawianie właściwości pola w widoku arkusza danych

Podczas pracy w widoku arkusza danych można zmienić nazwę pola, typ danych pola, właściwość Format i kilka innych właściwości pola.

  • Aby otworzyć tabelę w widoku arkusza danych:    W okienku nawigacji kliknij prawym przyciskiem myszy tabelę, a następnie w menu skrótów kliknij polecenie Widok arkusza danych.

  • Aby zmienić nazwę pola:   Po dodaniu pola przez wprowadzenie danych w widoku arkusza danych program Access automatycznie przypisuje temu polu nazwę ogólną. Program Access przypisuje nazwę Pole1 pierwszemu nowemu polu, nazwę Pole2 — drugiemu nowemu polu i tak dalej. Domyślnie nazwa pola jest używana jako etykieta podczas wyświetlania pola, między innymi w nagłówku kolumny w arkuszu danych. Zmiana nazw pól na bardziej opisowe ułatwia korzystanie z nich podczas wyświetlania lub edytowania rekordów.

  • Kliknij prawym przyciskiem myszy nagłówek pola, którego nazwę chcesz zmienić (na przykład Pole1).

  • W menu skrótów kliknij polecenie Zmień nazwę kolumny.

  • Wprowadź nową nazwę w nagłówku pola.

Nazwy pól mogą zawierać maksymalnie 64 znaki (litery oraz liczby) z uwzględnieniem spacji.

Zmienianie typu danych pola

Po utworzeniu pola przez wprowadzenie danych w widoku arkusza danych program Access sprawdza te dane w celu określenia odpowiedniego typu danych dla pola. Jeśli na przykład zostanie wprowadzony ciąg 2006-01-01, program Access rozpozna te dane jako datę i ustawi dla pola typ danych Data/Godzina. Jeśli program Access nie może jednoznacznie określić typu danych, typ danych jest domyślnie ustawiany jako Tekst.

Typ danych pola określa, jakie inne właściwości pola można ustawiać. Na przykład właściwość Tylko dołącz można ustawić jedynie dla pól o typie danych Hiperłącze lub Nota.

Czasami jest konieczna ręczna zmiana typu danych pola. Załóżmy, że numery pokoi przypominają daty, na przykład 10-2001. Jeśli w nowym polu w widoku arkusza danych zostanie wprowadzony ciąg 10-2001, funkcja automatycznego wykrywania typu danych wybierze dla tego pola typ danych Data/Godzina. Ponieważ numery pokoi są etykietami, a nie datami, powinny mieć typ danych Tekst. Poniższa procedura umożliwia zmianę typu danych pola.

  1. Kliknij kartę Arkusz danych.

  2. Na liście Typ danych w grupie Typ i formatowanie danych wybierz odpowiedni typ danych.

    Obraz wstążki programu Access przedstawiający grupę Typ i formatowanie danych

Zmienianie formatu pola

Program Access nie tylko określa typ danych nowego pola, ale może również ustawić właściwość Format pola, zależnie od wprowadzonej wartości. Jeśli na przykład zostanie wprowadzony ciąg 10:50am, program Access ustawi typ danych na wartość Data/Godzina, a właściwość Format na wartość Godzina średnia. Aby ręcznie zmienić właściwość Format pola, należy wykonać następujące czynności:

  1. Na Wstążce kliknij kartę Arkusz danych.

  2. Na liście Format w grupie Typ i formatowanie danych wprowadź żądany format.

    Uwaga : W przypadku niektórych pól (na przykład pól typu Tekst) lista Format może być niedostępna. Zależy to od typu danych pola.

Ustawianie innych właściwości pola

  1. W widoku arkusza danych kliknij pole, dla którego chcesz ustawić właściwość.

  2. Na karcie Arkusz danych w grupie Typ i formatowanie danych wybierz żądane właściwości.

    Obraz wstążki programu Access przedstawiający grupę Typ i formatowanie danych

Początek strony

Ustawianie właściwości pola

Właściwość pola można ustawić, otwierając tabelę w widoku projektu.

  • Aby otworzyć tabelę w widoku projektu   : w okienku nawigacji kliknij prawym przyciskiem myszy tabelę, a następnie w menu skrótów kliknij polecenie Widok projektu.

  • Aby zmienić typ danych pola   : zlokalizuj nazwę pola, którego typ danych chcesz ustawić, kliknij pole Typ danych, a następnie wybierz typ danych z listy.

  • Aby ustawić inne właściwości pola   : w siatce projektu tabeli zaznacz pole, dla którego chcesz ustawić właściwości. W okienku Właściwości pola wprowadź żądane ustawienia poszczególnych właściwości. Naciśnij klawisze CTRL+S, aby zapisać zmiany.

    Uwaga :  Od typu danych pola zależy, jakie właściwości można ustawiać.

Początek strony

Tabele w aplikacjach sieci web programu Access

Klienta programu Access zawiera projektantów do tworzenia i modyfikowania tabel, które będą przechowywane w programie SQL Server. Informacje, które wymaga programu Access w celu tworzenia i zarządzania na tabelę i właściwości, takie jak informacje odnośnika i formatowanie są przechowywane w tabeli systemowej (Access.ColumnProperties) w bazie danych użytkownika. Aby uzyskać więcej informacji zobacz Tworzenie aplikacji programu Access.

Początek strony

Zapisywanie tabeli

Po utworzeniu lub zmodyfikować tabelę, należy zapisać jej projekt w bazie danych pulpitu. Po zapisaniu tabeli po raz pierwszy, nadaj nazwę opisującą danymi, które zawiera. Służy do 64 znaków alfanumerycznych, włącznie ze spacjami. Na przykład można nadać nazwę tabeli Klienci, Zapasy części lub produkty.

Program Access udostępnia wiele elastyczność jeśli chodzi o nadawaniu nazw tabel w aplikacjach sieci web; Istnieją jednak pewne ograniczenia, o których warto pamiętać. Nazwa tabeli może być maksymalnie 64 znaki, mogą zawierać dowolną kombinację liter, cyfr, spacji i znaków specjalnych z wyjątkiem kropki (.), wykrzyknika (!), nawiasów kwadratowych ([]), początkowych spacji wiodących znak równości (=) lub znaku niedrukowane, takie jak karetki zwracana. Nazwa również nie może zawierać żadnego z następujących znaków: "/ \:; * ? "" < > | # < TAB > {} % ~ &.

Porada : Warto wybrać konwencję nazewnictwa obiektów w bazie danych i konsekwentnie ją stosować.

  1. Kliknij przycisk Zapisz na pasku narzędzi Szybki dostęp lub naciśnij klawisze CTRL + s

  2. Jeśli zapisujesz tabelę po raz pierwszy, wpisz nazwę tabeli, a następnie kliknij przycisk OK.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×