Wprowadzenie do programu SharePoint Designer 2010

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Microsoft SharePoint Designer 2010 jest sieci Web i programie do projektowania aplikacji umożliwia projektowanie, tworzenie, dostosowywanie witryny sieci Web na SharePoint Foundation 2010 i Microsoft SharePoint Server 2010. Z SharePoint Designer 2010 można utworzyć sformatowanych danych stron sieci Web, tworzenie zaawansowanych rozwiązań z obsługą przepływu pracy i projektowanie wyglądu i działania witryny.

Aby dowiedzieć się więcej o SharePoint Designer 2010 za pośrednictwem artykułów, klipów wideo i inne materiały szkoleniowe, skorzystaj z poniższych łączy. Za pomocą procedury, które należy wykonać, aby poznać podstawowe zadania, które można wykonywać w SharePoint Designer 2010.

Wprowadzenie — logo

Co zrobić

Miejsce docelowe

Chcesz wiedzieć, co się zmieniło?   

Poznaj nowości w tej wersji i dowiedz się, jak najlepiej wykorzystać możliwości stwarzane przez nowe funkcje.

Co nowego w programie SharePoint Designer 2010

Szukasz 2007 menu i poleceń?   

Zobacz tabelę menu i poleceń paska narzędzi z wersji 2007, aby poznać ich nowe umiejscowienie, korzystając z tego skoroszytu mapowania.

Mapowanie prowadnice aplikacji pakietu Microsoft Office

Dotychczas nie korzystali z programu SharePoint Designer przed?   

Dowiedz się, jakie SharePoint Designer 2010 jest i jak w pełni wykorzystać ją w Twojej organizacji.

Wprowadzenie do programu SharePoint Designer 2010

Szukasz szkolenie z innymi członkom zespołu?   

Rozpoczęcie wydajnej więcej w tej wersji z szkolenie dotyczące SharePoint Designer 2010.

Szkolenia dotyczące pakietu Microsoft Office

Podstawowe zadania w SharePoint Designer 2010

Otwieranie i tworzenie witryn programu SharePoint

Tworzenie list, bibliotek i łączenie się ze źródłami danych

Tworzenie niestandardowych widoków i formularzy

Tworzenie niestandardowych przepływów pracy

Projektowanie stron witryny, strony wzorcowe i układy stron

Zapisywanie jako szablonu

Otwieranie i tworzenie witryn programu SharePoint

W SharePoint Designer 2010 można otworzyć istniejące witryny programu SharePoint na serwerze i rozpoczęcia ich dostosowywania, można tworzyć nowe witryny na podstawie szablony witryn programu SharePoint lub witryny nowy, pusty, które można dostosować od podstaw.

Otwieranie witryn

Aby otworzyć istniejącą witrynę, kliknij kartę Plik, wybierz pozycję Witryny i wykonaj jedną z następujących czynności:

  • Aby przejrzeć listę witryn dostępnych na serwerze, kliknij pozycję Otwórz witrynę.

  • Aby otworzyć i dostosować swoją witrynę Moja witryna, kliknij pozycję Dostosuj witrynę Moja witryna.

  • W obszarze Ostatnio używane witryny wybierz ostatnio używaną witrynę.

Tworzenie witryn

Aby utworzyć nową witrynę, kliknij kartę Plik, wybierz pozycję Witryny i wykonaj jedną z następujących czynności:

  • Aby utworzyć nową pustą witrynę programu SharePoint, kliknij pozycję Nowa pusta witryna sieci Web.

  • Aby utworzyć nową witrynę w witrynie Moja witryna, kliknij pozycję Dodaj podwitrynę do mojej witryny.

  • W obszarze Szablony witryn wybierz szablon, aby utworzyć nową witrynę na podstawie Szablon programu SharePoint.

Uwaga : Oprócz otwierania i tworzenia witryn z poziomu SharePoint Designer 2010, można otworzyć witrynę programu SharePoint przy użyciu przeglądarki sieci, a następnie otwórz tej witryny w SharePoint Designer 2010 za pomocą łączy dostępnych w menu Akcje witryny, wstążki i innych miejscach w programie SharePoint.

Początek strony

Tworzenie list, bibliotek i połączeń ze źródłami danych

W SharePoint Designer 2010 możesz utworzyć list i bibliotek, które często służą jako źródła danych dla witryny programu SharePoint, i można tworzyć połączenia ze źródłami danych do plików XML, zewnętrznych baz danych i usług sieci Web.

Listy i biblioteki programu SharePoint

Aby utworzyć listę lub bibliotekę programu SharePoint, w okienku Nawigacja kliknij pozycję Listy i biblioteki, a następnie na karcie Listy i biblioteki wybierz jedną z następujących opcji:

  • Aby utworzyć pustą listę od podstaw, kliknij pozycję Lista niestandardowa.

  • Aby utworzyć listę opartą na szablonie listy programu SharePoint, kliknij pozycję Lista programu SharePoint.

  • Aby utworzyć bibliotekę opartą na szablonie biblioteki programu SharePoint, kliknij pozycję Biblioteka dokumentów.

  • Aby utworzyć zewnętrzną listę opartą na typie zawartości zewnętrznej, kliknij pozycję Lista zewnętrzna (typy zawartości zewnętrznej omówiono poniżej).

  • Aby utworzyć listę na podstawie zaimportowanego arkusza kalkulacyjnego, kliknij pozycję Lista z arkusza kalkulacyjnego.

Połączenia ze źródłami danych

Aby utworzyć połączenie ze źródłem danych, w okienku Nawigacja kliknij pozycję Źródła danych, a następnie na karcie Źródła danych wybierz jedną z następujących opcji:

  • Aby utworzyć połączenie z kilkoma źródłami danych, kliknij pozycję Połączone źródło danych.

  • Aby utworzyć połączenie z bazą danych obsługującą protokół OLE DB lub ODBC, kliknij pozycję Połączenie bazy danych.

  • Aby utworzyć połączenie z usługą XML sieci Web przy użyciu protokołu SOAP (Simple Object Access Protocol), kliknij pozycję Połączenie usługi SOAP.

  • Aby utworzyć połączenie ze skryptem na serwerze przy użyciu usługi REST (Representational State Transfer), kliknij pozycję Połączenie usługi REST.

  • Aby utworzyć połączenie z plikiem źródłowym XML, kliknij pozycję Połączenie pliku XML.

Typy zawartości zewnętrznej

Za pomocą typów zawartości zewnętrznej można tworzyć połączenia z zewnętrznymi źródłami danych biznesowych, a także integrować te źródła z witryną programu SharePoint i obsługiwanymi aplikacjami klienckimi. Po utworzeniu typu zawartości zewnętrznej można utworzyć listy zewnętrzne, dzięki którym użytkownicy będą mogli korzystać z danych w taki sposób, jakby znajdowały się na dowolnej liście lub w dowolnej bibliotece programu SharePoint.

Aby utworzyć typ zawartości zewnętrznej, należy wykonać poniższe czynności.

  1. W okienku Nawigacja kliknij pozycję Typy zawartości zewnętrznej.

  2. Na karcie Typy zawartości zewnętrznej kliknij pozycję Typ zawartości zewnętrznej, a następnie zaprojektuj operacje, pola i pozostałe aspekty typu zawartości zewnętrznej.

Początek strony

Tworzenie niestandardowych widoków i formularzy

W SharePoint Designer 2010 można utworzyć niestandardowych widoków i formularzy danych źródeł, które naprawdę stają się interfejs do czytania i pisania danych do tych źródeł danych.

Widoki

Widok jest live wyświetlania dostosowywanych źródła danych, który można dodać do dowolnej strony programu SharePoint. W SharePoint Designer 2010 można utworzyć listy widoków, (które za pomocą składnika Web Part Widok listy XSLT) i danych (które za pomocą składnika Web Part formularza danych). Wykonaj jedną z poniższych czynności, aby utworzyć widok listy lub dane.

  • W okienku Nawigacja kliknij pozycję Listy i biblioteki, wybierz listę, dla której chcesz utworzyć widok, a następnie na karcie Ustawienia listy kliknij pozycję Widok listy.

    Uwaga : Zostanie utworzony widok skojarzony z listą lub biblioteką. Użytkownicy będą mogli go wyświetlać i dostosowywać za pomocą opcji dostępnych w grupie Zarządzanie widokami umieszczonej na wstążce programu SharePoint.

  • W okienku Nawigacja kliknij pozycję Strony witryny, zmodyfikuj stronę, na której chcesz utworzyć widok, kliknij kartę Wstawianie, wybierz pozycję Widok danych, a następnie wybierz listę lub bibliotekę programu SharePoint, z którą ma być powiązany widok.

Formularze

Formularz jest dostosowywanych wyświetlanie źródła danych, które umożliwia przesyłanie lub odpisać ze źródłem danych. W SharePoint Designer 2010 można utworzyć formularze list i formularzy danych (one za pomocą składnika Web Part formularza danych). Wykonaj jedną z następujących czynności, aby utworzyć formularz z listy lub dane.

  • W okienku Nawigacja kliknij pozycję Listy i biblioteki, wybierz listę, dla której chcesz utworzyć formularz, a następnie na karcie Ustawienia listy kliknij pozycję Formularz listy.

  • W okienku Nawigacja kliknij pozycję Strony witryny, zmodyfikuj stronę, na której chcesz utworzyć formularz, kliknij kartę Wstawianie, wybierz pozycję Formularz nowego elementu, Formularz edycji elementu lub Formularz wyświetlania elementu, a następnie wybierz źródło danych, z którym ma być powiązany formularz.

Uwaga : Oprócz korzystania z narzędzi do projektowania formularzy w SharePoint Designer 2010, można utworzyć i dostosowywanie formularzy programu SharePoint przy użyciu Microsoft InfoPath 2010.

Początek strony

Tworzenie niestandardowych przepływów pracy

W SharePoint Designer 2010 można zarządzać procesami biznesowymi korzystania z przystosowanych przepływów pracy. Przepływy pracy może służyć do zarządzania procesów aplikacji, a także człowieka procesów współpracy. Masz kilka możliwości podczas tworzenia przepływów pracy.

Tworzenie przepływów pracy w SharePoint Designer 2010

Użytkownik może tworzyć przepływy pracy oparte na liście lub bibliotece programu SharePoint, przepływy pracy wielokrotnego użytku stosowane do różnych list i bibliotek oraz przepływy pracy witryny funkcjonujące na poziomie całej witryny.

Aby utworzyć takie przepływy pracy, w okienku Nawigacja kliknij pozycję Przepływy pracy, a następnie na karcie Przepływy pracy wykonaj jedną z następujących czynności:

  • Kliknij pozycję Przepływ pracy dla listy i wybierz listę, którą chcesz skojarzyć z przepływem.

  • Kliknij pozycję Przepływ pracy wielokrotnego użytku, aby utworzyć przepływ pracy wielokrotnego użytku, który będzie można skojarzyć z dowolną listą lub biblioteką.

  • Kliknij pozycję Przepływ pracy dla witryny, aby utworzyć przepływ pracy, który będzie można zastosować na poziomie witryny.

Po utworzeniu przepływu pracy użyj projektanta przepływów pracy, aby utworzyć warunki, akcje i etapy przepływu pracy. Aby zarządzać zdarzeniami skojarzonymi z poszczególnymi zadaniami, użyj projektanta zadań.

Importowanie przepływów pracy z Microsoft Visio 2010

Oprócz tworzenia przepływów pracy w SharePoint Designer 2010, możesz zaimportować zaprojektowane w Microsoft Visio 2010 za pomocą przepływu pracy w podanym wzorniki i szablony przepływu pracy.

Aby zaimportować przepływ pracy, w okienku Nawigacja kliknij pozycję Przepływy pracy, a następnie na karcie Przepływy pracy wykonaj następujące czynności:

  1. Kliknij pozycję Importuj z programu Visio, a następnie w systemie plików lub w bibliotece dokumentów programu SharePoint przejdź do żądanego pliku w formacie Wymiana przepływów pracy programu Visio (vwi).

  2. Określ, czy przepływ ma być skojarzony z listą, czy pełnić rolę przepływu pracy wielokrotnego użytku, a następnie kliknij przycisk Zakończ.

  3. Rozpocznij dostosowywanie przepływu pracy w programie SharePoint Designer.

Początek strony

Projektowanie stron witryn, stron wzorcowych i układów stron

W SharePoint Designer 2010 można utworzyć i dostosowywanie stron witryny, strony wzorcowe i układy stron. Podczas każdego z tych stron służy do innych celów, przypomina środowisko edytowania strony. Można dodawać i usuwać tekst, obrazy, łącza, tabel, składniki Web Part, kontrolki serwera i więcej. Stosowanie definicje stylów i kaskadowe arkusze stylów do stron wzorcowych i układów stron, aby zmienić wygląd i działanie witryny lub znakowanie go zgodnie z Twojej firmy tożsamości.

Strony witryny

Aby utworzyć stronę witryny, w okienku Nawigacja kliknij pozycję Strony witryny, a następnie na karcie Strony wykonaj jedną z następujących czynności:

  • Kliknij pozycję Strona składników Web Part, aby utworzyć stronę zawierającą składniki Web Part nagłówka i treści. Strona będzie skojarzona ze stroną wzorcową witryny.

  • Kliknij pozycję Strona i wybierz pozycję ASPX lub HTML, aby utworzyć pustą stronę witryny, która nie będzie skojarzona ze stroną wzorcową witryny.

Strony wzorcowe

  • W okienku Nawigacja kliknij pozycję Strony wzorcowe, a następnie na karcie Strony wzorcowe kliknij pozycję Pusta strona wzorcowa.

Układy stron

  • W okienku Nawigacja kliknij pozycję Układy stron, na karcie Układy stron kliknij pozycję Nowy układ strony, a następnie wybierz grupę i nazwę typu zawartości, na którym ma być oparty układ strony.

Uwaga : Strony wzorcowe i układy stron są domyślnie wyłączone dla wszystkich użytkowników z wyjątkiem administratorów zbioru witryn. Jeśli nie widzisz opcji do wyświetlania lub edytowania stron wzorcowych i układów stron w SharePoint Designer 2010, skontaktuj się z administratorem witryny włączenie tych opcji.

Początek strony

Zapisywanie witryny jako szablonu

Po zakończeniu dostosowywania witryny można zapisać witrynę lub jej fragmenty jako szablon, na podstawie którego inni użytkownicy w organizacji będą mogli tworzyć listy, widoki, przepływy pracy, strony witryn i inne elementy.

Szablon może także posłużyć do dalszego dostosowania witryny w innym środowisku lub przez innych użytkowników, na przykład w przeglądarce albo w programie Microsoft Visual Studio.

Poszukaj opcji Zapisz jako szablon w SharePoint Designer 2010 skorzystać z tej funkcji.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×