Wprowadzenie do kwerend

Uwaga:  Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Jeśli chcesz przejrzeć, dodawanie, zmienianie lub usuwanie danych z bazy danych należy rozważyć kwerendy.

Korzystanie z kwerendy, możesz odebrać bardzo konkretne pytania dotyczące danych, która może być trudne do odpowiedzi, wyświetlając dane tabeli bezpośrednio. Za pomocą kwerendy do filtrowania danych, aby wykonywać obliczenia z danymi i podsumowywanie danych. Za pomocą kwerendy można również zautomatyzować wiele zadań zarządzania danymi i przeglądanie zmian w danych, zanim klikniesz przycisk Potwierdź tych zmian.

Uwaga: Funkcje kwerendy agregacji, takiej jak Suma lub Liczba, nie są dostępne w kwerendy sieci Web.

Użycie kwerend ułatwia wykonywanie wielu zadań związanych z bazą danych

W tym artykule

Omówienie

Przyjrzyj się podzestawu danych w tabeli

Jednoczesne przeglądanie danych pochodzących z więcej niż jednej tabeli

Poproś odmiany zapytania zgodnie z parametrami

Wykonywanie obliczeń na podstawie danych

Przeglądanie danych podsumowanych lub zagregowanych

Tworzenie nowej tabeli przy użyciu danych z innych tabel

Dodawanie danych do tabeli za pomocą danych z innych tabel

Zmienianie danych w zautomatyzowany sposób

Usuwanie danych w zautomatyzowany sposób

Omówienie

Ten artykuł zawiera podstawowe informacje na temat kwerend i znajdują się przykłady różnych typów kwerend.

Kwerenda jest żądanie wyniki dane dla akcji w danych lub dla obu. Za pomocą kwerendy odpowiedzi na pytanie proste, do przeprowadzenia obliczeń, do łączenia danych z różnych tabel lub nawet na dodawanie, zmienianie lub usuwanie danych tabeli. Kwerendy, których używasz, aby pobrać dane z tabeli lub wykonywanie obliczeń są nazywane kwerend wybierających. Zapytania, które Dodawanie, zmienianie lub usuwanie danych są nazywane kwerend funkcjonalnych.

Za pomocą kwerendy można również dostarczać dane dla formularza lub raportu. Dobrze zaprojektowany bazy danych dane, które chcesz przedstawić przy użyciu formularza lub raportu często znajduje się kilka różnych tabel. Za pomocą kwerendy, można utworzyć dane, które ma być używany przed projektowania formularza lub raportu.

Aby uzyskać więcej informacji o podanie danych formularzy i raportów za pomocą kwerendy zapoznaj się z łączy w sekcji Zobacz też, lub przeszukaj Pomoc.

Otwieranie istniejącej kwerendy

Jeśli nie znasz okienka nawigacji, może nie wiesz, jak otworzyć kwerendę, która już istnieje. Okienko nawigacji jest funkcję, która zastępuje okno bazy danych z wersji wcześniejszych niż program Access 2007. Pojawi się okienko nawigacji z lewej strony ekranu.

Aby otworzyć dowolny obiekt bazy danych, w tym kwerendy, możesz kliknąć dwukrotnie ten obiekt w okienku nawigacji.

Korzystanie z bazy danych Northwind do opracowania oraz przykłady

Uwaga: Przykłady w tym artykule za pomocą bazy danych, który został utworzony przy użyciu szablonu bazy danych Northwind 2010.

  1. Kliknij kartę Plik, a następnie kliknij pozycję Nowy.

  2. W środkowym okienku w obszarze Dostępne szablony kliknij pozycję Przykładowe szablony, a następnie kliknij pozycję Northwind.

  3. W okienku po prawej stronie Sprawdź nazwę pliku bazy danych w polu Nazwa pliku, a następnie wprowadź dowolne zmiany nazwy. Możesz również wyszukać inną lokalizację, klikając ikonę folderu.

  4. Kliknij przycisk Utwórz.

  5. Postępuj zgodnie ze wskazówkami na stronie Northwind Traders (na karcie obiektu Ekran uruchamiania), aby otworzyć bazę danych, a następnie zamknij okno dialogowe Logowanie.

Początek strony

Przyjrzyj się podzestawu danych w tabeli

Czasami warto przejrzeć wszystkie dane z tabeli, ale w innych przypadkach warto przejrzeć tylko dane z określonych pól lub warto przejrzeć dane tylko w przypadku niektórych pól spełniające pewne kryteria. Aby zapoznać się z części danych w tabeli, należy użyć kwerendy wybierającej.

Załóżmy, że chcesz przejrzeć listę produktów oraz ich ceny. Można utworzyć kwerendę, która zwraca produktu i cena informacji przy użyciu następującej procedury:

  1. Otwieranie Northwind bazy danych, które wcześniej skonfigurować przy użyciu następujące kroki.

  2. Na karcie Tworzenie w grupie Kwerendy kliknij przycisk Projekt kwerendy.

  3. W oknie dialogowym Pokazywanie tabeli na karcie tabele kliknij dwukrotnie produktów.

  4. Zamknij okno dialogowe Pokazywanie tabeli.

  5. W tabeli Produkty kliknij dwukrotnie Nazwa produktu i Cena, aby dodać te pola do kwerendy siatka projektu.

  6. Na karcie Projektowanie w grupie Wyniki kliknij przycisk Uruchom.

    Kwerenda jest uruchamiany, a następnie wyświetla listę produktów oraz ich ceny.

Początek strony

Jednoczesne przeglądanie danych pochodzących z więcej niż jednej tabeli

Tabele w bazie danych atrakcyjnego istnieją relacje logiczne ze sobą. Istnieje tych relacji na podstawie pól, które tabele mają wspólne. Przeglądanie danych pochodzących z powiązanych tabel, należy użyć kwerendy wybierającej.

Załóżmy, że chcesz przejrzeć zamówienia od klientów mieszkających w określonym mieście. Dane dotyczące zamówienia i dane dotyczące klientów są przechowywane w dwóch tabelach w tej samej bazy danych. Każda tabela zawiera pole Identyfikator klienta, które jest podstawą relacja jeden-do-wielu między dwiema tabelami. Można utworzyć kwerendę, która zwraca zamówienia od klientów z określonego miasta, na przykład Wyszków, wykonując poniższą procedurę:

  1. Otwieranie Northwind bazy danych, które wcześniej skonfigurować przy użyciu następujące kroki.

  2. Na karcie Tworzenie w grupie Kwerendy kliknij przycisk Projekt kwerendy.

  3. W oknie dialogowym Pokazywanie tabeli na karcie Tabele kliknij dwukrotnie tabele Klienci i Zamówienia.

  4. Zamknij okno dialogowe Pokazywanie tabeli.

    Zwróć uwagę na wiersz, o nazwie sprzężenia, łączącym pole Identyfikator w tabeli Klienci i pola Identyfikator klienta w tabeli zamówienia. Ten wiersz zawiera relacji między dwiema tabelami.

  5. W tabeli Klienci kliknij dwukrotnie pola Firma i Miasto, aby dodać je do siatki projektu kwerendy.

  6. W siatce projektu kwerendy w kolumnie Miasto wyczyść pole wyboru w Pokaż wiersz.

  7. W wierszu Kryteria kolumny Miasto wpisz Wyszków.

    Wyczyszczenie pola wyboru Pokaż uniemożliwia wyświetlanie miasta w wynikach kwerendy, a wpisywać Warszawie w wierszu kryteria Określa, że wyświetlić tylko te rekordy, które miejsce, w którym wartość pola Miasto jest Warszawie. W tym przypadku kwerenda zwraca jedynie klientów, które znajdują się w Warszawie — Firma G i Firma AA.

    Należy zauważyć, że nie masz wyświetlić pole, aby używać go z kryterium.

  8. W tabeli Zamówienia kliknij dwukrotnie pola Identyfikator zamówienia i Data zamówienia, aby dodać je do następnych dwóch kolumn siatki projektu kwerendy.

  9. Na karcie Projektowanie w grupie Wyniki kliknij przycisk Uruchom.

    Kwerenda jest uruchamiany, a następnie wyświetli listę zamówień dla klientów w Warszawie.

  10. Naciśnij klawisze CTRL+S, aby zapisać kwerendę.

    Zostanie wyświetlone okno dialogowe Zapisywanie jako.

  11. W polu Nazwa kwerendy wpisz nazwę zamówienia według miasta, a następnie kliknij przycisk OK.

Początek strony

Poproś odmiany zapytania zgodnie z parametrami

Czasami można uruchomić kwerendę, która jest tylko nieznacznie różni się od istniejącej kwerendy. Możesz zmienić oryginalny zapytania, aby użyć nowe kryteria, ale jeśli chcesz często uruchomić odmiany określonego kwerendy, warto rozważyć użycie kwerendy parametrycznej. Po uruchomieniu kwerendy parametrycznej kwerendy zostanie wyświetlony monit dla pola wartości, a następnie używa wartości, które dostarczają tworzenie kryteriów kwerendy.

W poprzednim przykładziemożesz utworzyć kwerendę, która zwraca zamówienia od klientów, którzy znajdują się w Warszawie. Możesz zmodyfikować kwerendę w celu wyświetlania monitu o określić miasto każdym uruchomieniu kwerendy przy użyciu poniższej procedury:

  1. Otwieranie Northwind bazy danych, które wcześniej skonfigurować przy użyciu następujące kroki.

  2. Naciśnij klawisz F11, aby wyświetlić okienko nawigacji.

    Uwaga: Ten krok nie jest konieczne, jeśli jest wyświetlany w okienku nawigacji.

  3. W okienku nawigacji kliknij prawym przyciskiem myszy kwerendę o nazwie Zamówienia według miasta (utworzoną w poprzedniej sekcji), a następnie w menu skrótów kliknij polecenie Widok projektu.

  4. W siatce projektu zapytania w wierszu Kryteria kolumny Miasto usuń nazwę miasta Wyszków, a następnie wpisz ciąg [Dla jakiego miasta?].

    Ciąg [dla jakiego city?] jest monitu o podanie parametru. Nawiasy kwadratowe oznacza, że ma kwerendy w celu wyświetlania monitu o wprowadzaniu danych i tekst (w tym przypadku dla jakiego miasta?) to pytanie, który zostanie wyświetlony monit o wprowadzenie parametru.

    Uwaga: W tekście monitu o podanie parametru nie można użyć kropki (.) ani wykrzyknika (!).

  5. Zaznacz pole wyboru w wierszu Pokaż kolumny Miasto, aby w wynikach kwerendy było wyświetlane miasto.

  6. Na karcie Projektowanie w grupie Wyniki kliknij przycisk Uruchom.

    Kwerendy zostanie wyświetlony monit o wprowadzenie wartości dla miasta.

  7. Wpisz Nowy Jork, a następnie naciśnij klawisz ENTER.

    Kwerenda zostanie uruchomiona, a następnie wyświetli zamówienia od klientów z Gdańska.

    Ale co zrobić, jeśli nie wiesz, jakie wartości można określić? Aby parametru bardziej elastyczne, można użyć symboli wieloznacznych jako w monicie:

  8. Na karcie Narzędzia główne w grupie Widoki kliknij pozycję Widok, a następnie kliknij pozycję Widok projektu.

  9. W siatce projektu zapytania, w wierszu Kryteria kolumny Miasto wpisz ciąg Like [Dla jakiego miasta?]&"*".

    W ten parametr w wierszu, takich jak słowo kluczowe, handlowe "i" (&) i gwiazdka (*) w cudzysłowie Zezwalaj użytkownikom na kombinację znaków, łącznie z symboli wieloznacznych, aby zwrócić różne wyniki. Na przykład jeśli użytkownik wpisze *, kwerenda zwraca wszystkie miejscowości; Jeśli użytkownik wpisze L, kwerenda zwraca wszystkie miast, które zaczynają się na literę "L"; i, jeśli użytkownik wpisze * s *, kwerenda zwraca wszystkie miast, które zawierają literą "s".

  10. Na karcie Projektowanie w grupie Wyniki kliknij przycisk Uruchom.

    W monicie kwerendy wpisz Nowy, a następnie naciśnij klawisz ENTER.

  11. Kwerenda zostanie uruchomiona, a następnie wyświetli zamówienia od klientów z Gdańska.

Określanie typów danych parametrów

Określić można również, jaki typ danych powinien być akceptowany przez parametr. Typ danych można ustawić dla dowolnego parametru, ale szczególnie istotne jest ustawienie typu dla danych liczbowych, walutowych oraz daty/godziny. Określenie typu danych akceptowanego przez parametr umożliwia wyświetlanie pomocnego komunikatu o błędzie w przypadku, gdy użytkownik wprowadzi nieprawidłowy typ danych — na przykład tekst, gdy oczekiwanym typem danych jest waluta.

Uwaga: Jeśli parametr jest tak ustawiony, aby akceptował dane tekstowe, wszelkie wprowadzone dane są interpretowane jako tekst i nie jest wyświetlany żaden komunikat o błędzie.

Aby określić typ danych dla parametrów w kwerendzie, wykonaj poniższą procedurę:

  1. Po otwarciu kwerendy w widoku projektu na karcie Projektowanie, w grupie Pokazywanie/ukrywanie kliknij przycisk Parametry.

  2. W oknie dialogowym Parametry kwerendy, w kolumnie Parametr wpisz monit dla każdego parametru, dla którego chcesz określić typ danych. Upewnij się, że każdy parametr jest zgodny z monitem użytym w wierszu Kryteria siatki projektu kwerendy.

  3. W kolumnie Typ danych wybierz typ danych dla każdego parametru.

Początek strony

Wykonywanie obliczeń na podstawie danych

W większości przypadków, tabele nie służy do przechowywania wartości obliczane, które są oparte na danych w tej samej bazy danych. Na przykład tabeli Szczegóły zamówień w bazę danych Northwind 2007 nie przechowywać sumy częściowe produktów, ponieważ częściową dla produktów jest obliczana przy użyciu danych przechowywanych w polu Ilość, cena jednostkowa i rabatu pól w tabeli Szczegóły zamówienia.

W niektórych przypadkach wartości obliczane może stać się nieaktualne, ponieważ wartości, że są one oparte na zmiany. Na przykład czy nie mają być przechowywane wiek danej osoby w tabeli, ponieważ każdego roku należy zaktualizować wartości; należy przechowywać osoby Data urodzenia, a następnie użyj wyrażenia w kwerendzie do obliczania wiek osoby.

Poniższa procedura umożliwia tworzenie kwerendy zwracającej sumy częściowe produktów na podstawie danych z tabeli Szczegóły zamówienia.

  1. Otwieranie Northwind bazy danych, które wcześniej skonfigurować przy użyciu następujące kroki.

  2. Na karcie Tworzenie w grupie Kwerendy kliknij przycisk Projekt kwerendy.

  3. W oknie dialogowym Pokazywanie tabeli na karcie tabele kliknij dwukrotnie Szczegóły zamówienia.

  4. Zamknij okno dialogowe Pokazywanie tabeli.

  5. W tabeli Szczegóły zamówienia kliknij dwukrotnie Identyfikator produktu, aby dodać to pole w pierwszej kolumnie siatki projektu kwerendy.

  6. W drugiej kolumnie siatki kliknij prawym przyciskiem myszy wiersz pole, a następnie kliknij polecenie Powiększenie w menu skrótów.

  7. W polu Powiększenie wpisz lub wklej następujący ciąg:

    Suma częściowa: ([Ilość] * [Cena jednostkowa])-([Ilość] * [Cena jednostkowa]*[Rabat])

    Kliknij przycisk OK.

    To pole obliczeniowe. Pole obliczeniowe mnoży ilość każdego produkt przez cenę jednostkową dla tego produktu mnoży ilość każdego produktu, cena jednostkowa i rabat dla tego produktu, a następnie odejmuje wartość rabatu od ceny jednostkowej sumy.

  8. Na karcie Projektowanie w grupie Wyniki kliknij przycisk Uruchom.

    Kwerenda jest uruchamiany, a następnie wyświetla listę produktów i sumy częściowe na zamówienie.

  9. Naciśnij klawisze CTRL + S, aby zapisać kwerendę, a następnie nadaj jej nazwę Sumy częściowe produktów.

Początek strony

Przeglądanie danych podsumowanych lub zagregowanych

Używasz tabel sklep regularnie występujące dane liczbowe lub transakcje rekordów jest przydatne móc przeglądać dane w agregacji, na przykład sum lub średnich.

Access umożliwia przeglądanie prosty agregowanie danych w dowolnym arkusz danych, dodając wiersz Suma. Wiersz sumy to wiersz w dolnej części arkusza danych, który można wyświetlać sumy bieżącej lub innych wartości agregacji.

Uwaga: Nie możesz dodać wiersz sumy w arkuszu danych kwerendy sieci Web.

Wiersz sumy można dodać do kwerendę sumy częściowe produktów utworzoną w poprzednim przykładzie przy użyciu następującej procedury:

  1. Uruchom kwerendę Sumy częściowe produktów i pozostaw jej wyniki otwarte w widok arkusza danych.

  2. Na karcie Narzędzia główne w grupie Rekordy kliknij pozycję Sumy.

    W dolnej części arkusza danych, z programem word sumy w pierwszej kolumnie pojawi się nowy wiersz.

  3. Kliknij komórkę w ostatnim wierszu arkusza danych o nazwie Suma.

    Zauważ, że w komórce zostanie wyświetlona strzałka.

  4. Kliknij strzałkę, aby wyświetlić dostępne funkcje agregujące.

    Ponieważ kolumna zawiera dane tekstowe, dostępne są tylko dwie opcje: Brak i Liczba.

  5. Wybierz pozycję liczność.

    Zawartość komórki zmienia się z całkowitej liczby wartości kolumn.

  6. Kliknij komórkę sąsiednich (drugiej kolumny).

    Zauważ, że w komórce zostanie wyświetlona strzałka.

  7. Kliknij strzałkę, a następnie kliknij polecenie Suma.

    To pole zawiera sumę wartości kolumn.

  8. Pozostaw kwerendę otwartą w widoku arkusza danych.

Tworzenie kwerendy podsumowującej dla bardziej złożone podsumowań

Wiersz sumy w arkuszu jest bardzo przydatne, ale bardziej złożone pytania za pomocą kwerendy podsumowującej. Kwerendy podsumowującej jest kwerendę wybierającą, która umożliwia grupowanie i podsumowywanie danych. Załóżmy na przykład, że chcesz obliczyć całkowitą sprzedaż dla każdego produktu. Suma, funkcja agregująca kwerendy podsumowującej umożliwia obliczyć całkowitą sprzedaż dla każdego produktu.

Uwaga: Nie można użyć funkcji agregujących kwerendy sieci Web.

Użyj poniższej procedury, aby zmodyfikować kwerendę sumy częściowe produktów, aby nadać mu podsumowywanie sumy częściowe produktów według produktu.

  1. Na karcie Narzędzia główne w grupie Widoki kliknij pozycję Widok, a następnie kliknij pozycję Widok projektu.

    Kwerenda Sumy częściowe produktów zostanie otwarta w widoku projektu.

  2. Na karcie Projektowanie w grupie Pokazywanie/ukrywanie kliknij pozycję Sumy.

    W siatce projektu kwerendy zostanie wyświetlony wiersz Sumy.

    Uwaga: Mimo podobnych nazw wiersz Sumy w siatce projektu i wiersz Suma w arkuszu danych to dwa różne wiersze:

    • Za pomocą wiersza Sumy w siatce projektu można grupować dane według wartości pól.

    • Wiersz Suma arkusza danych można dodać do wyników kwerendy podsumowującej.

    • Gdy jest używany wiersz Sumy w siatce projektu, należy wybrać funkcję agregującą dla każdego pola. Aby nie wykonywać obliczenia dla określonego pola, można pogrupować dane według tego pola.

  3. W drugiej kolumnie siatki projektu, w wierszu Suma wybierz funkcję Suma z listy rozwijanej.

  4. Na karcie Projektowanie w grupie Wyniki kliknij przycisk Uruchom.

    Zostanie uruchomiona kwerenda, a następnie wyświetla listę produktów z sumy częściowe.

  5. Naciśnij klawisze CTRL+S, aby zapisać kwerendę. Pozostaw ją otwartą.

Tworzenie kwerendy krzyżowej, aby dodać kolejne poziomu grupowania

Teraz można założyć, że chce się przejrzeć sumy częściowe produktów, ale jednocześnie chce się agregować według miesiąca, aby w każdym wierszu były wyświetlane sumy częściowe produktu, a w każdej kolumnie były wyświetlane sumy częściowe produktów za miesiąc. Aby wyświetlić sumy częściowe produktu oraz sumy częściowe produktów za miesiąc, należy użyć zapytanie krzyżowe.

Uwaga: Kwerendy krzyżowej nie można wyświetlić w przeglądarce sieci web.

Ponownie możesz zmodyfikować kwerendę Sumy częściowe produktów, aby zwracała wiersze sum częściowych produktów oraz kolumny miesięcznych sum częściowych.

  1. Na karcie Narzędzia główne w grupie Widoki kliknij pozycję Widok, a następnie kliknij pozycję Widok projektu.

  2. W grupie Konfiguracja kwerendy kliknij przycisk Pokaż tabelę.

  3. W oknie dialogowym Pokazywanie tabeli kliknij dwukrotnie pozycję Zamówienia, a następnie kliknij przycisk Zamknij.

  4. Na karcie Projektowanie w grupie Typ zapytania kliknij przycisk Krzyżowe.

    W siatce projektu jest ukryty wiersz Pokaż i jest wyświetlany wiersz Krzyżowe.

  5. W trzeciej kolumnie siatki projektu kliknij prawym przyciskiem myszy wiersz Pole, a następnie w menu skrótów kliknij polecenie Powiększenie. Zostanie otwarte okno Powiększenie.

  6. W polu Powiększenie wpisz lub wklej następujący ciąg:

    Miesiąc: "Miesiąc" & DatePart ("m", [Data zamówienia])

  7. Kliknij przycisk OK.

  8. W wierszu krzyżowe wybierz z listy rozwijanej następujące wartości: Nagłówek wiersza dla pierwszej kolumny, wartość dla drugiej kolumny i Nagłówek kolumny dla trzeciej kolumny.

  9. Na karcie Projektowanie w grupie Wyniki kliknij przycisk Uruchom.

    Zostanie uruchomiona kwerenda, a następnie wyświetla sumy częściowe produktów, łączone według miesięcy.

  10. Naciśnij klawisze CTRL+S, aby zapisać kwerendę.

Początek strony

Tworzenie nowej tabeli przy użyciu danych z innych tabel

Aby utworzyć nową tabelę z danych przechowywanych w innych tabelach, można użyć kwerendy tworzącej tabele.

Uwaga: Nie można uruchomić kwerendy tworzącej tabelę w przeglądarce sieci web.

Wyobraź sobie na przykład, że chcesz wysłać dane zamówień z Kielc do partnera biznesowego z Kielc, który przygotowuje raporty w programie Access. Zamiast wysyłać wszystkie dane zamówień, chcesz ograniczyć wysyłane dane do danych dotyczących zamówień z Kielc.

Wykonując poniższą procedurę, można utworzyć kwerendę wybierającą, która zawiera dane zamówień z Kielc, a następnie za jej pomocą utworzyć nową tabelę,

  1. Otwieranie Northwind bazy danych, które wcześniej skonfigurować przy użyciu następujące kroki.

  2. Do uruchomienia kwerendy tworzącej tabele może być konieczne włączenie zawartości tej bazy danych za pomocą paska komunikatów, który pojawia się pod wstążką, jeśli baza danych jest niezaufanych po jego otwarciu.

    Pokaż, jak włączyć bazy danych

    • Na pasku komunikatów kliknij pozycję Włącz zawartość.

    Jeśli bazy danych znajduje się w zaufanej lokalizacji, nie jest wyświetlana na pasku komunikatów i włączenie zawartości nie jest konieczne.

  3. Zamknij formularz, okno dialogowe Logowanie.

  4. Na karcie Tworzenie w grupie Kwerendy kliknij przycisk Projekt kwerendy.

  5. W oknie dialogowym Pokazywanie tabeli kliknij dwukrotnie Szczegóły zamówienia i zamówienia.

  6. Zamknij okno dialogowe Pokazywanie tabeli.

  7. W tabeli Zamówienia kliknij dwukrotnie pola Identyfikator klienta i Miasto odbiorcy, aby dodać je do siatki projektu.

  8. W tabeli Szczegóły zamówienia kliknij dwukrotnie pola Identyfikator zamówienia, Identyfikator produktu, Ilość, Cena jednostkowa i Rabat, aby dodać je do siatki projektu.

  9. W kolumnie Miasto odbiorcy w siatce projektu wyczyść pole w wierszu Pokaż. W wierszu kryteria wpisz 'nazwę Kielce' (zawiera pojedynczy cudzysłów).

    Sprawdź wyniki kwerendy, przed użyciem ich w celu utworzenia tabeli.

  10. Na karcie Projektowanie w grupie Wyniki kliknij przycisk Uruchom.

  11. Naciśnij klawisze CTRL+S, aby zapisać kwerendę.

    Zostanie wyświetlone okno dialogowe Zapisywanie jako.

  12. W polu Nazwa zapytania wpisz nazwę Zapytanie zamówień z Kielc, a następnie kliknij przycisk OK.

  13. Na karcie Narzędzia główne w grupie Widoki kliknij pozycję Widok, a następnie kliknij pozycję Widok projektu.

  14. Na karcie Projektowanie w grupie Typ zapytania kliknij pozycję Utwórz tabelę.

    Zostanie wyświetlone okno dialogowe Tworzenie tabeli.

  15. W oknie dialogowym Tworzenie tabeli w polu Nazwa tabeli wpisz nazwę Zamówienia z Kielc, a następnie kliknij przycisk OK.

  16. Na karcie Projektowanie w grupie Wyniki kliknij przycisk Uruchom.

  17. W oknie dialogowym potwierdzenia kliknij przycisk Tak, aby potwierdzić.

    Nowa tabela zostanie utworzona i tabeli jest wyświetlana w okienku nawigacji.

    Uwaga: Jeśli tabela, która ma o określonej nazwie już istnieje, tej tabeli zostanie usunięty przed uruchomieniem kwerendy.

  18. Na karcie Projektowanie w grupie Wyniki kliknij przycisk Uruchom.

    Ponieważ istnieje w tabeli zamówienia z Kielc, zostanie wyświetlone okno dialogowe Ostrzeżenie.

  19. Kliknij przycisk nie, aby anulować akcję i zamknąć okno dialogowe.

Początek strony

Dodawanie danych do tabeli za pomocą danych z innych tabel

Aby pobrać dane z jednej lub kilku tabel i dodać je do innej tabeli, możesz użyć kwerendy dołączającej.

Uwaga: Nie można uruchomić kwerendę dołączającą w przeglądarce sieci web.

Załóżmy, że utworzono tabeli, aby udostępnić Skojarz firm Chicago, ale okazuje się, że działa także skojarzyć z klientami w obszarze nazwę Toruń. Chcesz dodać wiersze zawierające nazwę Toruń obszar danych do tabeli przed udostępnieniem tabeli z Skojarz.

Można dodać nazwę Toruń obszar danych w tabeli zamówienia z Kielc, utworzoną w poprzednim przykładzie przy użyciu następującej procedury:

  1. Otwórz w widoku projektu kwerendę o nazwie „Kwerenda zamówień z Kielc”.

  2. Na karcie Projektowanie w grupie Typ zapytania kliknij przycisk Dołącz. Zostanie otwarte okno dialogowe Dołączanie.

  3. W oknie dialogowym Dołączanie kliknij strzałkę w polu Nazwa tabeli, a następnie wybierz z listy rozwijanej Zamówienia z Kielc.

  4. Kliknij przycisk OK.

    Zamyka okno dialogowe Dołączanie. W siatce projektu zniknie wiersz Pokaż, a zostanie wyświetlony wiersz Dołączanie do.

  5. W siatce projektu w wierszu Kryteria kolumny Miasto odbiorcy usuń nazwę 'Kielce', a następnie wpisz nazwę 'Toruń'.

  6. W wierszu Dołączanie do wybierz odpowiednie pole dla każdej kolumny.

    W tym przykładzie wartości wiersza Dołączanie do powinny być zgodne z wartościami wiersza Pole, ale nie jest to wymagane do działania kwerend dołączających.

  7. Na karcie Projektowanie w grupie Wyniki kliknij przycisk Uruchom.

Uwaga:  Uruchomienie kwerendy zwracającej dużą ilość danych może spowodować pojawienie się komunikatu o błędzie z informacją, że cofnięcie kwerendy nie będzie możliwe. Aby umożliwić przeprowadzenie kwerendy, należy spróbować zwiększyć ograniczenie segmentu pamięci do 3 MB.

Początek strony

Zmienianie danych w zautomatyzowany sposób

Aby zmienić dane w tabelach i wprowadzić kryteria określające, które wiersze powinny zostać zaktualizowane, możesz użyć kwerendy aktualizującej. Kwerenda aktualizująca daje możliwość przejrzenia zaktualizowanych danych przed wykonaniem aktualizacji.

Ważne: Kwerendy funkcjonalnej nie można cofnąć. Należy rozważyć utworzenie kopii zapasowej wszelkich tabel, które zostaną zaktualizowane za pomocą kwerendy aktualizującej.

Uwaga: Nie można uruchomić kwerendy aktualizującej w przeglądarce sieci web.

W poprzednim przykładziewierszy jest dołączany do tabeli zamówienia z Kielc. W tabeli zamówienia z Kielc pole Identyfikator produktu zawiera liczbowe identyfikator produktu. Aby wprowadzić dane przydatności dla raportów, można zastąpić identyfikatory produktu nazwy produktów. Aby zamienić identyfikatorów produktu, należy najpierw zmienić typ danych pola Identyfikator produktu w tabeli zamówienia z Kielc od numeru do tekstu, tak, aby zaakceptować nazwy produktów pola Identyfikator produktu.

Wartości w tabeli zamówienia z Kielc można aktualizować przy użyciu następującej procedury:

  1. Otwórz w widoku projektu tabelę Zamówienia z Kielc.

  2. W wierszu Identyfikator produktu zmień typ danych z Liczba na Tekst.

  3. Zapisz i zamknij tabelę Zamówienia z Kielc.

  4. Na karcie Tworzenie w grupie Kwerendy kliknij przycisk Projekt kwerendy.

  5. W oknie dialogowym Pokazywanie tabeli kliknij dwukrotnie Zamówienia z Kielc i produktów.

  6. Zamknij okno dialogowe Pokazywanie tabeli.

  7. Na karcie Projektowanie w grupie Typ kwerendy kliknij przycisk Aktualizuj.

    W siatce projektu znikną wiersze Sortuj i Pokaż oraz zostanie wyświetlony wiersz Aktualizacja do.

  8. W tabeli Zamówienia z Kielc kliknij dwukrotnie pole Identyfikator produktu, aby dodać je do siatki projektu.

  9. W siatce projektu w wierszu Aktualizacja do kolumny Identyfikator produktu wpisz lub Wklej po:

    [Produkt]. [Nazwa produktu]

    Porada: Za pomocą kwerendy aktualizującej możesz usunąć wartości pól, stosując w wierszu Aktualizacja do pusty ciąg ("") lub wartość NULL.

  10. W wierszu kryteria wpisz lub wklej następujący ciąg:

    [Idproduktu] Przykład ([Produkty]. [ IDENTYFIKATOR])

    Słowa kluczowego Like jest konieczne, ponieważ pola, które są porównanie zawierać różne typy danych (identyfikator produktu jest danych tekstowych, identyfikator jest dane liczbowe).

  11. Wartości, które zostaną zmienione przez kwerendę aktualizującą, możesz przejrzeć, wyświetlając kwerendę w widoku arkusza danych.

    Na karcie Projektowanie w grupie Wyniki kliknij przycisk Widok, a następnie kliknij pozycję Widok arkusza danych.

    Kwerenda zwraca listę identyfikatorów produktów, które zostaną zaktualizowane.

  12. Na karcie Projektowanie w grupie Wyniki kliknij przycisk Uruchom.

    Po otwarciu tabeli zamówienia z Kielc, pojawi się, że wartości liczbowych w polu Identyfikator produktu zostały zastąpione nazwy produktów z tabeli Produkty.

Początek strony

Usuwanie danych w zautomatyzowany sposób

Za pomocą kwerendy usuwającej możesz usuwać dane z tabel i wprowadzać kryteria określające, które wiersze powinny zostać usunięte. Kwerenda usuwająca zapewnia możliwość przejrzenia wierszy, które zostaną usunięte, przed wykonaniem operacji usunięcia.

Uwaga: Nie można uruchomić kwerendę usuwającą w przeglądarce sieci web.

Załóżmy, że przygotowujesz Wyślij skojarzyć tabelę zamówienia z Kielc (zaktualizowane w poprzednim przykładzie) dla Twojej firmy Chicago i zwróć uwagę, że niektóre wiersze zawierają liczby pustych pól. Czy chcesz usunąć te wiersze, które zawierają puste pola, przed wysłaniem tabeli. Może po prostu otwórz tabelę i ręcznie Usuń wiersze, ale może okazać się korzystanie z kwerendy usuwającej, jeśli istnieje więcej niż kilku wierszy, które chcesz usunąć, i masz Wyczyść kryteria, dla których powinny zostać usunięte wiersze.

Aby za pomocą kwerendy usunąć wiersze z tabeli Zamówienia z Kielc, które nie mają wartości dla pola Identyfikator zamówienia, wykonaj poniższą procedurę:

  1. Na karcie Tworzenie w grupie Kwerendy kliknij przycisk Projekt kwerendy.

  2. W oknie dialogowym Pokazywanie tabeli kliknij dwukrotnie Zamówienia z Kielc.

  3. Zamknij okno dialogowe Pokazywanie tabeli.

  4. Na karcie Projektowanie w grupie Typ zapytania kliknij pozycję Usuwające.

    W siatce projektu zniknie wiersz Sortuj i Pokaż, a zostanie wyświetlony wiersz Usuń.

  5. W tabeli Zamówienia z Kielc kliknij dwukrotnie pole Zamówienie, aby dodać je do siatki.

  6. W siatce projektu w wierszu Kryteria kolumny Identyfikator zamówienia wpisz ciąg Is Null.

  7. Na karcie Projektowanie w grupie Wyniki kliknij przycisk Uruchom.

Początek strony

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×