Utworzyć rozwiązanie śledzenie elementów zawartości przy użyciu programu InfoPath i programu Excel

Uwaga:  Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Program Microsoft Office InfoPath umożliwia tworzenie szablonów formularzy do wprowadzania danych i pobranie. Microsoft Office Excel 2007 pozwala użytkownikom na obliczanie wykresu i analizowania danych. Przy użyciu zarówno tych programów i XML, można łatwo tworzyć proste, ale rozwiązania biznesowego skuteczne, bez użycia kodu do śledzenia składników majątku w firmie.

Przegląd rozwiązania do śledzenia składników majątku

W tym artykule

Wprowadzenie do tworzenia rozwiązanie śledzenia składników majątku

Krok 1: Dostosowywanie szablonu formularza śledzenia składników majątku

Krok 2: Mapowanie pliku schematu i dostosować układ tabeli w programie Excel

Krok 3: Tworzenie raportu podsumowującego tabeli przestawnej i wykresu przestawnego

Krok 4: Zbieranie informacji zawartości przed użytkownikami

Krok 5: Importowanie formularzy w programie Excel

Ostateczne pomysły: Korzystanie z listy programu SharePoint lub bazy danych programu Access

Wprowadzenie do tworzenia rozwiązanie śledzenia składników majątku

Można się wymieniać dane XML między programem InfoPath i programu Excel. Mimo że polecenia programu Infopath, Eksportowanie jest proste, proste sposób wysłać danych formularza do programu Excel, ma innej metody można wykonać, która zapewnia większą elastyczność. Wyraźnie mapowanie pliku schematu programu InfoPath XML (XSD) w programie Excel, a następnie importując pliki formularza programu InfoPath (XML) do programu Excel możesz dostosować układ danych i lepiej wykorzystać funkcje w programie Excel ułatwiające zarządzanie i analizowanie danych zwiększyć wydajność.

W tym artykule użyjemy szablonu formularza przykładowe śledzenia składników majątku programu InfoPath aby przedstawić, jak można wprowadzić programu InfoPath, XML i współpraca programu Excel. Załóżmy, że każdego roku organizacji spisy składników majątku w każdym z pracowników w pakiecie office. Raport programu Excel jest przemieszczać się ułatwić podjęcie decyzji o sposobie Alokacja budżetu sprzętu następny rok. Poniższym diagramie przedstawiono sposób gromadzenie, śledzenie i raportowanie danych o wyposażeniu z działu.

a

1 zostanie utworzony szablon formularza śledzenia składników majątku.

2. pliku schematu są mapowane do tabeli programu Excel i jest dostosowany układ tabeli.

3. utworzono pustej tabeli przestawnej i wykresu przestawnego raportu podsumowującego.

4 formularz śledzenia składników majątku służy do zbierania danych od użytkowników.

5. tabeli programu Excel są eksportowane wszystkie dane formularzy i raportów w formie tabeli przestawnej i wykresu przestawnego są odświeżane.

To rozwiązanie obejmuje następujące role użytkownika i produktów:

Ikona pełnej obsługi = wymagane Ikona braku obsługi = wymagane

Wymagania dotyczące oprogramowania

Role

Office InfoPath 2007

Office Outlook 2007

Office Excel 2007

Projektant rozwiązanie

Ikona pełnej obsługi

Ikona pełnej obsługi

Ikona pełnej obsługi

Instytucjach

Ikona pełnej obsługi

Ikona pełnej obsługi

Ikona pełnej obsługi

Pracowników

Ikona pełnej obsługi

Ikona pełnej obsługi

Ikona braku obsługi

Początek strony

Krok 1: Dostosowywanie szablonu formularza śledzenia składników majątku

Szablon formularza śledzenia składników majątku, który znajduje się w programie InfoPath, umożliwia zbieranie informacji na temat poszczególnych elementów zawartości w pakiecie office pracownika, należący do kategorii składniki majątku i szczegółowe informacje dotyczące poszczególnych składników majątku pracownika działu. W tym rozwiązaniu Projektant formularza prześle szablonu formularza do konta e-mail maker decyzji przy użyciu Office Outlook 2007.

Szablon śledzenia wyposażenia

Otwórz zadanie 1: I dostosowywanie szablonu formularza śledzenia składników majątku

Ponieważ nie można opublikować szablonu formularza do listy adresatów wiadomości e-mail, jeśli został formantu pola tekstu sformatowanego zawierające obrazy połączone, należy wprowadzić niewielkie zmiany do śledzenia składników majątku przykładowego szablonu formularza.

  1. W menu plik kliknij pozycję Projektowanie szablonu formularza.

  2. W oknie dialogowym Projektowanie szablonu formularza w obszarze, Otwórz szablon formularza, kliknij przycisk Dostosuj próbki.

  3. W oknie dialogowym Wprowadzenie kliknij próbka - śledzenia składników majątku, a następnie w obszarze Zadania formularza kliknij przycisk Projektuj ten formularz.

  4. Kliknij prawym przyciskiem myszy kontrolkę assetNotes, wskaż polecenie Właściwości Pole tekstu sformatowanego, kliknij kartę Wyświetlanie, a następnie w obszarze Dostępne formatowanie, wyczyść pole wyboru Połączone obrazy.

Zadanie 2: Definiowanie opcje przesyłania

Następnego zadania jest zdefiniowanie opcje przesyłania, tak aby pracownicy mogą przesyłać plik o unikatowej nazwie formularza (XML) do konta e-mail maker decyzji jako załączony plik.

  1. W menu Narzędzia kliknij polecenie Opcje przesyłania.

  2. W oknie dialogowym Opcje przesyłania zaznacz pole wyboru Zezwalaj użytkownikom na przesyłanie tego formularza.

  3. Kliknij przycisk Wyślij danych formularza do jednego miejsca docelowego, a następnie na liście kliknij pozycję wiadomość E-mail.

  4. Kliknij przycisk Dodaj.

    Zostanie wyświetlony Kreator połączenia danych.

  5. W polu do wpisz alias instytucjach, które będą otrzymywać przesłanych formularzy.

  6. Aby określić unikatowy temat w polu temat:

    • Kliknij przycisk Wstaw formułę Obraz przycisku .

    • Wpisz następującą formułę:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  • Kliknij przycisk Sprawdź formułę, a następnie kliknij przycisk OK.

  • W oknie dialogowym wprowadzenie wpisz odpowiedni komunikat lub Dodaj ważne instrukcje dla tego rozwiązania.

  • Kliknij przycisk Dalej.

  • Na następnej stronie kreatora kliknij przycisk Wyślij danych formularza jako załącznik, a następnie zaznacz pole wyboru Dołącz szablon formularza, aby upewnić się, że użytkownicy mogą otwierać formularz.

    Pomaga to zapewnić, że pracownicy mają dostęp do pliku szablonu formularza (xsn), w przypadku, gdy odmowie dostępu z jego lokalizacji sieciowej.

  • Aby określić nazwę pliku dla każdego pliku formularza (XML) w polu Nazwa załącznika:

    1. Kliknij przycisk Wstaw formułę Obraz przycisku .

    2. Wpisz tę samą formułę jako znajdującą się w wierszu tematu:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  1. Kliknij przycisk Sprawdź formułę, a następnie kliknij przycisk OK.

  • Kliknij przycisk Dalej.

  • Na następnej stronie kreatora w polu Wprowadź nazwę dla tego połączenia danych wpisz opisową nazwę dla tego przedstawia połączenia danych.

  • Sprawdź, że informacje są prawidłowe, w sekcji Podsumowanie, a następnie kliknij przycisk Zakończ.

  • Zapisz formularz go do folderu sieciowego publicznej dostępny instytucjach i wszystkich pracowników.

Początek strony

Krok 2: Mapowanie pliku schematu i dostosować układ tabeli w programie Excel

Konfigurowanie połączenia między programem InfoPath i Excel wymaga trzech zadań: wyodrębnianie pliku schematu dla szablonu formularza śledzenia składników majątku, mapowanie tego pliku schematu w programie Excel i dostosowywanie domyślnego układu tabeli programu Excel, zawierające wszystkie importowanej zawartości XML pliki danych formularza.

Zadanie 1: Wyodrębnianie pliku schematu programu InfoPath

  1. W programie InfoPath Otwórz plik szablonu formularza śledzenia składników majątku.

  2. W menu Narzędzia kliknij przycisk Projektuj ten formularz.

  3. W menu plik kliknij polecenie Zapisz jako pliki źródłowe.

  4. W oknie dialogowym Przeglądanie w poszukiwaniu folderu wybierz folder lub Utwórz nowy folder, w którym chcesz przechowywać plik schematu.

Uwaga lokalizację folderu, w którym wszystkie pliki źródłowe zostaną zapisane i nazwę pliku schematu, w tym przypadku myschema.xsd, zawierający definicja schematu formularza danych XML.

Zadanie 2: Mapowanie pliku schematu programu InfoPath w programie Excel

  1. Tworzenie nowego pliku programu Excel, a następnie zapisz ją w lokalizacji dostępnej dla instytucjach.

  2. W programie Excel Jeśli karta Deweloper nie jest widoczna, wykonaj następujące czynności:

    1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij przycisk Opcje programu Excel.

    2. W kategorii Popularne w obszarze Najczęściej używane opcje w pracy z programem Excel zaznacz pole wyboru Pokaż kartę Deweloper na Wstążce, a następnie kliknij przycisk OK.

      Uwaga: Wstążka to element udostępniany przez interfejs użytkownika Microsoft Office Fluent.

  3. Na karcie Deweloper w grupie XML kliknij przycisk Źródło.

    Grupa XML na Wstążce

    Wyświetlane jest okienko zadań Źródło XML.

  4. Kliknij przycisk Mapy XML, a następnie w oknie dialogowym Mapy XML, kliknij przycisk Dodaj.

  5. Na komputerze z systemem Windows Vista   

    1. Na pasku adresu kliknij dysk lub folder, który zawiera plik myschema.xsd , który został utworzony w kroku 2 sekcji zadania 1: wyodrębniania pliku schematu programu InfoPath.

      Na komputerze, na którym działa program Microsoft Windows XP   

    2. Na liście Szukaj kliknij dysk lub folder, który zawiera plik myschema.xsd , który został utworzony w kroku 2 sekcji zadania 1: wyodrębniania pliku schematu programu InfoPath.

  6. Kliknij plik, a następnie kliknij przycisk Otwórz.

  7. Gdy pojawi się okno dialogowe Wiele katalogów głównych, kliknij węzeł główny assetTracking, która jest zdefiniowana w pliku myschema.xsd, a następnie kliknij przycisk OK.

    Mapa XML zostanie wyświetlona w okienku zadań Źródło XML.

  8. Przeciągnij element węzeł ns1:asset, czyli powtarzający się element XML do lokalizacji w arkuszu miejsce, w którym ma się pojawić tabela programu Excel.

    Mapowanie pliku schematu programu InfoPath na dane programu Excel

Zadanie 3: Dostosowywanie układu tabeli programu Excel

Domyślnie program Excel używa tych nazw elementów XML jako nagłówków kolumn w tabeli. Nagłówki kolumn można zmieniać, edytując komórki nagłówka kolumny.

  1. Aby zmodyfikować nagłówków kolumn domyślnych, zachowania po zaznaczeniu tabeli programu Excel, znajdź następujący prefiks ciąg ns1:asset i usuń ją. Na przykład chcesz zmienić ns1:assetIDID.

    Dostosowywanie nagłówków tabeli programu Excel

  2. Aby dopasować szerokość kolumny, kliknij przycisk Zaznacz wszystko, a następnie kliknij dwukrotnie dowolne obramowanie nagłówka kolumny.

Początek strony

Krok 3: Tworzenie raportu podsumowującego tabeli przestawnej i wykresu przestawnego

Decydentów za pomocą tabeli przestawnej i wykresu przestawnego raportów do analizowania, eksplorowanie i wizualizowanie danych podsumowania. Konfigurowanie raportów tabeli przestawnej i wykresu przestawnego, który ma być używany w tym scenariuszu wyprzedzeniem, będzie ona prostych operacji dla instytucjach do późniejszego uruchomienia raportu z danymi złożonym.

  1. Zaznacz komórkę w tabeli programu Excel.

  2. Na karcie Wstawianie w grupie tabele kliknij przycisk Tabela przestawna, a następnie kliknij przycisk Tabela przestawna.

    Obraz Wstążki programu Excel

    W programie Excel zostanie wyświetlone okno dialogowe Tworzenie tabeli przestawnej.

  3. Aby umieścić raport w formie tabeli przestawnej w nowym arkuszu, zaczynając od komórki A1, kliknij przycisk Nowy arkusz, a następnie kliknij przycisk OK.

    Program Excel doda pusty raport w formie tabeli przestawnej we wskazanej lokalizacji oraz wyświetli Listę pól tabeli przestawnej, umożliwiając dodawanie pól, utworzenie układu i dostosowanie raportu w formie tabeli przestawnej.

  4. Aby utworzyć raport tabelaryczny krzyżowe danych, przeciągnij pole identyfikator do obszaru wartości, pole działu do obszaru etykiety kolumn, pole kategorii do obszaru etykiety wierszy i pole AssignedTo do obszaru filtru raportu.

  5. Kliknij raport w formie tabeli przestawnej.

  6. Na karcie Wstawianie w grupie Wykresy kliknij typ wykres słupkowy.

    Obraz Wstążki programu Excel

  7. W obszarze słupkowy 2-W, zaznacz Słupkowy grupowany.

  8. Dopasuj rozmiar i położenie raportu wykresu przestawnego do preferencji.

Puste raporty w postaci tabeli przestawnej i wykresu przestawnego

Początek strony

Krok 4: Zbieranie informacji zawartości przed użytkownikami

Teraz, że szablon formularza jest gotowy do wypełniania przez wszystkich pracowników, musisz opublikować formularz i wyślij ją do każdego pracownika. Po każdym z pracowników prześle wypełniony formularz, jest wysyłana jako plik danych XML (XML) dołączony do wiadomości e-mail do konta e-mail maker decyzji. Instytucjach następnie przenieść wszystkie wiadomości w dedykowanej folderze programu InfoPath w programie Outlook. W tym scenariuszu zaleca się przypisanie określonego przedziału czasu dla wszystkich użytkowników do wykonania formularzy, tak aby instytucjach można uruchomić raport z wypełnionych formularzy, gdy została osiągnięta terminu ostatecznego zbierania danych.

Wprowadzanie danych w formularzach śledzenia wyposażenia

  1. W programie InfoPath, otwieranie szablonu formularza (xsn), który został zapisany w Krok 1: Projektowanie szablonu formularza przykładowe śledzenia składników majątku

  2. W menu Narzędzia kliknij przycisk Projektuj ten formularz.

  3. W menu plik kliknij pozycję Publikuj.

  4. W Kreatorze publikowania kliknij do listy adresatów wiadomości e-mail, a następnie kliknij przycisk Dalej.

  5. Na następnej stronie kreatora, w polu Nazwa szablonu formularza wpisz nazwę dla szablonu formularza, a następnie kliknij przycisk Dalej. Nazwa szablonu formularza pojawi się w temacie nagłówek wiadomości, które są wysyłane do adresatów wiadomości e-mail.

  6. Opcjonalnie na następnej stronie kreatora, możesz utworzyć kolumny, które będą wyświetlane w folderach programu Outlook ułatwia organizowanie wiadomości e-mail.

  7. Kliknij przycisk Dalej.

  8. Kliknij pozycję Opublikuj.

  9. Po zakończeniu Kreatora publikowania publikowanie szablonu formularza wiadomości e-mail z formularzem zostanie otwarty.

  10. Wypełnij wiadomość, wpisz w polu nazwy pracowników lub za pomocą listy dystrybucyjnej, a następnie wyślij wiadomość.

W programie Outlook instytucjach można zorganizować wszystkie przesłane formularze XML w jeden z dwóch sposobów:

  • Jeśli po raz pierwszy pojawi się okno komunikatu Foldery formularzy programu InfoPath zostanie otwarta wiadomość, kliknij przycisk Utwórz Folder formularzy.

  • Tworzenie reguły w programie Outlook, aby przenieść wszystkie powiązane formularze programu InfoPath z folderem programu InfoPath.

    Aby uzyskać więcej informacji zobacz Zarządzanie wiadomościami za pomocą reguł.

Początek strony

Krok 5: Importowanie formularzy w programie Excel

Ponieważ utworzone kroki skoroszytu programu Excel, 2 i 3, jest proste sprawą producenta decyzji eksportowanie i przeglądanie danych formularza. Maker decyzji należy po prostu wyeksportować pliki xml (XML) z programu Outlook, Importuj wszystkie pliki formularza (XML) do skoroszytu programu Excel, a następnie odświeżania danych.

Zadanie 1: Eksportowanie formularzy z programu Outlook do folderu systemu Windows

  1. W programie Outlook wybierz folder, który zawiera wszystkie formularze, które zostały uzyskane od pracowników, a następnie naciśnij klawisze CTRL + A, aby zaznaczyć wszystkie wiadomości e-mail formularza.

  2. Kliknij prawym przyciskiem myszy zaznaczenie, wskaż pozycję Akcje programu InfoPath, a następnie kliknij Eksportowanie formularzy.

  3. W oknie dialogowym Eksportowanie formularzy wybierz folder, a następnie kliknij przycisk OK.

Zadanie 2: Importowanie formularzy w programie Excel

  1. W skoroszycie programu Excel, który został utworzony na Krok 2: mapowanie pliku schematu i dostosować układ tabeli w programie Excel, wybierz jedną z zamapowanych komórek w tabeli programu Excel.

  2. Na karcie Deweloper w grupie XML kliknij przycisk Importuj.

    Grupa XML na Wstążce

    Zostanie wyświetlone okno dialogowe Importowanie plików XML.

  3. Na komputerze z systemem Windows Vista   

  4. Wykonaj jedną z następujących czynności:

    • Jeśli pliki są ciągłe, przytrzymaj naciśnięty klawisz SHIFT, a następnie kliknij pierwszy i ostatni plik na liście.

    • Jeśli pliki są ciągłe, przytrzymując naciśnięty klawisz CTRL, a następnie kliknij każdy plik, który chcesz zaimportować na liście.

  5. Kliknij przycisk Importuj.

    Tabela programu Excel z importowanymi danymi

Domyślnie programu Excel zostaną zastąpione wszelkie dane znajdujące się w zamapowanych komórek, czyli odpowiedniej ostateczny wynik dla tego rozwiązania biznesowego. Jednak instytucjach można na przykład zaimportować dane kilka razy do oceny postępu zaplanowanym terminie.

Uwaga: W programie Excel można także dołączyć dane przy użyciu opcji Dołącz nowe dane do istniejących tabel XML (na karcie Deweloper w grupie XML kliknij przycisk Właściwości mapy), które mogą być odpowiednie dla innych rozwiązań.

Aby uzyskać więcej informacji zobacz Importowanie plików XML danych.

Zadanie 3: Odświeżanie raportów tabeli przestawnej i wykresu przestawnego

  • Kliknij komórkę w raporcie tabeli przestawnej.

  • Na karcie Opcje w grupie dane kliknij strzałkę obok pozycji Odśwież wszystko, a następnie kliknij polecenie Odśwież.

    Obraz Wstążki programu Outlook

raport końcowy w formie tabeli i wykresu przestawnego

Skoroszyt programu Excel zawiera teraz wszystkie dane i podsumowanie raportów, musisz pomóc Alokacja budżetu sprzętu następny rok. Oczywiście, możesz wykonać dalszej analizy w skoroszycie programu Excel, jeśli to konieczne, takie jak sortowanie, filtrowanie i formatowanie warunkowe danych.

Początek strony

Ostateczne pomysły: Korzystanie z listy programu SharePoint lub bazy danych programu Access

Alternatywnie warto rozważyć użycie listy programu SharePoint lub bazy danych programu Access, zamiast XML, do przenoszenia danych między programem InfoPath i programu Excel.

Za pomocą listy programu SharePoint

Z poziomu programu InfoPath można łatwo używać listy programu SharePoint jako źródła danych tylko do odczytu. Możesz wykonać jedną z dwóch czynności:

  • Z listy programu SharePoint Wyeksportuj dane do programu Excel, co powoduje automatyczne utworzenie połączenia danych w programie Excel.

  • Z programu Excel jawnie Utwórz połączenie danych z listy programu SharePoint.

Po utworzeniu połączenia danych można odświeżyć dane w programie Excel w celu zaktualizowania danych.

Listy programu SharePoint umożliwia dodawanie i aktualizowanie danych, formularz programu InfoPath umożliwia wyświetlenie elementu z listy (na przykład złożonych długi element lub najlepsze wyświetlany pionowo) i dalszej analizy danych za pomocą programu Excel.

Łączenie programu InfoPath, listy programu SharePoint i programu Excel

1. wyświetlanie pojedynczego elementu do przejrzenia łatwe w programie InfoPath.

2. Dodawanie i aktualizowanie danych na liście programu SharePoint.

3. odświeżanie i zgłoś aktualne z programem Excel.

Aby uzyskać więcej informacji zobacz Dodawanie połączenia danych do listy lub biblioteki dokumentów programu SharePoint

Używanie bazy danych programu Access

Z poziomu programu InfoPath można utworzyć połączenie odczytu/zapisu bazy danych programu Access. Z programu Excel możesz utworzyć jawnie połączenie danych z bazy danych programu Access można odświeżać w celu zaktualizowania danych. Można nawet zdefiniować połączenie w celu odświeżenia automatycznie podczas otwierania skoroszytu lub okresowo odświeżać, takie jak co 5 minut.

Za pomocą bazy danych programu Access jako pośrednik między programem InfoPath i programu Excel. Po przesłaniu formularza programu InfoPath do programu Access, możesz zaktualizować bazę danych programu Access. Po odświeżeniu połączenia danych w programie Excel można pobierać zaktualizowane dane z programu Access. W praktyce przesyłasz dane bezpośrednio z poziomu programu InfoPath w skoroszycie programu Excel.

Łączenie programów InfoPath, Access i Excel

1. wyświetlane i przesyłania formularza do bazy danych programu Access.

2. przechowywania danych w bazie danych programu Access.

3. odświeżanie i zgłoś aktualne z programem Excel.

Aby uzyskać więcej informacji zobacz Projektowanie szablonu formularza jest oparty na bazie danych programu Microsoft Access.

Porada: Czy wiesz, że można utworzyć formularz programu InfoPath bezpośrednio z programu Access 2007? Jeśli użytkownicy mają program Outlook 2007 i InfoPath 2007 na swoich komputerach, możesz Zbierz dane od różnych użytkowników bezpośrednio z programu Access 2007 przy użyciu kreatora Zbieranie danych z wiadomości e-mail. Aby uzyskać więcej informacji zobacz temat pomocy 2007 dostęp Zbieranie danych przy użyciu wiadomości e-mail.

Początek strony

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×