Ustawianie opcji użytkownika dla bieżącej bazy danych

Uwaga : Ten artykuł nie dotyczy aplikacji sieci Web programu Access — typu baz danych projektowanych przy użyciu programu Access i publikowanych w trybie online. Aby uzyskać więcej informacji, zobacz Tworzenie aplikacji programu Access.

Aby dostosować ustawienia użytkownika, na przykład sposób wyświetlania okien obiektów, skróty klawiaturowe i opcje korekty automatycznej dla aktualnie otwartej bazy danych dla komputerów stacjonarnych programu Access, kliknij kolejno pozycje Plik i Opcje, a następnie zmień opcje w kategorii Bieżąca baza danych.

Uwaga : Jeśli nie zaznaczono inaczej, zmiany ustawień zostaną zastosowane dopiero po zamknięciu i ponownym otwarciu bazy danych.

Co chcesz zrobić?

Dostosowywanie opcji dla bieżącej bazy danych

Istnieje możliwość szybkiego dostosowania sposobu wyświetlania nazwy i logo aplikacji, wyświetlania okien obiektów oraz zarządzania plikami w bieżącej aplikacji lub bazie danych. W otwartej bazie danych W przypadku bieżącej aplikacji lub bazy danych:

  1. Kliknij pozycję Plik > Opcje > Bieżąca baza danych.

  2. Wybierz ustawienia dla bieżącej bazy danych. Oto najczęściej używane ustawienia — więcej z nich opisano w dalszej części artykułu.

Ustawienie

Opis

Tytuł aplikacji

Umożliwia określenie niestandardowej nazwy, która będzie wyświetlana na pasku tytułu systemu Windows bieżącej bazy danych.

Ikona aplikacji

Umożliwia wybranie ikony dla bieżącej bazy danych. Należy wpisać nazwę pliku obrazu lub kliknąć przycisk Przeglądaj, aby znaleźć ten plik. Wybrana ikona będzie wyświetlana na pasku tytułu systemu Windows.

Użyj jako ikony formularza i raportu

Jeśli ta opcja jest zaznaczona, ikona aplikacji będzie wyświetlana na kartach wszystkich formularzy i raportów bieżącej bazy danych. Jeśli karty dokumentów nie są włączone, ikona nie będzie wyświetlana.

Wyświetl formularz

Umożliwia określenie formularza, który będzie wyświetlany po otwarciu bazy danych. Jeśli po otwarciu bazy danych nie ma być wyświetlany żaden formularz, należy zostawić ustawienie domyślne (brak).

Formularz wyświetlany w sieci Web

Jeśli ta opcja jest zaznaczona, użytkownicy mogą określać, zmieniać i usuwać formularze wyświetlane w sieci Web.

Wyświetl pasek stanu

Jeśli ta opcja jest zaznaczona, w dolnej części obszaru roboczego programu Access jest wyświetlany pasek stanu.

  1. Po zakończeniu kliknij przycisk OK.

    Niektóre ustawienia wymagają zamknięcia i ponownego otwarcia bazy danych, aby zmiany zostały wprowadzone.

Początek strony

Wybieranie ustawień wyglądu okien obiektów

Program Access zawiera opcję umożliwiającą wyświetlenie wszystkich otwartych obiektów na szeregu łatwo dostępnych kart wzdłuż górnej krawędzi okna obiektów. W obszarze Opcje okna dokumentu w kategorii Bieżąca baza danych możesz ustawić następujące opcje wyświetlania.

Ustawienie

Opis

Nakładające się okna

Jeśli ta opcja jest zaznaczona, wiele otwartych obiektów nakłada się jeden na drugi.

Sposób wyświetlania okien obiektów w widoku nakładających się okien

Dokumenty kartotekowe

Jeśli ta opcja jest zaznaczona, w danej chwili widać tylko jeden obiekt, nawet jeśli jest otwartych wiele obiektów.

Obraz przedstawiający sposób wyświetlania otwartych obiektów po zaznaczeniu opcji dokumentów kartotekowych

Ustawienia Dokument kartotekowy można używać bez wyświetlonych kart dokumentów, co jest pomocne w sytuacji, gdy użytkownicy muszą pracować z obiektami pojedynczo. Usuwając zaznaczenie tej opcji, należy zaznaczyć inną opcję nawigacji, aby umożliwić użytkownikom przełączanie obiektów.

Wyświetl karty dokumentów

Po zaznaczeniu opcji Dokumenty kartotekowe można zaznaczyć także tę opcję, aby wyświetlić karty wszystkich otwartych obiektów.

Użyj kontrolek z motywów systemu Windows w formularzach

Jeśli ta opcja jest zaznaczona, w kontrolkach formularzy i raportów w bieżącej bazie danych jest używana kompozycja systemu Windows użytkownika.

Włącz widok układu

Jeśli ta opcja jest zaznaczona, na pasku stanu programu Access i w menu skrótów wyświetlanym po kliknięciu prawym przyciskiem myszy karty obiektu jest widoczny przycisk Widok układu. W przypadku wyczyszczenia tej opcji użytkownik nie będzie mógł otwierać formularzy ani raportów w widoku układu.

Uwaga : Jeśli ta opcja jest wyczyszczona, opcja Widok układu nie jest dostępna w grupie Widoki ani w żadnym menu skrótów.

Włącz zmiany projektu w tabelach w widoku arkusza danych

Jeśli ta opcja jest zaznaczona, można zmieniać projekt tabel w widoku arkusza danych.

Wyszukaj obcięte pola liczbowe

Jeśli ta opcja jest zaznaczona, to w sytuacji, gdy kolumna jest zbyt wąska, aby wyświetlić całą wartość, liczby w programie Access są wyświetlane w postaci „#####”. Jeśli ta opcja nie jest zaznaczona, to w kolumnie jest widoczna tylko część wartości.

Format przechowywania właściwości obrazów

Jeśli ta opcja jest zaznaczona, to obrazy będą przechowywane w programie Access w ich oryginalnym formacie. Tę opcję należy zaznaczyć, aby zmniejszyć rozmiar bazy danych.

Konwertuj wszystkie dane obrazu na mapy bitowe (zgodne z programem Access 2003 i wcześniejszymi wersjami)

Jeśli ta opcja jest zaznaczona, w programie Access jest tworzona kopia oryginalnego pliku obrazu w formacie mapy bitowej Windows lub mapy bitowej niezależnej od urządzenia. Tę opcję należy zaznaczyć, aby przeglądać obrazy w bazach danych utworzonych za pomocą programu Office Access 2003 i starszych wersji.

Początek strony

Umożliwianie korzystania ze skrótów klawiaturowych programu Access

Jeśli jest zaznaczona opcja Użyj specjalnych klawiszy programu Access, użytkownicy mogą używać w bieżącej bazie danych następujących skrótów klawiaturowych:

Klawisze

Wynik

F11

Wyświetlanie i ukrywanie okienka nawigacji.

CTRL+G

Wyświetlanie okna Bezpośrednie w Edytorze Visual Basic.

ALT+F11

Uruchamianie Edytora Visual Basic.

CTRL+BREAK

Naciśnięcie tej kombinacji klawiszy powoduje, że program Access przestaje pobierać rekordy z serwera.

Początek strony

Ustawianie opcji zarządzania plikami dla bieżącej bazy danych

Ustawienia zarządzania plikami mają zastosowanie wyłącznie do bazy danych otwartej podczas zaznaczania tych opcji.

Ustawienie

Opis

Kompaktuj przy zamknięciu

Jeśli ta opcja jest zaznaczona, baza danych jest automatycznie kompaktowana i naprawiana przy zamknięciu.

Usuń informacje osobiste z właściwości pliku przy zapisywaniu

Jeśli ta opcja jest zaznaczona, podczas zapisywania pliku z jego właściwości są automatycznie usuwane informacje osobiste.

Początek strony

Wybieranie opcji nawigacji dla bieżącej bazy danych

Nawigację dla bieżącej aplikacji można dostosować za pomocą następujących opcji:

Ustawienia opcji nawigacji

Ustawienie

Opis

Wyświetl okienko nawigacji

Jeśli ta opcja jest wyczyszczona, okienko nawigacji nie będzie wyświetlane po otwarciu bieżącej bazy danych.

Opcje nawigacji

Jeśli ta opcja jest zaznaczona, można zmieniać kategorie i grupy wyświetlane w okienku nawigacji oraz ustawiać opcje otwierania obiektów w bieżącej bazie danych.

Nazwa wstążki

Umożliwia wybranie nazwy dla niestandardowej grupy wstążki.

Pasek menu skrótów

Pozwala ustawiać lub zmieniać domyślny pasek menu skrótów.

Zezwalaj na pełne menu

Jeśli to pole wyboru jest wyczyszczone, na wstążce jest widoczna tylko karta Narzędzia główne. Ponadto po kliknięciu karty Plik nie są dostępne polecenia Zapisz i Zapisz jako.

Zezwalaj na domyślne menu skrótów

Pozwala włączać lub wyłączać menu skrótów (menu podręczne) wyświetlane po kliknięciu prawym przyciskiem myszy obiektu bazy danych w okienku nawigacji lub kontrolki w formularzu bądź raporcie. Wprowadzone tu zmiany zostaną zastosowane po zamknięciu i ponownym otwarciu bieżącej bazy danych.

Początek strony

Ustawianie opcji śledzenia i poprawiania nazw pól w bieżącej bazie danych

Opcja Autokorekta nazw umożliwia śledzenie i poprawianie przez program Access odwołań do nazw pól w formularzach, raportach i zapytaniach. Dla bieżącej bazy danych można ustawić następujące opcje:

Ustawienie

Opis

Śledź informacje autokorekty nazw

Jeśli ta opcja jest zaznaczona, w programie Access są przechowywane informacje potrzebne do poprawiania błędów nazw. Opcja ta umożliwia korzystanie z funkcji Zależności obiektu. Jednak w programie Access błędy nie są naprawiane, dopóki nie zostanie zaznaczona opcja Wykonaj autokorektę nazw.

Wykonaj autokorektę nazw

Jeśli ta opcja jest zaznaczona, w programie Access błędy nazw są naprawiane w momencie ich wystąpienia. W przypadku zaznaczenia opcji Śledź informacje autokorekty nazw i pozostawienia jej pustej program Access przechowuje wszelkie dane o błędach do momentu zaznaczenia tej opcji.

Rejestruj zmiany autokorekty nazw

Program Access rejestruje zmiany wprowadzone w bazie danych podczas naprawiania błędów nazw i zapisuje te dane w tabeli o nazwie AutoCorrect.log.

Początek strony

Ustawianie opcji filtru dla bieżącej bazy danych

Informacje wyświetlane w formularzu można sortować, definiując filtr przy użyciu definicji Filtruj według formularza i wybierając wartości wyświetlane w oknie Filtruj według formularza dla bieżącej bazy danych.

Opcje wymienione w tej sekcji sterują kilkoma funkcjami, takimi jak rozmiar list wartości wyświetlanych dla danego pola w oknie Filtruj według formularza. Istnieją opcje określające, czy użytkownik może wyświetlać wartości dla pól indeksowanych i nieindeksowanych oraz dla tabeli połączonej w pliku zewnętrznym. Można też wybrać opcje określające, czy po użyciu funkcji Filtruj według formularza listy wartości są wyświetlane w kontrolkach w formularzu.

Ustawienie

Opis

Lokalne pola indeksowane

Jeśli ta opcja jest zaznaczona, wartości z lokalnych pól indeksowanych są widoczne na listach wartości wyświetlanych w oknie Filtruj według formularza.

Lokalne pola nieindeksowane

Pozwala uwzględniać wartości z lokalnych pól nieindeksowanych na listach wartości wyświetlanych w oknie Filtruj według formularza.

Pola ODBC

Pozwala uwzględniać wartości z tabel połączonych za pomocą połączenia ODBC (Open Database Connectivity).

Nie wyświetlaj list, w których przeczytanych rekordów jest więcej niż

W tym polu należy wprowadzić maksymalną liczbę rekordów, które mają być odczytywane w programie Access podczas tworzenia listy wartości w celu wykonania operacji Filtruj według formularza. Lista wartości nie zostanie wyświetlona, jeśli liczba rekordów potrzebnych do ukończenia listy przekracza liczbę określoną w tym miejscu. Wszystkie listy wartości będą zawierały tylko wartości unikatowe, nawet jeśli ich pola nie są indeksowane. Wartość domyślna to 1000.

Początek strony

Włączanie typu danych Duża liczba na potrzeby operacji łączenia i importowania

Typ danych Duża liczba przechowuje wartość liczbową inną niż pieniężna oraz jest zgodny z typem danych SQL_BIGINT w technologii ODBC. Ten typ danych pozwala wydajnie obliczać duże liczby, a jego zakres wynosi od -2^63 do 2^63-1.

Uwaga : Typ danych Duża liczba jest dostępny tylko w przypadku posiadania subskrypcji usługi Office 365. Jeśli jesteś subskrybentem usługi Office 365, upewnij się, że masz najnowszą wersję pakietu Office. Jeśli jesteś specjalistą IT zarządzającym procesem aktualizacji usługi Office 365, odwiedź stronę kanałów udostępniania, aby dowiedzieć się, które aktualizacje zostały udostępnione w poszczególnych kanałach.

Ustawienie

Opis

Obsługuj typ danych Bigint dla tabel połączonych/importowanych

Zaznaczenie tej opcji powoduje włączenie obsługi danych Duża liczba na potrzeby operacji łączenia lub importowania z zewnętrznych baz danych, w których są używane równoważne typy danych, takie jak bigint w programie SQL Server. Program Access wyświetla ostrzeżenie, że ustawienie tej opcji wprowadza trwałą zmianę w formacie pliku bazy danych, w przypadku którego należy pamiętać o uwagach dotyczących zgodności z poprzednimi wersjami. Wykonaj jedną z następujących czynności:

  • Wybierz przycisk OK, aby wprowadzić zmianę na stałe. Po wprowadzeniu zmiany nie będzie można jej cofnąć.

  • Wybierz przycisk Anuluj, aby nie wprowadzać zmiany.

Aby uzyskać więcej informacji, zobacz Korzystanie z typu danych Duża liczba.

Uwaga : Włączenie tej opcji umożliwia korzystanie z typu danych Duża liczba w celu łączenia i importowania przed zamknięciem bazy danych. Aby jednak zobaczyć zmiany w sygnaturze formatu pliku na pasku tytułu bazy danych, konieczne jest zamknięcie i otwarcie bazy danych.

Początek strony

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×