Używanie w formule funkcji zagnieżdżonych

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Za pomocą funkcji, jak jeden z argumentów w formule, która została użyta funkcja nosi nazwę zagnieżdżenia, a firma Microsoft będzie odwołują się do tej funkcji zagnieżdżonych funkcji. Na przykład przez zagnieżdżanie funkcji średnia i Suma w argumentach funkcji Jeżeli, poniższa formuła sumuje zbioru liczb (G2: G5) tylko wtedy, gdy średnia innego zbioru liczb (F2: F5) jest większa niż 50. W przeciwnym razie zwraca wartość 0.

Funkcje zagnieżdżone

Funkcje średnia i Suma są zagnieżdżone w funkcji Jeżeli.

W formule można zagnieździć maksymalnie 64 poziomy funkcji.

  1. Kliknij komórkę, w której chcesz wprowadzić formułę.

  2. Aby rozpocząć formułę funkcją, kliknij przycisk Wstaw funkcję Obraz przycisku na podstawie wzoru paska Obraz przycisku .

    Program Excel wstawi znak równości (=).

  3. W polu Lub wybierz kategorię wybierz pozycję Wszystkie.

    Użytkownik zaznajomiony z kategoriami funkcji może także wybrać kategorię.

    Jeśli użytkownik nie wie, której funkcji użyć, może wpisać pytanie opisujące żądaną funkcję w polu Wyszukaj funkcję (na przykład „dodawanie liczb” zwraca funkcję SUMA).

  4. Aby wprowadzić kolejną funkcję jako argument, wprowadź ją w odpowiednim polu argumentu.

    Elementy formuły wyświetlane w oknie dialogowym Argumenty funkcji odpowiadają funkcji wybranej w poprzednim kroku.

    W razie kliknięcia pozycji JEŻELI w oknie dialogowym Argumenty funkcji wyświetlone zostaną argumenty funkcji JEŻELI. Aby zagnieździć inną funkcję, wprowadza się ją w polu argumentu. Można na przykład wprowadzić SUMA(G2:G5) w polu Wartość_jeżeli_prawda funkcji JEŻELI.

  5. Wprowadź wszelkie dodatkowe argumenty potrzebne do działania formuły.

    Zamiast wpisywać odwołania do komórek, można także zaznaczyć komórki, na które ma wskazywać odwołanie. Kliknij przycisk Obraz przycisku , aby zminimalizować okno dialogowe, zaznacz komórki, na które ma wskazywać odwołanie, a następnie kliknij przycisk Obraz przycisku , aby ponownie rozwinąć ono dialogowe.

    Porada : Aby uzyskać więcej informacji o funkcji i jej argumentach, należy kliknąć łącze Pomoc dotycząca tej funkcji.

  6. Po zakończeniu wybierania argumentów dla formuły kliknij przycisk OK.

  1. Kliknij komórkę, w której chcesz wprowadzić formułę.

  2. Aby rozpocząć formułę funkcją, kliknij przycisk Wstaw funkcję Obraz przycisku na podstawie wzoru paska Obraz przycisku .

  3. W oknie dialogowym Wstawianie funkcji w oknie dialogowym Wybierz kategorię wybierz pozycję wszystko.

    Użytkownik zaznajomiony z kategoriami funkcji może także wybrać kategorię.

  4. Aby wprowadzić kolejną funkcję jako argument, wprowadź ją w polu argumentu w Konstruktorze formuł lub bezpośrednio w komórce.

  5. Wprowadź wszelkie dodatkowe argumenty potrzebne do działania formuły.

  6. Po wpisaniu argumentów formuły, naciśnij klawisz ENTER.

Przykłady

Poniżej przedstawiono przykład użycia zagnieżdżonych Jeśli funkcje przypisuje ocenę do liczbową test wynik.

Skopiuj przykładowe dane z poniższej tabeli i wklej je w komórce A1 nowego arkusza programu Excel. Aby formuły wyświetlały wyniki, zaznacz je, naciśnij klawisz F2, a następnie naciśnij klawisz Enter. Jeśli to konieczne, możesz dostosować szerokości kolumn, aby wyświetlić pełne dane.

Punkty

45

o 90 stopni.

78

Formuła

Opis

Wynik

'=JEŻELI(A2>89;"6";JEŻELI(A2>79;"5";JEŻELI(A2>69;"4";JEŻELI(A2>59;"3";"1"))))

Przypisuje ocenę do wyniku w komórce A2 przy użyciu zagnieżdżonych warunków JEŻELI.

=JEŻELI(A2>89;"6";JEŻELI(A2>79;"5";JEŻELI(A2>69;"4";JEŻELI(A2>59;"3";"1"))))

'=JEŻELI(A3>89;"6";JEŻELI(A3>79;"5";JEŻELI(A3>69;"4";JEŻELI(A3>59;"3";"1"))))

Przypisuje ocenę do wyniku w komórce A3 przy użyciu zagnieżdżonych warunków JEŻELI.

=JEŻELI(A3>89;"6";JEŻELI(A3>79;"5";JEŻELI(A3>69;"4";JEŻELI(A3>59;"3";"1"))))

'=JEŻELI(A4>89;"6";JEŻELI(A4>79;"5";JEŻELI(A4>69;"4";JEŻELI(A4>59;"3";"1"))))

Przypisuje ocenę do wyniku w komórce A4 przy użyciu zagnieżdżonych warunków JEŻELI.

=JEŻELI(A4>89;"6";JEŻELI(A4>79;"5";JEŻELI(A4>69;"4";JEŻELI(A4>59;"3";"1"))))

Porady : 

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Zobacz też

Klip wideo: Zagnieżdżone funkcje Jeżeli

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×