Używanie raportu tabeli przestawnej do udostępniania danych tabeli zewnętrznej w usługach programu Excel

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Podczas pracy z danymi tabeli w oparciu o połączenie z danymi zewnętrznymi w programie Usługi programu Excel używanie zakresu danych zewnętrznych (nazywanego również tabelą kwerend) jest niemożliwe. Należy utworzyć raport tabeli przestawnej, który pozwala przekształcić wielowymiarowe dane o strukturze hierarchicznej na dwuwymiarową tabelę. Poniżej wyjaśniono, jak to zrobić.

Porównanie danych wielowymiarowych i dwuwymiarowych

1. Konwertowanie wielowymiarowego raportu tabeli przestawnej...

2. …na dwuwymiarowy raport tabeli przestawnej…

3. …w celu wyświetlenia uproszczonych danych tabeli w usługach programu Excel.

Co chcesz zrobić?

Dowiedz się, jak usługi programu Excel obsługuje połączenia z zewnętrznymi źródłami danych

Dowiedz się więcej o różnice między raportami tabeli przestawnej, które są połączone z danymi zewnętrznymi i zakresy danych zewnętrznych

Tworzenie dwuwymiarowych, tabelarycznego raportu tabeli przestawnej

Tworzenie raportu tabeli przestawnej i połączyć go z zewnętrznego źródła danych

Dodawanie, układ i rozmieszczanie pól w obszarze etykiety wierszy

Zmień opcje tabeli przestawnej i ustawienia pola

Układ raportu tabeli przestawnej jako tabelę dwuwymiarowych

Dostosować projekt raportu tabeli przestawnej

Publikowanie skoroszytu w usługach programu Excel

Dowiedz się jak w usługach programu Excel obsługiwane są połączenia z zewnętrznymi źródłami danych

Raporty tabel przestawnych są przeznaczone do agregowania dużych ilości danych numerycznych w sumy i pracowania z wielowymiarowymi danymi zorganizowanymi hierarchicznie. Z drugiej strony zakresy danych zewnętrznych to dwuwymiarowe tabele, których struktura wierszy i kolumn pozwala wyświetlać niezagregowane rekordy danych źródłowych.

Nawiązywanie połączenia z danymi zewnętrznymi za pomocą Kreatora połączenia danych lub programu Microsoft Query możesz zazwyczaj utworzyć zakresu danych zewnętrznych. Jedynym wyjątkiem jest podczas tworzenia raportu tabeli przestawnej, który jest połączony z danymi zewnętrznymi. Raport tabeli przestawnej nie tworzy zakresu danych zewnętrznych. Ta różnica w ten sposób utworzenia połączenia jest ważne, aby dowiedzieć się, kiedy publikowanie skoroszytu w usługach programu Excel, ponieważ usług programu Excel tylko obsługuje połączenia danych zewnętrznych według raportów w formie tabeli przestawnej, a nie obsługuje zakresy danych zewnętrznych.

Początek strony

Poznaj różnice między raportami tabeli przestawnej połączonymi z danymi zewnętrznymi i zakresami danych zewnętrznych

Podczas pracy z raportem w formie tabeli przestawnej jest połączony dane zewnętrzne, weź pod uwagę różnice między zachowanie raportu w formie tabeli przestawnej i zakresu danych zewnętrznych, że należy pamiętać, łącznie z następujących czynności:

W raportach tabel przestawnych dane są umieszczane w grupach i podgrupach w kolejności od lewej do prawej

Grupowanie danych jest oparte na sortowaniu ich według jednej lub wielu kolumn. Aby na przykład wyświetlić informacje o pracownikach pogrupowane według działów, należy zastosować główne sortowanie danych według działów i pomocnicze sortowanie według pracowników. Można również zagnieżdżać grupy, takie jak Linia produktów, Kategoria, Produkt, Obszar, Kraj/region, Województwo i Miasto. Domyślnie raporty tabel przestawnych są automatycznie sortowane w grupy i podgrupy w kolejności od lewej do prawej, aby ułatwić oglądanie pokrewnych danych, wyświetlanie nagłówków i informacji podsumowujących, a także rozwijanie i zwijanie powiązanych ze sobą elementów.

Dane pogrupowane według Linii produktówi subgrouped w każdym Wierszu produktu według kategorii

Linia produktów

Kategoria

Produkt

Silniki

Samolot

Mocowane na skrzydłach

Mocowane na ogonie

Dopalacz

Samochód

269 KM

454 KM

Układy wydechowe

Osobowy

Wysokotemperaturowy

Standardowy

Terenowy

Mały

Umieszczając kolumnę unikatowych wartości w obszarze Etykiety wierszy po prawej stronie, można automatycznie zmniejszyć wielowymiarowość danych.

Tych samych danych Linii produktów spłaszczoną przez dodanie kolumny Identyfikator Num

Nr ew.

Linia produktów

Kategoria

Produkt

WM-345

Silniki

Samolot

Mocowane na skrzydłach

TM-231

Silniki

Samolot

Mocowane na ogonie

BSTR-567

Silniki

Samolot

Dopalacz

6C-734

Silniki

Samochód

269 KM

8C-121

Silniki

Samochód

454 KM

MF-202

Układy wydechowe

Osobowy

Wysokotemperaturowy

MF-321

Układy wydechowe

Osobowy

Standardowy

MF-211

Układy wydechowe

Terenowy

Mały

Jeśli nie chcesz, aby ta kolumna była wyświetlana, po dodaniu jej do raportu tabeli przestawnej możesz ją ukryć. W tym celu zaznacz tę kolumnę, a następnie na karcie Narzędzia główne w grupie Komórki kliknij strzałkę obok przycisku Format, wskaż polecenie Ukryj i odkryj i kliknij polecenie Ukryj kolumny.

Ważne : Jeśli w raporcie tabeli przestawnej zostaną wykryte duplikaty wierszy danych pochodzących ze źródła danych, tylko jeden z tych wierszy zostanie wyświetlony w raporcie. Aby wyświetlić w raporcie tabeli przestawnej wszystkie wiersze (nawet duplikaty), należy dodać do tabeli, kwerendy lub widoku kolumnę zawierającą unikatowe wartości, które są importowane ze źródła danych. W przypadku, gdy źródło danych nie zawiera unikatowej kolumny, należy ją dodać do źródła danych. Do tabeli programu Microsoft Office Access można na przykład dodać kolumnę z typem danych autonumerowania. Natomiast do tabeli programu Microsoft SQL Server można dodać kolumnę z identyfikacyjnym typem danych lub kolumnę obliczeniową wyświetlającą unikatowy numer każdego rekordu w kwerendzie bazy danych albo widoku.

Edytowanie danych w komórkach i dodawanie kolumn obliczeniowych

Przed opublikowanie skoroszytu w usługach programu Excel można edytować jego dane przy użyciu zakresu danych zewnętrznych. Dane w raporcie tabeli przestawnej są zawsze tylko do odczytu.

Dwukrotne kliknięcie komórki w zakresie danych zewnętrznych powoduje przejście do trybu edycji i umożliwia zmianę wartości, a nawet wprowadzenie formuły. Należy jednak zauważyć, że zmianom nie ulegają oryginalne wartości w źródle danych i podczas następnego odświeżenia danych nowe wartości mogą zostać zastąpione zależnie od ustawienia właściwości Jeśli liczba wierszy w zakresie danych zmieni się podczas odświeżania zakresu danych zewnętrznych.

Dwukrotne kliknięcie komórki etykiety wierszy w raporcie tabeli przestawnej powoduje rozwinięcie lub zwinięcie komórki z elementami tej etykiety wierszy. Po przekształceniu raportu tabeli przestawnej na dwuwymiarową tabelę, wszystkie wartości wierszy w grupie po lewej stronie komórki znikają lub pojawiają się ponownie.

Kolumny obliczeniowe można dodawać w dowolnym miejscu tabeli programu Microsoft Office Excel opartej na zakresie danych zewnętrznych. Można również wstawiać kolumny i wpisywać formuły w zakresie danych zewnętrznych. Wstawianie kolumn obliczeniowych w raporcie tabeli przestawnej jest niemożliwe (choć można wstawiać pola obliczeniowe). Dostępna jest jednak opcja dodawania kolumny wpisującej dane lub formuły bezpośrednio po lewej lub prawej stronie raportu tabeli przestawnej. We wpisanych formułach można używać odwołań do komórek raportu tabeli przestawnej.

Tworzenie wykresów

Jeśli chcesz utworzyć wykres na podstawie danych w raporcie tabeli przestawnej, możesz utworzyć raportu wykresu przestawnego, który zachowuje się podobnie do wykresów standardowy, ale istnieją pewne niektóre różnice, łącznie z następujących czynności:

Interakcja     W przypadku standardowych wykresów użytkownik tworzy osobny wykres dla każdego widoku danych, który chce przeglądać, lecz wykresy te nie są interakcyjne. W przypadku raportów wykresu przestawnego można utworzyć jeden wykres i interakcyjnie przeglądać dane w różny sposób, zmieniając układ raportu lub wyświetlane szczegóły. W usługach programu Excel zarówno standardowy wykres, jak i raport tabeli przestawnej można aktualizować w oparciu o interakcje użytkownika ze skoroszytem, jednak oba wykresy są wyświetlane jako obrazy statyczne.

Typy wykresów     Domyślnym typem standardowego wykresu jest grupowany wykres kolumnowy, który służy do porównywania wartości w różnych kategoriach. Domyślnym typem wykresu dla raportu wykresu przestawnego jest skumulowany wykres kolumnowy, który służy do porównywania udziału poszczególnych wartości w sumie w poszczególnych kategoriach. Raport wykresu przestawnego można zamienić na wykres dowolnego typu z wyjątkiem wykresu xy (punktowego), giełdowego i bąbelkowego.

Elementy wykresu     Raporty w formie wykresu przestawnego zawierają te same elementy co standardowy wykresy, ale zawierają również pola i elementy, które można dodać do, obrócony lub usuwać w celu wyświetlenia różnych widoków danych. Kategorie, serii i danych na wykresach standardowe są pól kategorii, serii, a pola wartości w raportach w formie wykresu przestawnego. Raporty w formie wykresu przestawnego może również zawierać filtry raportu. Każde z tych pól zawiera elementy, które w standardowymi wykresami są wyświetlane jako etykiety kategorii lub serii nazwy w legendy.

Formatowanie     Większość formatowania, takich jak elementy, układ i styl, są zachowywane podczas możesz odświeżanie raportu wykresu przestawnego. Jednak linie trendu, etykiety danych, słupki błędów i inne zmiany w serii danych nie są zachowywane. Standardowymi wykresami nie utracić formatowanie zastosowane.

Przenoszenie lub zmienianie rozmiaru elementów     W raporcie wykresu przestawnego nie można przenosić ani zmieniać rozmiaru obszar kreślenia, legendy, a także tytułów wykresu ani osi, mimo że można wybrać jedną z kilku wstępnie ustawionych pozycji legendy i zmienić rozmiar czcionki tytułów. W przypadku standardowego wykresu można przenosić i zmieniać rozmiar wszystkich tych elementów.

Po utworzeniu raportu wykresu przestawnego, jeśli wolisz, możesz przekonwertować go na wykres standardowy. Aby uzyskać więcej informacji zobacz artykuł Tworzenie tabeli przestawnej z danymi arkusza anaylzelub Tworzenie wykresu przestawnego.

Porównanie właściwości zakresu danych zewnętrznych z opcjami tabeli przestawnej

Zakresy danych zewnętrznych i raporty tabeli przestawnej zostały wyposażone we właściwości służące do sterowania formatowaniem danych i układem, a także działaniem odświeżania danych.

Zarówno zakresy danych zewnętrznych, jak i raporty tabeli przestawnej umożliwiają dostosowywanie szerokości kolumn, zachowywanie sortowania kolumn, filtrowania, formatowania komórek, a także układu danych w przypadku odświeżenia danych zewnętrznych.

Zakresu danych zewnętrznych możesz również dostępna opcja łącznie z numerami wierszy jako pierwszą kolumnę danych. W raporcie tabeli przestawnej jest opcja Brak podobne. Zapoznaj się z sekcją, grupy i podgrupy dane w kolejności od lewej do prawej raportów tabel przestawnych, aby uzyskać omówienie dodanie unikatowych kolumny w źródle danych.

Podczas odświeżania zakresu danych zewnętrznych można decydować o tym, co się stanie z istniejącymi danymi, jeśli liczba wierszy w zakresie danych ulegnie zmianie, ustawiając jedną z poniższych opcji:

  • Wstaw komórki dla nowych danych, usuń nieużywane komórki (ustawienie domyślne)

  • Wstaw całe wiersze dla nowy danych i usuń nieużywane komórki

  • Zastąp istniejące komórki nowymi danymi, wyczyść nieużywane komórki

Po odświeżeniu raportu tabeli przestawnej, po prostu żywą nowe dane. Jednak możesz się monitu i monit z pytaniem, czy zastąpić istniejące komórki poniżej bieżącego raportu.

Filtrowanie danych

Filtrowanie danych w zakresie danych zewnętrznych i raporcie tabeli przestawnej przebiega podobnie. Są jednak następujące różnice:

  • W zakresach danych zewnętrznych używa się poleceń Filtr tekstu, Filtr liczb i Filtr dat, natomiast w raportach tabeli przestawnej stosuje się polecenia Filtr etykiet, Filtr wartości i Filtr dat.

  • Menu Filtr zakresu danych zewnętrznych zawsze usuwa elementy, które nie są już prawidłowe, i menu filtru nigdy nie zawiera nowych elementów przy użyciu zastosowanego filtru po zakończeniu operacji odświeżania, ale raport tabeli przestawnej zawiera opcje, aby kontrolować to zachowanie. Aby uzyskać więcej informacji zobacz sekcję Opcje tabeli przestawnej Zmień i ustawienia pola.

  • Raport tabeli przestawnej zawiera niedostępną w zakresie danych zewnętrznych funkcję filtru raportu, która umożliwia użytkownikom pracę z podzbiorem danych w raporcie tabeli przestawnej.

Sortowanie danych

W zakresie danych zewnętrznych można przeprowadzić wielokolumnowe sortowanie według maksymalnie 64 kolumn, wybierając dowolną kolumnę jako główne kryterium sortowania i inne kolumny jako kryteria pomocnicze. Proces sortowania danych w raporcie tabeli przestawnej przebiega inaczej. W przeciwieństwie do zakresu danych zewnętrznych, główne sortowanie w raporcie tabeli przestawnej można przeprowadzić tylko według najbardziej skrajnej lewej kolumny. Wszystkie pozostałe kolumny stanowią kolejne kryteria pomocnicze. Sortowanie główne i pomocnicze można przeprowadzać tylko w kolejności od lewej do prawej.

Ponadto wstawienie kolumny z unikatowymi wartościami jako pierwszej od lewej powoduje, że sortować można wyłącznie według tej kolumny, ponieważ każdy wiersz staje się grupą główną. W zależności od potrzeb użytkowników dane można posortować wstępnie w programie Excel, a następnie po opublikowaniu skoroszytu w usługach programu Excel wyłączyć sortowanie przez wyczyszczenie pola wyboru Sortowanie w okienku narzędzi składnika Web Part programu Microsoft Office Excel Web Access.

Używanie hiperłączy

W odróżnieniu od zakresów danych zewnętrznych, aktywne hiperłącza nie są obsługiwane w komórkach tabel przestawnych. Hiperłącze jest traktowane jako tekst i nie można za jego pomocą przejść do strony sieci Web albo dokumentu w programie Excel lub w usługach programu Excel.

Początek strony

Tworzenie dwuwymiarowego raportu tabeli przestawnej w formie tabelarycznej

Do przekształcenia wielowymiarowych danych na dwuwymiarowy raport tabeli przestawnej w formie tabelarycznej niezbędne jest wykonanie kilku kroków. Aby uzyskać najlepsze wyniki, należy wykonać kolejno poniższe procedury.

Początek strony

Tworzenie raportu tabeli przestawnej i łączenie go z zewnętrznym źródłem danych

  1. Zaznacz pustą komórkę.

  2. Na karcie Wstawianie w grupie Tabele kliknij przycisk Tabela przestawna, a następnie kliknij polecenie Tabela przestawna.

    Obraz Wstążki programu Excel

    Zostanie wyświetlone okno dialogowe Tworzenie tabeli przestawnej.

  3. Kliknij pozycję Użyj zewnętrznego źródła danych.

  4. Kliknij przycisk Wybierz połączenie.

    Na Zostanie wyświetlone okno dialogowe Istniejące połączenia.

  5. Na liście Pokaż u góry okna dialogowego wybierz kategorię połączeń, z której chcesz wybrać połączenie, lub zaznacz opcję Wszystkie istniejące połączenia (jest to domyślne ustawienie).

  6. Wybierz połączenie z listy Wybierz połączenie, a następnie kliknij przycisk Otwórz.

  7. Wprowadź lokalizację. Wykonaj jedną z następujących czynności:

    • Aby umieścić raport tabeli przestawnej w nowym arkuszu tak, aby zaczynał się w komórce A1, kliknij przycisk Nowy arkusz.

    • Aby umieścić raport tabeli przestawnej w istniejącym arkuszu, wybierz pozycję Istniejący arkusz, a następnie określ pierwszą komórkę zakresu komórek, w którym chcesz umieścić raport tabeli przestawnej.

      Alternatywnie kliknij przycisk Zwiń okno dialogowe Obraz przycisku tymczasowo ukryć okno dialogowe, zaznaczyć początkową komórkę w arkuszu, a następnie kliknij przycisk Rozwiń okno dialogowe Obraz przycisku .

  8. Kliknij przycisk OK.

We wprowadzonej lokalizacji zostanie dodany pusty raport tabeli przestawnej z wyświetloną listą pól tabeli przestawnej.

Początek strony

Dodawanie, układanie i rozmieszczanie pól w obszarze Etykiety wierszy

Lista pól tabeli przestawnej służy do dodawania, układania i rozmieszczania pól, a także pozwala upewnić się, że wszystkie pola zostały dodane do obszaru Etykiety wierszy.

  1. Kliknij raport tabeli przestawnej.

  2. Wykonaj co najmniej jedną z następujących czynności:

    • Aby dodać pola do raportu, należy wykonać jedną lub więcej z poniższych czynności:

      • Zaznacz pole wyboru obok każdej nazwy pola w sekcji pól na liście pól. Każde pole zostanie umieszczone w obszarze domyślnym sekcji układu, ale rozmieszczenie pól można zmienić.

        Domyślnie pola nienumeryczne są dodawane do obszaru Etykiety wierszy, pola numeryczne są dodawane do obszaru Wartości, a pola daty/godziny — do obszaru Etykiety kolumn.

      • Aby przenieść pole do obszaru Etykiety wierszy, kliknij prawym przyciskiem myszy nazwę pola, a następnie wybierz w menu skrótów polecenie Dodaj do etykiet wierszy.

        Porada : Można też kliknąć i przytrzymać nazwę pola, a następnie przeciągnąć pole z sekcji pól do obszaru w sekcji układu.

    • Aby ponownie rozmieścić pola, kliknij nazwę pola w jednym z obszarów, a następnie wybierz jedno z następujących poleceń:

Przenieś w górę    

Powoduje przeniesienie pola o jedną pozycję w górę w obrębie obszaru.

Przenieś w dół    

Powoduje przeniesienie pola o jedną pozycję w dół w obrębie obszaru.

Przenieś na początek    

Powoduje przeniesienie pola na początek obszaru.

Przechodzenie do zakończenia   

Powoduje przeniesienie pola na koniec obszaru.

Przenieś do etykiet wierszy    

Powoduje przeniesienie pola do obszaru etykiet wierszy.

  • Aby usunąć pole, kliknij pole Nazwa w jednym z obszarów układ, a następnie kliknij pozycję Usuń pole lub wyczyść pole wyboru obok nazw poszczególnych pól, który chcesz usunąć, w sekcji pól.

    Porada : Można też kliknąć i przytrzymać nazwę pola w sekcji układu, a następnie przeciągnąć ją poza okno Lista pól tabeli przestawnej.

    Uwaga : Wyczyszczenie pola wyboru w sekcji pól powoduje usunięcie z raportu wszystkich wystąpień pola.

Początek strony

Zmienianie opcji tabeli przestawnej i ustawień pól

Aby upewnić się, że działanie raportu tabeli przestawnej będzie podobne do zachowania zakresu zewnętrznego, należy wykonać następujące czynności:

Zmień opcje tabeli przestawnej   

  1. Kliknij raport tabeli przestawnej.

  2. Na karcie Opcje w grupie Tabela przestawna kliknij przycisk Opcje.

    Zostanie wyświetlone okno dialogowe Opcje tabeli przestawnej.

  3. Aby szerokość kolumn była automatycznie dostosowywana po przeprowadzeniu operacji odświeżania, kliknij kartę Układ i format, a następnie w sekcji Wyświetl zaznacz pole wyboru Automatycznie dopasuj szerokość kolumn podczas aktualizacji.

  4. W celu zachowania formatowania podczas każdego odświeżania danych kliknij kartę Układ i format, a następnie w sekcji Wyświetl zaznacz pole wyboru Zachowaj formatowanie komórek podczas aktualizacji.

  5. Jeśli chcesz mieć pewność, że menu Filtr będzie usuwało elementy, które straciły swoją ważność, po przeprowadzeniu operacji odświeżania, kliknij kartę Dane i w polu Liczba elementów do zachowania w każdym polu wybierz opcję Brak.

Zmień ustawienia pól   

  1. Kliknij raport tabeli przestawnej.

  2. Aby nowe elementy były dołączane do raportu tabeli przestawnej z zastosowanym filtrem, dla każdego pola kliknij prawym przyciskiem myszy komórkę, kliknij w menu skrótów polecenie Ustawienia pola, kliknij kartę Sumy częściowe i filtry, a następnie w sekcji Filtry zaznacz pole wyboru Dołącz nowe elementy do filtru ręcznego.

Początek strony

Tworzenie dwuwymiarowego układu raportu tabeli przestawnej

Aby ustalić układ raportu tabeli przestawnej jako dwuwymiarową tabelę, wykonaj następujące czynności:

  1. Kliknij raport tabeli przestawnej.

  2. Na karcie Projektowanie w grupie Układ kliknij przycisk Sumy częściowe, a następnie kliknij opcję Nie pokazuj sum częściowych.

  3. Na karcie Projektowanie w grupie Układ kliknij przycisk Sumy końcowe, a następnie kliknij opcję Wyłącz dla wierszy i kolumn.

  4. Na karcie Projektowanie w grupie Układ kliknij przycisk Układ raportu, a następnie kliknij opcję Pokaż w formie tabelarycznej.

  5. Na karcie Opcje w grupie Pokazywanie/ukrywanie kliknij przycisk Nagłówki pól.

Początek strony

Dostosowywanie projektu raportu tabeli przestawnej

Wbudowane style tabeli przestawnej i opcje stylu są przeznaczone dla danych wielowymiarowych nie dwuwymiarowych tabelę. Gdy Spłaszcz raport do tabeli dwuwymiarowych tych stylów Nie wyświetlaj obramowania komórek, a Wiersze naprzemienne i Kolumny naprzemienne pola wyboru w grupie Opcje stylu tabeli przestawnej, na karcie Projektowanie nie wpływają na formatowanie komórek. Jednak styl tabeli przestawnej można dostosować tak, aby każdej komórki ma obramowania komórek i raport tabeli przestawnej korzysta z formatowania warunkowego do wyświetlenia naprzemienne wiersze lub kolumny.

Dostosowywanie stylu tabeli przestawnej   

  1. Kliknij raport tabeli przestawnej.

  2. Na karcie Projektowanie w grupie Style tabeli przestawnej zaznacz odpowiedni styl, a następnie wykonaj poniższe czynności:

    1. Kliknij prawym przyciskiem myszy widoczny styl, przewiń okno galerii lub kliknij przycisk Więcej u dołu paska przewijania, aby zobaczyć wszystkie dostępne style.

    2. Kliknij polecenie Duplikuj.

      Zostanie otwarte okno dialogowe Modyfikowanie szybkiego stylu tabeli przestawnej.

    3. Opcjonalnie wprowadź nową nazwę w polu Nazwa.

    4. W polu Element tabeli wybierz opcję Cała tabela, a następnie kliknij przycisk Formatuj.

      Zostanie wyświetlone okno dialogowe Formatowanie komórek.

    5. Kliknij kartę Obramowanie, a następnie określ obramowanie komórek.

    6. Opcjonalnie po kliknięciu kart Wypełnienie i Czcionka możesz wprowadzić inne zmiany.

    7. Kliknij dwa razy przycisk OK.

    8. Kliknij przycisk Więcej u dołu paska przewijania, a następnie w kategorii Niestandardowe kliknij właśnie utworzony styl tabeli przestawnej.

Wyświetlanie naprzemienne wiersze lub kolumny naprzemienne przy użyciu formatowania warunkowego   

  1. Zaznacz wszystkie kolumny w raporcie tabeli przestawnej.

  2. Na karcie Narzędzia główne w grupie Style kliknij strzałkę obok przycisku Formatowanie warunkowe, a następnie kliknij polecenie Zarządzaj regułami.

    Obraz Wstążki programu Excel

    Zostanie wyświetlone okno dialogowe Menedżer reguł formatowania warunkowego.

  3. Aby dodać format warunkowy, kliknij przycisk Nowa reguła.

    Zostanie wyświetlone okno dialogowe Nowa reguła formatowania.

  4. W obszarze Wybierz typ reguły kliknij opcję Użyj formuły do określenia komórek, które należy sformatować.

    1. W obszarze Edytuj opis reguły, w polu Formatuj wartości, dla których następująca formuła jest prawdziwa wprowadź formułę.

    2. Wykonaj jedną z następujących czynności: 

      • Aby wyświetlić wiersze naprzemiennie, wprowadź następującą formułę:

=AND(MOD(ROW(),2)=1,ROW()<=COUNTA(A:A))

  • Aby wyświetlić kolumny naprzemiennie, wprowadź następującą formułę:

=AND(MOD(COLUMN(),2)=1,COLUMN()<=COUNTA(1:1))

  • Aby wyświetlić wiersze i kolumny naprzemiennie, wprowadź następującą formułę:

=AND(MOD(ROW(),2)=1,ROW()<=COUNTA(A:A),MOD(COLUMN(),2)=1,COLUMN()<=COUNTA(1:1))

  1. Kliknij przycisk Formatuj, aby wyświetlić okno dialogowe Formatowanie komórek.

  2. Wybierz format liczby, czcionki, obramowania lub wypełnienia, jaki ma zostać zastosowany, gdy wartość komórki będzie spełniać określony warunek, a następnie kliknij przycisk OK.

    Można wybrać więcej niż jeden format. Wybrane formaty są wyświetlane w polu Podgląd.

Początek strony

Publikowanie skoroszytu w usługach programu Excel

  1. Kliknij Przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , kliknij strzałkę obok przycisku Publikuj, a następnie kliknij Usług programu Excel w obszarze Rozpowszechnij dokument do innych osób.

  2. W polu Nazwa pliku wprowadź ścieżkę do serwera, akceptując przy tym sugerowaną nazwę skoroszytu lub wprowadzając nową.

    Na komputerze z uruchomionym systemem Windows Vista    

    • Na pasku adresu wybierz lokalizację sieciową, która jest dostępna dla odpowiednich użytkowników, a następnie kliknij przycisk Zapisz.

      Na komputerze z uruchomionym systemem Microsoft Windows XP    

    • W polu Zapisz w wybierz lokalizację sieciową, która jest dostępna dla odpowiednich użytkowników, a następnie kliknij przycisk Zapisz.

      Na przykład wpisz http://witryny/serwera/nazwy pliku

      Uwaga : Program Excel może opublikować na serwerze skoroszyt tylko w następujących formatach programu Microsoft Office Excel 2007: format plików oparty na języku XML (xlsx) lub binarny format plików programu Office Excel 2007 (xlsb).

  3. Kliknij przycisk OK.

  4. Aby sprawdzić, czy widoczne obszary skoroszytu są poprawnie wyświetlane w przeglądarce, zaznacz pole wyboru Otwórz ten skoroszyt w mojej przeglądarce po zapisaniu pliku.

  5. Kliknij przycisk Zapisz.

Aby uzyskać więcej informacji zobacz artykuł Publikowanie skoroszytu w usługach programu Excel.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×