Używanie raportów do pomiaru wydajności i użycia witryny

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Do użytkownika odpowiedzialnego za zarządzanie witryną są kierowane typowe pytania dotyczące witryny, na przykład:

  • Jak wiele osób odwiedza witrynę?

  • Jak w miarę upływu czasu zmienia się ruch w witrynie?

  • Jakie osoby najczęściej korzystają z witryny?

  • Skąd pochodzi ruch w witrynie?

  • Które strony i zasoby w witrynie są najczęściej używane?

  • W jaki sposób dokumenty i inne zasoby są używane w procesie przepływu pracy?

Menedżer witryny sieci Web może również często potrzebować odpowiedzi na określone pytania, takie jak:

  • Czy w witrynie znajdują się zasoby, które można usunąć, ponieważ nie są używane lub są przestarzałe?

  • Jak można stwierdzić problemy w witrynie (takie jak pliki niepołączone, powolne strony i przerwane hiperłącza), zanim zostaną one zauważone i zgłoszone przez użytkowników?

Znalezienie odpowiedzi na te pytania może wydawać się trudne, ale używając programu Microsoft Office SharePoint Designer 2007 i witryny programu Windows SharePoint Services 3.0 lub witryny programu Microsoft Office SharePoint Server 2007, można łatwo uzyskać potrzebne informacje za pomocą raportów programu Office SharePoint Designer 2007. W tym artykule przedstawiono sposoby używania raportów do pomiaru wydajności i użycia witryny.

Ważne : Dane raportów generowanych w programie Office SharePoint Designer 2007 są zapisywane na serwerze, na którym witryna jest obsługiwana. Administratorzy serwerów mogą udzielać lub odmawiać dostępu do tych raportów. Jeśli żądany raport nie zawiera żadnych danych, należy skontaktować się z administratorem serwera w celu uzyskania pomocy. Aby uruchamiać raporty użycia, wymagane jest uprawnienie Wyświetlanie danych użycia, a ponadto administrator serwera musi włączyć zbieranie danych użycia na serwerze. Domyślnie zbieranie danych użycia na serwerze jest wyłączone.

Co chcesz zrobić?

Wyświetl raport Podsumowanie witryny

Wyświetlanie raportów dotyczących plików

Wyświetlanie raportów dotyczących zawartości udostępnionej

Wyświetlanie raportów dotyczących problemów

Wyświetl raport Podsumowanie użycia

Wyświetlanie raportów szczegółowy opis sposobu użycia

Wyniki zastosowania danych wykresu

Sortowanie raportu

Filtrowanie raportu

Skopiuj raport

Zapisywanie raportu

Wyświetlanie raportu Podsumowanie witryny

Raport Podsumowanie witryny zawiera ogólne informacje o witrynie, a także łącza do bardziej szczegółowych raportów. Można na przykład utworzyć raport Podsumowanie witryny podobny do przedstawionego na poniższej ilustracji.

Raport Podsumowanie witryny

Aby wygenerować raport Podsumowanie witryny, należy wykonać następujące czynności:

  1. W programie Office SharePoint Designer 2007 otwórz witrynę, dla której chcesz uruchomić raport.

  2. W menu Witryna wskaż polecenie Raporty, a następnie kliknij polecenie Podsumowanie witryny.

    Raport zostanie wygenerowany.

Uwaga : Można klikać hiperłącza w kolumnie Nazwa, aby przejść do bardziej szczegółowych raportów. Na przykład łącze Przerwane hiperłącza pozwala przejść bezpośrednio do raportu Przerwane hiperłącza.

Początek strony

Wyświetlanie raportów o plikach

Istnieje możliwość generowania raportów wyświetlających wszystkie pliki, pliki niedawno dodane, pliki niedawno zmienione lub starsze pliki. Aby na przykład wyróżnić nową zawartość na stronie głównej witryny lub w biuletynie reklamującym witrynę, można użyć raportu Niedawno dodane pliki w celu szybkiego zidentyfikowania nowej zawartości. Można też użyć raportu Starsze pliki do zidentyfikowania starej zawartości, którą należy przejrzeć w celu ewentualnego usunięcia lub aktualizacji.

Przed uruchomieniem raportów o plikach należy określić definicje niedawno używanych i starszych plików, a także określić, ile miesięcy ma być uwzględnianych w raportach wyświetlanych według miesięcy:

  1. W programie Office SharePoint Designer 2007 otwórz witrynę sieci Web, dla której chcesz uruchomić raport.

  2. W menu Narzędzia kliknij polecenie Opcje aplikacji.

  3. Kliknij kartę Widok Raporty.

    Okno dialogowe Opcje aplikacji z wyświetloną kartą Widok Raporty

  4. W polu Niedawno używane pliki mają mniej niż wprowadź liczbę dni identyfikującą niedawno wyświetlaną stronę.

  5. W polu Starsze pliki mają więcej niż wprowadź liczbę dni identyfikującą starszą stronę.

  6. W polu Liczba pokazywanych miesięcy wprowadź liczbę miesięcy, które mają być uwzględniane w raportach wyświetlanych według miesięcy.

  7. Kliknij przycisk OK.

    Od tego momentu można uruchamiać raporty.

  8. W menu Witryna wskaż polecenie Raporty, wskaż polecenie Pliki, a następnie kliknij raport, który chcesz uruchomić:

    • Wszystkie pliki     Zostanie wyświetlona lista wszystkich plików w witrynie.

    • Niedawno dodane pliki     Zostanie wyświetlona lista plików, które zostały dodane do witryny w ciągu liczby dni określonej w kroku 4.

    • Niedawno zmienione pliki     Zostanie wyświetlona lista plików, które zostały zmodyfikowane w witrynie w ciągu liczby dni określonej w kroku 4.

    • Starsze pliki     Zostanie wyświetlona lista plików, które zostały uznane za „starsze” zgodnie z liczbą dni określoną w kroku 5.

    • Stan wyewidencjonowania     Zostanie wyświetlona lista plików w witrynie wraz z bieżącym stanem wyewidencjonowania każdego pliku. Ten raport zawiera także kolumny danych Wyewidencjonowane przez, Wersja oraz Data zablokowania.

      W widoku Raporty można klikać dostępne na liście opcje dotyczące raportów o plikach w celu szybkiego zmieniania ustawień dla starszych lub niedawno używanych plików.

      Widok Raporty z wyświetlonym menu do filtrowania według wieku pliku

Początek strony

Wyświetlanie raportów o zawartości udostępnionej

Zawartość udostępniona może obejmować strony wzorcowe, strony dostosowane oraz inne strony uwzględnione w definicji witryny oraz w łączach arkusza stylów. Program Office SharePoint Designer 2007 ułatwia lokalizowanie zawartości udostępnionej. Aby na przykład zmienić logo na wszystkich stronach w witrynie sieci Web (jeśli do kontrolowania formatowania stron są używane strony wzorcowe), można użyć raportu Strony wzorcowe, który pozwala szybko odnaleźć wszystkie strony wzorcowe, na których należy zmienić logo. Można też użyć raportu Łącza arkusza stylów, aby odnaleźć wszystkie arkusze stylów, jakie należy zaktualizować w celu uwzględnienia zmian czcionki lub formatowania, które użytkownik chce zastosować w całej witrynie.

  1. W programie Office SharePoint Designer 2007 otwórz witrynę sieci Web, dla której chcesz uruchomić raport.

  2. W menu Witryna wskaż polecenie Raporty, wskaż polecenie Zawartość udostępniona, a następnie kliknij raport, który chcesz uruchomić:

    • Dynamiczne szablony sieci Web     Zostanie wyświetlona lista wszystkich stron w witrynie wraz z kolumną Dynamiczny szablon sieci Web, która wskazuje, czy dana strona jest dołączona do dynamicznego szablonu sieci Web (i jeśli tak jest, do którego).

    • Strony wzorcowe     Zostanie wyświetlona lista wszystkich stron w witrynie wraz z kolumną Strona wzorcowa, która wskazuje, czy dana strona jest dołączona do strony wzorcowej (i jeśli tak jest, do której).

    • Strony dostosowane     Zostanie wyświetlona lista wszystkich stron w witrynie wraz z kolumną Dostosowana, która wskazuje, czy dana strona oparta na definicji witryny została dostosowana.

    • Łącza arkusza stylów     Zostanie wyświetlona lista wszystkich stron w witrynie wraz z kolumną Łącza arkusza stylów, która wskazuje, czy dana strona jest dołączona do arkusza stylów.

      Uwaga : Wyświetlone łącza arkusza stylów są statycznymi łączami arkusza stylów (tagi <link>). Dynamiczne łącza arkusza stylów generowane przez formanty Microsoft ASP.NET (takie jak formant <SharePoint:CssLink>) nie są uwzględniane w tym raporcie.

Początek strony

Wyświetlanie raportów o problemach

Raporty programu Office SharePoint Designer 2007 dotyczące problemów mogą okazać się pomocne w przewidywaniu potencjalnych problemów i ich naprawianiu, zanim wpłyną na pracę użytkowników. Tych raportów można na przykład używać do identyfikowania powolnych stron, lokalizowania przerwanych hiperłączy, a także do wyszukiwania plików nadających się do usunięcia, które nie są połączone z innymi plikami. W celu uruchamiania raportów o problemach należy najpierw ustawić preferencje dotyczące definiowania powolnych stron.

  1. W programie Office SharePoint Designer 2007 otwórz witrynę sieci Web, dla której chcesz uruchomić raport.

  2. W menu Narzędzia kliknij polecenie Opcje aplikacji.

  3. Kliknij kartę Widok Raporty.

    Okno dialogowe Opcje aplikacji z wyświetloną kartą Widok Raporty

  4. W polu Pobranie powolnych stron trwa przynajmniej wprowadź liczbę sekund określającą, jak długo jest pobierana powolna strona.

  5. W polu Zakładana szybkość połączenia wprowadź liczbę kilobitów na sekundę (Kb/s) odpowiadającą średniej szybkości połączenia użytkownika.

  6. Kliknij przycisk OK.

    Od tego momentu można uruchamiać raporty.

  7. Kliknij menu Witryna, wskaż polecenie Raporty, wskaż polecenie Problemy, a następnie kliknij raport, który chcesz uruchomić:

    • Pliki niepołączone     Zostanie wyświetlona lista wszystkich plików w witrynie, do których nie ma żadnych łączy. Za pomocą tej listy można odnaleźć nieużywane pliki, które powinny zostać usunięte z witryny. Należy zauważyć, że w tym raporcie nie są brane pod uwagę łącza wygenerowane przez formanty ASP.NET (takie jak składnik Web Part Spis treści) w witrynach programu Office SharePoint Server 2007.

    • Powolne strony     Zostanie wyświetlona lista stron w witrynie zidentyfikowanych jako ładujące się powoli (według definicji określonej w kroku 3 oraz średniej szybkości połączenia określonej w kroku 4). Należy zauważyć, że w tym raporcie jest uwzględniany czas wymagany do załadowania znaczników strony. Zawartość dynamiczna generowana przez formanty ASP.NET nie jest brana pod uwagę.

    • Hiperłącza     Zostanie wyświetlona lista wszystkich hiperłączy w witrynie. Po uruchomieniu tego raportu zostanie wyświetlone okno dialogowe z pytaniem, czy hiperłącza w witrynie mają zostać sprawdzone. Kliknij przycisk Tak, jeśli chcesz, aby każde hiperłącze zostało sprawdzone w programie Office SharePoint Designer 2007. W rezultacie zostanie utworzona lista hiperłączy, na której stan każdego z nich zostanie zidentyfikowany jako OK lub Przerwane. Aby edytować dowolne przerwane łącze, kliknij je w raporcie, a następnie kliknij przycisk Edytuj hiperłącze na pasku narzędzi, który jest wyświetlany w prawym górnym rogu okna dokumentu w widoku Raporty.

      Uwaga :  Okno dialogowe Edytowanie hiperłącza

    • Błędy składników     Zostanie wyświetlona lista składników — takich jak przyciski interakcyjne lub licznik trafień (ogólnie nazywanych składnikami webbot lub robotami) — które aktualnie generują błędy. Można wyświetlić listę składników sieci Web, klikając polecenie Składnik sieci Web w menu Wstaw.

Początek strony

Wyświetlanie raportu Podsumowanie użycia

Raporty użycia witryny pomagają jej właścicielom uzyskać odpowiedzi na niektóre z najważniejszych pytań dotyczących witryny, na przykład: jak wiele osób używa witryny, które zasoby są najpopularniejsze, kto najczęściej używa witryny i skąd odwiedzający przechodzą do witryny. Raport Podsumowanie użycia zawiera podsumowanie całkowitej liczby odwiedzin, liczby trafień strony, pobranych bajtów itp.

Raport Podsumowanie użycia

W celu uruchomienia raportu Podsumowanie użycia postępuj zgodnie z poniższą procedurą:

  1. W programie Office SharePoint Designer 2007 otwórz witrynę sieci Web, dla której chcesz uruchomić raport.

  2. W menu Witryna wskaż polecenie Raporty, wskaż polecenie Użycie, a następnie kliknij polecenie Podsumowanie użycia.

    Raport zostanie wygenerowany. W celu wyświetlenia szczegółowych raportów kliknij dowolny element z hiperłączem w kolumnie Nazwa.

Początek strony

Wyświetlanie szczegółowych raportów użycia

W celu uzyskania odpowiedzi na pytania dotyczące sposobu uzyskiwania przez użytkowników dostępu do witryny można uruchomić szczegółowe raporty użycia. Raport Podsumowanie użycia, który został wygenerowany w poprzedniej sekcji, przedstawia całkowitą liczbę trafień strony, ale na przykład raport Miesięczna liczba trafień strony przedstawia szczegółowo, ile trafień zliczono dla każdej ze stron w witrynie. Poniżej przedstawiono procedurę uruchamiania szczegółowych raportów użycia:

  1. W programie Office SharePoint Designer 2007 otwórz witrynę sieci Web, dla której chcesz uruchomić raport.

  2. W menu Witryna wskaż polecenie Raporty, wskaż polecenie Użycie, a następnie kliknij raport, który chcesz uruchomić:

    • Podsumowanie miesięczne     Zostanie wyświetlone podsumowanie liczby odwiedzin, liczby trafień, całkowitej liczby trafień oraz rozmiaru pobranych danych w witrynie według miesięcy.

    • Podsumowanie tygodniowe     Zostanie wyświetlone podsumowanie liczby odwiedzin, liczby trafień, całkowitej liczby trafień oraz rozmiaru pobranych danych w witrynie według tygodni.

    • Podsumowanie dzienne     Zostanie wyświetlone podsumowanie liczby odwiedzin, liczby trafień, całkowitej liczby trafień oraz rozmiaru pobranych danych w witrynie według dni.

    • Miesięczna liczba trafień strony     Zostanie wyświetlone podsumowanie liczby trafień oraz całkowitej liczby trafień dla każdej strony w witrynie sieci Web według miesięcy.

    • Tygodniowa liczba trafień strony     Zostanie wyświetlone podsumowanie liczby trafień oraz całkowitej liczby trafień dla każdej strony w witrynie sieci Web według tygodni.

    • Dzienna liczba trafień strony     Zostanie wyświetlone podsumowanie liczby trafień oraz całkowitej liczby trafień dla każdej strony w witrynie sieci Web według dni.

    • Odwiedzający użytkownicy     Zostanie wyświetlone podsumowanie liczby odwiedzających użytkowników oraz wartość procentowa sumy całkowitej dla wybranego miesiąca.

    • Systemy operacyjne     Zostanie wyświetlone podsumowanie liczby systemów operacyjnych odwiedzających użytkowników oraz wartość procentowa sumy całkowitej dla wybranego miesiąca.

    • Przeglądarki     Zostanie wyświetlone podsumowanie liczby przeglądarek odwiedzających użytkowników oraz wartość procentowa sumy całkowitej dla wybranego miesiąca.

    • Domeny odwołań     Zostanie wyświetlone podsumowanie liczby odwiedzin pochodzących z określonej domeny oraz wartość procentowa sumy całkowitej dla wybranego miesiąca.

    • Adresy URL odwołań     Zostanie wyświetlone podsumowanie liczby odwiedzin pochodzących z określonego adresu URL oraz wartość procentowa sumy całkowitej dla wybranego miesiąca.

    • Ciągi wyszukiwania     Zostanie wyświetlona lista przedstawiająca liczbę wyszukiwań ciągów wpisanych w polu wyszukiwania witryny oraz wartość procentowa sumy całkowitej dla wybranego miesiąca.

Początek strony

Tworzenie wykresu wyników danych użycia

Użytkownik może łatwo utworzyć wykres przedstawiający dane użycia w formacie graficznym, co ułatwia zauważenie trendów i zidentyfikowanie wzorców użycia.

  1. W menu Witryna wskaż polecenie Raporty, wskaż polecenie Użycie, a następnie kliknij raport, który chcesz uruchomić.

  2. Na pasku narzędzi w prawym górnym rogu okna dokumentu na liście Wykres kliknij typ wykresu, który chcesz utworzyć, na przykład Wykres kolumnowy.

    Pasek narzędzi w widoku Raporty z wyświetloną listą wykresów

    Raport zostanie otwarty w nowym oknie.

    Wykres danych użycia

    Uwaga : Domyślnie dane wykresu są generowane razem z raportami użycia. Jeśli nie można ich odnaleźć podczas próby uruchomienia raportu, w menu Narzędzia kliknij polecenie Opcje aplikacji, kliknij kartę Widok Raporty, a następnie upewnij się, że pole wyboru Dołącz wykres podczas zapisywania raportu dotyczącego użycia jest zaznaczone.

Początek strony

Sortowanie raportu

W widoku Raporty można sortować raport, klikając nagłówki kolumn.

Początek strony

Filtrowanie raportu

Wyniki raportu można zawęzić w celu przeglądania tylko wybranych informacji. Dane można filtrować według jednej kolumny lub według wielu kolumn, aby utworzyć filtr progresywny.

  1. W menu Witryna wskaż polecenie Raporty, a następnie kliknij raport, który chcesz uruchomić.

  2. Kliknij strzałkę obok nagłówka kolumny, według której chcesz filtrować dane, a następnie kliknij dane, których chcesz użyć do filtrowania.

    Jeśli na przykład filtrujesz dane według typu pliku, możesz kliknąć strzałkę obok nagłówka kolumny Typ, a następnie kliknąć pozycję bmp, aby wyświetlać w raporcie tylko pliki map bitowych.

    Kolumna Typ z wyświetlonym menu filtru

  3. Aby filtrować dane według kilku kolumn, powtórz krok 2 dla każdej kolumny.

  4. Aby utworzyć dla kolumny filtr niestandardowy, kliknij strzałkę obok nagłówka kolumny, a następnie kliknij pozycję (Niestandardowe). Wprowadź kryteria wyszukiwania, a następnie kliknij przycisk OK.

    Można na przykład użyć autofiltru niestandardowego, aby zidentyfikować wszystkie pliki obrazów bmp i gif znajdujące się w witrynie.

    Okno dialogowe Autofiltr niestandardowy

  5. Aby wyczyścić filtr w dowolnej kolumnie, kliknij strzałkę obok nagłówka tej kolumny, a następnie kliknij pozycję (Wszystkie).

Uwaga : Po zamknięciu witryny ustawienia aktualnie zastosowanego filtru są zapisywane. Jeśli w nowo uruchomionym raporcie nie można odnaleźć plików, mogą one być ukryte w wyniku zastosowania filtrów podczas poprzedniej sesji.

W celu usunięcia z raportu wszystkich filtrów kliknij prawym przyciskiem myszy dowolny nagłówek kolumny, a następnie w menu skrótów kliknij polecenie Usuń filtry.

Początek strony

Kopiowanie raportu

Po uruchomieniu raportu można skopiować wyniki i wkleić je do wiadomości e-mail lub innego dokumentu (na przykład arkusza programu Microsoft Office Excel). Można kopiować każdy raport oprócz raportu Podsumowanie witryny.

  1. Kliknij prawym przyciskiem myszy dowolny nagłówek kolumny w uruchomionym raporcie, a następnie w menu skrótów kliknij polecenie Kopiuj raport.

    Menu kolumny Nazwa z zaznaczonym poleceniem Kopiuj raport

  2. Wklej dane do dokumentu lub wiadomości.

Początek strony

Zapisywanie raportu

Raport można zapisać, aby użyć programu Microsoft Office Excel 2007 do wyświetlania i analizowania wyników lub na ich podstawie utworzyć wykresy niestandardowe.

  1. W menu Witryna wskaż polecenie Raporty, a następnie kliknij raport, który chcesz uruchomić.

  2. Kliknij polecenie Zapisz w menu Plik lub naciśnij klawisze CTRL+S.

  3. W polu Nazwa pliku wpisz nazwę raportu, a następnie kliknij przycisk Zapisz. Raport zostanie zapisany w witrynie jako plik htm.

    Raport otwarty w programie Excel

  4. Aby otworzyć raport, kliknij go dwukrotnie.

    Raport zostanie otwarty w programie Office Excel 2007.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×