Używanie argumentu tabela_tablica w funkcji wyszukiwania

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Podczas tworzenia formuły za pomocą funkcji WYSZUKAJ.PIONOWO lub WYSZUKAJ.POZIOMO należy wprowadzić argument tabela_tablica, który jest zakresem komórek, na przykład D2:F39. Funkcja wyszukuje zakres danych, które chcesz znaleźć.

Argument tabela_tablica jest drugim argumentem (pierwszym jest szukana wartość) wymaganym do działania funkcji WYSZUKAJ.PIONOWO i WYSZUKAJ.POZIOMO. Bez argumentu tabela_tablica te funkcje nie będą działać.

Pierwszy argument może mieć określoną wartość, taką jak „41” lub „maj”, lub może mieć postać odwołania do komórki, takiego jak F2. Ten argument wygląda następująco:

=WYSZUKAJ.PIONOWO(F2;...

Argument tabela_tablica zawsze występuje po szukanej wartości, na przykład:

=WYSZUKAJ.PIONOWO(F2;B4:D39;...

Zakres komórek wskazywany przez argument tabela_tablica może zawierać odwołania względne i bezwzględne. Jeśli zamierzasz kopiować formułę do innych komórek, musisz użyć bezwzględnych odwołań do komórek (pamiętaj o znaku $), na przykład:

=WYSZUKAJ.PIONOWO(F2;$B$2:BD$39;...

Jeśli komórki w argumencie tabela_tablica znajdują się w innym arkuszu w skoroszycie, argument powinien zawierać nazwę arkusza i wykrzyknik. Składnia powinna wyglądać następująco:

=WYSZUKAJ.PIONOWO(F2;Arkusz 2!$C$14:E$42;...

Kolumna, która zawiera szukane wartości, jest trzecim wprowadzonym argumentem. Jest to kolumna odnośnika. Jeśli wartości, które chcesz wyświetlić, znajdują się w kolumnie D (trzeciej kolumnie w argumencie tabela_tablica), ostatni argument ma wartość 3.

=WYSZUKAJ.PIONOWO(F2;B4:D39;3)

Jest to rozwiązanie opcjonalne, ale zaleca się użycie czwartego argumentu: Prawda lub Fałsz. Jeśli szukasz dokładnego dopasowania, użyj argumentu Fałsz.

=WYSZUKAJ.PIONOWO(F2;B4:D39;3;Fałsz)

Jeśli użyjesz argumentu Prawda lub pozostawisz ten argument pusty, funkcja zwróci wyniki przybliżone do pierwszego argumentu. Jeśli na przykład pierwszy argument zawiera tekst „maj” i użyjesz argumentu Prawda, to funkcja WYSZUKAJ.PIONOWO zwróci wartości „maj”, „majówka” itp. Jeśli jednak czwartym argumentem będzie Fałsz, wyniki funkcji będą zawierały tylko dokładne dopasowanie („maj”), czyli to, czego najczęściej szukamy.

Korzystając z argumentu Prawda, musisz pamiętać o tym, że jeśli kolumna odnośnika — określona w trzecim argumencie — nie jest posortowana rosnąco (od A do Z lub od najmniejszej do największej liczby), funkcja może zwrócić nieprawidłowy wynik.

Aby uzyskać więcej informacji na temat funkcji WYSZUKAJ.PIONOWO i WYSZUKAJ.POZIOMO, zobacz Funkcje wyszukiwania i odwołań.

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×