Tworzenie wykresu przestawnego

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Czasami trudno jest uzyskać pełny obraz sytuacji w przypadku danych w dużej tabeli przestawnej lub arkusza z dużą ilością złożonych danych zawierających tekst i liczby z nagłówkami kolumn. Przykład:

Złożone dane arkusza

Wykres przestawny może pomóc w zrozumieniu danych. Na wykresie przestawnym serie danych, kategorie i osie wykresu są wyświetlane w standardowy sposób, ale na takim wykresie są także dostępne interakcyjne kontrolki filtrowania umożliwiające szybkie analizowanie podzbioru danych.

Wykres przestawny z wyświetlonymi kontrolkami filtrowania

W przypadku danych z arkusza wykres przestawny można utworzyć bez konieczności wcześniejszegoutworzenia tabeli przestawnej. Można także utworzyć wykres przestawny polecany dla używanych danych. W takim przypadku program Excel automatycznie utworzy odpowiednią tabelę przestawną. Można to zrobić w następujący sposób:

  1. Kliknij dowolne miejsce w obszarze danych.

  2. Na karcie Wstawianie w grupie Wykresy wybierz pozycję Polecane wykresy.

    Przycisk Polecane wykresy na karcie Wstawianie

  3. Na karcie Polecane wykresy wybierz dowolny wykres z ikoną wykresu przestawnego Przycisk wskaźnika wykresu przestawnego w górnym rogu. W okienku podglądu zostanie wyświetlony podgląd wybranego wykresu przestawnego.

    Okno dialogowe Wstawianie wykresu z wyświetlonymi polecanymi wykresami przestawnymi

  4. Po znalezieniu odpowiedniego wykresu przestawnego kliknij przycisk OK.

Uwaga : Jeśli nie znajdziesz odpowiedniego wykresu przestawnego, kliknij pozycję Wykres przestawny na karcie Wstawianie zamiast pozycji Polecane wykresy.

  1. Na wyświetlonym wykresie przestawnym kliknij dowolną kontrolkę interakcyjną, a następnie wybierz odpowiednie opcje sortowania lub filtrowania.

    Opcje filtrowania i sortowania na wykresie przestawnym

    Porada : Aby usunąć niepotrzebny wykres przestawny, zaznacz go, a następnie naciśnij przycisk Usuń.

Inne sposoby tworzenia wykresu przestawnego

Jeśli już masz tabelę przestawną, możesz na jej podstawie utworzyć wykres przestawny. A jeśli korzystasz z połączenia z zewnętrznym źródłem danych OLAP (Online Analytical Processing) lub modelu danych, możesz utworzyć autonomiczny „odłączony” wykres przestawny bez konieczności tworzenia tabeli przestawnej.

Tworzenie wykresu przestawnego dla istniejącej tabeli przestawnej

Nawiązywanie połączenia z danymi zewnętrznymi w celu utworzenia wykresu przestawnego

Tworzenie wykresu przestawnego na podstawie istniejącego połączenia z danymi zewnętrznymi

Tworzenie wykresu przestawnego dla istniejącej tabeli przestawnej

  1. Kliknij dowolne miejsce tabeli przestawnej, aby wyświetlić kartę Narzędzia tabel przestawnych na wstążce.

    Narzędzia tabel przestawnych

  2. Kliknij pozycję Analiza > Wykres przestawny.

    Przycisk Wykres przestawny na karcie Analiza

  3. W oknie dialogowym Wstawianie wykresu kliknij odpowiedni typ i podtyp wykresu. Może to być dowolny typ wykresu oprócz wykresu punktowego (XY), bąbelkowego i giełdowego.

    Okno dialogowe Wstawianie wykresu dotyczące wykresów przestawnych

Aby dowiedzieć się więcej o typach wykresów, zobacz Dostępne typy wykresów.

  1. Kliknij przycisk OK.

  2. Na wyświetlonym wykresie przestawnym kliknij dowolną kontrolkę interakcyjną, a następnie wybierz odpowiednie opcje sortowania lub filtrowania.

Początek strony

Nawiązywanie połączenia z danymi zewnętrznymi w celu utworzenia wykresu przestawnego

  1. Kliknij pozycję Dane > Z innych źródeł, a następnie wybierz odpowiednie źródło danych. Możesz na przykład wybrać pozycję Z usług analiz, aby nawiązać połączenie z plikiem modułu OLAP (Online Analytical Processing).

    Przycisk Z innych źródeł na karcie Dane

  2. Wykonaj czynności przedstawione w Kreatorze połączenia danych, a następnie kliknij przycisk Zakończ.

  3. W oknie dialogowym Importowanie danych wybierz pozycję Wykres przestawny oraz lokalizację, w której mają być umieszczone dane, a następnie kliknij przycisk OK.

    Zostanie wyświetlony pusty wykres przestawny oraz lista pól umożliwiająca dodawanie pól oraz zmienianie ich rozmieszczenia na wykresie przestawnym.

  4. W obszarze Lista pól wybierz pola, które mają być wyświetlane na wykresie przestawnym.

Lista pól z wyświetloną sekcją pól oraz sekcją obszarów

  1. Po utworzeniu wykresu przestawnego możesz go dostosować w taki sam sposób, jak standardowy wykres. Po zaznaczeniu wykresu przestawnego:

  2. Dwa przyciski wyświetlane obok wykresu, dzięki czemu można szybko dodać lub zmienić elementy wykresu, takie jak tytuły lub etykiety danych, lub zmienianie stylu wykresu i kolory wykresie przestawnym tak samo jak w wykresu standardowego.

    Przyciski Elementy wykresu i Style wykresu obok wykresu przestawnego

  3. Na wstążce zostanie wyświetlona karta Narzędzia wykresów przestawnych. Za pomocą opcji znajdujących się na kartach Analiza, Projektowanie i Formatowanie można pracować z wykresem przestawnym i dostosowywać go.

    Karta Narzędzia wykresów przestawnych na wstążce

Początek strony

Tworzenie wykresu przestawnego na podstawie istniejącego połączenia z danymi zewnętrznymi

  1. Kliknij pozycję Wstawianie > Wykres przestawny.

    Przycisk Wykres przestawny na karcie Wstawianie

  2. W oknie dialogowym Tworzenie wykresu przestawnego kliknij pozycję Użyj zewnętrznego źródła danych, a następnie kliknij pozycję Wybierz połączenie.

  3. W oknie dialogowym Istniejące połączenia na karcie Połączenia kliknij dwukrotnie odpowiednie połączenie.

  4. Kliknij przycisk OK.

    Zostanie wyświetlony pusty wykres przestawny oraz lista pól umożliwiająca dodawanie pól oraz zmienianie ich rozmieszczenia na wykresie przestawnym.

  5. W obszarze Lista pól wybierz pola, które mają być wyświetlane na wykresie przestawnym.

Lista pól z wyświetloną sekcją pól oraz sekcją obszarów

  1. Po utworzeniu wykresu przestawnego możesz go dostosować w taki sam sposób, jak standardowy wykres. Po zaznaczeniu wykresu przestawnego:

  • Dwa przyciski wyświetlane obok wykresu, dzięki czemu można szybko dodać lub zmienić elementy wykresu, takie jak tytuły lub etykiety danych, lub zmienianie stylu wykresu i kolory wykresie przestawnym tak samo jak w wykresu standardowego.

    Przyciski Elementy wykresu i Style wykresu obok wykresu przestawnego

  • Na wstążce zostanie wyświetlona karta Narzędzia wykresów przestawnych. Za pomocą opcji znajdujących się na kartach Analiza, Projektowanie i Formatowanie można pracować z wykresem przestawnym i dostosowywać go.

    Karta Narzędzia wykresów przestawnych na wstążce

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×