Tworzenie wykazu seryjnego

Ten artykuł można komentować. Redaktorzy przeczytają przekazane komentarze i poprawią ten artykuł przed jego ostateczną publikacją. Komentarze można wysyłać, klikając pozycję Tak lub Nie na końcu tego artykułu, a następnie dołączając własną opinię na temat tego, co zostało omówione w sposób zadowalający, a co należałoby zmienić. Dziękujemy.

Program Publisher udostępnia szablony, za pomocą których można tworzyć krótkie wykazy. Wystarczy wybrać szablon wykazu, a następnie wstawić własne obrazy w miejsce obrazów zastępczych i wpisać odpowiedni tekst.

Aby utworzyć dłuższy wykaz, należy użyć wykazu seryjnego. Służy on również do tworzenia katalogów, albumów fotograficznych i innego typu publikacji, w których na każdej stronie są wyświetlane elementy. Okienko zadań Wykaz seryjny pakietu Microsoft Office prowadzi użytkownika krok po kroku przez cały proces tworzenia wykazu seryjnego.

W tym artykule

Jak działa wykaz seryjny

Planowanie wykazu

Tworzenie szablonu

Ustanawianie połączenia ze źródłem danych

Wstawianie pól scalania

Kończenie, drukowanie i zapisywanie publikacji z wykazem

Jak działa wykaz seryjny

Wykaz seryjny przypomina korespondencję seryjną. Gdy jest używany wykaz seryjny, jest tworzony szablon wykazu seryjnego, który jest łączony z informacjami ze źródła danych w celu wygenerowania scalonych stron.

Data source combined with a merge template to generate pages for a publication

1. Źródło danych z informacjami rekordów, takimi jak nazwy i opisy elementów.

2. Szablon wykazu seryjnego z obszarem wykazu seryjnego zawierającym pola scalania, które są symbolami zastępczymi informacji rekordów.

3. Wynikowe scalone strony. Na każdej stronie jest wyświetlanych kilka rekordów.

Wykaz seryjny można zapisać w postaci nowej publikacji lub dodać na końcu istniejącej publikacji. Można również zapisać szablon wykazu seryjnego i użyć go ponownie w celu utworzenia dodatkowych zestawów scalonych stron, jeśli informacje w źródle danych zostaną zaktualizowane.

Przed rozpoczęciem

Poniższe porady pomogą pomyślnie utworzyć wykaz seryjny:

  • Rozpocznij tworzenie wykazu seryjnego w nowej publikacji.

  • Ogranicz długość szablonu wykazu seryjnego do jednej strony.

  • Ustaw takie wymiary strony szablonu wykazu seryjnego, jakie mają mieć finalne scalone strony.

  • Jeśli jest planowane dodanie tworzonych scalonych stron na końcu istniejącej publikacji, upewnij się, że szablon wykazu seryjnego jest pod następującymi względami zgodny z istniejącą publikacją:

    • Rozmiar strony (wysokość i szerokość)

    • Widok strony (jedno- lub dwustronicowy)

    • Typ publikacji (w sieci Web lub drukowana)

    • Kolejność stron (od lewej do prawej lub od prawej do lewej)

Początek strony

Planowanie wykazu

Przed przystąpieniem do tworzenia wykazu seryjnego należy się zastanowić, jakiego rodzaju informacje mają znajdować się na ostatecznych scalonych stronach.

  • Czy mają być zawarte nazwy i ceny elementów?

  • Czy mają być zawarte opisy poszczególnych elementów?

  • Czy mają być zawarte obrazy poszczególnych elementów?

Planowanie źródła danych

Po określeniu rodzaju informacji, które będą znajdować się w wykazie, można utworzyć źródło danych, które będzie używane dla potrzeb tego wykazu. Jeśli źródło danych już istnieje, należy się upewnić, że zawiera wszystkie informacje, które mają znajdować się w wykazie seryjnym.

Okienko zadań Wykaz seryjny umożliwia korzystanie z wielu formatów źródeł danych. Jeśli nie utworzono jeszcze źródła danych dla potrzeb wykazu seryjnego, można je wygenerować w programie Publisher. Można również utworzyć je w arkuszu kalkulacyjnym programu Microsoft Office Excel lub w tabeli programu Microsoft Office Word.

pole danych zawarte w źródle danych odpowiadają pole korespondencji seryjnej wstawionym do szablonu wykazu seryjnego.

Po skonfigurowaniu źródła danych należy utworzyć kolumnę dla każdego typu informacji, na przykład nazwy elementu, numeru magazynowego i ceny. Każdy wiersz (rekord) odpowiada informacjom o jednym elemencie.

Ważne : Należy się upewnić, że źródło danych zawiera pole danych lub kolumnę dla każdego typu informacji, które zostaną scalone. W przypadku niektórych typów źródeł danych można modyfikować dane po ustanowieniu połączenia z nimi w programie Publisher, lecz lepiej wprowadzić wszystkie informacje przed rozpoczęciem pracy.

Jeśli jest planowane scalanie fotografii na stronach wykazu, należy utworzyć kolumnę z informacją o ścieżka do każdego pliku obrazu, który ma być używany. Nie należy umieszczać rzeczywistych obrazów w źródle danych.

Jeśli źródło danych ma zostać utworzone w programie Publisher, można to zrobić po utworzeniu szablonu.

Początek strony

Tworzenie szablonu

Teraz można utworzyć szablon wykazu seryjnego, który służy do projektowania układu ostatecznych scalonych stron. Kiedy scalanie zostanie zakończone, za pomocą szablonu wykazu seryjnego zostaną wygenerowane scalone strony, które można zapisać jako nową publikację lub dodać na końcu istniejącej publikacji.

Szablon wykazu seryjnego powinien mieć taki sam układ (rozmiar i orientacja strony) jak układ przewidziany dla ostatecznych scalonych stron. Ponadto powinien zawierać tekst i grafikę, które będą występować na każdej stronie ostatecznej publikacji, na przykład obraz tła lub nazwę firmy.

Jeśli planowane jest dodanie scalonych stron na końcu istniejącej publikacji, należy upewnić się, że szablon wykazu seryjnego pod następującymi względami jest zgodny z istniejącą publikacją:

  • Rozmiar strony (wysokość i szerokość)

  • Widok strony (jedno- lub dwustronicowy)

  • Typ publikacji (w sieci Web lub drukowana)

  • Kolejność stron (od lewej do prawej lub od prawej do lewej)

Tworzenie szablonu wykazu seryjnego

  1. W menu Plik kliknij polecenie Nowy.

  2. W okienku zadań Nowy plik publikacji kliknij pozycję Rozmiary pustych stron, a następnie wybierz odpowiedni rozmiar.

    Uwaga : Jeśli jest planowane ogłoszenie wykazu w witrynie sieci Web, w obszarze Rozmiary pustych stron kliknij pozycję Witryny sieci Web, a następnie kliknij rozmiar odpowiadający docelowej rozdzielczości ekranu.

  3. Kliknij przycisk Utwórz.

  4. W menu Plik kliknij polecenie Ustawienia strony.

  5. W oknie dialogowym Ustawienia strony wprowadź odpowiednie zmiany w ustawieniach marginesów, a następnie kliknij przycisk OK.

  6. W menu Narzędzia wskaż polecenie Korespondencja i wykazy seryjne, a następnie kliknij polecenie Wykaz seryjny.

Początek strony

Ustanawianie połączenia ze źródłem danych

Po sformatowaniu strony szablonu wykazu seryjnego należy utworzyć źródło danych lub zlokalizować je i ustanowić połączenie z nim za pomocą okienka zadań Wykaz seryjny. Rozwiązanie wybrane w następnym kroku zależy od tego, czy źródło danych już istnieje, czy należy utworzyć nową listę w programie Publisher.

  1. W okienku zadań Wykaz seryjny w obszarze Wybieranie listy produktów wykonaj jedną z następujących czynności:

  2. Kliknij przycisk Następny: Tworzenie listy produktów (lub połączenie z listą).

Używanie istniejącej listy

  1. W oknie dialogowym Wybieranie źródła danych znajdź i kliknij odpowiednie źródło danych.

    Domyślnie program Publisher przechowuje źródła danych w folderze Moje źródła danych. Przejście do folderu Moje źródła danych może być konieczne w celu znalezienia odpowiedniego źródła danych.

  2. Kliknij przycisk Otwórz.

    W zależności od typu wybranego źródła danych mogą zostać wyświetlone inne okna dialogowe, w których trzeba będzie podać określone informacje. Na przykład, jeśli źródłem danych jest arkusz programu Excel, w którym dane znajdują się na kilku kartach, należy wybrać kartę zawierającą odpowiednie informacje, a następnie kliknąć przycisk OK.

Wybieranie z kontaktów programu Outlook

  1. Wykonaj jedną z następujących czynności:

    • W oknie dialogowym Wybieranie kontaktów kliknij listę kontaktów, której chcesz użyć.

    • W oknie dialogowym Wybieranie profilu wybierz profil kontaktów, którego chcesz użyć.

  2. Kliknij przycisk OK.

Wpisywanie nowej listy

  1. W oknie dialogowym Nowa lista produktów wpisz informacje dotyczące pierwszego elementu (rekordu), który ma się znaleźć w wykazie.

    Aby dodać lub usunąć kolumny (jeśli na przykład nie będą dołączane obrazy), kliknij przycisk Dostosuj kolumny, a następnie wprowadź odpowiednie zmiany.

  2. Po wpisaniu wszystkich informacji dotyczących pierwszego rekordu kliknij przycisk Nowa pozycja, a następnie wpisz informacje dotyczące następnego rekordu. Powtarzaj te czynności do momentu wpisania informacji dotyczących wszystkich rekordów, które mają zostać dołączone.

  3. Po zakończeniu tworzenia nowej listy kliknij przycisk OK.

  4. W oknie dialogowym Zapisywanie listy adresów wpisz nazwę nowej listy, a następnie kliknij przycisk Zapisz.

Dodawanie kolejnych list

Aby użyć większej liczby list w wykazie seryjnym, należy dodać kolejne listy.

  1. W oknie dialogowym Lista produktów wykazu seryjnego w obszarze Dodawanie do listy produktów kliknij przycisk Wybierz istniejącą listę lub Wybierz z kontaktów programu Outlook, w zależności od typu tworzonej publikacji.

Dodawanie kolejnych elementów

Aby dodać tylko kilka elementów, należy utworzyć listę nowych elementów i połączyć ją z wybraną wcześniej listą.

  1. W oknie dialogowym Lista produktów wykazu seryjnego w obszarze Dodawanie do listy produktów kliknij przycisk Wpisz nową listę.

  2. W oknie dialogowym Nowa lista produktów wpisz informacje dotyczące pierwszego elementu, który ma się znaleźć w wykazie.

    Aby dodać lub usunąć kolumny w celu dopasowania ich do drugiej używanej listy, kliknij przycisk Dostosuj kolumny, a następnie wprowadź odpowiednie zmiany.

  3. Po wpisaniu wszystkich informacji dotyczących pierwszego rekordu kliknij przycisk Nowa pozycja, a następnie wpisz informacje dotyczące następnego rekordu. Powtarzaj te czynności do momentu wpisania informacji dotyczących wszystkich rekordów, które mają zostać dołączone.

  4. Po zakończeniu tworzenia nowej listy kliknij przycisk OK.

  5. W oknie dialogowym Zapisywanie listy adresów wpisz nazwę nowej listy, a następnie kliknij przycisk Zapisz.

  6. Nowa lista zostanie automatycznie wyświetlona w obszarze Źródła danych w oknie dialogowym Lista produktów wykazu seryjnego.

Wybieranie rekordów do dołączenia

  1. W oknie dialogowym Lista produktów wykazu seryjnego wykonaj jedną z następujących czynności:

    • Zaznacz pola wyboru obok rekordów, które chcesz uwzględnić, i wyczyść pola wyboru obok rekordów, które chcesz wykluczyć.

      Porada : Jeśli chcesz uwzględnić tylko kilka rekordów, kliknij przycisk Wyczyść wszystko, a następnie zaznacz odpowiednie rekordy.

    • Przefiltruj listę według określonego kryterium, klikając strzałkę obok nagłówka kolumny dotyczącej elementu, według którego chcesz wykonać filtrowanie, a następnie klikając wartość, której chcesz użyć jako filtru.

      • (Puste) wyświetla wszystkie rekordy, w których odpowiednie pole jest puste.

      • (Niepuste) wyświetla wszystkie rekordy, w których odpowiednie pole zawiera informacje.

        Uwaga : Jeśli źródło danych zawiera rekordy współdzielące tę samą informację, a w kolumnie istnieje co najwyżej dziesięć unikatowych wartości, możliwe jest filtrowanie według określonej informacji. Na przykład jeśli źródło danych jest listą własności sprzedaży i istnieje kilka rekordów własności, w których pole miasto/lokalizacja ma wartość „Wrocław”, to można filtrować według wartości Wrocław.

        W oknie dialogowym Lista produktów wykazu seryjnego zostaną wyświetlone tylko wyznaczone rekordy. Aby ponownie wyświetlić wszystkie rekordy, kliknij opcję (Wszystkie).

    • Posortuj elementy na liście, klikając nagłówek kolumny elementu, według którego chcesz posortować. Na przykład, aby wyświetlić listę według miasta/lokalizacji w kolejności alfabetycznej, kliknij nagłówek kolumny Miasto/lokalizacja.

  2. Kliknij przycisk OK, aby wrócić do okienka zdań Wykaz seryjny. Program Publisher użyje rekordów wyznaczonych do scalenia.

  3. Kliknij przycisk Następny: Przygotowywanie publikacji.

Początek strony

Wstawianie pól scalania

Czas zorganizować informacje, które mają być wyświetlane w publikacji. Aby utworzyć układ strony, należy dodać pola scalania do obszaru wykazu seryjnego. Każde pole scalania reprezentuje kolumnę w źródle danych, a w obszarze wykazu seryjnego można zobaczyć, w jaki sposób będą wyświetlane informacje w jednym rekordzie.

Obszar wykazu seryjnego można zorganizować w dowolny sposób. Można też określić, ile razy ten obszar ma być powielony na każdej stronie. Można na przykład wyświetlić cztery elementy na stronie. Każdy element będzie wyświetlany tak samo, w zależności od sposobu zorganizowania obszaru wykazu seryjnego. Można dostosować rozmiar każdego elementu oraz obszaru wykazu seryjnego.

Ważne :  Jeśli pola scalania zostaną wstawione poza obszarem wykazu seryjnego, to nie będą powtarzane po ukończeniu scalania.

Wstawianie pól scalania do obszaru wykazu seryjnego

  • W okienku zadań Wykaz seryjny w obszarze Przygotowywanie publikacji kliknij pierwsze pole scalania, które chcesz wstawić.

  • W obszarze wykazu seryjnego zaznacz pole scalania, a następnie przenieś je lub zmień jego rozmiar, wykonując następujące czynności:

    • Aby przenieść pole scalania, umieść wskaźnik myszy na polu scalania, tak aby zmienił się we wskaźnik Przenieś Wskaźnik przenoszenia , a następnie przeciągnij pole scalania w nowe miejsce.

    • Aby zmienić rozmiar pola scalania, umieść wskaźnik myszy na jednym z dojście pola tekstowego lub obrazu, tak aby wskaźnik zmienił się we wskaźnik Zmień rozmiar move ruler , a następnie przeciągnij wskaźnik w celu uzyskania odpowiedniego rozmiaru ramki pola tekstowego lub obrazu.

  • Kliknij poza obszarem pola scalania, aby anulować zaznaczenie tego pola.

  • Powtarzaj kroki od 1 do 3 do momentu wstawienia wszystkich odpowiednich pól ze źródła danych.

    Jeśli przed wstawieniem nowego pola scalania jest zaznaczone wcześniej wstawione pole scalania, nowe pole zostanie wstawione obok wcześniej wstawionego pola.

Formatowanie pól scalania

Aby sformatować dane wykazu seryjnego, należy sformatować pola scalania w szablonie wykazu seryjnego.

  1. W szablonie wykazu seryjnego zaznacz pole zawierające informacje, które chcesz sformatować, wraz ze znakami otaczającymi pole scalania («« »»).

  2. W menu Format kliknij polecenie Czcionka, a następnie zaznacz odpowiednie opcje.

Przenoszenie obszaru wykazu seryjnego lub zmienianie jego rozmiaru

Jeśli sformatowane pola scalania nie pasują już do obszaru wykazu seryjnego, można zmienić ich rozmiar.

Uwaga : Zwiększenie rozmiaru może wiązać się z koniecznością umieszczenia mniejszej liczby elementów (rekordów) na każdej stronie.

  1. Kliknij obszar wykazu seryjnego, aby go zaznaczyć.

  2. Umieść wskaźnik myszy na jednym z dojście w obszarze wykazu seryjnego, a następnie przeciągnij myszą.

  3. Określ liczbę elementów, które mają być wyświetlane na każdej stronie, wpisując na pasku narzędzi Układ wykazu seryjnego odpowiednie liczby dla elementów wzdłuż i w poprzek strony.

Kończenie pracy i wyświetlanie podglądu szablonu

  1. Wpisz dowolny powtarzający się tekst lub informacje, które będą występować obok informacji pochodzących ze źródła danych. Na przykład dodaj symbol waluty obok pola scalania zawierającego cenę.

  2. W obszarze Podgląd strony klikaj odpowiednie strzałki, aby wyświetlić poszczególne strony scalonych danych.

    Jeśli dany element nie ma zostać uwzględniony, kliknij obszar wykazu seryjnego tego elementu, a następnie kliknij pozycję Wyklucz ten element w okienku zadań Wykaz seryjny.

  3. Kliknij przycisk Następny: Tworzenie scalonych publikacji, aby kontynuować.

Początek strony

Kończenie, drukowanie i zapisywanie publikacji z wykazem

Aby zakończyć scalanie, należy wykonać jedną z następujących czynności:

  • Bezpośrednie wydrukowanie scalonej publikacji.

  • Utworzenie i wydrukowanie nowej publikacji zawierającej scaloną zawartość. Zawartość tej publikacji można modyfikować tak jak każdą inną publikację programu Publisher.

  • Dodanie scalonej zawartości do istniejącej publikacji.

Aby dodać przednią lub tylną okładkę do publikacji albo dodać kolejne strony, należy utworzyć nową publikację lub dodać nową zawartość do istniejącej publikacji.

Drukowanie scalonej publikacji

  • W okienku zadań Wykaz seryjny kliknij przycisk Drukuj.

    Program Publisher wydrukuje scalone strony.

Scalanie z nową publikacją

Aby edytować lub zapisać scalone strony albo wydrukować je później, należy zebrać i zapisać wszystkie scalone strony jako nową scaloną publikację zawierającą rzeczywiste dane (na przykład nazwy i ceny produktów) zamiast pól scalania.

  • W okienku zadań Wykaz seryjny kliknij przycisk Scal z nową publikacją.

    Program Publisher utworzy nową publikację, którą można zapisać lub edytować. Można nawet dodać przednią i tylną okładkę.

    Uwaga : Jeśli wykaz może być drukowany jako broszura, całkowita liczba stron musi być wielokrotnością liczby 4.

  • W okienku zadań Wykaz seryjny kliknij przycisk Zapisz tę publikację.

  • W polu Nazwa pliku wpisz nazwę nowej publikacji, a następnie kliknij przycisk Zapisz.

  • Jeśli jest to konieczne, zapisz zmiany wprowadzone w szablonie wykazu seryjnego. Tego szablonu można użyć ponownie, aby utworzyć dodatkowe scalone strony po zaktualizowaniu informacji w źródle danych.

Dodawanie do istniejącej publikacji

Jeśli okładki zostały już skonfigurowane w osobnej publikacji lub jeśli wykaz ma zostać umieszczony na końcu dłuższej publikacji, scaloną zawartość można dodać bezpośrednio.

Przed dodaniem scalonych stron na końcu istniejącej publikacji należy się upewnić, że szablon wykazu seryjnego jest zgodny z istniejącą publikacją pod następującymi względami:

  • Rozmiar strony (wysokość i szerokość)

  • Widok strony (jedno- lub dwustronicowy)

  • Typ publikacji (w sieci Web lub drukowana)

  • Kolejność stron (od lewej do prawej lub od prawej do lewej)

Uwaga : Program Publisher nie może dodać scalonych stron do otwartej publikacji. W przypadku korzystania z publikacji, do której mają zostać dodane scalone strony, należy zapisać i zamknąć tę publikację przed zakończeniem scalania.

  1. W okienku zadań Wykaz seryjny kliknij przycisk Dodaj do istniejącej publikacji. W oknie dialogowym Otwieranie publikacji znajdź i zaznacz publikację, do której chcesz dodać scalone strony, a następnie kliknij przycisk Otwórz.

    Program Publisher doda scalone strony na końcu istniejącej publikacji.

    Porada : Aby zmienić układ stron w zaktualizowanej publikacji, w widoku sortowania stron kliknij stronę, którą chcesz przenieść, a następnie przeciągnij ją do nowej lokalizacji.

  2. W istniejącej publikacji w menu Plik kliknij polecenie Zapisz, aby zapisać aktualizacje.

  3. Jeśli jest to konieczne, zapisz zmiany wprowadzone w szablonie wykazu seryjnego. Tego szablonu można użyć ponownie, aby utworzyć dodatkowe scalone strony po zaktualizowaniu informacji w źródle danych.

Drukowanie i zapisywanie publikacji z wykazem

Jeśli utworzono nową scaloną publikację lub dodano wykaz seryjny do istniejącej publikacji, można wydrukować tę publikację przez kliknięcie polecenia Drukuj w menu Plik.

Drukowanie publikacji z wykazem jako broszury

  1. W menu Plik kliknij polecenie Ustawienia strony.

  2. W obszarze Prowadnice marginesów kliknij przycisk Zaawansowane.

  3. W obszarze Typ układu kliknij pozycję Broszura.

  4. W obszarze Strona dostosuj ustawienia Szerokość i Wysokość, tak aby odpowiadały oryginalnym wymiarom publikacji.

    Ważne : Jeśli szerokość i wysokość strony nie zostaną dostosowane, dwie strony broszury zostaną umieszczone na stronie o oryginalnym rozmiarze, przez co wykaz się nie zmieści.

Zapisywanie szablonu do ponownego użycia

Dobrym rozwiązaniem jest zapisanie szablonu wykazu seryjnego. Można go użyć ponownie w celu utworzenia dodatkowych zestawów scalonych stron po zaktualizowaniu informacji w źródle danych. Aby zapisać publikację z wykazem seryjnym, należy wykonać następujące czynności:

  1. Upewnij się, że jest wyświetlana publikacja z wykazem seryjnym.

  2. W menu Plik kliknij polecenie Zapisz.

  3. Wprowadź nazwę publikacji z wykazem seryjnym, a następnie kliknij przycisk Zapisz.

Początek strony

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×