Tworzenie widoku programu InfoPath dla szablonu formularza zgodnego z przeglądarkami sieci Web

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

W tym artykule

Wprowadzenie do widoków programu InfoPath

Scenariusze zastosowania

Krok 1: Dodanie widoku programu InfoPath do szablonu formularza zgodnego z przeglądarkami

Krok 2: Wyświetlanie widoku przeglądarki w przypadku otwarcia szablonu obsługiwanego przez przeglądarkę w przeglądarce sieci Web

Krok 3: Wyświetlanie widoku programu InfoPath w przypadku otwarcia szablonu obsługiwanego przez przeglądarkę w programie InfoPath

Wprowadzenie do widoków programu InfoPath

Administrator może utworzyć jeden szablon formularza przeznaczony zarówno dla użytkowników, którzy korzystają z programu Microsoft Office InfoPath, jak i dla osób, na których komputerach ta aplikacja nie jest zainstalowana. Taki typ szablonu jest nazywany „szablonem formularza zgodnym z przeglądarkami”. W szablonie tym wszelkie funkcje, ustawienia i formanty programu InfoPath, które nie działają w przeglądarce sieci Web, są w tryb projektowania ukryte lub wyłączone. Pozwala to zapobiec ich omyłkowemu użyciu w projekcie.

Gdy przygotujesz można udostępnić użytkownikom szablonu formularza zgodnego z przeglądarkami, możesz opublikować go na serwerze z programem InfoPath Forms Services, a następnie wprowadź je obsługiwanych w przeglądarce. Jeśli użytkownicy mają zainstalowanego na komputerze programu InfoPath, formularz zostanie otwarty w programie InfoPath. Jeśli nie mają zainstalowanego programu InfoPath, formularz zostanie otwarty w przeglądarce sieci Web. W obu przypadkach szablonu formularza nie zawiera funkcje programu InfoPath, ustawień lub kontrolek, które nie będą działać w przeglądarce.

Gdy istnieje uzasadnione przypuszczenie, że komputery większości użytkowników będą wyposażone w program InfoPath, można zrezygnować z ograniczania funkcjonalności szablonu do zbioru formantów obsługiwanych przez przeglądarkę sieci Web. Lepiej utworzyć dwa widoki szablonu: jeden przeznaczony dla użytkowników, którzy będą otwierać formularz w przeglądarce sieci Web, a drugi — dla osób korzystających z programu InfoPath. Szablon przeznaczony wyłącznie dla aplikacji InfoPath nigdy nie będzie wyświetlany w przeglądarce sieci Web, dlatego można w nim zastosować pełny wachlarz funkcji programu InfoPath, takich jak role użytkowników czy formanty główne/szczegółowe.

W tym temacie omówiono procedurę konstruowania widoku szablonu formularza zgodnego z przeglądarkami przeznaczonego wyłącznie dla programu InfoPath. Przedstawiono również proces tworzenia reguła służącej do sprawdzania, czy na komputerze użytkownika otwierającego formularz jest zainstalowana aplikacja InfoPath. Jeśli tak, szablon zostanie otwarty w widoku programu InfoPath. Jeśli nie, szablon zostanie otwarty w widoku przeglądarki w przeglądarce sieci Web.

Początek strony

Scenariusze zastosowania

Przypuśćmy, że pracujesz w firmie ubezpieczeniowej i projektujesz szablon formularza zgodny z przeglądarkami, który będzie służył do składania wniosków o wypłatę odszkodowania. Szablon musi uwzględnić potrzeby zarówno klientów, którzy będą go wypełniali w firmowej witrynie sieci Web, oraz wewnętrznych pracowników firmy, którzy będą sprawdzać formularze pod kątem merytorycznym i przekazywać je do zatwierdzenia. Oceniasz, że użytkownicy zewnętrzni nie korzystają z programu InfoPath, natomiast jest on zainstalowany na komputerach użytkowników wewnętrznych. W związku z tym możesz utworzyć dwa odrębne formularze, jednak lepszym i szybszym rozwiązaniem będzie zaprojektowanie jednego szablonu formularza zgodnego z przeglądarkami, który połączy oba widoki:

Widok 1: dla użytkowników zewnętrznych wypełniających formularz     Ten widok będzie prezentowany posiadaczom polis po zalogowaniu się do firmowej witryny sieci Web i otwarciu formularza wniosku. Ponieważ nie wiadomo, czy wnioskodawca ma na komputerze program InfoPath, szablon musi być zgodny z przeglądarką. Innymi słowy należy dopilnować, aby wszystkie pola formularza można było wypełnić w przeglądarce sieci Web.

Widok 2: dla użytkowników wewnętrznych rozpatrujących wnioski     Ten widok jest przeznaczony dla osób rozpatrujących wnioski o wypłatę odszkodowania. Sprawdzają one złożone dokumenty pod kątem poprawności merytorycznej i kierują do likwidatorów w celu zatwierdzenia. Na komputerach wszystkich pracowników firmy jest zainstalowana aplikacja InfoPath, dlatego też można zaprojektować dedykowany widok. W odróżnieniu od widoku przeznaczonego do wprowadzania danych, który jest otwierany w przeglądarce sieci Web, widok programu InfoPath jest wyświetlany wyłącznie w programie InfoPath. Z tego względu może zawierać wszelkie funkcje, formanty i ustawienia niedostępne w widoku szablonu przeznaczonym dla przeglądarki.

Początek strony

Krok 1: Dodanie widoku programu InfoPath do szablonu formularza zgodnego z przeglądarkami

Aby utworzyć widok programu InfoPath w szablonie formularza zgodnym z przeglądarkami, należy zmienić odpowiednie ustawienie w oknie dialogowym Właściwości widoku. Powoduje ono, że formularz można wyświetlać w programie InfoPath, ale już nie w przeglądarce sieci Web.

  1. Otwórz szablon formularza zgodny z przeglądarkami.

  2. W menu Widok kliknij polecenie Zarządzaj widokami.

  3. W obszarze Czynności w okienku zadań Widoki kliknij przycisk Dodaj nowy widok.

  4. W oknie dialogowym Dodawanie widoku wpisz nazwę, pod jaką ma być prezentowany widok, a następnie kliknij przycisk OK.

  5. Na liście Wybierz widok kliknij dwukrotnie widok, który właśnie został utworzony.

  6. Kliknij kartę Ogólne.

  7. Wyczyść pole wyboru Pokaż w menu Widok podczas wypełniania formularza.

    Uwaga : Wyczyszczenie tego pola wyboru zapobiegnie próbom przechodzenia do widoku programu InfoPath przez użytkowników, którzy nie mają na komputerach tej aplikacji.

  8. Zaznacz pole wyboru Zezwalaj tylko na funkcje programu InfoPath (widok będzie niedostępny w przeglądarkach sieci Web) i kliknij przycisk OK.

  9. Zaprojektuj widok w zwykły sposób.

    Teraz w widoku programu InfoPath będzie można korzystać z wielu funkcji, formantów i ustawień, które byłyby niedostępne w szablonie zgodnym z przeglądarkami. Możesz na przykład używać formantów zlokalizowanych w okienku zadań Formanty bez konieczności ograniczania się do formantów obsługiwanych w przeglądarkach. Ponadto w okienku zadań Sprawdzanie projektu nie będą wyświetlane błędy ani komunikaty dotyczące zgodności z przeglądarką.

    Uwaga : O ile w widoku programu InfoPath można używać większości funkcji tego programu, niektóre opcje i ustawienia mające zastosowanie ogólnie do szablonów formularzy zgodnych z przeglądarkami pozostają wyłączone lub ukryte. Na przykład w skali całego formularza nie można włączyć funkcji używania podpisów cyfrowych ani stosować skryptów, ponieważ jeden z widoków musi być w pełni obsługiwany przez przeglądarki.

  10. Aby do szablonu formularza zgodnego z przeglądarkami sieci Web dodać kolejne widoki przeznaczone wyłącznie dla programu InfoPath, powtórz kroki od 2. do 9.

Początek strony

Krok 2: Wyświetlanie widoku przeglądarki w przypadku otwarcia szablonu obsługiwanego przez przeglądarkę w przeglądarce sieci Web

Poniżej opisano procedurę tworzenia reguły decydującej o doborze widoku prezentowanego użytkownikom, gdy po raz pierwszy otworzą formularz bazujący na szablonie formularza zgodnym z przeglądarkami. Reguła jest inicjowana przy otwieraniu formularza po raz pierwszy, ale po spełnieniu określonego warunku. Warunek dotyczy narzędzia użytego do otwarcia formularza, tzn. czy jest to przeglądarka sieci Web. Jeśli tak, zostanie wyświetlony widok przeznaczony wyłącznie dla przeglądarek. Zakres użytych w nim funkcji jest ograniczony wyłącznie do funkcji obsługiwanych przez przeglądarkę.

  1. Otwórz zgodny z przeglądarką szablon formularza zawierający widok przeznaczony tylko dla programu InfoPath.

  2. W menu Narzędzia kliknij polecenie Opcje formularza.

  3. Na liście Kategoria kliknij opcję Otwieranie i zapisywanie.

  4. W obszarze Zachowanie podczas otwierania kliknij opcję Reguły.

  5. W oknie dialogowym Reguły otwierania formularzy kliknij przycisk Dodaj.

  6. W oknie dialogowym Reguła wpisz nazwę, która będzie się jednoznacznie kojarzyła z tą regułą, np. Reguła 1: Przełączanie do widoku przeglądarki.

  7. Aby określić, kiedy reguła ma być stosowana, kliknij przycisk Ustaw warunek.

  8. W pierwszym polu, w obszarze Zastosuj regułę, jeżeli ten warunek jest spełniony kliknij opcję Wyrażenie.

  9. W drugim polu wpisz wyrażenie xdEnvironment:IsBrowser() i kliknij przycisk OK.

  10. W oknie dialogowym Reguła kliknij przycisk Dodaj akcję.

  11. Na liście Akcja zaznacz pozycję Przełącz widoki.

  12. Na liście Widok zaznacz widok przeglądarki, który ma być otwierany, a następnie kliknij przycisk OK.

  13. Aby zapobiec stosowaniu dalszych reguł po tej regule (dla bieżącego zdarzenia), zaznacz pole wyboru Zatrzymaj przetwarzanie reguł po zakończeniu stosowania reguły w oknie dialogowym Reguła.

    Utworzona reguła będzie inicjowana po otwarciu szablonu formularza w sposób zgodny z określonym w warunku, czyli za pomocą przeglądarki sieci Web.

Początek strony

Krok 3: Wyświetlanie widoku programu InfoPath w przypadku otwarcia szablonu obsługiwanego przez przeglądarkę w programie InfoPath

Do szablonu formularza zgodnego z przeglądarkami zostanie dodana kolejna reguła. Będzie ona inicjowana przy otwieraniu formularza po raz pierwszy, ale po spełnieniu określonego warunku. Warunek dotyczy tego, czy na komputerze użytkownika otwierającego szablon jest zainstalowany program InfoPath. Jeśli tak, nastąpi otwarcie widoku przeznaczonego wyłącznie dla aplikacji InfoPath. Ponieważ widok będzie prezentowany tylko w tym programie, może zawierać jego wszystkie funkcje.

  1. Otwórz zgodny z przeglądarką szablon formularza zawierający widok przeznaczony tylko dla programu InfoPath.

  2. W menu Narzędzia kliknij polecenie Opcje formularza.

  3. Na liście Kategoria kliknij opcję Otwieranie i zapisywanie.

  4. W obszarze Zachowanie podczas otwierania kliknij opcję Reguły.

  5. Kliknij przycisk Dodaj.

  6. W oknie dialogowym Reguła wpisz nazwę, która będzie się jednoznacznie kojarzyła z tą regułą, np. Reguła 1: Przełączanie do widoku programu InfoPath.

  7. Aby określić, kiedy reguła ma być stosowana, kliknij przycisk Ustaw warunek.

  8. W pierwszym polu, w obszarze Zastosuj regułę, jeżeli ten warunek jest spełniony kliknij opcję Wyrażenie.

  9. W drugim polu wpisz wyrażenie not(xdEnvironment:IsBrowser()).

  10. Zaznacz opcję I.

  11. W ustawieniach pierwszego warunku na liście zaznacz pozycję Wyrażenie.

  12. W polu tekstowym wpisz wyrażenie not(xdEnvironment:IsMobile()) i kliknij przycisk OK.

  13. W oknie dialogowym Reguła kliknij przycisk Dodaj akcję.

  14. W oknie dialogowym Akcja na liście Akcja zaznacz opcję Przełącz widoki.

  15. Na liście Widok zaznacz widok programu InfoPath, który ma być otwierany, a następnie kliknij przycisk OK.

  16. Aby zapobiec stosowaniu dalszych reguł po tej regule (dla bieżącego zdarzenia), zaznacz pole wyboru Zatrzymaj przetwarzanie reguł po zakończeniu stosowania reguły w oknie dialogowym Reguła.

    Utworzona reguła będzie inicjowana po otwarciu szablonu formularza w sposób zgodny z określonym w warunku, czyli za pomocą programu InfoPath, a nie w przeglądarce sieci Web czy na urządzeniu przenośnym.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×