Tworzenie widoku danych

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

W organizacji są zbierane i przechowywane duże ilości danych. Aby ułatwić użytkownikowi i jego zespołowi dostęp do tych danych i wykonywanie na nich operacji, należy utworzyć aplikację śledzącą lub raportującą na zespołowej witrynie programu Microsoft SharePoint. Od czego zacząć?

Za pomocą programu Microsoft Office SharePoint Designer 2007 można szybko utworzyć widok niestandardowy danych dynamicznych nazywany widokiem danych. Widoku danych można używać w celu przeglądania danych z różnych źródeł, takich jak kwerendy bazy danych, dokumenty XML, usługi sieci Web, listy i biblioteki programu SharePoint oraz skrypty strony serwera.

Istnieją dwie metody wstawiania widoku danych na stronie. Można utworzyć widok danych, przeciągając źródło danych z listy folderów lub z biblioteki źródeł danych na nową lub istniejącą stronę w witrynie sieci Web. Widok danych można także utworzyć, używając polecenia Wstaw widok danych. Następnie można go od razu go zmodyfikować, wstawiając z okienka zadań Szczegóły źródła danych tylko te pola, które mają zostać wyświetlone.

Ten artykuł jest wprowadzeniem do widoków danych. Dodatkowo przedstawiono w nim tworzenie przykładowego pliku XML używanego jako źródło danych, a następnie tworzenie opartego na nim widoku danych: najpierw używając metody „przeciągnij i upuść”, a następnie przy użyciu okienka zadań Szczegóły źródła danych. W tym artykule plik xml jest używany jako źródło danych, co umożliwia łatwe utworzenie źródła danych i wykonywanie kolejnych czynności. Poniższe procedury są jednak odpowiednie w przypadku dowolnego źródła danych, zwłaszcza danych listy programu SharePoint, które mogą być najczęstszymi źródłami danych przy tworzeniu widoku danych.

Ważne : W tym artykule opisano tworzenie widoków danych w witrynach programu SharePoint umieszczonych na serwerach z programem Windows SharePoint Services 3.0. W przypadku witryny umieszczonej na serwerze, na którym nie ma programu Windows SharePoint Services 3.0, pełen zakres funkcji może być niedostępny.

W tym artykule

Co to jest widok danych?

Tworzenie pliku XML jako źródła danych przykładowych

Tworzenie widoku danych przez przeciągnięcie źródła danych na stronie

Tworzenie widoku danych za pomocą okienka zadań Szczegóły źródła danych

Sugerowane następne kroki

Co to jest widok danych?

Widok danych jest live, które można dostosować widok źródła danych, która korzysta z technologii Microsoft ASP.NET. Office SharePoint Designer 2007 pobiera dane ze źródła danych w formularzu z języka XML (Extensible Markup) i wyświetla dane przy użyciu przekształcenia języka rozszerzonego arkusza stylów (XSLT). Office SharePoint Designer 2007 można zmodyfikować widok danych. Widok danych można wyświetlać dane z wielu różnych źródeł, takich jak kwerendy bazy danych, dokumenty XML, usług sieci Web, listy programu SharePoint i bibliotek i skryptów po stronie serwera. Możesz również utworzyć widok danych, w którym są wyświetlane dane z wielu źródeł danych.

Widok danych, który pobiera dane ze źródła danych i wyświetla je przy użyciu przekształcenia XSLT

W widoku danych są prezentowane widoki dynamiczne danych, które można filtrować, sortować lub grupować. Ponadto można zmienić układ, zastosować style lub zastosować formatowanie warunkowe w środowisku WYSIWYG (what you see is what you get — uzyskujesz to, co widzisz).

Po wstawieniu widoku danych na stronie, możesz także użyć narzędzia WYSIWYG w Office SharePoint Designer 2007, dodawanie lub usuwanie kolumn, zmienić formatowanie czcionki i stosowanie kolorów. Jeśli widok danych można sformatować przy użyciu WYSIWYG narzędzi dostępnych w Office SharePoint Designer 2007, Extensible Stylesheet Language (XSL) zostanie wstawiony bezpośrednio w formacie HTML. W trakcie można edytować XSL bezpośrednio w widoku Kod można używać narzędzi do formatowania, w Office SharePoint Designer 2007, aby szybko stosować XSL oraz łatwo bez znajomości dowolnego XSL.

Początek strony

Tworzenie pliku xml jako przykładowego źródła danych

Firma Northwind Traders zajmuje się sprzedażą wyszukanych potraw, a listę swoich produktów przechowuje w formacie XML. Lista produktów zawiera informacje o zapasach w magazynie. Obecnie zespół śledzi inwentaryzację, drukując raporty, które są przekazywane innym zespołom. Zasugerowano utworzenie widoku danych w witrynie intranetowej, co umożliwi pozostałym zespołom w firmie szybki i łatwy dostęp do informacji o zapasach produktów i wyeliminuje konieczność drukowania raportów inwentaryzacyjnych.

Wykonanie poniższych procedur wymaga używania pliku xml jako źródła danych. Jeśli witryna programu SharePoint nie zawiera pliku xml, należy najpierw utworzyć listę produktów firmy Northwind Traders. Następnie, używając widoku danych, można utworzyć widok danych zawartych na liście.

Tworzenie pliku produkty.xml

  1. W menu Plik kliknij polecenie Otwórz witrynę.

  2. W oknie dialogowym Otwieranie witryny przejdź do witryny programu SharePoint i zaznacz ją, a następnie kliknij przycisk Otwórz.

  3. Gdy zostanie wyświetlony monit, w oknie dialogowym Łączenie z wpisz nazwę użytkownika i hasło, a następnie kliknij przycisk OK.

  4. W menu Plik kliknij polecenie Nowy.

  5. W oknie dialogowym Nowy kliknij dwukrotnie pozycję Plik tekstowy.

    W witrynie sieci Web zostanie otworzony nowy plik tekstowy.

  6. Skopiuj poniższe wiersze kodu, zaznaczając je, a następnie naciskając klawisze CTRL+C.

    <?xml version="1.0" encoding="utf-8"?>
    <ProductsRoot>
    <Products>
    <ProductID>1</ProductID>
    <ProductName>Chai</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>10 boxes x 20 bags</QuantityPerUnit>
    <UnitPrice>18</UnitPrice>
    <UnitsInStock>39</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>10</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>2</ProductID>
    <ProductName>Chang</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>24 - 12 oz bottles</QuantityPerUnit>
    <UnitPrice>19</UnitPrice>
    <UnitsInStock>17</UnitsInStock>
    <UnitsOnOrder>40</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>3</ProductID>
    <ProductName>Aniseed Syrup</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>12 - 550 ml bottles</QuantityPerUnit>
    <UnitPrice>10</UnitPrice>
    <UnitsInStock>13</UnitsInStock>
    <UnitsOnOrder>70</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>4</ProductID>
    <ProductName>Chef Anton's Cajun Seasoning</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>48 - 6 oz jars</QuantityPerUnit>
    <UnitPrice>22</UnitPrice>
    <UnitsInStock>53</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>5</ProductID>
    <ProductName>Chef Anton's Gumbo Mix</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>36 boxes</QuantityPerUnit>
    <UnitPrice>21.35</UnitPrice>
    <UnitsInStock>0</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>1</Discontinued>
    </Products>
    </ProductsRoot>
  7. W programie Office SharePoint Designer 2007 umieść punkt wstawiania u góry strony, a następnie naciśnij klawisze CTRL+V, aby wkleić skopiowany kod na stronie.

  8. W menu Plik kliknij polecenie Zapisz jako.

  9. W oknie dialogowym Zapisywanie jako w polu Nazwa pliku wpisz plik produkty.XML.

  10. Na liście Zapisz jako typ kliknij pozycję XML, a następnie kliknij przycisk Zapisz.

Początek strony


Tworzenie widoku danych przez przeciąganie źródła danych na stronę

Po przeciągnięciu źródła danych na stronie, wynikiem jest domyślny widok danych z pięć pierwszych pól w źródle danych znajdujących się w każdym wierszu w tabeli podstawowej. Widok danych jest jednak całkowicie można dostosować. Po wstawieniu widok danych, możesz łatwo dodać kolumny lub usuwanie kolumn z widoku danych najlepiej stosownie do potrzeb. Aby uzyskać więcej informacji zobacz temat Modyfikowanie kolumn w widoku danych.

Widoki danych są oparte na technologii Microsoft ASP.NET 2.0. Aby utworzyć widok danych, należy najpierw utworzyć stronę programu ASP.NET (plik aspx). W tym przykładzie zostanie utworzona nowa strona programu ASP.NET, a następnie zostanie utworzony widok danych przez przeciągnięcie źródła danych na stronę.

  1. W menu Plik kliknij polecenie Nowy.

  2. W oknie dialogowym Nowy kliknij dwukrotnie pozycję ASPX.

    Zostanie otwarta nowa strona z tagiem FORM.

    Tag form programu ASP.NET

  3. Wykonaj jedną z następujących czynności:

    • W okienku Lista folderów zlokalizuj źródło danych — w tym przykładzie plik produkty.xml — a następnie przeciągnij je na stronę.

    • W menu Okienka zadań kliknij polecenie Biblioteka źródeł danych. W okienku zadań Biblioteka źródeł danych zlokalizuj źródło danych — w tym przykładzie plik produkty.xml — a następnie przeciągnij je na stronę.

      Na stronie zostanie wyświetlony widok danych i zostanie otwarte okienko zadań Szczegóły źródła danych.

      Widok danych utworzony przez przeciągnięcie źródła danych zawierającego pięć pierwszych pól
      Pięć pierwszych pól są wyświetlane w układ tabeli podstawowej.

Początek strony


Tworzenie widoku danych przy użyciu okienka zadań Szczegóły źródła danych

Podczas tworzenia widoku danych przy użyciu okienka zadań Szczegóły źródła danych należy najpierw wstawić widok danych na stronę. Następnie w okienku zadań Biblioteka źródeł danych, które umożliwia zarządzanie dostępnymi źródłami danych dla witryny programu SharePoint, zaznacz źródło danych. Po zaznaczeniu źródła danych zostanie otwarte okienko zadań Szczegóły źródła danych. W okienku zadań Szczegóły źródła danych należy wybrać pola, które mają być wyświetlane, a następnie wstawić je do widoku danych.

Widoki danych są oparte na technologii ASP.NET 2.0. Aby utworzyć widok danych, należy najpierw utworzyć stronę programu ASP.NET (plik aspx). W tym przykładzie zostanie utworzona nowa strona programu ASP.NET, a następnie zostanie utworzony widok danych przy użyciu okienka zadań Szczegóły źródła danych.

  1. W menu Plik kliknij polecenie Nowy.

  2. W oknie dialogowym Nowy kliknij dwukrotnie pozycję ASPX.

    Zostanie otwarta nowa strona z tagiem FORM.

    Tag form programu ASP.NET

  3. W menu Widok danych kliknij polecenie Wstaw widok danych.

    Na stronie zostanie wyświetlony pusty widok danych i zostanie otwarte okienko zadań Biblioteka źródeł danych.

    Pusty widok danych

    Po wstawieniu widoku danych można rozpocząć dodawanie danych.

  4. W okienku zadań Biblioteka źródeł danych zlokalizuj źródło danych, kliknij je, a następnie kliknij przycisk Pokaż dane.

    W tym przykładzie w obszarze Pliki XML kliknij pozycję produkty.xml, a następnie kliknij przycisk Pokaż dane. Jeśli nagłówek Pliki XML jest zwinięty, kliknij znak dodawania (+), aby go rozwinąć.

  5. W okienku zadań Szczegóły źródła danych kliknij pola, które chcesz wstawić w widoku danych.

    Porada : Aby zaznaczyć wiele pól, podczas ich klikania przytrzymaj wciśnięty klawisz CTRL.

    W tym przykładzie w folderze ProductsRoot w obszarze Products kliknij pozycję ProductName. Naciśnij i przytrzymaj klawisz CTRL podczas klikania pozycji UnitsInStock, UnitsOnOrder i ReorderLevel.

    Pola zaznaczone w okienku zadań Szczegóły źródła danych

  6. Kliknij przycisk Wstaw wybrane pola jako, a następnie kliknij polecenie Widok wielu elementów, aby wstawić zaznaczone dane do widoku danych.

    Uwaga : Polecenie Widok jednego elementu powoduje wyświetlanie jednego rekordu w widoku danych. Polecenie Widok wielu elementów powoduje wyświetlanie wielu rekordów w polach zawartych w kolumnach z nagłówkami.

    Pola zaznaczone w okienku zadań Szczegóły źródła danych zostaną teraz wyświetlone w tabeli.

    Plik produkty.xml w postaci wyświetlanej w widoku danych

    Po utworzeniu widoku danych można zmodyfikować czcionkę, wyrównać tekst lub zastosować kolory, używając narzędzi WYSIWYG, takich jak pasek narzędzi Formatowanie. Podczas stosowania nowego formatowania do punktu danych w widoku danych program Office SharePoint Designer 2007 stosuje formatowanie do wszystkich danych na tym samym poziomie w kodzie XML, modyfikując arkusz stylów XSLT dołączony do strony. Jeśli na przykład, jak na powyższej ilustracji, zaznaczono tekst Chai, a następnie kliknięto przycisk Pogrubienie na pasku narzędzi Formatowanie, program Office SharePoint Designer 2007 zastosuje to samo formatowanie do całej zawartości wyświetlanej w polu ProductName.

    Formatowanie pogrubione zastosowane do wszystkich danych w polu ProductName

Początek strony


Sugerowane nastepne kroki

Widoki danych są funkcjonalnymi widokami danych dynamicznych, które można w pełni dostosowywać. Teraz, gdy są już znane sposoby tworzenia widoku danych, można poznać inne metody:

  • Filtrowanie danych w widoku danych    Można łatwo filtrowanie danych w widoku danych. Aby uzyskać więcej informacji zobacz Filtrowanie danych w widoku danych.

  • Sortowanie i grupowanie danych w widoku danych     Można szybko sortować lub grupować dane w widoku danych. Aby uzyskać więcej informacji, zobacz Sortowanie i grupowanie danych w widoku danych.

  • Zastosuj formatowanie warunkowe do widoku danych    Możesz zastosować określone formatowanie do widoku danych, gdy dane w widoku danych spełniają określone warunki. Aby uzyskać więcej informacji zobacz Stosowanie formatowanie warunkowe do widoku danych.

  • Tworzenie formuły kolumny w widoku danych     Możesz utworzyć kolumnę obliczeniową, który wyświetla wynik obliczeń innych kolumn w widoku danych, tak jak w przypadku arkusza kalkulacyjnego. Można na przykład pomnożyć cena jednostkowa przez liczbę jednostek w magazynie i wyświetlić łączną liczbę elementów w oddzielnych kolumnach. Aby uzyskać więcej informacji zobacz Tworzenie kolumny formuły w widoku danych.

  • Modyfikowanie kolumn w widoku danych    Można szybko i łatwo Dodawanie, usuwanie lub rozmieszczanie kolumn w widoku danych. Aby uzyskać więcej informacji zobacz Modyfikowanie kolumn w widoku danych.

  • Wyświetlanie danych z wielu źródeł w jednym widoku danych     Można połączyć dwa lub więcej pokrewne źródła danych i wyświetlania danych z tych źródeł w jednym widoku danych. Aby uzyskać więcej informacji zobacz Wyświetlanie danych z wielu źródeł w jednym widoku danych.

  • Wyświetlanie przykładowych danych w widoku danych     Przykładowe dane można łatwo wyświetlać w widoku danych.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×