Tworzenie tabel w bazie danych

Tworzenie tabel w bazie danych

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Po utworzeniu bazy danych programu Access dane są przechowywane w tabelach — tematycznych listach zawierających wiersze i kolumny. Możesz na przykład utworzyć tabelę Kontakty, aby zapisać listę nazwisk, adresów i numerów telefonów, lub tabelę Produkty w celu przechowywania informacji o produktach.

W tym artykule wyjaśniono, jak utworzyć tabelę, jak dodać pola do tabeli i jak ustawić klucz podstawowy tabeli. Wyjaśniono również sposób określania właściwości tabeli i pól.

Ponieważ inne obiekty bazy danych polegają tak na tabele, zawsze należy rozpoczynać projekt bazy danych, tworzenie wszystkich tabel, a następnie utworzenie innych obiektów. Przed utworzeniem tabel starannie należy rozważyć, czy z wymaganiami i oznaczyć wszystkie tabele, które są potrzebne. Wprowadzenie do planowania i projektowania bazy danych zobacz artykuł podstawowe informacje o projekcie bazy danych.

W tym artykule

Omówienie

Tworzenie nowej tabeli

Dodawanie pola do tabeli

Zapisywanie tabeli

Omówienie

Tabela to obiekt bazy danych, w którym są przechowane dane dotyczące określonego tematu, na przykład pracowników lub produktów. Tabela zawiera rekordy i pola.

Każdy rekord zawiera dane dotyczące jednego wystąpienia tematu tabeli, na przykład określonego pracownika. Rekord nazywa się również często wierszem lub wystąpieniem.

Każde pole zawiera dane dotyczące jednego aspektu tematu tabeli, na przykład imienia lub adresu e-mail. Pole nazywa się również często kolumną lub atrybutem.

Rekord składa się z wartości pól, na przykład Contoso Ltd. czy osoba@example.com. Wartość pola nazywa się także faktem.

Tabela Klienci w programie Access, na przykładzie której pokazano układ rekordów i pól

1. Rekord

2. Pole

3. Wartość pola

Baza danych programu Access może zawierać wiele tabel, z których każda zawiera informacje dotyczące innego tematu. Każda tabela może zawierać wiele pól, w których przechowywane są różne typy danych, na przykład tekst, liczby, daty czy hiperlinki.

Właściwości tabel i pól

Tabele i pola mają również właściwości, które można określać, aby kontrolować ich cechy lub zachowanie.

Arkusze właściwości tabeli i pola
Tabela otwarta w widoku projektu.

1. Właściwości tabeli

2. Właściwości pola

W bazie danych programu Access właściwości tabeli są atrybutami wpływającymi na wygląd lub zachowanie tabeli jako całości. Właściwości tabeli określa się w arkuszu właściwości tabeli w widoku projektu. Możesz na przykład ustawić właściwość tabeli Widok domyślny, aby określić, w jaki sposób będzie domyślnie wyświetlana.

Właściwość pola dotyczy określonego pola w tabeli i definiuje jedną z cech tego pola lub jeden aspekt jego zachowania. Określenie niektórych właściwości pól umożliwia widok arkusza danych. Natomiast w widoku projektu można określić dowolne właściwości pól, korzystając z okienka Właściwości pola.

Typy danych

Każde pole ma określony typ danych. Typ danych pola określa rodzaj danych przechowywanych w tym polu, na przykład duże ilości tekstu lub dołączone pliki.

Ustawienie typu danych

Typ danych jest właściwością pola, ale różni się od innych właściwości pól w następujący sposób:

  • Typ danych pola określa się w siatce projektu tabeli, nie w okienku Właściwości pola.

  • Typ danych pola wpływa na dostępność innych właściwości tego pola.

  • Typ danych musi zostać określony podczas tworzenia pola.

    Nowe pole w programie Access można utworzyć, wprowadzając dane w nowej kolumnie w widoku arkusza danych. W przypadku utworzenia pola przez wprowadzenie danych w widoku arkusza danych program Access automatycznie przypisuje do tego pola typ danych na podstawie wprowadzonej wartości. Jeśli z wprowadzonych danych nie wynika żaden inny typ danych, program Access ustawia typ danych Tekst. W razie potrzeby można zmienić to ustawienie za pomocą Wstążki.

Przykłady automatycznego wykrywania typu danych

W poniższej tabeli przedstawiono sposób działania automatycznego wykrywania typu danych w widoku arkusza danych.

Po wprowadzeniu:

W programie Access zostanie utworzone pole o typie danych:

Michał

Tekst

http://www.contoso.com

Możesz użyć dowolnego prawidłowego prefiksu protokołu internetowego. Prawidłowe prefiksy to na przykład http://, https:// i mailto:

Hiperlink

1

Liczba całkowita długa

50 000

Liczba całkowita długa

50 000,99

Liczba, podwójna precyzja

50000,389

Liczba, podwójna precyzja

1967-12

Rozpoznawane są formaty daty i godziny zgodne z ustawieniami lokalnymi użytkownika.

Data/Godzina

31 grudnia 2016

Data/Godzina

10:50:23

Data/Godzina

10:50

Data/Godzina

17:50

Data/Godzina

12,50 zł

Rozpoznawany jest symbol waluty zgodny z ustawieniami lokalnymi użytkownika

Waluta

21,75

Liczba, podwójna precyzja

123,00%

Liczba, podwójna precyzja

3,46E+03

Liczba, podwójna precyzja

Relacje między tabelami

Choć każda tabela zawiera dane dotyczące innego tematu, tabele zawarte w bazie danych programu Access zazwyczaj przechowują dane dotyczące powiązanych ze sobą tematów. Na przykład baza danych może zawierać:

  • tabelę klientów obejmującą klientów firmy oraz ich adresy,

  • tabelę produktów obejmującą sprzedawane produkty, w tym ceny i zdjęcia każdego z nich,

  • tabelę zamówień umożliwiającą śledzenie zamówień klientów.

Ponieważ dane dotyczące różnych tematów są przechowywane w osobnych tabelach, potrzebny jest sposób na powiązanie tych danych tak, aby umożliwić łatwe łączenie podobnych danych z różnych tabel. Aby połączyć dane przechowywane w różnych tabelach, należy utworzyć relacje. Relacja to połączenie logiczne pomiędzy dwoma tabelami, określające, które pola są wspólne dla tych tabel.

Klucze

Pola będące częścią relacji tabel są określane jako klucze. Klucz zwykle składa się z jednego pola, ale może składać się z wielu pól. Istnieją dwa rodzaje kluczy:

  • Klucz podstawowy    Tabela może mieć tylko jeden klucz podstawowy. Klucz podstawowy składa się z pola lub kilku pól jednoznacznie identyfikujących poszczególne rekordy przechowywane w tabeli. Często funkcję klucza podstawowego pełni unikatowy numer, na przykład numer identyfikacyjny, numer seryjny lub kod. Na przykład w tabeli Klienci do każdego klienta może być przypisany unikatowy identyfikator klienta. Pole zawierające identyfikator klienta jest kluczem podstawowym tabeli Klienci. W przypadku gdy klucz podstawowy zawiera więcej niż jedno pole, najczęściej składa się z istniejących wcześniej pól, które łącznie tworzą unikatowe wartości. Na przykład kluczem podstawowym tabeli z danymi osób może być kombinacja nazwiska, imienia i daty urodzenia.

  • Klucz obcy    Tabela może mieć również klucz obcy lub kilka takich kluczy. Klucz obcy zawiera wartości odpowiadające wartościom w kluczu podstawowym innej tabeli. Przykładem może być tabela Zamówienia, w której dla każdego zamówienia istnieje numer identyfikacyjny klienta odpowiadający rekordowi w tabeli Klienci. Pole identyfikatora klienta jest kluczem obcym tabeli Zamówienia.

Podstawą relacji między tabelami jest zgodność wartości w polach kluczy. Takie relacje służą do łączenia danych z powiązanych tabel. Załóżmy na przykład, że utworzono tabelę Klienci i tabelę Zamówienia. W tabeli Klienci poszczególne rekordy są identyfikowane przy użyciu pola klucza podstawowego o nazwie Identyfikator.

Aby skojarzyć każde zamówienie z klientem, do tabeli Zamówienia należy dodać pole klucza obcego odpowiadające polu Identyfikator tabeli Klienci, a następnie utworzyć relację między tymi dwoma kluczami. W przypadku dodawania rekordu do tabeli Zamówienia używana wartość identyfikatora klienta będzie pochodzić z tabeli Klienci. Gdy będzie konieczne wyświetlenie informacji o kliencie związanym z określonym zamówieniem, ta relacja umożliwi zidentyfikowanie, które dane z tabeli Klienci odpowiadają poszczególnym rekordom w tabeli Zamówienia.

Relacja między tabelami programu Access widoczna w oknie Relacje
Relacja między tabelami widoczna w oknie Relacje.

1. Klucz podstawowy oznaczony ikoną klucza obok nazwy pola.

2. Klucz obcy — należy zwrócić uwagę na brak ikony klucza.

Zalety korzystania z relacji

Przechowywanie danych w osobnych, powiązanych tabelach ma następujące zalety:

  • Spójność    W związku z tym, że każdy element danych jest rejestrowany tylko raz, w jednej tabeli, zmniejsza się prawdopodobieństwo wystąpienia niejednoznaczności lub niespójności. Na przykład nazwa klienta jest przechowywana tylko raz, w tabeli dotyczącej klientów, a nie wielokrotnie (i potencjalnie niespójnie) w tabeli zawierającej dane dotyczące zamówień.

  • Wydajność    Rejestrowanie danych tylko w jednym miejscu zmniejsza użycie miejsca na dysku. Ponadto mniejsze tabele pozwalają udostępniać dane szybciej niż duże. Gdyby oddzielne tabele nie były stosowane w przypadku osobnych tematów, umożliwiłoby to wprowadzanie wartości null (brak danych) i nadmiarowych danych, co z kolei spowodowałoby utratę miejsca i pogorszenie wydajności.

  • Zrozumiałość    Projekt bazy danych jest łatwiejszy do zrozumienia, jeśli dane dla poszczególnych tematów są właściwie rozmieszczone w tabelach.

Porada : Podczas projektowania tabel należy brać pod uwagę ich relacje. Jeśli tabela zawierająca odpowiedni klucz podstawowy już istnieje, możesz utworzyć pole klucza obcego za pomocą Kreatora odnośników. Kreator odnośników utworzy relację.

Początek strony

Tworzenie nowej tabeli

Prosta baza danych, zawierająca na przykład listę kontaktów, może zawierać tylko jedną tabelę. Jednak wiele baz danych zawiera większą liczbę tabel. Podczas tworzenia nowej bazy danych na komputerze jest tworzony nowy plik, działający jako kontener dla wszystkich obiektów w bazie danych, w tym także dla tabel.

Możesz utworzyć tabelę, tworząc nową bazę danych, wstawiając tabelę do istniejącej bazy danych, a także importując tabelę albo tworząc link do tabeli z innego źródła danych — skoroszytu programu Microsoft Excel, dokumentu programu Microsoft Word, pliku tekstowego, czy też innej bazy danych. Do utworzonej nowej, pustej bazy danych jest automatycznie wstawiana nowa, pusta tabela. Następnie możesz wprowadzić dane do tabeli, aby rozpocząć definiowanie pól.

Co chcesz zrobić?

Tworzenie nowej tabeli w nowej bazie danych

Tworzenie nowej tabeli w istniejącej bazie danych

Importowanie lub łączenie w celu utworzenia tabeli

Tworzenie tabeli przy użyciu witryny programu SharePoint

Ustawianie klucza podstawowego tabeli

Ustawianie właściwości tabeli

Tworzenie nowej tabeli w nowej bazie danych

  1. Kliknij pozycję Plik > Nowy. Jeśli korzystasz z programu Access 2007, kliknij przycisk pakietu Microsoft Office > Nowy.

  2. W polu Nazwa pliku wpisz nazwę pliku nowej bazy danych.

  3. Aby przejść do innej lokalizacji w celu zapisania bazy danych, kliknij ikonę folderu.

  4. Kliknij przycisk Utwórz.

    Zostanie otwarta nowa baza danych, w której zostanie utworzona nowa tabela o nazwie Tabela1, wyświetlona w widoku arkusza danych.

Tworzenie tabeli w istniejącej bazie danych

  1. Kliknij pozycję Plik > Otwórz. Jeśli korzystasz z programu Access 2007, kliknij przycisk pakietu Microsoft Office > Otwórz.

  2. W oknie dialogowym Otwieranie zaznacz bazę danych, którą chcesz otworzyć, a następnie kliknij przycisk Otwórz.

  3. Na karcie Tworzenie w grupie Tabele kliknij pozycję Tabela.

    Nowa tabela zostanie wstawiona w bazie danych i otwarta w widoku arkusza danych.

Importowanie lub łączenie w celu utworzenia tabeli

Tabelę można utworzyć przez zaimportowanie danych przechowywanych w innym miejscu lub utworzenie do nich linku. Dotyczy to danych znajdujących się między innymi w arkuszu programu Excel, na liście programu SharePoint, w pliku XML, w innej bazie danych programu Access lub w folderze programu Microsoft Outlook.

Podczas importowania danych jest tworzona ich kopia w nowej tabeli w bieżącej bazie danych. Kolejne zmiany danych źródłowych nie będą miały wpływu na zaimportowane dane, a zmiany dotyczące zaimportowanych danych nie będą miały wpływu na dane źródłowe. Po nawiązaniu połączenia ze źródłem danych i zaimportowaniu danych można z nich korzystać, nie mając połączenia ze źródłem. Projekt zaimportowanej tabeli można zmienić.

Utworzenie łącza z danymi powoduje, że w bieżącej bazie danych jest tworzona tabela połączona, reprezentująca aktualizowane na bieżąco łącze z informacjami przechowywanymi w innym miejscu. Zmiana danych w tabeli połączonej powoduje ich zmianę w źródle. Każda zmiana danych w źródle jest widoczna w tabeli połączonej. W przypadku korzystania z tabeli połączonej użytkownik musi mieć możliwość nawiązania połączenia ze źródłem danych. Projektu tabeli połączonej nie można zmienić.

Uwaga : Przy użyciu tabeli połączonej nie można edytować danych w arkuszu programu Excel. Można natomiast zaimportować dane źródłowe do bazy danych programu Access, a następnie utworzyć link do nich z poziomu programu Excel.

Tworzenie nowej tabeli przez zaimportowanie lub połączenie danych zewnętrznych

  1. Kliknij pozycję Plik > Otwórz. Jeśli korzystasz z programu Access 2007, kliknij przycisk pakietu Microsoft Office > Otwórz.

  2. W oknie dialogowym Otwieranie wybierz i otwórz bazę danych, w której chcesz utworzyć nową tabelę.

  3. Na karcie Dane zewnętrzne w grupie Importowanie i łączenie kliknij jedno z dostępnych źródeł danych. Jeśli korzystasz z programu Access 2007, źródła danych są w grupie Importowanie.

    Obraz wstążki programu Access

  4. Postępuj zgodnie z instrukcjami w oknach dialogowych wyświetlanych na poszczególnych etapach.

    Program Access utworzy nową tabelę i wyświetli ją w okienku nawigacji.

Możesz również zaimportować listę programu SharePoint lub utworzyć do niej link, korzystając z polecenia na karcie Tworzenie.

Początek strony

Tworzenie tabeli przy użyciu witryny programu SharePoint

W bazie danych można utworzyć tabelę w celu zaimportowania danych z listy programu SharePoint lub utworzenia linku do takiej listy. Można również utworzyć nową listę programu SharePoint, korzystając ze wstępnie zdefiniowanego szablonu. W programie Access są dostępne takie wstępnie zdefiniowane szablony, jak Kontakty, Zadania, Problemy i Zdarzenia.

  1. Kliknij pozycję Plik > Otwórz. Jeśli korzystasz z programu Access 2007, kliknij przycisk pakietu Microsoft Office > Otwórz.

  2. W oknie dialogowym Otwieranie zaznacz bazę danych, w której chcesz utworzyć nową tabelę, a następnie kliknij przycisk Otwórz.

  3. Na karcie Tworzenie w grupie Tabele kliknij pozycję Listy SharePoint.

  4. Wykonaj jedną z następujących czynności:

    • Tworzenie listy programu SharePoint na podstawie szablonu

      1. Kliknij pozycję Kontakty, Zadania, Problemy lub Wydarzenia.

      2. W oknie dialogowym Tworzenie nowej listy wpisz adres URL witryny programu SharePoint, w której chcesz utworzyć listę.

      3. Wprowadź nazwę nowej listy oraz jej opis w polach Określ nazwę nowej listy i Opis.

      4. Aby po utworzeniu połączonej tabeli otworzyć ją, zaznacz pole wyboru Otwórz listę po zakończeniu (domyślnie zaznaczone).

    • Tworzenie nowej listy niestandardowej

      1. Kliknij pozycję Niestandardowa.

      2. W oknie dialogowym Tworzenie nowej listy wpisz adres URL witryny programu SharePoint, w której chcesz utworzyć listę.

      3. Wprowadź nazwę nowej listy oraz jej opis w polach Określ nazwę nowej listy i Opis.

      4. Aby po utworzeniu połączonej tabeli otworzyć ją, zaznacz pole wyboru Otwórz listę po zakończeniu (domyślnie zaznaczone).

    • Importowanie danych z istniejącej listy

      1. Kliknij pozycję Istniejąca lista programu SharePoint.

      2. W oknie dialogowym Pobieranie danych zewnętrznych wpisz adres URL witryny programu SharePoint zawierającej dane, które chcesz zaimportować.

      3. Kliknij pozycję Importuj dane źródłowe do nowej tabeli w bieżącej bazie danych, a następnie kliknij przycisk Dalej.

      4. Zaznacz pole wyboru obok każdej listy programu SharePoint, którą chcesz zaimportować.

    • Łączenie z istniejącą listą

      1. Kliknij pozycję Istniejąca lista programu SharePoint.

      2. W oknie dialogowym Pobieranie danych zewnętrznych — witryna programu SharePoint wpisz adres URL witryny programu SharePoint zawierającej listę, do której chcesz utworzyć łącze.

      3. Kliknij pozycję Połącz ze źródłem danych, tworząc tabelę połączoną, a następnie kliknij przycisk Dalej.

      4. Zaznacz pole wyboru obok każdej listy programu SharePoint, do której chcesz utworzyć łącze.

Początek strony

Ustawianie klucza podstawowego tabeli

O ile nie ma konkretnych przesłanek, aby tego nie robić, należy określić klucz podstawowy tabeli. W programie Access klucz podstawowy jest automatycznie indeksowany, co może poprawić wydajność bazy danych. Program Access sprawdza również, czy każdy rekord zawiera wartość w polu klucza podstawowego i czy ta wartość jest unikatowa. Wartości te muszą być unikatowe, ponieważ w przeciwnym razie nie będzie możliwe prawidłowe rozróżnienie poszczególnych wierszy.

Podczas tworzenia nowej tabeli w widoku arkusza danych w programie Access jest automatycznie tworzony klucz podstawowy z przypisaną nazwą pola Identyfikator i typem danych Autonumerowanie.

W widoku projektu możesz zmienić lub usunąć klucz podstawowy, a także ustawić klucz podstawowy tabeli, która jeszcze go nie ma.

Określanie pól używanych jako kluczy podstawowych

W niektórych przypadkach dane, których chcesz użyć jako klucza podstawowego, są już dostępne. Na przykład możesz mieć już numery identyfikacyjne swoich pracowników. Tworząc tabelę do przechowywania informacji o pracownikach, możesz wybrać istniejące identyfikatory użytkowników jako klucz podstawowy tabeli. Być może jednak identyfikator pracownika jest unikatowy wyłącznie w kombinacji z identyfikatorem działu, w związku z czym klucz podstawowy musi zawierać oba te pola. Potencjalny klucz podstawowy powinien spełniać następujące warunki:

  • Każdy rekord zawiera unikatową wartość w tym polu lub w tej kombinacji pól.

  • Dane pole lub dana kombinacja pól zawsze zawiera wartości — nie występują pola puste ani wartości null.

  • Wartości nie zmieniają się.

Jeśli nie zostały jeszcze wprowadzone dane odpowiednie do użycia jako klucz podstawowy, możesz utworzyć w tym celu nowe pole. Tworząc nowe pole, które będzie używane jako klucz podstawowy, ustaw typ danych Autonumerowanie, aby mieć pewność, że pole to będzie spełniało trzy warunki wymienione powyżej.

Ustawianie lub zmienianie klucza podstawowego

  1. Zaznacz tabelę, w której chcesz ustawić lub zmienić klucz podstawowy.

  2. Na karcie Narzędzia główne w grupie Widoki kliknij pozycję Widok, a następnie kliknij pozycję Widok projektu.

  3. W siatce projektu tabeli zaznacz pole lub pola, których chcesz użyć jako klucza podstawowego.

    Aby zaznaczyć jedno pole, kliknij selektor wiersza odpowiedniego pola.

    Aby zaznaczyć więcej niż jedno pole, naciśnij i przytrzymaj klawisz CTRL, a następnie kliknij selektory wiersza poszczególnych pól.

  4. Na karcie Projektowanie w grupie Narzędzia kliknij przycisk Klucz podstawowy.

    Grupa Narzędzia na karcie Projektowanie

    Po lewej stronie pól określanych jako klucz podstawowy jest wyświetlany znacznik klucza.

Usuwanie klucza podstawowego

  1. Zaznacz tabelę, której klucz podstawowy chcesz usunąć.

  2. Na karcie Narzędzia główne w grupie Widoki kliknij pozycję Widok, a następnie kliknij pozycję Widok projektu.

  3. Kliknij selektor wiersza bieżącego klucza podstawowego. Jeśli klucz podstawowy obejmuje wiele pól, przytrzymaj naciśnięty klawisz CTRL, a następnie kliknij selektory wierszy poszczególnych pól.

  4. Na karcie Projektowanie w grupie Narzędzia kliknij przycisk Klucz podstawowy.

    Grupa Narzędzia na karcie Projektowanie

    Wskaźnik klucza zostanie usunięty z pól, które zostały wcześniej określone jako klucz podstawowy.

Uwaga : Podczas zapisywania nowej tabeli bez uprzedniego ustawienia klucza podstawowego w programie Access zostanie wyświetlony monit o utworzenie nowego pola klucza podstawowego. Jeśli klikniesz przycisk Tak, w programie Access zostanie utworzone pole Identyfikator z typem danych Autonumerowanie w celu zapewnienia unikatowej wartości w każdym rekordzie. Jeśli tabela zawiera już pole z typem danych Autonumerowanie, to pole zostanie użyte jako klucz podstawowy. Jeśli klikniesz przycisk Nie, w programie Access nie zostanie utworzone nowe pole i klucz podstawowy nie zostanie ustawiony.

Początek strony

Ustawianie właściwości tabeli

Oprócz właściwości pól możesz ustawić także właściwości stosowane do całej tabeli lub do całych rekordów.

  1. Zaznacz tabelę, której właściwości chcesz ustawić.

  2. Na karcie Narzędzia główne w grupie Widoki kliknij pozycję Widok, a następnie kliknij pozycję Widok projektu.

  3. Na karcie Projektowanie w grupie Pokazywanie/ukrywanie kliknij przycisk Arkusz właściwości.

    Grupa Pokazywanie/ukrywanie na karcie Projektowanie w programie Access

    Zostanie wyświetlony arkusz właściwości tabeli.

  4. W arkuszu właściwości kliknij kartę Ogólne.

  5. Kliknij pole po lewej stronie właściwości, którą chcesz ustawić, a następnie wprowadź ustawienie tej właściwości.

    Dostępne właściwości tabeli

    Właściwość tabeli

    Cel

    Wyświetl widoki w witrynie programu SharePoint

    Określenie, czy widoki utworzone na podstawie tabeli mogą być wyświetlane w witrynie programu SharePoint.

    Uwaga : Skutki użycia tego ustawienia zależą od ustawienia właściwości bazy danych Wyświetl wszystkie widoki w witrynie programu SharePoint.

    Rozwinięty podarkusz danych

    Rozwijanie wszystkich podarkuszy danych po otwarciu tabeli.

    Wysokość podarkusza danych

    Wykonaj jedną z następujących czynności:

    • Jeśli chcesz, aby okno podarkusza danych było rozwijane w celu wyświetlenia wszystkich wierszy, pozostaw dla tej właściwości ustawienie 0 cm.

    • Jeśli chcesz sterować wysokością podarkusza danych, wprowadź żądaną wysokość w centymetrach.

    Orientacja

    Ustawienie orientacji widoku zgodnie ze sposobem czytania używanego języka — od lewej do prawej lub od prawej do lewej.

    Opis

    Podanie opisu tabeli. Ten opis będzie wyświetlany w etykietkach narzędzi danej tabeli.

    Widok domyślny

    Ustawienie domyślnego widoku używanego po otwarciu tabeli (widok Arkusz danych, Tabela przestawna lub Wykres przestawny). Zwróć uwagę, że opcje tabeli przestawnej i wykresu przestawnego zostały usunięte z programu Access począwszy od wersji 2013 tego programu.

    Reguła poprawności

    Wprowadzenie wyrażenia, które musi być spełnione przy dodawaniu lub zmienianiu rekordu.

    Tekst reguły sprawdzania poprawności

    Wprowadzenie tekstu komunikatu wyświetlanego w sytuacji, gdy rekord jest niezgodny z wyrażeniem we właściwości Reguła poprawności.

    Filtr

    Zdefiniowanie kryteriów służących do wyświetlania tylko dopasowanych wierszy w widoku arkusza danych.

    Uporządkuj według

    Określenie domyślnego porządku sortowania wierszy w widoku arkusza danych przez wybranie co najmniej jednego pola.

    Nazwa podarkusza danych

    Określenie, czy podarkusz danych powinien być wyświetlany w widoku arkusza danych, a jeśli tak, określenie, z której tabeli lub którego zapytania mają pochodzić wiersze podarkusza.

    Podrzędne pola łączące

    Określenie listy pól w tabeli lub zapytaniu, które są używane w podarkuszu danych i są zgodne z właściwością Nadrzędne pola łączące określoną dla danej tabeli.

    Nadrzędne pola łączące

    Określenie listy pól w tabeli, które są zgodne z właściwością Podrzędne pola łączące określoną dla danej tabeli.

    Filtruj przy ładowaniu

    Automatyczne stosowanie kryteriów filtrowania określonych we właściwości Filtr po otwarciu tabeli w widoku arkusza danych (przez ustawienie tej właściwości na wartość Tak).

    Porządkuj przy ładowaniu

    Automatyczne stosowanie kryteriów sortowania określonych we właściwości Uporządkuj według po otwarciu tabeli w widoku arkusza danych (przez ustawienie tej właściwości na wartość Tak).

    Porada : Aby uzyskać więcej miejsca na wprowadzanie lub edytowanie ustawienia w polu właściwości, należy nacisnąć klawisze SHIFT+F2 w celu wyświetlenia okna Powiększenie. Jeśli we właściwości Reguła poprawności jest ustawiane wyrażenie i jest potrzebna pomoc przy jego konstruowaniu, należy kliknąć przycisk Przycisk Konstruktor obok pola właściwości RegułaPoprawności w celu wyświetlenia Konstruktora wyrażeń.

  6. Aby zapisać zmiany, naciśnij klawisze CTRL+S.

Początek sekcji

Początek strony

Wstawianie, dodawanie lub tworzenie nowego pola w tabeli

Każdy element danych, który ma być śledzony, jest przechowywany w polu. Na przykład w tabeli kontaktów można utworzyć pola Nazwisko, Imię, Numer telefonu i Adres. W tabeli produktów można utworzyć pola Nazwa produktu, Identyfikator produktu i Cena.

Przed utworzeniem pól warto rozdzielić dane na najmniejsze użyteczne elementy. O wiele łatwiej jest później połączyć te dane, niż je rozdzielać. Na przykład zamiast pola Imię i nazwisko warto rozważyć utworzenie osobnych pól dla nazwiska i dla imienia. Dzięki temu będzie można łatwo przeprowadzać wyszukiwanie lub sortowanie według pola Imię, według pola Nazwisko lub według obu tych pól jednocześnie. Jeśli w przypadku określonego elementu danych są planowane operacje raportowania, sortowania, wyszukiwania lub obliczania, należy umieścić ten element w osobnym polu.

Po utworzeniu pola można również ustawić właściwości pola w celu sterowania jego wyglądem i zachowaniem.

Co chcesz zrobić?

Dodawanie pola przez wprowadzenie danych

Po utworzeniu nowej tabeli lub otwarciu istniejącej tabeli w widoku arkusza danych można dodać pole do tabeli, wprowadzając dane w kolumnie Dodaj nowe pole w arkuszu danych.

Arkusz danych w programie Access z kolumną Dodaj nowe pole

1. Wprowadź dane w kolumnie Dodaj nowe pole.

  1. Utwórz lub otwórz tabelę w widoku arkusza danych, klikając prawym przyciskiem myszy odpowiednią tabelę w okienku nawigacji, a następnie klikając w menu skrótów pozycję Widok arkusza danych.

  2. W kolumnie Dodaj nowe pole wprowadź nazwę pola, które chcesz utworzyć.

    Użyj nazwy opisowej, aby można było łatwiej zidentyfikować to pole.

  3. Wprowadź dane w nowym polu.

Dodawanie pola za pomocą szablonu pola

Czasem łatwiej jest wybrać pole odpowiednie do potrzeb z listy wstępnie zdefiniowanych pól, niż tworzyć je ręcznie. Aby wybrać pole z listy szablonów pól, w programach Access 2010, 2013 lub 2016 można użyć listy Więcej pól, a w programie Access 2007 okienka zadań Szablony pól. Szablon pola to wstępnie zdefiniowany zbiór cech i właściwości opisujących pole. Definicja szablonu pola obejmuje nazwę pola, typ danych, ustawienie właściwości Format i inne właściwości pola.

Jeśli korzystasz z programu Access 2010, 2013 lub 2016, wykonaj poniższe czynności.

  1. Na karcie Narzędzia główne w grupie Widoki kliknij pozycję Widok, a następnie kliknij pozycję Widok arkusza danych.

  2. Na karcie Pola w grupie Dodawanie i usuwanie kliknij pozycję Więcej pól.

    Zrzut ekranu grupy Dodawanie i usuwanie na karcie wstążki Pola.

  3. Z listy Więcej pól wybierz pole, aby wstawić nową kolumnę. Program Access umieści pole z prawej strony kolumny, w której jest obecnie umieszczony kursor. Jeśli wybierzesz jedną z opcji pola pod nagłówkiem Szybki start, na przykład Adres, program Access utworzy w tabeli kilka pól zawierających różne składniki adresu.

Jeśli korzystasz z programu Access 2007, wykonaj poniższe czynności.

  1. Na karcie Narzędzia główne w grupie Widoki kliknij pozycję Widok, a następnie kliknij pozycję Widok arkusza danych.

  2. Na karcie Arkusz danych w grupie Pola i kolumny kliknij pozycję Nowe pole.

    Obraz wstążki programu Access

  3. Zaznacz co najmniej jedno pole w okienku Szablony pól, a następnie przeciągnij je do miejsca w tabeli, w którym chcesz wstawić nową kolumnę.

Ustawianie właściwości pola

Po utworzeniu pola można ustawić właściwości pola w celu sterowania jego wyglądem i zachowaniem.

Ustawiając właściwości pola, można na przykład:

  • sterować wyglądem danych w polu,

  • zapobiec wprowadzaniu niepoprawnych danych w polu,

  • określić wartości domyślne pola,

  • przyspieszyć wyszukiwanie i sortowanie w polu.

Niektóre z dostępnych właściwości można ustawić podczas pracy w widoku arkusza danych. Aby jednak uzyskać dostęp do pełnej listy właściwości pola i móc je ustawiać, należy korzystać z widoku projektu.

Ustawianie właściwości pola w widoku arkusza danych

Podczas pracy w widoku arkusza danych można zmienić nazwę pola, typ danych pola, właściwość Format i kilka innych właściwości pola.

Otwieranie tabeli w widoku arkusza danych

  1. W okienku nawigacji kliknij prawym przyciskiem myszy tabelę, którą chcesz otworzyć.

  2. W menu skrótów kliknij polecenie Widok arkusza danych.

Zmienianie nazwy pola

Po dodaniu pola przez wprowadzenie danych w widoku arkusza danych program Access automatycznie przypisuje temu polu nazwę ogólną. Program Access przypisuje nazwę Pole1 pierwszemu nowemu polu, nazwę Pole2 — drugiemu nowemu polu i tak dalej. Domyślnie nazwa pola jest używana jako etykieta podczas wyświetlania pola, między innymi w nagłówku kolumny w arkuszu danych. Zmiana nazw pól na bardziej opisowe ułatwia korzystanie z nich podczas wyświetlania lub edytowania rekordów.

  1. Kliknij prawym przyciskiem myszy nagłówek pola, którego nazwę chcesz zmienić (na przykład Pole1).

  2. W menu skrótów kliknij polecenie Zmień nazwę pola. Jeśli korzystasz z programu Access 2007, w menu skrótów kliknij polecenie Zmień nazwę kolumny.

  3. Wprowadź nową nazwę w nagłówku pola.

    Nazwy pól mogą zawierać maksymalnie 64 znaki (litery oraz liczby) z uwzględnieniem spacji.

Zmienianie typu danych pola

Po utworzeniu pola przez wprowadzenie danych w widoku arkusza danych program Access sprawdza te dane w celu określenia odpowiedniego typu danych dla pola. Jeśli na przykład zostanie wprowadzony ciąg 2017-01-01, program Access rozpozna te dane jako datę i ustawi dla pola typ danych Data/Godzina. Jeśli program Access nie może jednoznacznie określić typu danych, domyślnie ustawiany jest typ danych Tekst (Krótki tekst w przypadku programu Access 2016).

Typ danych pola określa, jakie inne właściwości pola można ustawiać. Na przykład właściwość Tylko dołącz można ustawić jedynie dla pól o typie danych Hiperłącze lub Nota (Długi tekst w przypadku programu Access 2016).

Czasami jest konieczna ręczna zmiana typu danych pola. Załóżmy, że numery pokoi przypominają daty, na przykład 10-2017. Jeśli w nowym polu w widoku arkusza danych zostanie wprowadzony ciąg 10-2017, funkcja automatycznego wykrywania typu danych wybierze dla tego pola typ danych Data/Godzina. Ponieważ numery pokoi są etykietami, a nie datami, powinny mieć typ danych Tekst. Poniższa procedura umożliwia zmianę typu danych pola.

  1. Na Wstążce kliknij kartę Pola. Jeśli korzystasz z programu Access 2007, kliknij kartę Arkusz danych.

  2. Na liście Typ danych w grupie Formatowanie wybierz odpowiedni typ danych. Jeśli korzystasz z programu Access 2007, na liście Typ danych w grupie Typ i formatowanie danych wybierz odpowiedni typ danych.

    Jakie typy danych są dostępne?

    Zobacz Typy danych w bazach danych programu Access dla komputerów stacjonarnych, aby uzyskać pełną listę dostępnych typów danych w bazach danych programu Access.

    Uwaga : Maksymalny rozmiar pliku bazy danych programu Access to 2 gigabajty.

    Porady dotyczące typów danych

    • W celu optymalizacji wydajności należy podczas tworzenia pola typu Tekst lub Liczba korzystać z najbardziej odpowiedniego ustawienia właściwości Rozmiar pola. Na przykład jeśli chcesz przechowywać kody pocztowe o przewidywalnej długości, wskaż tę długość jako rozmiar pola. Rozmiar pola możesz określić, wprowadzając wartość w polu właściwości Rozmiar pola. Aby uzyskać więcej informacji, zobacz sekcję Ustawianie innych właściwości pola.

    • W przypadku numerów telefonów, numerów części i innych wartości liczbowych, które nie będą używane w obliczeniach matematycznych, należy wybrać typ danych Tekst, a nie Liczba. Przechowywanie wartości liczbowej w formacie tekstowym ułatwia jej logiczne sortowanie i filtrowanie.

Zmienianie formatu pola

Program Access nie tylko określa typ danych nowego pola, ale może również ustawić właściwość Format pola, zależnie od wprowadzonej wartości. Jeśli na przykład zostanie wprowadzony ciąg 10:50am, program Access ustawi typ danych na wartość Data/Godzina, a właściwość Format na wartość Godzina średnia. Aby ręcznie zmienić właściwość Format pola, należy wykonać następujące czynności:

  1. Na Wstążce kliknij kartę Pola. Jeśli korzystasz z programu Access 2007, kliknij kartę Arkusz danych.

  2. Na liście Format w grupie Formatowanie wprowadź odpowiedni format. Jeśli korzystasz z programu Access 2007, na liście Format w grupie Typ i formatowanie danych wprowadź odpowiedni format.

    Uwaga : W przypadku niektórych pól (na przykład pól typu Tekst) lista Format może być niedostępna. Zależy to od typu danych pola.

Ustawianie innych właściwości pola

  1. W widoku arkusza danych kliknij pole, dla którego chcesz ustawić właściwość.

  2. Jeśli korzystasz z programu Access 2010, 2013 lub 2016, na karcie Pola w grupie Właściwości, Formatowanie lub Sprawdzanie poprawności pola wybierz odpowiednie właściwości.

  3. Jeśli korzystasz z programu Access 2007, na karcie Arkusz danych w grupie Typ i formatowanie danych wybierz odpowiednie właściwości.

Ustawianie właściwości pola w widoku projektu

Możesz ustawić dowolną właściwość pola podczas pracy z tabelą w widoku projektu. W widoku projektu możesz ustawić typ danych pola w siatce projektu tabeli, a pozostałe właściwości w okienku Właściwości pola.

Otwieranie tabeli w widoku projektu

  1. W okienku nawigacji kliknij tabelę prawym przyciskiem myszy.

  2. W menu skrótów kliknij polecenie Widok projektu.

Zmienianie typu danych pola

  1. W siatce projektu tabeli znajdź pole, dla którego chcesz ustawić typ danych.

  2. W kolumnie Typ danych wybierz z listy odpowiedni typ danych.

    Jakie typy danych są dostępne?

    Zobacz Typy danych w bazach danych programu Access dla komputerów stacjonarnych, aby uzyskać pełną listę dostępnych typów danych w bazach danych programu Access.

    Uwaga : Maksymalny rozmiar pliku bazy danych programu Access to 2 gigabajty.

    Porady dotyczące typów danych

    • W przypadku numerów telefonów, numerów części i innych wartości liczbowych, które nie będą używane w obliczeniach matematycznych, należy wybrać typ danych Tekst, a nie Liczba. Przechowywanie wartości liczbowej w formacie tekstowym ułatwia jej logiczne sortowanie i filtrowanie, ale uniemożliwia jej łatwe używanie w obliczeniach.

    • W przypadku typów danych Tekst i Liczba możesz dokładniej określić rozmiar pola lub typ danych, wprowadzając wartość w polu właściwości Rozmiar pola.

Ustawianie innych właściwości pola

  1. W siatce projektu tabeli zaznacz pole, którego właściwości chcesz ustawić. Właściwości tego pola zostaną wyświetlone w programie Access w okienku Właściwości pola.

    Typ danych pola określa właściwości, które można ustawić.

  2. W okienku Właściwości pola wprowadź odpowiednie ustawienia poszczególnych właściwości lub naciśnij klawisz F6 i użyj klawiszy strzałek, aby wybrać właściwość.

    Jakie właściwości pól są dostępne?

    Zobacz Wprowadzenie do typów danych i właściwości pól, aby uzyskać pełną listę właściwości pola dostępnych dla każdego typu danych w bazach danych programu Access.

    Uwaga : Nie wszystkie właściwości są dostępne dla każdego pola. Typ danych pola wpływa na dostępność jego właściwości.

  3. Aby uzyskać większą ilość miejsca do wprowadzania lub edytowania ustawień właściwości w polu właściwości, naciśnij klawisze SHIFT+F2 w celu wyświetlenia pola Powiększenie.

    Porada : Jeśli wprowadzasz maskę wprowadzania lub wyrażenie reguły sprawdzania poprawności i potrzebujesz pomocy przy ich tworzeniu, kliknij przycisk Przycisk Konstruktor obok pola właściwości, aby wyświetlić odpowiedniego konstruktora.

  4. Aby zapisać zmiany, naciśnij klawisze CTRL+S.

Zapisywanie tabeli

Po utworzeniu lub zmodyfikowaniu tabeli należy zapisać jej projekt. Podczas zapisywania tabeli po raz pierwszy nadaj jej nazwę opisującą zawarte w niej dane. Możesz użyć maksymalnie 64 znaków alfanumerycznych ze spacjami. Możesz na przykład nazwać tabelę Klienci, Katalog części lub Produkty.

Porada : Warto wybrać konwencję nazewnictwa obiektów w bazie danych i konsekwentnie ją stosować.

  1. Jeśli korzystasz z programu Access 2010, 2013 lub 2016, kliknij pozycję Plik > Zapisz lub naciśnij klawisze CTRL+S.

  2. Jeśli korzystasz z programu Access 2007, kliknij przycisk pakietu Microsoft Office, a następnie kliknij polecenie Zapisz lub naciśnij klawisze CTRL+S.

  3. Jeśli zapisujesz tabelę po raz pierwszy, wpisz nazwę tabeli, a następnie kliknij przycisk OK.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×