Tworzenie spisu treści w programie Word

Aby utworzyć łatwy w aktualizowaniu spis treści, zastosuj style nagłówków do tekstu, który chcesz uwzględnić w tym spisie. Następnie program Word utworzy automatyczny spis treści na podstawie ustawionych nagłówków.

Stosowanie stylów nagłówków

Zaznacz tekst, który chcesz uwzględnić w spisie treści, a następnie na karcie Narzędzia główne kliknij odpowiedni styl nagłówka, na przykład Nagłówek 1.

Kliknięcie stylu nagłówka na Wstążce

Powtórz tę czynność dla całego tekstu, który chcesz uwzględnić w spisie treści.

Tworzenie spisu treści

Program Word używa nagłówków dokumentu do utworzenia automatycznego spisu treści, który można aktualizować po zmianie kolejności, poziomu lub tekstu nagłówka.

  1. Kliknij miejsce, w którym chcesz wstawić spis treści — zwykle na początku dokumentu.

  2. Kliknij pozycję Odwołania > Spis treści, a następnie wybierz z listy styl Automatyczny spis treści.

    Uwaga : Jeśli użyjesz stylu Ręczny spis treści, program Word nie użyje nagłówków do utworzenia spisu treści i automatyczne aktualizowanie spisu nie będzie możliwe. Zamiast tego program Word zastosuje tekst zastępczy, tworzący strukturę spisu treści, w którym możesz ręcznie wprowadzić poszczególne wpisy.

    Kliknięcie pozycji Spis treści na karcie Odwołania, a następnie wybranie stylu Automatyczny spis treści z galerii

Jeśli chcesz, możesz sformatować lub dostosować spis treści. Możesz na przykład zmienić liczbę poziomów nagłówków i czcionkę oraz wyświetlić lub ukryć linie kropkowane między wpisami a numerami stron.

Można też ręcznie utworzyć spis treści. Ręcznie tworzony spis treści sprawdza się czasem w przypadku krótkich dokumentów, które nie ulegną zmianie, lub w przypadku dokumentów z nagłówkami, do których nie zastosowano wbudowanych stylów nagłówków. Ręcznie utworzony spis treści wymaga więcej obsługi przy aktualizacji niż automatyczny spis treści, ponieważ musi być aktualizowany ręcznie po każdym dodaniu, zmianie lub usunięciu nagłówków albo stron w dokumencie.

Automatyczne tworzenie spisu treści

Dodawanie spisu treści

  1. W dokumencie zastosuj style nagłówków (Nagłówek 1, Nagłówek 2 itd., aż do stylu Nagłówek 9) do tekstu, który ma zostać uwzględniony w spisie treści.

    Jeśli nie widzisz stylu nagłówka, którego chcesz użyć, na karcie Narzędzia główne w obszarze Style wskaż styl, a następnie kliknij przycisk Strzałka w dół Więcej .

    Porada : Aby tytuł dokumentu nie był wyświetlany w spisie treści, nie stosuj do niego stylu Nagłówek 1. Zamiast stylu nagłówka zastosuj do tytułu styl Tytuł, Tytuł książki lub inny.

  2. Kliknij miejsce w dokumencie, w którym chcesz wstawić spis treści.

    Porada : Jeśli chcesz wstawić spis treści na osobnej stronie lub użyć dla spisu treści innej numeracji stron niż dla reszty dokumentu, umieść spis treści w osobnej sekcji, dodając przed nimi i po nim podziały sekcji.

  3. W menu Widok kliknij polecenie Układ wydruku.

  4. Na karcie Elementy dokumentu w obszarze Spis treści kliknij projekt spisu treści, którego chcesz użyć.

    Karta Elementy dokumentów, grupa Spis treści

Zmienianie liczby poziomów w spisie treści

Domyślnie spis treści zawiera trzy poziomy nagłówków. Można jednak zmniejszyć lub zwiększyć liczbę poziomów uwzględnianych w spisie treści.

  1. Na karcie Elementy dokumentów w obszarze Spis treści kliknij pozycję Opcje.

    Karta Elementy dokumentów, grupa Spis treści

  2. Na karcie Spis treści w polu Pokaż poziomy wprowadź liczbę poziomów, które chcesz uwzględnić (maksymalnie 9), a następnie kliknij przycisk OK.

    Jeśli zostanie wyświetlony monit z zapytaniem, czy zastąpić zaznaczony spis treści, kliknij przycisk Tak.

Aktualizowanie spisu treści

Możesz zaktualizować spis treści, aby uwzględnić zmiany wprowadzone w dokumencie. Możesz zaktualizować cały spis treści lub tylko numery stron.

  1. Przytrzymaj naciśnięty klawisz CONTROL, kliknij spis treści, a następnie kliknij pozycję Aktualizuj pole.

  2. Kliknij odpowiednią opcję.

    Jeśli zobaczysz komunikat „Błąd! Nie zdefiniowano zakładki”

    Jeśli zobaczysz komunikat „Błąd! Nie zdefiniowano zakładki” zamiast numerów stron w spisie treści, oznacza to, że w dokumencie wprowadzono zmiany po zaktualizowaniu spisu treści lub że kod pola jest uszkodzony. Spis treści nie jest zsynchronizowany z dokumentem i trzeba go zaktualizować.

Usuwanie spisu treści

  1. Kliknij spis treści.

  2. W wyświetlonej ramce kliknij strzałkę obok pozycji Spis treści, a następnie kliknij polecenie Usuń spis treści w menu skrótów.

    Menu skrótów Spis treści

Dostosowywanie formatowania spisu treści

Możesz zmienić styl poszczególnych poziomów spisu treści stosownie do swoich potrzeb. Na przykład jeśli obowiązujący arkusz stylów wymaga innego formatowania spisu treści niż to zawarte we wbudowanych szablonach, możesz zmienić styl czcionki, wcięcia, znaki wiodące tabulacji i inne atrybuty.

  1. Na karcie Elementy dokumentów w obszarze Spis treści kliknij pozycję Opcje.

    Karta Elementy dokumentów, grupa Spis treści

    Porada : Aby zmienić znaki wiodące tabulacji, kliknij odpowiedni styl w menu podręcznym Znaki wiodące tabulacji.

  2. Na karcie Spis treści kliknij pozycję Modyfikuj.

  3. W polu Style kliknij poziom spisu treści, który chcesz zmienić (na przykład Spis treści 1 w przypadku poziomu 1).

  4. Kliknij pozycję Modyfikuj, a następnie dostosuj czcionkę, rozmiar i kolor czcionki itd. do swoich potrzeb.

    Aby zmienić wcięcia, odstępy między akapitami i inne atrybuty, w menu podręcznym Format kliknij zmianę, którą chcesz wprowadzić, wybierz odpowiednie opcje w wyświetlonych menu podręcznych, a na koniec kliknij przycisk OK.

    Porada : Aby zmienić wielkość liter, w menu podręcznym Format kliknij pozycję Czcionka, a następnie wyczyść pole wyboru Kapitaliki lub Wszystkie wersaliki.

  5. Powtórz kroki 3 i 4 dla poszczególnych poziomów spisu treści, a następnie kliknij przycisk Zastosuj.

  6. Gdy w polu Podgląd będą widoczne style zgodne z Twoimi oczekiwaniami, kliknij przycisk OK.

Zapisywanie stylu spisu treści jako szablonu

Możesz w przyszłości ponownie wykorzystać określone formatowanie spisu treści w dokumentach, jeśli zapiszesz to formatowanie jako szablon w folderze Moje szablony. Szablon można następnie otworzyć, korzystając z Galerii dokumentów, a następnie wstawić spis treści przy użyciu menu wstawiania.

  1. Wprowadź wszelkie zmiany stylów, które chcesz zapisać, w dokumencie, który będzie podstawą szablonu.

  2. Usuń wszystkie elementy tekstowe i graficzne, które nie mają pojawiać się w nowych dokumentach.

  3. W menu Plik kliknij polecenie Zapisz jako.

  4. W menu podręcznym Format kliknij pozycję Szablon programu Word (dotx).

  5. W polu Zapisz jako wpisz nazwę nowego szablonu, a następnie kliknij przycisk Zapisz.

    O ile nie wybierzesz innej lokalizacji, program Word zapisze plik szablonu w folderze: /Użytkownicy/nazwa_użytkownika/Biblioteki/Application Support/Microsoft/Office/Szablony użytkownika/Moje szablony/.

    Uwagi : 

    • Aby utworzyć nowy dokument na podstawie szablonu, w menu Plik kliknij pozycję Nowy z szablonu. W obszarze Szablony kliknij folder Moje szablony, a następnie kliknij dwukrotnie wybrany szablon.

    • Aby wstawić spis treści na podstawie szablonu, w menu Wstaw kliknij pozycję Indeks i spisy, a następnie w polu Formaty kliknij pozycję Z szablonu.

Ręczne tworzenie spisu treści

  1. Kliknij miejsce w dokumencie, w którym chcesz wstawić spis treści.

    Porada : Jeśli chcesz wstawić spis treści na osobnej stronie lub użyć dla spisu treści innej numeracji stron niż dla reszty dokumentu, umieść spis treści w osobnej sekcji, dodając przed nimi i po nim podziały sekcji.

  2. W menu Widok kliknij polecenie Układ wydruku.

  3. Na karcie Elementy dokumentu w obszarze Spis treści wskaż styl spisu treści, kliknij pozycję Strzałka w dół Więcej , a następnie w obszarze Ręczny spis treści kliknij odpowiedni projekt.

    Karta Elementy dokumentów, grupa Spis treści

    Uwaga : Jeśli zostanie wyświetlony komunikat o błędzie informujący, że program Word nie znalazł żadnych pozycji spisu treści, oznacza to, że wybrano styl automatycznego spisu treści, ale nie ma żadnych nagłówków sformatowanych przy użyciu jednego z wbudowanych stylów nagłówków. Powtórz krok 3, wybierając projekt ręcznego spisu treści.

  4. Wpisz w spisie treści nagłówki i numery stron zgodne z miejscami, w których występują w dokumencie.

  5. Aby dodać kolejne elementy, skopiuj istniejący wpis i wklej go w odpowiednim miejscu w spisie treści.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×