Tworzenie prostego raportu

W programie Access można tworzyć proste lub skomplikowane raporty. Pierwszym krokiem jest wybranie źródła rekordów dla raportu. Niezależnie od tego, czy raport będzie zwykłą listą rekordów, czy pogrupowanym podsumowaniem sprzedaży w regionie, na początku należy ustalić pola zawierające dane do umieszczenia w raporcie i określić, w których tabelach lub zapytaniach znajdują się te pola.

Po wybraniu źródła rekordów najłatwiej jest utworzyć raport za pomocą Kreatora raportów. Jest to funkcja programu Access, która generuje raport zgodnie z odpowiedziami na pytania zadane użytkownikowi.

Co chcesz zrobić?

Wybieranie źródła rekordów

Tworzenie raportu przy użyciu narzędzia Raport

Tworzenie raportu przy użyciu Kreatora raportów

Tworzenie etykiet przy użyciu Kreatora etykiet

Tworzenie raportu przy użyciu narzędzia Pusty raport

Opis sekcji raportu

Opis kontrolek

Dostosowywanie raportu w widoku układu

Dostosowywanie raportu w widoku projektu

Dodawanie kontrolek do raportu

Zapisywanie wyników pracy

Wyświetlanie i drukowanie raportu oraz wysyłanie raportu jako wiadomości e-mail

Wyświetlanie raportu

Drukowanie raportu

Wysyłanie raportu jako wiadomości e-mail

Wybieranie źródła rekordów

Raport składa się z informacji pobieranych z tabel lub zapytań oraz informacji przechowywanych w projekcie raportu, takich jak etykiety, nagłówki i grafika. Tabele lub zapytania zawierające dane są też określane jako źródło rekordów raportu. Jeśli wszystkie pola raportu są przechowywane w jednej tabeli, należy jej użyć jako źródła rekordów raportu. Gdy pola raportu znajdują się w wielu tabelach, należy użyć zapytania lub wielu zapytań jako źródła rekordów. Potrzebne zapytania mogą już istnieć w bazie danych, może także być konieczne utworzenie nowych zapytań specjalnie na potrzeby raportu.

Tworzenie raportu przy użyciu narzędzia Raport

Narzędzie Raport umożliwia szybkie utworzenie raportu — jest on generowany natychmiast i nie wymaga podawania dodatkowych informacji. W takim raporcie są umieszczane wszystkie pola tabeli źródłowej lub zapytania źródłowego. Narzędzie Raport nie zawsze pozwala uzyskać raport dokładnie spełniający wymagania, ale umożliwia szybkie przejrzenie danych. Można zapisać tak utworzony raport i zmodyfikować go w widoku układu lub projektu, dostosowując do własnych potrzeb.

  1. W okienku nawigacji kliknij tabelę lub zapytanie, które ma być podstawą raportu.

  2. Na karcie Tworzenie w grupie Raporty kliknij pozycję Raport. Obraz przycisku

    Program Access utworzy raport i wyświetli go w widoku układu.

  3. Aby uzyskać więcej informacji o wyświetlaniu i drukowaniu raportu, zobacz sekcję Wyświetlanie i drukowanie raportu oraz wysyłanie raportu jako wiadomości e-mail.

Po przejrzeniu raportu można go zapisać i zamknąć raport oraz tabelę lub zapytanie użyte jako źródło rekordów. Przy następnym otwarciu raportu program Access wyświetli bieżące dane przechowywane w źródle rekordów.

Tworzenie raportu przy użyciu Kreatora raportów

Kreator raportów pozwala wybrać pola, które mają zostać ujęte w raporcie. Ponadto jest możliwe określenie sposobu grupowania i sortowania danych oraz użycie pól z wielu tabel lub zapytań, jeśli wcześniej zostały określone relacje między tabelami i zapytaniami.

  • Na karcie Tworzenie w grupie Raporty kliknij pozycję Kreator raportów.

  • Postępuj zgodnie z instrukcjami wyświetlanymi na stronach Kreatora raportów. Na ostatniej stronie kliknij przycisk Zakończ.

    Korzystając z podglądu wydruku, można sprawdzić, jak będzie wyglądał raport po wydrukowaniu. Można także powiększyć widok, aby informacje szczegółowe były bardziej czytelne. Aby uzyskać więcej informacji o wyświetlaniu i drukowaniu raportu, zobacz sekcję Wyświetlanie i drukowanie raportu oraz wysyłanie raportu jako wiadomości e-mail.

Uwaga : Aby ująć w raporcie pola z wielu tabel i zapytań, po wybraniu pól z pierwszej tabeli lub zapytania na pierwszej stronie Kreatora raportów nie klikaj przycisku Dalej ani Zakończ. Zamiast tego powtórz czynności w celu wybrania tabeli lub zapytania i kliknij dodatkowe pola, które chcesz zawrzeć w raporcie. Następnie kliknij przycisk Dalej lub Zakończ, aby kontynuować.

Tworzenie etykiet przy użyciu Kreatora etykiet

Kreator etykiet pozwala w łatwy sposób tworzyć różnego rodzaju etykiety o standardowych rozmiarach.

  1. W okienku nawigacji otwórz tabelę lub zapytanie, które ma być źródłem rekordów dla etykiet, klikając dwukrotnie tabelę lub zapytanie.

  2. Na karcie Tworzenie w grupie Raporty kliknij pozycję Etykiety.

  3. Postępuj zgodnie z instrukcjami wyświetlanymi na stronach Kreatora etykiet. Na ostatniej stronie kliknij przycisk Zakończ.

Program Access wyświetli etykiety w podglądzie wydruku, który przedstawia wygląd etykiet po wydrukowaniu. Suwak umieszczony na pasku stanu programu Access umożliwia sterowanie powiększeniem w celu zwiększenia czytelności szczegółów. Aby uzyskać więcej informacji o wyświetlaniu i drukowaniu raportu, zobacz sekcję Wyświetlanie i drukowanie raportu oraz wysyłanie raportu jako wiadomości e-mail.

Uwaga : Podgląd wydruku jest jedynym widokiem, który pozwala przeglądać wiele kolumn — w innych widokach dane są wyświetlane w pojedynczej kolumnie.

Tworzenie raportu przy użyciu narzędzia Pusty raport

Jeśli nie chcesz tworzyć raportu za pomocą narzędzia Raport ani Kreatora raportów, możesz użyć narzędzia Pusty raport i utworzyć raport od podstaw. W ten sposób można bardzo szybko utworzyć raport, szczególnie wtedy, gdy ma on zawierać niewiele pól. Aby użyć narzędzia Pusty raport, postępuj zgodnie z poniższą procedurą:

  • Na karcie Tworzenie w grupie Raporty kliknij pozycję Pusty raport. Obraz przycisku

    Zostanie wyświetlony pusty raport w widoku układu, a po prawej stronie okna programu Access pojawi się okienko Lista pól.

  • W okienku Lista pól kliknij znak plus obok tabel zawierających pola, które mają być wyświetlane w raporcie.

  • Przeciągnij pola pojedynczo do raportu lub przytrzymaj wciśnięty klawisz CTRL i zaznacz kilka pól, a następnie przeciągnij je wszystkie do raportu.

  • Użyj narzędzi z grupy Nagłówek/stopka na karcie Projektowanie, aby dodać do raportu logo, tytuł, numerację stron lub datę i godzinę. Uwaga: jeśli korzystasz z programu Access 2007, te narzędzia są w grupie Formanty na karcie Formatowanie.

Opis sekcji raportu

Projekt raportu w programie Access jest podzielony na sekcje. Sekcje raportu są wyświetlane w widoku projektu. Tworzenie użytecznych raportów wymaga zrozumienia sposobu działania każdej sekcji. Należy między innymi pamiętać o tym, że sposób obliczania wyników dla kontrolki obliczeniowej przez program Access zależy od tego, w której sekcji jest umieszczona dana kontrolka. Poniższa lista zawiera podsumowanie typów sekcji i sposobów ich użycia:

  • Nagłówek raportu     Ta sekcja jest drukowana tylko raz — na początku raportu — i służy do umieszczania informacji, które zwykle występują na stronie tytułowej, takich jak logo, tytuł lub data. Umieszczenie w tej sekcji kontrolki obliczeniowej, która korzysta z funkcji agregującej Suma, spowoduje obliczenie sumy dla całego raportu. Nagłówek raportu jest drukowany przed nagłówkiem strony.

  • Nagłówek strony     Ta sekcja jest drukowana u góry każdej strony. Można jej użyć, aby na przykład powtórzyć tytuł raportu na każdej stronie.

  • Nagłówek grupy     Ta sekcja jest drukowana na początku każdej nowej grupy rekordów i umożliwia drukowanie nazwy grupy. Jeśli w raporcie jest na przykład używane grupowanie według produktów, nagłówek grupy pozwala wydrukować nazwę produktu. Umieszczenie w tej sekcji kontrolki obliczeniowej, która korzysta z funkcji agregującej Suma, spowoduje obliczenie sumy dla bieżącej grupy.

  • Szczegóły     Ta sekcja jest drukowana jednorazowo dla każdego wiersza w źródle rekordów. Zawiera ona kontrolki tworzące główną treść raportu.

  • Stopka grupy     Ta sekcja jest drukowana na końcu każdej grupy rekordów. Umożliwia ona drukowanie informacji podsumowujących dla grup.

  • Stopka strony     Ta sekcja jest drukowana na końcu każdej strony. Stopka strony służy do drukowania numerów stron lub innych informacji dotyczących poszczególnych stron.

  • Stopka raportu     Ta sekcja jest drukowana tylko raz — na końcu raportu. Stopka raportu służy do drukowania sum oraz innych informacji podsumowujących cały raport.

    Uwaga : W widoku projektu stopka raportu jest wyświetlana poniżej stopki strony. Jednak na podglądzie lub wydruku raportu stopka raportu jest umieszczana powyżej stopki strony, zaraz za ostatnią stopką grupy lub wierszem szczegółów na ostatniej stronie.

Początek strony

Opis kontrolek

Kontrolki umożliwiają wyświetlanie danych, wykonywanie akcji, a także wyświetlanie informacji zwiększających funkcjonalność interfejsu użytkownika (takich jak etykiety i obrazy) oraz pracę z tymi informacjami. Program Access obsługuje trzy typy kontrolek: powiązane, niepowiązane i obliczeniowe:

  • Kontrolka powiązana     Źródłem danych takiej kontrolki jest pole tabeli lub zapytania. Kontrolki powiązane służą do wyświetlania wartości pól bazy danych. Takimi wartościami mogą być dane tekstowe, daty, liczby, wartości Tak/Nie, obrazy lub wykresy. Najczęściej spotykanym typem kontrolki powiązanej jest pole tekstowe. Pole tekstowe formularza, w którym jest wyświetlane nazwisko pracownika, może na przykład pobierać tę informację z pola Nazwisko w tabeli Pracownicy.

  • Kontrolka niepowiązana     Jest to kontrolka bez źródła danych (pola lub wyrażenia). Kontrolki niepowiązane służą do wyświetlania informacji, linii, prostokątów i obrazów. Przykładem może być etykieta wyświetlająca tytuł raportu.

  • Kontrolka obliczeniowa     Źródłem danych takiej kontrolki nie jest pole, tylko wyrażenie. Wartość kontrolki jest definiowana przez wyrażenie jako źródła danych kontrolki. Wyrażenie może zawierać operatory (na przykład = i +), nazwy kontrolek, nazwy pól, funkcje zwracające pojedynczą wartość i wartości stałe. Na przykład następujące wyrażenie oblicza cenę towaru przy rabacie wynoszącym 25 procent, mnożąc wartość w polu Cena jednostkowa przez wartość stałą (0,75).

    = [Cena jednostkowa] * 0,75

    Wyrażenie może używać danych z pola tabeli lub zapytania źródłowego raportu albo z kontrolki w raporcie.

Podczas tworzenia raportu zwykle najlepiej jest najpierw dodać i rozmieścić wszystkie kontrolki powiązane, zwłaszcza wtedy, gdy stanowią one większość kontrolek w raporcie. Następnie można dodać kontrolki niepowiązane i obliczeniowe, używając narzędzi z grupy Formanty na karcie Projektowanie.

Kontrolkę można powiązać z polem, wskazując pole, z którego mają być pobierane dane kontrolki. Kontrolkę powiązaną z wybranym polem można utworzyć, przeciągając pole z okienka Lista pól do raportu. W okienku Lista pól są wyświetlane pola tabeli lub zapytania źródłowego raportu. Aby wyświetlić okienko Lista pól, na karcie Projektowanie w grupie Formanty kliknij przycisk Dodaj istniejące pole.

Pole można także powiązać z kontrolką, wpisując nazwę pola w kontrolce lub w polu zawierającym wartość właściwości ŹródłoFormantu w arkuszu właściwości kontrolki. Arkusz właściwości umożliwia zdefiniowanie cech kontrolki, takich jak nazwa, źródło danych i ich format.

Tworzenie kontrolki przy użyciu okienka Lista pól jest najlepszą metodą z dwóch powodów:

  • Do kontrolki powiązanej jest dołączana etykieta zawierająca domyślnie nazwę pola (lub etykietę zdefiniowaną dla niego w tabeli lub zapytaniu źródłowym), dzięki czemu nie trzeba jej wpisywać samodzielnie.

  • Kontrolka powiązana dziedziczy wiele ustawień pola z tabeli lub zapytania źródłowego, na przykład właściwości Format, MiejscaDziesiętne i MaskaWprowadzania. Dzięki temu możesz mieć pewność, że właściwości pola pozostaną takie same dla każdej powiązanej z nim kontrolki.

Aby powiązać z polem utworzoną wcześniej kontrolkę niepowiązaną, ustaw nazwę pola jako wartość właściwości ŹródłoFormantu kontrolki. Szczegółowe informacje na temat właściwości ŹródłoFormantu można uzyskać, wyszukując w Pomocy hasło „ŹródłoFormantu”.

Początek strony

Dostosowywanie raportu w widoku układu

Po utworzeniu raportu można w łatwy sposób dostosować jego projekt, korzystając z widoku układu. Po wyświetleniu rzeczywistych danych raportu można dopasować szerokości i zmienić układ kolumn, a także dodać poziomy grupowania i sumy. Można umieszczać pola w projekcie raportu oraz ustawiać właściwości raportu i jego kontrolek.

Aby przełączyć się do widoku układu, w okienku nawigacji kliknij prawym przyciskiem myszy nazwę raportu, a następnie kliknij polecenie Widok układu Obraz przycisku .

Program Access wyświetli widok układu raportu.

Do modyfikowania właściwości raportu, jego kontrolek i sekcji służy arkusz właściwości. Aby wyświetlić arkusz właściwości, naciśnij klawisz F4.

Okienko Lista pól umożliwia dodawanie pól z tabeli lub zapytania źródłowego do projektu raportu. Aby wyświetlić okienko Lista pól, wykonaj jedną z poniższych czynności:

  • Na karcie Projektowanie w grupie Narzędzia kliknij pozycję Dodaj istniejące pola Obraz przycisku . Uwaga: jeśli korzystasz z programu Access 2007, polecenie Dodaj istniejące pola znajduje się w grupie Formanty na karcie Formatowanie.

  • Naciśnij klawisze ALT+F8.

Następnie można dodać pola, przeciągając je z okienka Lista pól do raportu.

Początek strony

Dostosowywanie raportu w widoku projektu

Szczegółowe dostosowanie projektu raportu jest również możliwe w widoku projektu. Pozwala on dodawać nowe kontrolki i pola do raportu przez dodanie do siatki projektu. Arkusz właściwości udostępnia wiele właściwości, które ułatwiają dostosowywanie raportu.

Aby przełączyć się do widoku projektu, w okienku nawigacji kliknij prawym przyciskiem myszy nazwę raportu, a następnie kliknij polecenie Widok projektu Obraz przycisku .

Program Access wyświetli widok projektu raportu.

Do modyfikowania właściwości raportu, jego kontrolek i sekcji służy arkusz właściwości. Aby wyświetlić arkusz właściwości, naciśnij klawisz F4.

Okienko Lista pól umożliwia dodawanie pól z tabeli lub zapytania źródłowego do projektu raportu. Aby wyświetlić okienko Lista pól, wykonaj jedną z poniższych czynności:

  • Na karcie Formatowanie w grupie Formanty kliknij pozycję Dodaj istniejące pola Obraz przycisku . Uwaga: jeśli korzystasz z programu Access 2007, polecenie Dodaj istniejące pola znajduje się w grupie Formanty na karcie Formatowanie.

  • Naciśnij klawisze ALT+F8.

Następnie można dodać pola, przeciągając je z okienka Lista pól do raportu.

Początek strony

Dodawanie pól z okienka Lista pól

  • Aby dodać pole, przeciągnij je z okienka Lista pól do sekcji raportu, w której ma być wyświetlane.

  • Aby dodać kilka pól jednocześnie, przytrzymaj wciśnięty klawisz CTRL i kliknij odpowiednie pola. Następnie przeciągnij zaznaczone pola do raportu.

Po upuszczeniu pól w sekcji raportu program Access utworzy powiązaną kontrolkę pola tekstowego dla każdego pola i automatycznie umieści etykiety obok pól.

Początek strony

Dodawanie kontrolek do raportu

Niektóre kontrolki są tworzone automatycznie. Dotyczy to między innymi powiązanej kontrolki pola tekstowego, która jest tworzona po dodaniu do raportu pola z okienka Lista pól. W widoku projektu można utworzyć wiele innych kontrolek — służą do tego narzędzia w grupie Formanty na karcie Projektowanie.

Ustalanie nazwy narzędzia

  • Umieść wskaźnik myszy na narzędziu.

    Program Access wyświetli nazwę narzędzia.

Tworzenie kontrolki przy użyciu narzędzi z grupy Formanty

  1. Kliknij narzędzie odpowiadające typowi kontrolki, którą chcesz dodać. Aby na przykład utworzyć pole wyboru, kliknij narzędzie Pole wyboru Obraz przycisku .

  2. Kliknij siatkę projektu raportu w miejscu, w którym chcesz umieścić lewy górny róg kontrolki. Kliknij raz, aby utworzyć kontrolkę o rozmiarze domyślnym lub kliknij narzędzie i utwórz kontrolkę o odpowiednich wymiarach, przeciągając wskaźnik myszy w siatce projektu raportu.

  3. Jeśli położenie wstawionej kontrolki będzie nieodpowiednie, możesz ją przenieść, korzystając z następujące procedury:

    1. Kliknij kontrolkę, aby ją zaznaczyć.

    2. Umieść wskaźnik myszy nad krawędzią kontrolki i poczekaj, aż zmieni się w strzałkę z czterema grotami Wskaźnik przenoszenia .

    3. Przeciągnij kontrolkę do odpowiedniego położenia.

Ta procedura umożliwia utworzenie kontrolki „niepowiązanej”. Jeśli użyty typ kontrolki służy do wyświetlania danych (na przykład jest to pole tekstowe lub pole wyboru), należy wprowadzić nazwę pola lub wyrażenie w polu właściwości ŹródłoFormantu, aby kontrolka mogła wyświetlać dane. Aby uzyskać więcej informacji, zobacz sekcję Opis kontrolek w tym temacie.

Wyświetlanie arkusza właściwości

Aby wyświetlić arkusz właściwości w widoku projektu, wykonaj jedną z następujących czynności:

  • Na karcie Projektowanie w grupie Narzędzia kliknij pozycję Arkusz właściwości. Uwaga: jeśli korzystasz z programu Access 2007, polecenie Arkusz właściwości znajduje się w grupie Pokazywanie/ukrywanie na karcie Projektowanie.

  • Naciśnij klawisz F4.

Początek strony

Zapisywanie wyników pracy

Po zapisaniu projektu raportu można tworzyć raport w dowolnym momencie. Projekt nie zmieni się, ale wydrukowany lub wyświetlony raport zawsze będzie zawierał bieżące dane. Jeśli będzie potrzebny nieco inny raport, można zmodyfikować jego projekt lub utworzyć nowy, podobny raport, oparty na wcześniej utworzonym.

Zapisywanie projektu raportu

  • Kliknij pozycję Plik > Zapisz lub naciśnij klawisze CTRL+S. Uwaga: jeśli korzystasz z programu Access 2007, naciśnij klawisze CTRL+S lub kliknij przycisk pakietu Microsoft Office, a następnie kliknij polecenie Zapisz.

    Możesz też kliknąć przycisk Zapisz Obraz przycisku na pasku narzędzi Szybki dostęp.

  • Jeśli raport nie ma tytułu, wpisz nazwę w polu Nazwa raportu, a następnie kliknij przycisk OK.

Zapisywanie projektu raportu przy użyciu nowej nazwy

  • Jeśli korzystasz z programu Access 2013 lub jego nowszej wersji, kliknij pozycję Plik > Zapisz jako > Zapisz obiekt jako.

    Jeśli korzystasz z programu Access 2010, kliknij pozycję Plik > Zapisz obiekt jako.

    Jeśli korzystasz z programu Access 2007, kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Zapisz jako > Zapisz obiekt jako.

  • W oknie dialogowym Zapisywanie jako wpisz nazwę nowego raportu w polu Zapisz obiekt Raport do, a następnie kliknij przycisk OK.

Początek strony

Wyświetlanie i drukowanie raportu oraz wysyłanie raportu jako wiadomości e-mail

Zapisanego projektu raportu można używać wielokrotnie. Projekt nie zmieni się, ale wydrukowany lub wyświetlony raport zawsze będzie zawierał bieżące dane. Jeśli będzie potrzebny nieco inny raport, można zmodyfikować jego projekt lub utworzyć nowy, podobny raport, oparty na wcześniej utworzonym.

Wyświetlanie raportu

Raport można wyświetlać na wiele sposobów. Właściwa metoda zależy od tego, jakie czynności związane z raportem i danymi będą wykonywane:

  • Jeśli przed wydrukowaniem raportu chcesz tymczasowo zmienić ujęte w nim dane albo skopiować dane z raportu do schowka, użyj widoku raportu.

  • Jeśli chcesz zmienić projekt raportu podczas przeglądania danych, użyj widoku układu.

  • Jeśli chcesz tylko sprawdzić, jak będzie wyglądał raport po wydrukowaniu, użyj podglądu wydruku.

Uwaga : Jeśli raport jest sformatowany za pomocą wielu kolumn, układ kolumn jest widoczny tylko w podglądzie wydruku. W widoku raportu i widoku układu raport jest wyświetlany w postaci pojedynczej kolumny.

Wyświetlanie raportu w widoku raportu

Widok raportu jest używany domyślnie po dwukrotnym kliknięciu raportu w okienku nawigacji. Jeśli raport nie jest otwarty, kliknij dwukrotnie jego nazwę w okienku nawigacji, aby wyświetlić widok raportu.

Jeśli raport jest już otwarty, kliknij prawym przyciskiem myszy nazwę raportu w okienku nawigacji, a następnie kliknij polecenie Widok raportu.

Praca z danymi w widoku raportu

Widok raportu umożliwia zaznaczenie tekstu i skopiowanie go do schowka. Aby zaznaczyć całe wiersze, kliknij margines i przeciągnij wskaźnik myszy obok wierszy, które chcesz zaznaczyć. Te wiersze możesz następnie skopiować do schowka, wykonując jedną z poniższych czynności:

  1. Na karcie Narzędzia główne w grupie Schowek kliknij przycisk Kopiuj Obraz przycisku .

  2. Kliknij prawym przyciskiem myszy zaznaczone wiersze, a następnie kliknij polecenie Kopiuj.

  3. Skrót klawiaturowy: naciśnij klawisze CTRL+C.

Wyświetlanie tylko wybranych wierszy za pomocą filtrów

Możesz zastosować filtry bezpośrednio do raportu bez opuszczania widoku raportu. Jeśli na przykład istnieje kolumna „Kraj/region” i chcesz wyświetlić tylko wiersze, w których ta kolumna ma wartość „Kanada”, wykonaj następujące czynności:

  1. Odszukaj wyraz „Kanada” w raporcie i kliknij go prawym przyciskiem myszy.

  2. Kliknij pozycję Równa się „Kanada”.

Program Access utworzy filtr i zastosuje go.

Włączanie i wyłączanie filtru

Można przełączać się między widokiem filtrowanym i niefiltrowanym, klikając przycisk Przełącz filtr w grupie Sortowanie i filtrowanie na karcie Narzędzia główne. Filtr nie jest usuwany — jest tylko włączany lub wyłączany.

Usuwanie filtru

  1. Kliknij prawym przyciskiem myszy pole, z którego chcesz usunąć filtr.

  2. Kliknij polecenie Wyczyść filtr z nazwa_pola. (Nazwa_pola odpowiada rzeczywistej nazwie pola).

Po usunięciu filtru nie można włączyć go ponownie za pomocą polecenia Przełącz filtr. Trzeba najpierw utworzyć ten filtr ponownie.

Uwaga : Zapisanie i zamknięcie raportu po zastosowaniu filtru powoduje również zapisanie filtru. Jednak po ponownym otwarciu raportu w programie Access filtr nie zostanie zastosowany. Aby ponownie zastosować filtr, na karcie Narzędzia główne w grupie Sortowanie i filtrowanie kliknij przycisk Przełącz filtr.

Wyświetlanie raportu w podglądzie wydruku

W okienku nawigacji kliknij prawym przyciskiem myszy wybrany raport, a następnie kliknij polecenie Podgląd wydruku w menu skrótów.

Za pomocą przycisków nawigacyjnych można przeglądać kolejne strony raportu albo przejść bezpośrednio do dowolnej strony.

Przyciski nawigacyjne

1. Kliknij ten przycisk, aby wyświetlić pierwszą stronę.

2. Kliknij ten przycisk, aby wyświetlić poprzednią stronę.

3. Kliknij ten przycisk, aby wyświetlić następną stronę.

4. Kliknij ten przycisk, aby wyświetlić ostatnią stronę.

5. Aby przejść do określonej strony, wpisz jej numer w tym polu, a następnie naciśnij klawisz ENTER.

Podgląd wydruku umożliwia powiększenie widoku w celu wyświetlenia szczegółów oraz pomniejszenie go w celu ocenienia rozmieszczenia danych na stronie. Umieść wskaźnik myszy w obszarze raportu i kliknij raz. Kliknij ponownie, aby cofnąć efekt powiększenia. Do sterowania powiększeniem możesz też użyć kontrolki powiększenia na pasku stanu programu Access.

Aby zamknąć podgląd wydruku, wykonaj jedną z następujących czynności:

  • Na karcie Podgląd wydruku kliknij przycisk Zamknij podgląd wydruku.

  • Kliknij prawym przyciskiem myszy raport w okienku nawigacji, a następnie kliknij polecenie Widok układu Obraz przycisku lub Widok projektu Obraz przycisku w menu skrótów.

Porada : Po przejrzeniu raportu można wyeksportować wyniki do programu Microsoft Word lub Microsoft Excel albo do innych programów pakietu Office. Na karcie Dane zewnętrzne w grupie Eksportowanie kliknij przycisk dla odpowiedniego formatu, a następnie postępuj zgodnie z instrukcjami.

Początek strony

Drukowanie raportu

Raport można wydrukować, jeśli jest otwarty w dowolnym widoku, a nawet jeśli jest zamknięty. Przed rozpoczęciem drukowania sprawdź ustawienia strony, takie jak marginesy i orientacja strony. W programie Access ustawienia strony są zapisywane razem z raportem, dzięki czemu wystarczy określić je tylko raz. Ustawienia można zmieniać, dostosowując je do zmieniających się potrzeb drukowania.

Zmienianie ustawień strony

  1. Otwórz raport w widoku Podgląd wydruku. Ustawienia strony można zmieniać w każdym widoku, ale podgląd wydruku najlepiej nadaje się do tego celu, gdyż pozwala natychmiast sprawdzić efekty wprowadzonych zmian.

  2. Na karcie Podgląd wydruku w grupach Układ strony i Rozmiar strony kliknij przycisk Pionowa Obraz przycisku lub przycisk Pozioma Obraz przycisku , aby ustawić orientację strony, kliknij przycisk Rozmiar Obraz przycisku , aby ustawić rozmiar papieru, kliknij przycisk Marginesy Obraz przycisku , aby dopasować marginesy itd.

  3. Po wprowadzeniu zmian przejrzyj kilka stron przy użyciu przycisków nawigacyjnych, aby upewnić się, że nie pojawiły się problemy z formatowaniem na dalszych stronach.

Wysyłanie raportu do drukarki

  1. Otwórz raport w dowolnym widoku lub zaznacz raport w okienku nawigacji.

  2. Kliknij pozycję Plik > Drukuj > Drukuj. Uwaga: jeśli korzystasz z programu Access 2007, kliknij przycisk pakietu Microsoft Office, a następnie kliknij polecenie Drukuj > Drukuj.

    Program Access wyświetli okno dialogowe Drukowanie.

  3. Wprowadź wybrane opcje, na przykład wybierz drukarkę, zakres wydruku lub liczbę kopii.

  4. Kliknij przycisk OK.

Początek strony

Wysyłanie raportu jako wiadomości e-mail

Zamiast drukować kopię na papierze, można wysłać raport do odbiorców jako wiadomość e-mail:

  1. Kliknij odpowiedni raport w okienku nawigacji. Na karcie Dane zewnętrzne w grupie Eksportowanie kliknij przycisk Wyślij wiadomość e-mail. Uwaga: jeśli korzystasz z programu Access 2007, kliknij raport w okienku nawigacji, aby go zaznaczyć, kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Wyślij wiadomość e-mail.

  2. W oknie dialogowym Wysyłanie obiektu jako na liście Wybierz format wyjściowy kliknij format pliku, którego chcesz użyć.

  3. Ukończ wypełnianie opcji pozostałych okien dialogowych.

  4. W aplikacji poczty e-mail wpisz szczegóły wiadomości, a następnie wyślij ją.

Początek strony

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×